G++ is the C++ front-end of the Gnu Compiler Collection (GCC)

learn more… | top users | synonyms

1
vote
1answer
81 views

How to install gcc 4.9 on Ubuntu 14.04?

Now that gcc 4.9 is officially released, is there an easy and convenient way to install it on Ubuntu 14.04 through the package manager (ie. apt-get)? I would also appreciate information on how to ...
0
votes
0answers
25 views

I already have the newest version of g++ but I still get a 127 error what do I do?

I have done the following. I just don't know what to try next. I supposedly have the newest version of gcc by following these directions sudo add-apt-repository ppa:ubuntu-toolchain-r/test sudo ...
0
votes
0answers
46 views

Unable to install g++-multilib on Ubuntu 13.10 64 bit [duplicate]

When i open Terminal and write below command it not work to install. sudo apt-get install g++-multilib It give me below Error: > Reading package lists... Done Building dependency tree ...
0
votes
0answers
5 views

Compilation of Logstalgia: compilation - undefined reference to symbol 'glEnd'

I'm trying to build Logstalgia https://github.com/acaudwell/Logstalgia.git CFLAGS="-O2 -Wall -march=native -I/opt/AMDAPP/include" LDFLAGS="-L/opt/AMDAPP/lib/x86_64" ./configure ...
0
votes
3answers
69 views

Problem With g++

I want to install g++ but i can't do it. I tried installing it from Software center and terminal using apt-get install g++ but it won't work. I'm getting the following error: The following packages ...
0
votes
1answer
43 views

How to create alias with g++?

I'm trying to create an alias on ubuntu for the bellow commands: g++ -lSDL -lSDLmain -lSDL_image -lGL -lGLU src.cpp -o a.out g++ -lGL -lglut `sdl-config --cflags --libs` src.cpp -o a.out When I ...
2
votes
1answer
743 views

Getting + installing gcc/g++ 4.9 on Ubuntu?

How do I install the latest version of gcc and g++? I am using a variety of C++11 and C++1y features; which is why I need this.
0
votes
0answers
57 views

Can not install g++ completely

The following packages have unmet dependencies: g++-4.8 : Depends: libstdc++-4.8-dev (= 4.8.1-10ubuntu9) but it is not going to be installed E: Unmet dependencies. Try 'apt-get -f install' with no ...
1
vote
1answer
312 views

Error: ‘strlen’ was not declared in this scope

I am trying to compile several third-party software from source code (i.e. zchaff, argosat) and get errors such as: Error: ‘strlen’ was not declared in this scope Error: ‘strcmp’ was not declared in ...
0
votes
1answer
194 views

install gcc and g++

I tried all the commands sudo apt-get build-dep build-essential sudo apt-get install gcc sudo apt-get install g++ But all time I am getting this error. The following packages have unmet ...
1
vote
2answers
692 views

G++ compilation error “cc1plus” not found

I think I accidentally deleted a couple files from my machine, and now G++ won't compile. I tried to apt-get remove it then apt-get install it to see if it would fix it, but it didn't work. Now I have ...
0
votes
1answer
263 views

“undefined reference to `std::ios_base::Init::Init()” while compiling a hello world in netbeans

I am new to ubuntu and I want to code in C++. I intalled g++ through software manager and after I installed netbeans to have a nice IDE to code in C++. Then I write this simple code: #include ...
-1
votes
1answer
116 views

How to run g++-4.7 installed in the machine using g++ command?

I am using Ubuntu 13.10(Saucy). I installed g++-4.7 in my machine. But when I tried to run g++ or tried to check the version it is showing that the package is not installed. $ g++ --version The ...
0
votes
3answers
3k views

Installing gcc 4.8 on 13.10 “The following packages have unmet dependencies” [duplicate]

When i go to install gcc 4.8 using: sudo apt-get update sudo apt-get install gcc-4.8 g++-4.8 I get the error message: Some packages could not be installed. This may mean that you have requested an ...
0
votes
0answers
424 views

Can't install g++ on 13.10 (dependency problem) [duplicate]

I'm a newbie and I'm trying to make some c++ codes. I installed eclipse, but I can't install g++ and really don't know why. My command is this. sudo apt-get install g++ However, it doesn't work. ...
0
votes
0answers
227 views

C++ IDE Problem ubuntu 13.10

I'm installed Eclipse cdt in my OS (ubuntu 13.10) but i cant create C++ project, Im already insalled QT creator but i cant create C++ app in qt too... Im installed g++ 4.8
0
votes
1answer
172 views

“fatal error: GL/glfw.h: No such file or directory #include <GL/glfw.h>” - How to solve it?

I'm trying to install GLFW to develop a OpenGL 3.0+ program and I've followed a few tutorials on how to install GLFW and I keep getting this error. I know I have installed it correctly with cmake, ...
0
votes
0answers
345 views

How do I compile with GL/glew.h?

Whenever I try to compile a C++ file using: g++ cgaTOH.cpp I keep getting the following error: fatal error: GL/glew.h: No such file or directory Could someone advise on how to get GL/glew.h ...
0
votes
0answers
34 views

Alter Netbeans Debug options

I would start with specifications first. 1)Ubuntu 12.04 x86 2)NetBeans IDE 7.3.1 3)fuzzylite 3.1 My Query: The image in the above link the order of the debug option is incorrect as flag ...
0
votes
1answer
65 views

what is the command for compiling a 32-bit binary in Ubuntu 13.10?

I am trying to compile my program. Normally I just put the command gcc example.c -o example . So this compiles the .run file into 64-bit. But I want it as 32-bit. What is the command? I have installed ...
0
votes
1answer
92 views

Unable to include libv8 in a c++ app

I was trying to use the libv8-3.8.9.20 package in my c++ script. The package is installed in /usr/lib/ as supposed but if I try to compile my script using g++ script.cpp -Iv8 command, nothing happens. ...
0
votes
1answer
746 views

How to install boost 1.53 or 1.54 from terminal?

I'd like to install boost 1.53 or 1.54 from terminal in Ubuntu 12.04. How do I do this? I used the libboost command and it gave me 1.48, whereas I need a more recent version. Thanks in advance
4
votes
3answers
1k views

Downloaded g++ 4.8 but cant set it as default?

I have downloaded g++ 4.8 on Ubuntu 12.10 by doing: sudo add-apt-repository ppa:ubuntu-toolchain-r/test sudo apt-get update sudo apt-get install g++-4.8 but when I do: sudo update-alternatives ...
0
votes
1answer
1k views

Terminal commands for installing g++ 4.8?

Could somebody please advise how I could install g++ 4.8 ? I understand its not an official release yet (and that I would need to manually download a file) but I get internal compiler bug issues with ...
0
votes
1answer
588 views

“The program 'g++' can be found in the following packages”

I have g++ 4.6, 4.7 and 4.8 installed, but not g++ itself. I am using Ubuntu 12.04. If I do: g++ --version it says: The program 'g++' can be found in the following packages: * g++ * ...
0
votes
0answers
337 views

Get latest G++ (4.7) for C++11?

Netbeans is complaining because I selected C++11 and my G++ version is 4.6 (4.7 supports C++11). However, I have tried: sudo apt-get install build-essential But g++ --version tells me I have ...
1
vote
2answers
450 views

Where or what are the instructions for installing FMOD Ex for Linux to use in g++?

I'm looking for the instructions on how to install FMOD. I want to do extra credit for my computer graphics assignment - sound effects. A teammate wants me to go with something simple, and he ...
0
votes
0answers
117 views

ld error while linking to SDL2

i'm struggling in the attept to compile c++ with SDL2. I've done as always: checkout the code (both from mercurial and libsdl.org) ./configure, make, sudo make install But it keeps to say: ...
0
votes
0answers
419 views

g++ v 4.8.1 doesn't compile simple code, using thread header

I have ubuntu 13.10 64bit. The use of thread with the g++ v 4.8.1 compiler gives an error message : terminate called after throwing an instance of 'std::system_error' what(): Enable ...
0
votes
1answer
100 views

Problem with function fpos_t and fgetpos [closed]

when I try to use those functions it sends this error: main.cpp: In function ‘int main()’: main.cpp:11:17: error: conversion from ‘int’ to non-scalar type ‘fpos_t {aka _G_fpos_t}’ requested ...
-1
votes
1answer
460 views

How do I compile lbflow 1.1?

After using "sh ./configure" command, I encountered another error during lbflow package installation (a scientific one). The sequence of operations is here with error: ./configure --disable-gts ...
0
votes
1answer
324 views

Compiling c++ script with external libraries, not working

I can't seem to get this working. I have a c++ script that i haven't written myself, that i need to compile with g++. The start of the script looks like this: #include "x.hh" #include "y.hh" ...
1
vote
1answer
18k views

How to install g++ compiler?

I have tried the following: sudo apt-get install build-essential Reading package lists... Done Building dependency tree Reading state information... Done build-essential is already the newest ...
0
votes
1answer
438 views

g++ installation unmet dependencies error [duplicate]

I am trying to install g++.But not able to do it. amol@amol-System-Product-Name:~$ sudo apt-get install g++ [sudo] password for amol: Reading package lists... Done Building dependency tree ...
0
votes
2answers
164 views

not able to install g++

This is what I get when I run sudo apt-get install g++: libgtksourceview-3.0-0 is already the newest version. libgconf-2-4 is already the newest version. ibus-gtk is already the newest version. ...
0
votes
1answer
389 views

can't install g++ (worked fine before?)

Came back to my machine today, g++ won't run from the command line. output from sudo apt-get install g++: The following packages have unmet dependencies: fglrx : Depends: dkms but it is not ...
0
votes
0answers
276 views

cannot find include file “fstream.h”

I need to compile files using makedepend. The command is makedepend -v -I/usr/include/g++-3/ $(IFLAGS) -- $(CFLAGS) -- $(SRCS) which was given as part of the MakeFile (the MakeFile was not created by ...
1
vote
0answers
700 views

gcc without g++?

I run Ubuntu 13.04 (x86_64 if it matters) which I recently installed. Before, when using 12.10, I had both gcc and g++ from the beginning. However, with 13.04 after I downloaded gcc-4.8.1 sources I ...
1
vote
1answer
611 views

Trying to compile code results in error: make[1]: g++-3: Command not found

I am trying to compile a program on Ubuntu 12.04 (LTS), but the following error keeps resulting: evensteven@pc:~/Desktop/MimoComplexLdpc$ make all cd ./src; make; make[1]: Entering directory ...
1
vote
1answer
55 views

Is it possible to have two g++ executables with shared lib?

It might sound weird but I do want to have two g++ executables. One in normal /usr/bin/g++ which is currently working well. The other under /sandbox/g++ that is protected by apparmor. However when I ...
0
votes
0answers
91 views

JC1 error for make file on ubuntu terminal

I am new to Linux. Using make command resulted in the following error: LINK Sample_x86 jc1: error: unrecognized command line option ‘-quiet’ jc1: error: unrecognized command line option ‘-auxbase ...
2
votes
1answer
675 views

./ 1.cpp commands gives error: bash: ./: Is a directory [closed]

After vi 1.cpp I write my C++ Program. g++ 1.cpp -o 1.out works fine. But ./ 1.out gives Error: bash: ./: Is a directory
0
votes
1answer
92 views

Compilation problem for C++ program

How do I install g++ or pentium builder packages? Do I need to download those? Because when I try to compile the program and with this statement: g++ -Wall -W -Werror main.cpp -o HelloWorldCPP` ...
0
votes
1answer
718 views

g++ error “sstream.tcc:112:39: error: expected unqualified-id before ‘(’ token”

I tried to install install one program at Ubuntu and it uses main.cpp .I dont know why but it gives always error.(main.cpp syntax correct 100%) and this program works without error @Mac system but not ...
0
votes
2answers
116 views

Error while installing g++ [duplicate]

I am getting this error: sathiesh@sathiesh:~$ sudo apt-get install g++ [sudo] password for sathiesh: E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable) E: Unable ...
-2
votes
1answer
293 views

Is Gcc 4.8.1 RELEASE available under raring 13.04 ? ( no snapshot, only release )

I need full c++11 support and I need gcc 4.8.1 release, I'm under Ubuntu 13.04 64 bit, there is a gcc-snapshot package in the repository, but it's outdated and it's an old pre-release version. It's ...
1
vote
1answer
62 views

How to debug executable (using gdb) that reads another file?

I have a small application let's call it program. In general to use this application I need to stream a file into it: ./program < file_with_data.txt How do I debug such program using dbg? I ...
0
votes
2answers
613 views

How to install gcc/g++ 4.4 and make links

Because I cannot compile some code by gcc/g++ 4.7, I want to install gcc/g++ 4.4. I searched the Internet and found some different way. I don't know what is the best solution. Is it possible to ...
0
votes
0answers
177 views

Trying to install CERN root in 12.04 LTS

I'm getting errors in the standard CERN root install related to g++. I installed all of the necessary accompanying packages and installation was proceeding, but it stops with: g++ -O2 -pipe -m64 ...
0
votes
1answer
140 views

g++ fails to link to libmysqlclient

I use Ubuntu 12.04 on a virtual machine on my MacbookPro. I installed build-essential, mysql-server and libmysqlclient-dev. Both commands 'mysql' and 'mysql_config' work. However, the following ...