2
votes
0answers
96 views

Is it possible to compile a kernel module under chroot?

Under a chroot environment, is it possible to build a kernel module without having the kernel installed, just the headers? It sounds like something you wouldn't want to do, but in my case I do. I've ...
0
votes
0answers
36 views

Error! Bad return status for module build on kernel: 3.11.0-15 generic (x86_64) [duplicate]

I've installed Ubuntu 12.04 LTS and I have multiple GPUs (R9 280X, MSI Gaming 3g). I've followed the guides on how to install the GPU drivers correctly. Unfortunately, no matter what, during the ...
1
vote
2answers
813 views

Installing 3.13 kernel on Saucy (13.10) - possible? [duplicate]

I wanted to install 3.13.5 kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.13.5-trusty/ . I know that the folders are called trusty but can I install them on 13.10 ? After tying dpkg -i ...
1
vote
2answers
2k views

How fix ATI fglrx driver after kernel upgrade

I upgraded to the 12.04.4 lts saucy stack from 12.04.3: sudo apt-get install --install-recommends linux-generic-lts-saucy xserver-xorg-lts-saucy libgl1-mesa-glx-lts-saucy That installed the 3.11 ...
1
vote
1answer
1k views

Can't install fglrx on Kernel 3.11.0-12

I'm running Ubuntu Gnome 13.10 on a Sony Vaio laptop. I tried to install the newest fglrx driver from the cchtml.com guide but no matter which version I use (13.4 or even 13.9) the installation of the ...
0
votes
1answer
142 views

how to un-install a special driver/kernel in 13.04

I have tried to install a special ATI driver using a method described in http://debianhelp.wordpress.com/2012/09/28/to-do-list-after-installing-ubuntu-13-04-aka-raring-ringtail-operating-system/ ...
0
votes
1answer
2k views

Problem installing fglrx drivers 13.1 with kernel 3.4 on ubuntu 12.04.02 x64

I have tried to upgrade from kernel 3.2 to kernel 3.4 (here) and after that installing fglrx drivers 13.1 (compatible up to kernel 3.5). Here are the steps I followed: Removing (purging) existing ...
0
votes
1answer
747 views

Problem with DKMS upgrading 12.04 to kernel 3.6.9

I am trying to upgrade my Ubuntu 12.04 to Linux Kernel 3.6.9 as described here. This is what I get in console: andres@andres-nt:/tmp$ sudo sh linux-kernel-3.6.9 ########### This bash script is ...
4
votes
2answers
11k views

AMD Catalyst Driver installer failing at DKMS

I am following these instructions to install the fglrx drivers. When I am running sudo sh amd-driver-12-6-x86_64.run it tells me fglrx is already installed; even though I ran the commands to remove ...
2
votes
1answer
4k views

How to patch fglrx for installation on kernel 3.7rc7?

For a bug I need to check if a bug still occurs on upstream kernel 3.7rc7, and since the bug is related to fglrx I need to install a newer version as well that work with kernel 3.7. How do I do this ...
1
vote
1answer
3k views

Radeon Xpress 200M with Hardware Acceleration on Ubuntu 12.04

my notebook is running with the ATI Radeon Xpress 200M, which isn't supported by AMD anymore on Linux >2.6.28(fglrx 9.3). I would like to enable hardware acceleration.
1
vote
1answer
3k views

Ubuntu 12.04 amd64 kernel 3.5 and fglrx

Does anyone know how to install fglrx with the 3.5.x kernel? I can live with gallium, an I don't mind dual booting, but I would really love to see better 3D acceleration!
2
votes
1answer
2k views

After installing mainline kernel 3.4.3, why can't I build the AMD graphics binary module? [closed]

I recently updated my Ubuntu 12.04 kernel to 3.4.3-generic, and now my ATI/AMD drivers will not install correctly. AMD Catalyst Control Center is there, and I can open it fine, but it only shows 2D ...
8
votes
4answers
11k views

Ubuntu 12.04 fail to upgrade to kernel 3.4

Last night i intended to upgrade my kernel from 3.2 0-24 to 3.4... I followed the instruction on this Can I install Linux kernel 3.4 in Ubuntu and Kubuntu 12.04?. First i downloaded the kernel deb ...
2
votes
1answer
2k views

FGLRX (Catalyst 11.6) is it compatible with kernel 2.6.39?

I have recently Installed kernel 2.6.39 and also updated the AMD driver to version 11.6, however seems like it's not working. I was hoping that with this new driver AMD had support for the new kernel, ...
2
votes
1answer
444 views

How to solve the problem booting FGLRX 8.780 + Kernel 2.6.35-25? [duplicate]

Possible Duplicate: Boot screen in low graphics/text mode The situation before this all happened is pretty standard. I have a HP Pavillion dv5 laptop with an ATI Mobility Radeon 4200 ...