The Debian package management system that powers most software installs.

learn more… | top users | synonyms

0
votes
1answer
31 views

Virtual box dependency issue

I am newbie in ubunut and I am really confused in the installation of virtual box for college assignments. I am asking this on a new thread intentionally even though many existing threads try to ...
-1
votes
1answer
57 views

New software can't be installed because there is a problem with the software currently installed--trying to install Loggerpro for Ubuntu

When I try to install loggerpro, this is the message I get. I looked on the forum and tried the following commands: sudo apt-get install --reinstall deconf and then it says: unable to access ...
1
vote
2answers
981 views

(K)Ubuntu 16.04 can't install mysql server unmet dependencies

When I try to sudo apt-get install mysql-server I keep getting following error: The following packages have unmet dependencies: mysql-server : Depends: mysql-community-server (= 5.7.12-1ubuntu15....
0
votes
0answers
426 views

Can not install kvm on ubuntu 16.04 LTS

I recently installed Ubuntu 16.04 LTS on my laptop. when I tried installing kvm with **kvm-ok INFO: /dev/kvm exists KVM acceleration can be used** and when I tried installing **sudo apt-get ...
0
votes
0answers
20 views

Problem upgrading unity mail - dpkg error

I was trying to update unity mail but it kept failing saying it couldn't delete packages. I got the following error when I ran sudo apt upgrade and sudo apt install unity-mail Errors were encountered ...
0
votes
0answers
32 views

Cron script runs but dpkg command fails

I have a cron script that updates a package with dpkg. This is an oversimplified version of a much larger script. But this is the part that is not working. I copy the update cron script to /etc/...
0
votes
2answers
376 views

How to install StarUML and it's dependencies?

I just installed Ubuntu 16.04 and want to install StarUML. I downloaded StarUML from http://staruml.io/download/release/v2.0.2/StarUML-v2.0.2-64-bit.deb, then in the terminal: dpkg -i StarUML-v2.0....
0
votes
1answer
28 views

apt-get install fails because of libmagic1

my apt-get install is failing because of following error with respect to libmagic1. My Ubuntu version is 12.04 LTS. Can you please help if anyone aware of it? I need to fix this to update some ...
0
votes
0answers
24 views

How to make pre-depends install packages in debian packaging

I am building a package that depends on package X, Y, Z. So i put them into the control file und der Pre-Depends: X, Y, Z However, this doesn't install the packages it just says my package can't ...
1
vote
1answer
43 views

“loop involving service”: apt-get install breaks dpkg

One apt-get install went bad, now every apt command results in it trying to get apache2 into a consistent state, which of course crashes. I'm not sure that the package that did it matters, but it was ...
0
votes
1answer
34 views

Version range in debian/control

When declaring dependencies in debian/control to create a package, I can specify a lower or upper bound on the version. For example, if I depend on libvtk6-dev being at least version 6.0.0 I can write ...
0
votes
2answers
43 views

add dependency to cuurent kernel version

I want to depend my deb package to current kernel version that is installed on machine. for example if my kernel version is 3.13.0-77 my deb file depends on linux-headers-3.13.0.77-generic if I add "...
0
votes
0answers
12 views

debian package that installs other debian packages

I am trying to get familiar with debian packages and trying a couple of tutorials, so far this is the only one that makes sense and also works. So my goal is to build a package that downloads and ...
1
vote
0answers
60 views

Apt-get install -f and apt-get autoremove error

I've tried to install new software on Ubuntu and it told me to use that command apt-get install -f, but I get back an error message and I have no idea how to fix it. After that, I tried to use apt-...
-2
votes
1answer
27 views

How i can do for know what i have to do i this type of cases: root? [duplicate]

I receive that message when I want install or try to don know that was installed, after it's here : apt-get install linux-generic -(the error)- E: Could not open lock file /var/lib/dpkg/lock - open (...
1
vote
0answers
24 views

kubuntu-desktop dependencies problem, now forbidden icon

A week ago, one of my friends said that the kubuntu-desktop is cool. So I installed it. But now there are dependencies problem with kde-telepathy-minimal, and the forbidden icon turned up and said ...
1
vote
1answer
59 views

What is the difference between deb file and ddeb file in linux?

I need to install SystemTap on Ubuntu 14 and I would need to install debug symbols for kernel . I need brief explanation about ddeb file , why it should have different extension ?
0
votes
1answer
71 views

Unable to install npm on ubuntu 14.04 due to broken packages error

Tried installing npm on ubuntu 14.04 however the following error has occurred gwt@gwt-Aspire-E1-571:~$ sudo apt-get install npm Reading package lists... Done Building dependency tree Reading ...
0
votes
0answers
29 views

Getting this error :Sub-process /usr/bin/dpkg returned an error code (1) when I try to run sudo apt-get install python-matplotlib

I tried installing matplotlib, to make graphs on python on Ubuntu 14.04 and am getting the following error. I am unable to resolve this error: (env)ubuntu@ubuntu-Inspiron-5423:~/tweepy$ sudo apt-get ...
0
votes
0answers
29 views

apt-get gives disk space error but I have plenty of disk space [duplicate]

After a few hours of trying to install a desktop environment, I simply do not understand what I'm doing wrong. After I run sudo apt-get update and sudo apt-get upgrade, I get this error: Do you want ...
1
vote
3answers
786 views

Nginx installation error in Ubuntu 16.04

:~$ sudo apt-get remove nginx* && sudo apt-get install nginx-full* Reading package lists... Done Building dependency tree Reading state information... Done After this operation, 5,579 kB of ...
0
votes
0answers
14 views

java- error regarding /usr/bin/dpkg

yesterday i accidently removed openjdk-7 using autoremove command which removed a lot of other packages resulting broken dependency. i tried to recover but since i am new to ubuntu so i reinstalled ...
2
votes
1answer
186 views

Error installing snap ubuntu 16.04

I get this error when try to install snapd from terminal: Selecting previously unselected package squashfs-tools. (Reading database ... 265122 files and directories currently installed.) Preparing to ...
0
votes
1answer
714 views

Ubuntu 14.04 mysql-client-5.7 dependencies issue on update: Permanent solution?

When I run sudo apt-get update && sudo apt-get upgrade my package system gets broken because of mysql packages. I have tried to unistall the client and all the other packages, then to install ...
0
votes
0answers
13 views

How to install softwares kubuntu 15.10?

whenever I'm using sudo apt-get install software-center or anything else like gedit I'm getting these only Reading package lists... Done Building dependency tree Reading state information... ...
0
votes
0answers
31 views

14.04 hangs, suspicious broken dependency with libefl

Ubuntu's got a broken package dependency and I tried to fix it, but now it won't reboot. I have to admit I haven't been paying as much attention to my Ubuntu server as I should recently even though ...
0
votes
1answer
66 views

'dpkg-source' unpack error on Ubuntu GNOME 16.04

After installing Ubuntu GNOME 16.04 with GNOME 3.20 in a VM I have found that if I run an apt-get source command such as: apt-get source apt I get the following errors after it has downloaded the ...
0
votes
1answer
45 views

Mysql-common cannot be uninstalled

I'm trying to completely uninstall mysql to reinstall it later, after uninstalling all mysql-related packages, mysql-common seems to remain in a broken state. $ sudo dpkg -l | grep mysql pc mysql-...
0
votes
1answer
223 views

I'm getting this error when try to update to php5

When I try to upgrade php from 5.3 to 5.6, this wild error appears Extracting templates from packages: 100% (Reading database ... 98172 files and directories currently installed.) Unpacking apache2-...
0
votes
1answer
43 views

How can I know if some Ubuntu 10.04 packages are still available in Ubuntu 14.04?

I have an Ubuntu 10.04 running on a server. I know that it isn't supported anymore, so I want to upgrade it to Ubuntu 14.04. I have had problems trying to do this (in a testing environment, of course)...
4
votes
4answers
5k views

“google-chrome-stable depends on libstdc++6 (>= 4.8.0); however: Version of libstdc++6 on system is 4.6.3-1ubuntu5.”

I am trying to install google-chrome-stable on a fresh ubuntu 12.04 installation. I run the following commands wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb sudo dpkg ...
1
vote
0answers
38 views

Why is dpkg -i faster than the ubuntu software center?

Why is using sudo dpkg -i package.deb to install deb packages faster than double clicking on the deb file and installing it through the software center? I have seen a very significant time gap ...
0
votes
1answer
39 views

Problem with sudo apt-get upgrade

It tells me to try to run apt-get -f install. The error says "Unmet dependencies. Try using -f." When I try sudo apt-get -f install I get an error that says dpkg-deb: error: subprocess paste was ...
1
vote
1answer
92 views

Error while installing Adobe Acroread in Ubuntu 15.10

I am getting following error while installing Adobe Acroread in Ubuntu 15.10: xyz@abc:~$ sudo dpkg -i /home/shiva/acroread-bin_9.5.5-1raring1_i386.deb (Reading database ... 442228 files and ...
0
votes
0answers
13 views

DNS issues when ever I switch networks

I am having DNS issues, where when ever I switch networks, I can only access IP addresses, no domain names. I then run: $ sudo dpkg-reconfigure resolvconf which allows me to then start using the ...
0
votes
2answers
40 views

Getting following error while installing `cowsay` [duplicate]

I tried to install cowsay using the command: sudo apt-get install cowsay I received the following error message: E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily ...
3
votes
1answer
41 views

Which old kernel related files can I safely delete?

I frequently run into the issue described in Not enough free disk space when upgrading, because the boot partition created by the Ubuntu installation is too small. When cleaning up as described in the ...
0
votes
1answer
61 views

Help! I can't install anything because of subprocess error [SOLVED]

I don't know what happened but suddenly with no reason no apps and packages could get installed. When i want to install a package with sudo apt-get install <package> I get this error: mpiuser@...
1
vote
0answers
127 views

Unable to install anything using apt-get

I looked through some threads and couldn't find a solution, apologies if this is a duplicate. After messing up an installation of some package (see below), attempting to install anything yields: $ ...
1
vote
0answers
265 views

Mysql database browsers not working after upgrade

I needed version 5.7 of mysql server for a project. I upgraded from version 5.5 to 5.7 using this tutorial. The upgrade was successful and I am able to use the updated version via command line. ...
0
votes
0answers
27 views

dpkg: error processing package rsyslog (--configure): •

Rsyslog is getting uninstalled easily but when I tried reinstalling rsyslog, the installation is having following errors. I am having ubuntu 14.10 which is 32 bit Operating system and kernel version ...
1
vote
0answers
47 views

var lock issue right after installing JDK and soapUI on my machine

I have been dealing with an issue all day here. I cannot seem to have apt-get work for anything whatsoever. I have been through several parameters here including trying these following solutions: ...
1
vote
1answer
58 views

cant use apache2 in ubuntu 14.04

I need to install apache2 on my ubuntu system. On running the command: sudo apt-get install apache2 I get this error: Some packages could not be installed. This may mean that you have ...
0
votes
0answers
16 views

Haveing trouble installing veil-eversion

After this operation, 1,157 MB of additional disk space will be used. Do you want to continue? [Y/n] Y Extracting templates from packages: 100% Preconfiguring packages ... dpkg: error processing ...
0
votes
1answer
30 views

to remove broken packages 14.04

I want to remove/reinstall the broken package libopenni-sensor-primesense0 I have tried all commands i.e sudo aptitude install <packagename> sudo aptitude -f install <packagename> sudo ...
0
votes
1answer
55 views

Error while upgrading from 15.04 to 15.10

while running the upgrade a pop-up window appeared with the message "The upgrade has aborted. Your system could be in an unusable state. A recovery will run now (dpkg --configure -a)." After ...
0
votes
0answers
97 views

dpkg: error processing package at (--configure)

This is the full error message I am receiving when trying to install any new packages. I tried purging/removing the "at" package but those actions were overrided. I'm relatively new to linux/ubuntu ...
3
votes
1answer
192 views

GLEW from apt-get have no include files

enviroment info:ubuntu 14.04 LTS I just sudo apt-get install glew-utils. But when I find / -name "*glew*" I got someting like this: /usr/share/doc/libglewmx1.10 /usr/share/doc/glew-utils /usr/share/...
0
votes
0answers
45 views

install a package in deb file

I created a bash script with various customization in config files in my.cnf of mysql and other things. I need to create a deb package where I need to install mysql-server,mysql-client at first. I ...
0
votes
0answers
25 views

How do I update an application manually?

Two cases: I have installed an application directly using the .deb file. Now there is a new version (i.e. new .deb file). How do I update the current version (and not install the new version in ...