The Debian package management system that powers most software installs.

learn more… | top users | synonyms

8
votes
4answers
9k views

Find (and reinstall) packages with corrupted files (without breaking anything)

I usually prefer to fix a Linux system than to reinstall from scratch. My computers have seen many distribution upgrades and a list of PPAs or third-party repositories. APT usually makes sure that ...
10
votes
1answer
15k views

Force apt-get to overwrite file installed by another package

(I realize a similar question was asked before but the answers there don't handle these details) I'm on Ubuntu 10.10 and need both python2.5 (coming from deadnsakes -- ...
3
votes
3answers
627 views

How to find the most recent version of a package in the repositories?

How do I find the most recent version of a package in the repositories in a shell script? If I use apt-cache-policy, I get the installed version as "Candidate", not the most recent one from the ...
1
vote
1answer
4k views

How to download a package for offline installation? [duplicate]

Possible Duplicate: How can I install software offline? sudo apt-get install {x} ex: X = ghdl I want download the package "X" to my USB . How can I do that ? Second, my computer ...
19
votes
2answers
16k views

dpkg: error: parsing file '/var/lib/dpkg/available' near line 0

Been trying to install git-core package for almost more than half a day now. Everytime i do, I get this error: dpkg: error: parsing file '/var/lib/dpkg/available' near line 0: newline in field name ...
5
votes
3answers
3k views

How to cleanly remove a badly installed .deb?

Whenever I try to use dpkg or apt-get, I get the warning: dpkg: warning: parsing file '/var/lib/dpkg/available' near line 12674 package 'jarnal': error in Version string 'build901': version number ...
3
votes
1answer
191 views

What can I use to install a package file with dependency from command line?

I want to install my project's debian package from a shell script. For that I'm using the command sudo dpkg -i my_project_0.1.deb. But it's not going to install dependency. I've also tried sudo dpkg ...
26
votes
7answers
18k views

Is it possible to install a .deb from a URL?

Is there a way to install a deb package directly from a URL, using a shell? Something like dpkg -i http://domain.com/path/to/package.deb (I know I could use wget and then dpkg, I'm just wondering ...
5
votes
1answer
5k views

Can't upgrade packages, it gets stuck on openjdk-6-jre-headless

I am using Ubuntu Maverick (server). When I run: apt-get upgrade it gets stuck on: Setting up openjdk-6-jre-headless (6b20-1.9.7-0ubuntu1) ... Why? And what can I do to stop it? I tried ...
0
votes
1answer
491 views

dpkg: error processing ttf-droid (--remove) [closed]

I have been installing various applications on my Ubuntu 10.10 laptop and I've been noticing a common theme. There is always an error in the terminal at the end of the install and it is as follows: ...
4
votes
0answers
11k views

How can I clean up `/var/lib/dpkg/status`? [duplicate]

Possible Duplicate: How do I rebuild a corrupt dpkg status file? My system constantly complains about errors in my dpkg status file, and nothing I have tried from the internet seems to ...
4
votes
1answer
456 views

Recompile all packages and trigger on updates

I am using Ubuntu on a bespoke router and after seeing the latency drops capable with custom compiling on Gentoo, I would like to recompile all packages with CFLAGS="-march=atom". The guide for this ...
2
votes
1answer
64 views

dpkg --print-avail PACKAGE fails

I just happened to notice that dpkg --print-avail PACKAGE (same as dpkg -p PACKAGE) is failing on my Ubuntu 10.04.2 server. Should I be concerned? For example: $ dpkg -p a2ps Package `a2ps' is not ...
1
vote
1answer
1k views

KPackageKit stuck with ttf-mscorefonts-installer package

When I try to install any package or even apply updates, the installer try to install ttf-mscorefonts-installer package at the end and fails with error: One of the selected packages failed to ...
1
vote
1answer
3k views

fakeroot debian/rules binary error

I have a package I'm maintaining. When I issue "fakeroot debian/rules binary" I get this error: dh_install --sourcedir=debian/tmp cp: cannot stat `debian/tmp/usr/share/prg/1.svg': No such file or ...
0
votes
2answers
391 views

Unity is disturbed after a partial upgrade

I had upgraded my workstation from Maverick to Natty. I switched to unity after this upgrade and was quite happy. In the last week of May, 2011 update manager proposed a partial upgrade. After the ...
1
vote
0answers
961 views

Upgrading to 10.10 [closed]

Hey guys, Ive had some problems with my linux system, slowly been figuring things out. But im quite stumped on this problem, ill copy a section of code for you... Errors were encountered while ...
1
vote
1answer
43 views

If I add some packages to “Recommends:”, will apps pull them in with the update?

I have a quesion about Debian packaging. I know that if I make a package depend on a larger number of packages then before, the newly introduced dependencies will be automatically downloaded by almost ...
18
votes
3answers
8k views

How to list packages from a ppa/source in command line?

I want to list all the files from a source, say extras.ubuntu.com from the command line. What is the command for that? dpkg --list lists all files or just the filename.
3
votes
3answers
3k views

How to get dpkg working again?

i tried to install sqlite3 on ubuntu 10.04 by typing: sudo apt-get install sqlite3 this gave me the message E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the ...
93
votes
7answers
99k views

How to let `dpkg -i` install dependencies for me?

Say, I have foo-1.2.3.deb which depends on perl and python, however, running command: dpkg -i ./foo-1.2.3.deb won't install these dependencies. So I must apt-get install perl python by hand. How ...
1
vote
1answer
1k views

Upgrading to Ubuntu 11.04 failed

Today Ubuntu asked me to upgrade to 11.04. The installation went completely fine until right at the end when the following packages failed: install-info ubuntu-standard The installer hung so I had ...
4
votes
1answer
3k views

dump dpkg package list for fresh installation [duplicate]

Possible Duplicate: Best way to backup all settings, list of installed packages, tweaks, etc? I've heard that I can dump the dpkg package list of currently installed applications, then ...
0
votes
1answer
546 views

Package Manager Error: setting up language-selector-common

I'm using Ubuntu 10.04 and I wanted to install python-setuptools package. So I did a sudo apt-get install python-setuptools In the command line and It downloaded the package and went on to the ...
1
vote
1answer
172 views

Dependecies not met — language-selector

uri@uri-MS-7267:~$ LANG=c sudo dpkg --configure -a [sudo] password for uri: Setting up language-selector-common (0.6.7) ... dpkg: error processing language-selector-common (--configure): subprocess ...
10
votes
2answers
29k views

How force remove when post-installation script always fail

I have a custom package installed on my Ubuntu 10.10, and trying to remove it, I got: $ sudo dpkg -r package sub-process script post-installation installed returne an error state 127 (the message ...
1
vote
0answers
513 views

Ubuntu on a a stick, fails to upgrade kernel [closed]

I was told to run sudo dpkg --configure -a by ubuntu when I tried installing something with apt-get, it proceeded to try to install a new kernel but that failed. I'm perplexed as to why that happens ...
1
vote
0answers
185 views

unity.desktop xession file [closed]

I'm missing my unity.desktop xsession file. Can someone plese help me by posting their so I can se how it should look like? Bonus question: How does it get installed in the first place? dpkg -L ...
2
votes
0answers
596 views

Creating .deb with javahelper [closed]

I have already lost the full day trying to figure out what I'm doing bad. I can't package my Java application into .deb package. The steps I'm doing are: 1) Copy the src files into folder with name: ...
3
votes
4answers
7k views

Update manager can not open due to missing /var/lib/dpkg/status

Update manger won't open saying E: could not open file/var/lib/dpkg/status - open(2: No such file or directory), E:the package lists or status file could not be parsed or opened. what to do?
4
votes
3answers
31k views

How to repair apt-get command?

When I try to install new package with apt-get install, it doesn't work. apt-get update doesn't work too. Do you know how to reinstall it to work again? Output from sudo dpkg --configure -a : dpkg: ...
37
votes
1answer
5k views

How to create a meta-package that automatically installs other packages?

I'd like to be able to create a package that doesnt contain any code or programs itself, but instead installs other packages that exist in the repositories onto a computer, sort of how the ...
1
vote
1answer
661 views

How do I fix my package state after the installation process (dpkg) was interrupted? [duplicate]

I got the following message when I tried to open update. E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. E: _cache->open() failed, please ...
119
votes
5answers
120k views

How do I get a list of installed files from a package?

I want to know where I can find my installed application when I installed it on Ubuntu using package manager. I installed RabbitMQ and ran locate rabbitmq which gave me following result: ...
2
votes
0answers
544 views

After update: `/var/lib/dpkg/tmp.ci/md5sums': Is a directory [closed]

after updating my system today the following showed up. This is the result of running apt-get install -f: Reading package lists... Done Building dependency tree Reading state ...
2
votes
1answer
2k views

apt-get install problem: Errors were encountered while processing: sun-j2sdk1.6

I have the following problem every time i run apt-get install: for example : installing python-django-south ... Unpacking python-django-south (from .../python-django-south_0.5-2_all.deb) ... Setting ...
3
votes
1answer
2k views

Update/Installs fails with unrecoverable dpkg fatal error because libc6-i386 is missing

I keep receiving this error every-time I try to do some updates. I tried sudo dpkg --configure, sudo apt-get update and sudo apt-get install -f but they failed on me. installArchives() failed: ...
1
vote
1answer
53 views

File added to project doesn't get added to packages

I'm creating customized binary versions of OpenStack nova packages (lp:nova) using their packaging scripts (lp:~openstack-ubuntu-packagers/ubuntu/natty/nova/ubuntu). I create binaries by doing: ...
3
votes
2answers
443 views

Can I install Debian Unstable Scala 2.8.1 package in Ubuntu? Won't it cause problems?

I am coding Scala and would like an up-to-date 2.8.1 of it to be installed in my Ubuntu 10.10 system, but there is only obsolete 2.7 package available in Ubuntu repositories, so I have to go ...
5
votes
2answers
2k views

How to trick apt dependencies? [duplicate]

Possible Duplicate: How to create a meta-package that automatically installs other packages? I want to use Frescobaldi (an editor for Lilypond), but the packaged release of lilypond ...
2
votes
1answer
623 views

How to fix a broken Adobe Air package? [duplicate]

I'm using 64 bit version of Ubuntu 10.10 and have some problems with broken dependencies. I needed Adobe Air but it was not availble via apt-get, so I downloaded it from Adobe and installed. Then I ...
0
votes
2answers
159 views

dpkg snippet isn't working for me when fixing / installing dockbar

I'm trying to use this code from webupd8 to fix the problem I have. It seems it didn't work. sudo dpkg -i --force-overwrite /var/cache/apt/archives/smplayer_0.6.9+svn3595-1ppa1~maverick1_i386.deb ...
1
vote
2answers
183 views

Recovering package metadata info

From the console, is there a way to recover the architecture of a package when it is not currently installed ? I know the name and version of the package.
4
votes
1answer
104 views

Will packages work with older Ubuntu releases?

E.g., will Natty packages work on Maverick?
1
vote
1answer
6k views

How to install an older version of Java

I updated my installation of the sun-java6-jdk package today to version 6.24-1build0.10.10.1 after being prompted by the update manager. However this now causes some compilation failures so I'd like ...
24
votes
3answers
6k views

apt-get vs. aptitude .vs synaptic compatibility

I had been a Debian user for almost 3 years... but memories have gone really fuzzy... I "kind of" remember that I should only use one of the package managers... Either apt-get, aptitude, or synaptic, ...
2
votes
1answer
2k views

Multiple Depends/Recommends/[…] in a control file?

Is it possible to have multiple lines for any type of field in a dpkg control file? This is not about line continuation, but e.g. Depends interspersed with Recommends like so: Depends: git, ...
5
votes
1answer
87 views

How to find and back up only files not part of a package

How can I find a list of every file that is modified or added outside the debian package management system? Cruft is unmaintained and doesn't know about the way today's debian package management ...
5
votes
3answers
325 views

Find minimal equivalent of packages currently installed

I have used a tool that calculates the minimal set of packages you can install to get the current set of packages you have. This is different than telling you what your selections are. It literally ...
2
votes
1answer
311 views

Packages not showing up in created APT repository

I created an APT repository using deb-scanpackages, and it seemed to go well. When I did a apt-get update on another server, the Packages.gz file was retrieved, and all seemed well - until I went to ...