For questions about how to revert to an earlier version of a package or an earlier versions of Ubuntu.

learn more… | top users | synonyms

69
votes
5answers
86k views

How to Downgrade a Package via apt-get?

How to downgrade a package to an older version via apt-get?! Another tools are also accepted but apt-get is preferred.
20
votes
6answers
19k views

How do I downgrade to Subversion 1.6?

I'm trying to downgrade subversion to 1.6 from 1.7, doing sudo apt-get install subversion=1.6.17dfsg-3ubuntu3 does not seem to work, any idea on how to do this without breaking half the instalation? ...
14
votes
5answers
56k views

How to downgrade from PHP 5.4 to 5.3

Recently I upgraded PHP to 5.4, but it seems to be failing on me because APC isn't working with it, however this gave me no choice but to downgrade to 5.3, how can I do this? I executed apt-get ...
10
votes
6answers
10k views

I need downgrade from Subversion 1.8 to subversion 1.7

I've upgraded system from 13.10 to 14.04 LTS Now I need downgrade from Subversion 1.8 to Subversion 1.7, because formats 1.7 vs 1.8 are different and I can not access to svn repo of my team. I've ...
10
votes
2answers
6k views

How to downgrade packages on Ubuntu?

Update Manager keeps packages at the latest version, but occasionally a new package version may not work as expected or properly. How to downgrade an installed package and lock it at a specific ...
10
votes
2answers
8k views

How do I downgrade a package?

I just upgraded to Firefox 5 to find out that Selenium does not work on it. I'd like to downgrade to Firefox 4 but haven't found a way to do this. How do you downgrade to Firefox 4 on 11.04? Thanks ...
9
votes
4answers
4k views

downgrade ppa packages to versions available at a previous point in time

The backstory is that the normal Intel GPU drivers don't do the various OpenGL extensions that my hobby coding and some games want. So I have to install xorg-edgers and then its happy. However, last ...
8
votes
2answers
2k views

How can I downgrade packages without removing their dependants?

I have a number of mesa packages that I had upgraded to a PPA version, before purging the PPA so I could upgrade my system. The differences in the versions are minor (they are technically the same, ...
7
votes
4answers
14k views

downgrade php5 5.5.3 to php5 5.3 in ubuntu 13.10

I just upgraded to ubuntu 13.10.. I was working on a project that uses php 5.3 and now phpmyadmin is not working and when i try to open a page i see a ton of warning and the sign in page doesnt sign ...
6
votes
2answers
21k views

How can I remove new kernel versions after downgrading?

i have some problem. First i upgraded ubuntu to 12.04 and all of packages. But after that i have a lot of problems so i decided to downgrade to 11.10. After i did that i have two kernels 3.2.x and ...
6
votes
3answers
1k views

Error while purging PPA from Unity 5.0 testing repository [duplicate]

Possible Duplicate: How do I reinstall Unity? I installed Unity 5.0 to test it but I am having many problems with it, for example, the lenses don't work. But when I tried to downgrade, it ...
6
votes
2answers
2k views

How can I ensure I am running the current stock kernel?

At some point, I installed a new kernel, for no particular purpose but to try. I am having some problems, and would like to ensure that they are not caused by the kernel I installed. How can I ...
6
votes
1answer
3k views

How to install keryx?

How to install keryx in ubuntu 12.04? knowing that keryx1.0 needs python <2.7 and ubuntu 12.04 has python2.7.3 so what could i do either to downgrade python or installing keryx bas some way. Also ...
6
votes
3answers
17k views

Downgrade PHP Version from 5.5 to 5.4 on Ubuntu 14.04

First time I've ever needed to ask a question here that I don't think has already been answered. I've recently been working on transferring over a vBulletin site I run to a new server. Thinking that ...
5
votes
3answers
8k views

Downgrade PHP to PHP5.2?

I want to install PHP 5.2 in Ubuntu 11.04 , I had some script that did that thing good but only on Ubuntu 9, anyone has a script / instructions how to do it?
5
votes
1answer
12k views

what is the right way to downgrade kernel

I decide to downgrade kernel version due to unsolvable problem with wifi. Ubuntu version is 12.10, kernel version is 3.5. In http://packages.ubuntu.com/precise/kernel/ I found the previous kernel ...
5
votes
1answer
855 views

How do I export banshee library settings to another machine?

I am trying to downgrade my distro. The thing is, I have spent some few hours organising my music library and I do not want to lose my database. I have checked 'write meta data to files'. And so, my ...
5
votes
3answers
1k views

How do I remove Kernel 3.1 that I added via a PPA?

Is there a way to remove kernel 3.1 from Oneiric? I downloaded and upgraded to 3.1 with these instructions: Open the terminal and run these two commands for both 32-bit and 64-bit versions of ...
4
votes
2answers
11k views

How to install old AMD Catalyst 12.4 drivers on Ubuntu 12.10?

I have an ATi Radeon HD 3650 AGP, which does not support 12.8 and 12.9 drivers. The latest supported version is 12.4, but Catalyst 12.4 does not support Ubuntu 12.10. How can I downgrade to 12.4 or ...
4
votes
2answers
2k views

How to re-install GIMP 2.6 after trying GIMP 2.8?

Ok... I tried GIMP 2.8, but felt more comfortable with 2.6. I removed the PPA's from Ubuntu Software Centre, removed and purged GIMP, and even rm the .gimp-2.8 folder. But when I go to install GIMP ...
4
votes
1answer
14k views

How do I downgrade kernel on 12.10?

I did a fresh installation of Ubuntun 12.10 (kernel v3.5.0.21-generic, 64 bit, US English) on my computer after downloading the ISO from Ubuntu.com. In order for one of my installed programs to work, ...
4
votes
5answers
763 views

How do I stop update manager trying to downgrade my 3.4 kernel to 3.2?

I installed the 3.4 kernel for hardware support reasons, and everything is working swimmingly.. but UpdateManager keeps prompting me to install the 3.2 kernel again. Is there a way to stop it doing ...
4
votes
1answer
13k views

Downgrade from 14.04 to 12.04 [duplicate]

I recently installed version 14.04 on ubuntu laptop and sadly regretted it. Is it possible to downgrade back to 12.04 and if so, how? Thanks
4
votes
1answer
884 views

How to build a particular version of gcc (4.5.1)?

In my office we have gcc-4.5.1, with that version my c++ project works fine. If I compile the same project at home with Ubuntu 12.04 with gcc-4.6, I have lot of errors and I couldn't compile at all. ...
4
votes
2answers
6k views

How can I roll back xserver-xorg-core and xserver-common?

A recent update to Xorg broke my desktop, which now looks like this: In short, the desktop background is not updating on the secondary display. (And if there is no secondary display, the primary ...
4
votes
0answers
1k views

downgrading ubuntu from 11.10 to 10.04 [duplicate]

Possible Duplicate: How to roll back Ubuntu to a previous version? I have windows 7 installed on my C drive, ubuntu 11.10 installed on my D drive and then there are couple of more ...
4
votes
0answers
2k views

How to go from 11.04 to 10.04 [duplicate]

Possible Duplicate: How to roll back Ubuntu to a previous version? Ok, so I was running fine on 10.04 then I thought "why not upgrade to 11.04" So I did and a some bad stuff happened. Once ...
3
votes
2answers
2k views

How to downgrade Firefox from 30 to 28?

I've accidentally sudo apt-get upgrade (while c/p-ing instructions to do something and failing to notice that it isn't sudo apt-get update) and it upgraded Firefox from 28 to 30. Now my menus are ...
3
votes
2answers
1k views

Can I use an older version of LibreOffice?

Quantal has 3.6. I feel that the new version is heavier - at least for my specs. (Beside having this problem). How could I install an older version of LibreOffice?
3
votes
1answer
492 views

Use Old GCC Version

I've been trying to get an old version of GCC for my Ubuntu but I can't find any working way to achieve that. I'd like to use the version 4.1.2 of GCC, and I currently got the 4.7.2. How may I ...
3
votes
1answer
12k views

How to downgrade Oracle Java 7 to Java 6?

I recently changed my Wubi install into a full install, which runs a lot smoother than Wubi. I had to re-install all my stuff, because I did it the lazy-man's way, and after reinstalling Java, I ...
3
votes
2answers
5k views

How to downgrade Flash from 11.x to 10.3

Ubuntu v11.10 Adobe stripped gpu hardware acceleration from flash 11 due to security concerns. That's great, but I'd like to the accelerated video that Flash 10.3 affords on my nettop. The problem ...
3
votes
2answers
553 views

Can I downgrade compiz?

I'm just wondering if it is possible to downgrade compiz to maverick's version 0.8.6 like in natty? I have an ATI radeon mobile 3200/4330 dual GPU and the new compiz and even natty's compiz doesn't ...
3
votes
2answers
823 views

How to downgrade gtk+2.0 package to workaround bug #693758?

As it seems that I've been hit by the bug #693758 I am willing to downgrade gtk+.2.0 from 2.23.3 to 2.23.2. But it seems that I have no package with such a name in my system :-( how do I downgrade it ...
3
votes
1answer
738 views

How do I re-install 11.10 and wipe out 12.04?

I have had nothing but problems with 12.04 and want to return to 11.04. I do not want to try to fix it at this time and want to go back to what worked well for me. Can someone point me to the ...
3
votes
3answers
2k views

How to downgrade from LibreOffice 4.0 to 3.6?

How to "properly" downgrade LibreOffice versions deals with a downgrade from 3.5 to 3.4.*. Is there any way to nicely downgrade LibreOffice 4.0 to 3.6? The latter is not in the package ...
2
votes
3answers
4k views

How to revert an update?

The latest xorg update was a big regression for me on a dual display setup. Is there a simple way to revert to the previous version? I'm on Lucid Lynx.
2
votes
2answers
796 views

I need Mercurial 1.8.x back

I'm getting Mercurial from this PPA: https://launchpad.net/~mercurial-ppa/+archive/releases/+packages?field.name_filter=mercurial&field.status_filter=&field.series_filter= The Eclipse plugin ...
2
votes
2answers
2k views

How can I downgrade to an older Opera version?

I once installed Opera by adding their repository to my sources.list: deb http://deb.opera.com/opera/ stable non-free #Opera Since then I get regular updates via the usual "apt-get update ...
2
votes
1answer
6k views

How to downgrade PHP from 5.5.9 to 5.4 in Ubuntu 14.04 (Installed with LAMP)

I need to downgrade my PHP version from 5.5.9 to 5.4 (using Ubuntu 14.04), because I have a code that's using mySQL (which is deprecated in 5.5.9), and I cannot change that code. Is there a way to do ...
2
votes
1answer
218 views

How to use a old version of Unity in newer versions of Ubuntu?

How can I use the older version of unity (4.03) found in ubuntu 11.10 on Ubuntu 13.04? I understand that the new unity (7) has more improvements, but I just prefer the one in Ubuntu 11.10. Is it ...
2
votes
1answer
7k views

Can I downgrade 12.10 back to 12.04? [duplicate]

Possible Duplicate: How to roll back Ubuntu to a previous version? I have had nothing but problems with my box since I upgraded to 12.10. I'd like to go back to 12.04 (I had no problems at ...
2
votes
9answers
14k views

How to downgrade PHP from 5.3.x to 5.2.x

I need to downgrade my PHP to 5.2.x from 5.3.x Certain software I currently use requires it. I found all these link explaining how to do it but they no longer work because they show you how to use ...
2
votes
1answer
3k views

How to install firefox 20 in Ubuntu 12.04

I am using Firefox version 21, but it is too slow and many a time hangs the system. I want to downgrade my Firefox to version 20. Please tell me how to install through ppa repository or other ...
2
votes
1answer
334 views

How can I downgrade a system that accidentally had backports installed?

I installed a fresh Ubuntu system. Somehow - possibly through my own error - the backports repository got enabled. Then I did several upgrades. I noticed that this happened when networking suddenly ...
2
votes
1answer
162 views

Need to downgrade a package with many dependents

In order to get a working low-power video card setup I decided to use a custom xserver from Andrikos:ppa. It worked well, but when the official release caught up to the bug fixes I dried to drop the ...
2
votes
2answers
4k views

how can i downgrade from 12.04.3 kernel and it's xservers to 12.04.2 ones?

Hi how can i get back (downgrade) from 12.04.3 kernel and it's xservers to 12.04.2 ones? i have some problems with 12.04.3 kernel and want to downgrade.
2
votes
1answer
478 views

Downgrading nVidia driver problem

I have been experiencing the bug mentioned here. People have reported downgrading their driver to 290.10 prevented the issue for them so I tried this but I am not sure whether I have installed the ...
2
votes
3answers
2k views

How to downgrade Compiz to 0.8.6 in Ubuntu 12.04?

Is there a safe way to downgrade Compiz to 0.8.6 in Ubuntu 12.04? I don't want to use Unity anymore and due to bug #862430 and bug #933776 Compiz is unusable for me. I would appreciate any ...
2
votes
2answers
2k views

How to downgrade WINE?

Some Windows applications work better under an older version of WINE. From time to time it is even necessary to use a previous WINE version in order to get an application to start. However, the ...