For questions about how to revert to an earlier version of a package or an earlier versions of Ubuntu.

learn more… | top users | synonyms

4
votes
1answer
42 views

Apt doesn't want to install an older version of package

I'm building a debian package from the source code. The package has, among the others, the following dependency (part of debian/control): libswarm-dev (>= 0.6.1.0), libswarm-dev (<< 0.7), ...
1
vote
1answer
126 views

Downgrade from PHP 5.6 to 5.5

I need to downgrade my PHP from 5.6 to 5.5 Here is what I've done so far sudo aptitude purge `dpkg -l | grep php| awk '{print $2}' |tr "\n" " "` Then sudo apt-get install ...
1
vote
1answer
1k views

Downgrading libxml2 on 12.04

For some reason, on one of the servers that we have in our network running Ubuntu Server 12.04, the version of libxml2 is 2.8.0 (which is the one from Ubuntu 12.10). This creates some issues, ...
1
vote
1answer
46 views

Is there a way to install a package available in Ubuntu Karmic on Ubuntu Precise Pangolin?

I want to install gfortran-4.4.1 on Ubuntu 12.04 (Precise Pangolin). But the only versions available in repositories are 4.4.7, 4.5 and 4.6. However gfortran-4.4.1 can be easily installed via apt-get ...
1
vote
1answer
103 views

How to reset the channels and get back to the stable release

I am unable to update, and add repos. I upgraded to Ubuntu 13.10, but it now says I am using the developmental trusty channels, and I need some advice on how to reset the channels and get back to the ...
1
vote
1answer
1k views

How to downgrade VLC 2.0.1 to 1.1.x?

I haven't added any VLC PPA's and I have no clue how to solve this problem. If it's not possible to downgrade VLC, Running VLC in a portable mode is sufficient for me. I need the older version only ...
0
votes
1answer
607 views

Can I downgrade the kernel on Ubuntu 14.04.2?

I have an application that works fine on 14.04.1 but does not work fine on 14.04.2. I found a bug report that indicates the newer kernel in 14.04.2 is the source of this issue. Is possible to ...
0
votes
1answer
322 views

Fail to boot after downgrading from ubuntu 15.10 to 14.04lts

I can see only "Reboot and select proper device" on laptop startup. Here is my partition configs http://paste.ubuntu.com/10963438/ My laptop model is asus x553m. I need your help!
0
votes
1answer
59 views

How can i downgrade a package installed from source?

i installed glib2.42 from source but that's creating a problem for me. So i tried to downgrade it running make uninstall and installed glib2.28 afterwards. But now when i try to build a software using ...
0
votes
1answer
44 views

How to force apt-get to skip a package version

There is an excellent answer here on how to downgrade a package, but I would like to know how to force apt-get and Software Updater to skip a version. For example, the current release of Firefox is ...
0
votes
1answer
643 views

How to downgrade HWE?

I was running Ubuntu 12.04 LTS and was accepting all suggested upgrades. About a week ago I was prompted to upgrade the Hardware Enablement Stack because it was going out of support. So I did and I ...
0
votes
1answer
1k views

Downgrade Ubuntu 12.04 kernel to 2.6.x

I currently have the most up-to-date kernel (Linux user-desktop 3.2.0-67-generic #101-Ubuntu SMP Tue Jul 15 17:46:11 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux) of Ubuntu 12.04 on my x86_64 computer, but ...
0
votes
1answer
215 views

Apache Ant downgrade

I need Apache Ant 1.8 on my Ubuntu 14. But there is only one version available: $ apt-cache madison ant ant | 1.9.3-2build1 | http://de.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages ...
0
votes
1answer
575 views

Is there a way to downgrade or upgrade Samba in Trusty?

Logged a bug here: https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1318840 "Excel Mac open files as read-only on Samba 4.1.6-ubuntu" We didn't have this problem in Precise. I'd either like to: ...
0
votes
1answer
428 views

Ubuntu 14.04 asks to downgrade packages?

I'm new to ubuntu, so please excuse any naive questions. After a fresh install of 14.04, I was adding apps from the Software Center, but most of them continued to fail because "Package Dependencies ...
0
votes
1answer
306 views

How to downgrade the Thunderbird

I am using Thunderbird 24.2.0 and Ubuntu 13.10. I want to downgrade to the Thunderbird Version 17.0.11esr. http://www.mozilla.org/en-US/thunderbird/organizations/all-esr.html How can I do this? ...
0
votes
1answer
66 views

What Libre Office PPAs are available?

I think that I have to downgrade from LibreOffice 4.1.0.4 because of the bug in the time display. My previous version was 3.5.4. Is the 3.5.4 PPA still available? Do any of the versions between ...
0
votes
1answer
608 views

Is it safe to downgrade libgl1-mesa-glx?

I am trying to install qt-sdk but get the following error: The following packages have unmet dependencies: qt-sdk : Depends: libqt4-opengl-dev but it is not going to be installed E: Unable to ...
0
votes
1answer
1k views

How to upgrade back to xorg 1.13 after downgrade to 1.12 in ubuntu 12.10?

I had to downgrade Xorg from 1.13 to 1.12 in order to use the fglrx-legacy but it (fglrx-legacy) didn't work for me neither fglrx. So, is it possible to upgrade Xorg back to 1.13? and how?
0
votes
1answer
707 views

Downgrading a package and dependencies

I want to downgrade libcairo2 to the version from Precise (I'm running Quantal). I've added the precise source to my sources.list and can do 'apt-get install libcairo2=', but it's going to remove some ...
0
votes
1answer
330 views

Is it safe to downgrade X?

I have an old graphics-card which needs the nvidia-96 drivers. But the drivers need xorg-video-abi-10 to be installed, and my version of Ubuntu (Precise) has (i think) an newer version, because that ...
0
votes
1answer
188 views

How to use a driver for Ubuntu with a higher kernel version(2.6.36) on ubuntu with lower kernel version (2.6.30))

I want to use EASYCAP on my Ubuntu(kernel version 2.6.30). The problem is that ,the drivers for EASYCAP are included in kernel version 2.6.36 and higher. I have extracted all the files corresponding ...
0
votes
1answer
582 views

How can I downgrade a PPA package to the official version?

I have ppa:cr3/ppa in my sources list. It upgrades my checkbox, checkbox-gtk, and checkbox-qt packages to version 0.14~ppa6.12.04. And now I have problems with updating my system, and sometimes ...
0
votes
1answer
179 views

reinstall previous version on dual boot system

So, I tried to upgrade from 11.10 to 12.04 on a dual boot system but Ubuntu will not load. I then tried to boot from a USB stick with "start-up disc creator" and a 12.04 iso image(BIOS set to boot ...
-1
votes
1answer
257 views

Downgrade PHP from 5.5.9 to 5.2.4

I want to downgrade PHP for testing purpose. How i can safely do it? I have Distributor ID: Ubuntu Description: Ubuntu 14.04.1 LTS Release: 14.04 Codename: trusty
4
votes
0answers
77 views

Is there Ubuntu's analogue of snapshot.debian.org?

Debian users have a kind of "wayback machine": snapshot.debian.org , which is really great. There are regressions sometimes, and if I don't have local deb package with old version, I'm getting sad ...
2
votes
0answers
2k views

Ubuntu Server Install Old Version of Firefox

What is the best way to go back a version of Firefox on Ubuntu server. This is a server without a GUI so command line is the only thing that can be used. Also once you install that old version how do ...
1
vote
0answers
95 views

How to downgrade svn working copy with svn version?

I have downgrade my svn from version 1.8 to 1.7.9. Now When i type command like: svn info svn up or any other commands it give an error that: svn: E155021: This client is too old to work with the ...
1
vote
0answers
203 views

Downgrading hostapd didn't help!

I was searching through the forums to find a solution for the ap-hotspot error - the one that hangs at Starting wireless hotspot... By now I've tried several solutions including downgrading hostapd ...
1
vote
0answers
50 views

Downgrade all external packages to the official ones

Let's say I installed bunch of packages from external PPA repositories and they modified or replaced the existing default packages in the system. Assume that then I remove those PPAs from the ...
1
vote
0answers
262 views

How do I downgrade php5.5.3 to 5.4?

I am trying to downgrade php from 5.5.3 to 5.4. I tried to find a 5.4 version using aptitude versions php5-common Package php5-common: p A 5.5.3+dfsg-1ubuntu2 saucy ...
1
vote
0answers
640 views

PHP 5.1.6 on Ubuntu

I want to install PHP 5.1.6 on Ubuntu in order to work on legacy PHP application. How can I install PHP 5.1.6 on Ubuntu. I have tried to install 11.10 and followed many online resources to get it ...
1
vote
0answers
98 views

Install unity 7.1.2 in ubuntu 12.04, is possible?

I have upgraded Ubuntu 13.04 to 13.10. I like very more the default unity interface. The command unity --version return unity 7.1.2. The problem in Ubuntu 13.10 is than I give errors on installation ...
0
votes
0answers
158 views

Downgrade back to stock 3.16 kernel from 3.18.5 on Ubuntu 14.10

I upgraded the kernel to 3.18.5 for my Xbox One controller to use it, but I guess I failed because after I rebooted my laptop, it did a login loop after I logged in. Then I installed the kernel ...
0
votes
0answers
24 views

No USB ports working after updates

All usb ports stopped working. I observe the light coming out of the mouse and it stops lighting when that nvidia splash screen comes. (which I've never seen before) Apparently it is the graphics ...
0
votes
0answers
198 views

Downgrading GDB from 7.7.1 to 6.8 in Ubuntu 14.04

I currently have GDB version 7.7.1 installed on my system. However, for the combination of Eclipse and a software package called openFOAM (version 2.3.1) I need to downgrade the GDB version to 6.8 in ...
0
votes
0answers
259 views

Dual screens nvidia-331 ubuntu 14.04

I am trying to configure Ubuntu 14.04 to work with two screens. I have a laptop that uses Nvidia Prime 740M and an Intel graphics card. I am using Nvidia 331.113 driver presently. When trying to ...
0
votes
0answers
41 views

how to downgrade related packages together?

Related Question : downgrade a package The situation is a bit different, I have a group of packages say aaa-*.deb which was involved in the down grade. obviously I don't want to deal with them one ...
0
votes
0answers
102 views

Downgrade from dev to stable (GLIBC_2.19 to GLIBC_2.17)

just wondering if I could get some help here, at the minute my VPS has GLIBC_2.19 and I donot want that. I need GLIBC_2.17. I believe GLIBC_2.19 is a dev package. I am a newby to Linux so take it ...