Questions concerning package dependencies, in dpkg/apt, which are used as Ubuntu's package manager.

learn more… | top users | synonyms (1)

199
votes
13answers
193k views

How do I resolve unmet dependencies?

How do I resolve unmet package dependencies? Occasionally, when I'm installing stuff, I get an error like the following: Some packages could not be installed. This may mean that you have requested ...
41
votes
5answers
56k views

How to automatically fetch missing dependencies when installing software from .deb?

I'm trying to install MySQL Workbench on my Ubuntu box (11.04). The website has a Ubuntu .deb available for download (for 10.10 and 10.04 so I chose 10.10). However, sudo dpkg -i ...
28
votes
3answers
24k views

How can I install a package without installing some dependencies?

I'm trying to install the package LaTeXila, and the output looks like this: $ sudo apt-get install latexila --no-install-recommends Reading package lists... Done Building dependency tree ...
23
votes
4answers
16k views

How to list package dependencies (reverse dependencies)? [duplicate]

In order to research what caused the installation of a given package, I'd like to get a list of packages which depend on that package. I couldn't find anything obvious in man dpkg.
22
votes
4answers
2k views

Can I see why a package is installed?

For a specific package, can I find out why it is installed? So, can I see or it's manually installed, or that it is installed as a dependency of another package? Or that it is installed as part of ...
21
votes
6answers
41k views

How to install Google-Earth 64bit in Ubuntu 13.10, ia32-libs Dependency error

I want to install Google-Earth & it requires ia32-libs. So, I did apt-get install ia32-libs but error pops as Reading package lists... Done Building dependency tree Reading state information... ...
21
votes
2answers
8k views

How do I find the build dependencies of a package?

I'd like to find out which packages sudo apt-get build-dep <package> would install (if I already got some dependencies installed, I'd also like to see those → so running or simulating the ...
20
votes
3answers
13k views

How to reinstall Terminal?

While fixing package dependencies, the terminal application went missing, and now I cannot locate the application. Is there a way to reinstall the terminal application?
17
votes
5answers
26k views

How to remove an uninstalled package's dependencies?

I want to install a package (DigiKam), but it has a lot of dependencies. If I decide I no longer need this software and uninstall it, will the now unnessary dependencies be removed? If not, how can I ...
17
votes
1answer
799 views

How can I find out why a package was installed?

How can I find out why a particular package was installed? Is it part of the default installation? Was it specified manually, or was it chosen automatically to meet dependencies? Which packages are ...
15
votes
4answers
721 views

Why are softwares not packaged in a single file?

We see Most of the Windows softwares are packaged in a single executable file. When I double-click Setup file, it sets up all the files, binaries and libraries with it. I understand the dependency ...
15
votes
5answers
11k views

How to install only the dependencies of a package?

Running sudo apt-get install <PACKAGE> will install the package, its dependencies, and any other recommended packages. However, there does not seem to be a way to install only the dependencies ...
14
votes
2answers
115k views

Install gcc on Ubuntu 12.04 LTS

When I try to install gcc on Ubuntu 12.04 LTS Server with apt-get install gcc, I get the following error: The following packages have unmet dependencies: gcc : Depends: cpp (>= 4:4.6.1-2ubuntu5) ...
14
votes
5answers
16k views

How to remove a deb without removing its dependencies

I would like to install the most recent version of boto, which I do via python setup.py install Yet when I try to remove the old version the following packages also get removed: apt-get remove ...
14
votes
4answers
15k views

Google Chrome update won't install due to unmet dependencies

There was an update for Google Chrome today, and it wasn't installable due to unresolved dependencies. How can I correct this?
14
votes
2answers
260 views

Why do some commercial apps have a section called 'also requires' and free apps don't?

In the Ubuntu Software Center paid (commercial) applications get a section called 'Also requires' which is quite neat. Why don't the free applications get this feature? For example Amnesia: The Dark ...
12
votes
5answers
32k views

How can I completely remove xfce4 when apt-get remove --purge doesn't work?

Starting with a Ubuntu server, I wanted a window manager, so I installed xfce4. I used sudo apt-get install xfce4 to do this. To remove it, I used sudo apt-get remove --purge xfce4 which ...
12
votes
17answers
37k views

How do I install Draftsight CAD?

I've installed the 11.04 64bit version and now i can't install Draftsight (32bit with force architecture option) because there is an error with the library libexpat1.. anyone know how solve? ...
12
votes
4answers
35k views

Do Dpkg and apt-get install dependencies?

I've been wondering, is there a way to tell dpkg or apt-get that when I want to install a package also install all the dependencies it requires? I installed a package using dpkg but it complained ...
12
votes
1answer
600 views

Why is plymouth required?

Why is plymouth so important that cannot be removed on ubuntu desktop 11.04? It has priority required and mountall and cryptsetup depend on it. I do not have really any need to remove it, but a ...
12
votes
1answer
135 views

How to add dependency after submitting a proprietary app to USC?

I submitted my app "Brightness Controller" under proprietary license and it has been published. It contains an executable .py file. But the app depends on python-wxgtk2.8 I wrote it in the comments ...
11
votes
2answers
1k views

How Can I Remove Epiphany Without Removing Gnome?

I have Gnome Shell installed, and I want to remove the Epiphany browser. But when I click uninstall in the software center its says that Gnome-core is a dependency of Epiphany, so it will be ...
10
votes
1answer
840 views

How to upload package with dependencies to my PPA?

I made a package for my PPA and uploaded it. It built without any problems. Then I made another package that depended on the first and uploaded it. It failed because it couldn't find the files in the ...
9
votes
1answer
2k views

Dependency Walker for ubuntu

Is there a tool like Windows DependencyWalker for Ubuntu ? I would like to see all shared libraries my executable depends on.
9
votes
5answers
9k views

Cannot install icaclient due to problem with ia32-libs

Finally, Citrix released a new version and Ubuntu updated their guide HERE (apparently, it were the dependecy changes as we found out). It should work now kind of out of the box. I have a problem ...
8
votes
2answers
1k views

Installing particular versions when repo has newer versions?

Let's have a metapackage which depends on the following packages Depends: A (=2), B (=2), C (=2) Note the '=' - I want to install these particular versions, not the most recent ones. ...
8
votes
2answers
554 views

How can I downgrade packages without removing their dependants?

I have a number of mesa packages that I had upgraded to a PPA version, before purging the PPA so I could upgrade my system. The differences in the versions are minor (they are technically the same, ...
7
votes
2answers
11k views

“Depends: ia32-libs-multiarch but it is not installable” - Solution

I noticed this on 12.10 trying to get the Android SDK working. For 64 bit versions, it is required to install: sudo apt-get install ia32-libs However, under 64bit 12.10, I got the following error: ...
7
votes
1answer
9k views

I cannot install any package (linux-image-server, linux-server dependencies errors) [duplicate]

I'm very new to Ubuntu and I messed up something and I cannot install any packages with apt-get install. Initially I got this error: The following packages have unmet dependencies: ...
7
votes
2answers
1k views

How to visually display dependencies of a package?

This is just for fun and curiosity: is there a tool using which I can visually see the dependencies of a package as a graph? That is, the packages that a given package depends on. This can be a ...
7
votes
3answers
10k views

Dependency Problems installing Google Chrome package due to xdg-utils error

Trying to install Google Chrome on my fresh Ubuntu 12.04 install. I have run a full apt-get upgrade and apt-get update on this system before installing Chrome. I downloaded the 32-bit deb package from ...
7
votes
2answers
554 views

How do I build Nautilus 3.70/3.80 from source?

I've upgraded nautilus on my PC to 3.60 with the nice sidebar, but I'm finding the lack of recursive search difficult. I've downloaded Nautilus 3.7.5 and 3.7.1 which have replaced the recursive search ...
6
votes
3answers
8k views

Adobe reader x64 missing dependencies

I get the error after executing acroread: acroread: error while loading shared libraries: libxml2.so.2: cannot open shared object file: No such file or directory
6
votes
4answers
461 views

Is it safe to change my Lucid sources to Maverick, to get one app, then revert to Lucid?

I am considering to temporarily change my repositories to Maverick, on a Lucid system. I want to install a newer version of Evolution because it has a particular feature I want. I don't want to ...
6
votes
3answers
3k views

How can I determine why apt-get will install a package?

This question is similar to How can I find out why a package was installed?, but in my case I'd like to know before actually installing a package, why it will install a particular dependency. So for ...
6
votes
3answers
481 views

Why do many GNOME application packages depend on `libunity9`?

When investigating this question, I discovered that many GNOME applications' packages depend on the libunity9 package. If I try to uninstall libunity9 on Precise, it tries to uninstall lots of ...
6
votes
3answers
688 views

meta-package dependencies

I've got a pure vanilla Lucid Desktop installation on a severely RAM limited laptop (with a slow drive for extra happy swapping). I'm trying to remove packages that snuck in on ubuntu-desktop which I ...
6
votes
3answers
3k views

GIMP Package broken, Ubuntu Software centre not working

I'm using Ubuntu 11.10 and have installed GIMP last night. But today, my update manager is showing that your system has broken packages and dependencies. When I try to install the GIMP update that is ...
6
votes
2answers
99 views

How can I specify a dependency between 2 versions of a package?

In a debian/control file, how do I specify a dependency on a package between 2 versions of that package? For example: python 2.5 or higher but lower than python 2.7. Depends: python ...
6
votes
2answers
156 views

How to upgrade a particular package dependencies only?

Let's say I have a package A which has Depends: B (>= 1.0.0) in its control file. The B was installed as an A dependency some time ago with 1.0.0 version. Now B was updated in the repository to ...
6
votes
2answers
6k views

I downloaded Dwarf Fortress. Why won't it run?

I downloaded the version of Dwarf Fortress for Linux onto my computer, but when I click on the df file, it doesn't do anything. When I run it in a terminal, it gives me this message: error while ...
6
votes
2answers
306 views

Is there a way to test packages I build for correct dependencies?

I'm absolutely new to packaging, so forgive me if I am asking something obvious for an experienced packager... How can I be sure that mentioned all the dependencies correctly in my package? Say that ...
6
votes
3answers
2k views

Problems with QML Tool Kit Installation: “unmet dependencies: qt-components-ubuntu: … ”

I am following the directions on the page for Ubuntu App Development: http://developer.ubuntu.com/get-started/gomobile/ Command 1: sudo add-apt-repository ppa:canonical-qt5-edgers/qt5-beta1 ...
5
votes
6answers
2k views

Why does removing Firefox install another browser?

I want to remove firefox (with sudo apt-get purge firefox*) but without installing the epiphany browser. how to do it? PS : I want to remove firefox becouse I want to use and only use google-chrome ...
5
votes
4answers
17k views

'teamviewer depends on (…)' while trying to install TeamViewer

I recently got Ubuntu installed on my server, I wanted to install TeamViewer so i could easy manage the virtual machines, However, I get errors when installing it from App store?, And I also get ...
5
votes
3answers
7k views

How do I install Steam 64-bit when package dependencies cannot be resolved?

I'm currently running Ubuntu 12.10 on Wubi, and am trying to install Steam. Notably, when I am trying to "buy" steam from the store, it reads Package Dependencies cannot be resolved This ...
5
votes
1answer
856 views

How to create a .deb file with dependency?

I have a game made with the LÖVE framework and i want it into a .deb file so it can be easily installed by others and easily findable through the Unity dash for example. I also have the LÖVE framework ...
5
votes
4answers
1k views

Avoiding installation of certain dependency packages (texlive)

As Ubuntu's TeXLive is quite old (version 2009), I always hear TeX people recommending installing the latest TeXLive directly from CTAN. (Yes, I need the same package mentioned in that question.) I ...
5
votes
2answers
4k views

How to install upstart?

I use ubuntu 10.04. I install upstart with failed dependencies. sam@sam-desktop:~$ sudo apt-get install upstart Reading package lists... Done Building dependency tree Reading state ...
5
votes
2answers
14k views

Cannot install Skype due to dependency errors; dpkg doesn't install dependencies [closed]

I'm trying to install the newest Skype version (4.1) on my Linux. I have downloaded the skype-ubuntu-lucid_4.1.0.20-1_i386.deb package from the official Skype site. I removed all installed versions ...