Questions concerning software and package dependencies.

learn more… | top users | synonyms (1)

330
votes
15answers
424k views

How do I resolve unmet dependencies after adding a PPA?

Occasionally, when I'm installing stuff, I get an error like the following: Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the ...
70
votes
7answers
122k views

How to automatically fetch missing dependencies when installing software from .deb? [duplicate]

I'm trying to install MySQL Workbench on my Ubuntu box (11.04). The website has a Ubuntu .deb available for download (for 10.10 and 10.04 so I chose 10.10). However, sudo dpkg -i ...
55
votes
5answers
6k views

Can I see why a package is installed?

For a specific package, can I find out why it is installed? So, can I see or it's manually installed, or that it is installed as a dependency of another package? Or that it is installed as part of ...
51
votes
3answers
48k views

How can I install a package without installing some dependencies?

I'm trying to install the package LaTeXila, and the output looks like this: $ sudo apt-get install latexila --no-install-recommends Reading package lists... Done Building dependency tree ...
47
votes
4answers
49k views

How to list dependent packages (reverse dependencies)? [duplicate]

In order to research what caused the installation of a given package, I'd like to get a list of packages which depend on that package. I couldn't find anything obvious in man dpkg.
31
votes
3answers
16k views

How do I find the build dependencies of a package?

I'd like to find out which packages sudo apt-get build-dep <package> would install (if I already got some dependencies installed, I'd also like to see those → so running or simulating the ...
27
votes
5answers
32k views

Replace openjdk with oracle-jdk on Ubuntu

I have an ubuntu system and I want to replace my openjdk with oracle-jdk. However if I remove my open-jdk and then install oracle-jdk, when I try to install some packages they want to install ...
27
votes
6answers
54k views

How to install Google-Earth 64bit in Ubuntu 13.10, ia32-libs Dependency error

I want to install Google-Earth & it requires ia32-libs. So, I did apt-get install ia32-libs but error pops as: Reading package lists... Done Building dependency tree Reading state ...
26
votes
5answers
52k views

How to remove an uninstalled package's dependencies?

I want to install a package (DigiKam), but it has a lot of dependencies. If I decide I no longer need this software and uninstall it, will the now unnessary dependencies be removed? If not, how can I ...
24
votes
3answers
189k views

Install gcc on Ubuntu 12.04 LTS

When I try to install gcc on Ubuntu 12.04 LTS Server with apt-get install gcc, I get the following error: The following packages have unmet dependencies: gcc : Depends: cpp (>= 4:4.6.1-2ubuntu5) ...
22
votes
3answers
37k views

How to reinstall Terminal?

While fixing package dependencies, the terminal application went missing, and now I cannot locate the application. Is there a way to reinstall the terminal application?
21
votes
5answers
18k views

How to install only the dependencies of a package?

Running sudo apt-get install <PACKAGE> will install the package, its dependencies, and any other recommended packages. However, there does not seem to be a way to install only the dependencies ...
21
votes
0answers
1k views

How can I find out why a package was installed? [duplicate]

How can I find out why a particular package was installed? Is it part of the default installation? Was it specified manually, or was it chosen automatically to meet dependencies? Which packages are ...
19
votes
3answers
4k views

Why are there so many 32-bit dependencies for Skype?

When installing Skype, whether it's by running (after enabling the partner repository): sudo apt-get install skype Or installing it from the .deb file that you get from the Skype website. I always ...
19
votes
6answers
28k views

How to remove a deb without removing its dependencies

I would like to install the most recent version of boto, which I do via python setup.py install Yet when I try to remove the old version the following packages also get removed: apt-get remove ...
15
votes
4answers
740 views

Why are softwares not packaged in a single file?

We see Most of the Windows softwares are packaged in a single executable file. When I double-click Setup file, it sets up all the files, binaries and libraries with it. I understand the dependency ...
15
votes
2answers
3k views

How to visually display dependencies of a package?

This is just for fun and curiosity: is there a tool using which I can visually see the dependencies of a package as a graph? That is, the packages that a given package depends on. This can be a ...
14
votes
5answers
24k views

Steam Install Error on 14.04 Ubuntu 64bit

I have tried some of the solutions posted elsewhere in the support forum, one seemed like it worked but after a steam update i found myself back at square one I am a new Linux user and am already at ...
14
votes
4answers
18k views

Google Chrome update won't install due to unmet dependencies

There was an update for Google Chrome today, and it wasn't installable due to unresolved dependencies. How can I correct this?
14
votes
2answers
268 views

Why do some commercial apps have a section called 'also requires' and free apps don't?

In the Ubuntu Software Center paid (commercial) applications get a section called 'Also requires' which is quite neat. Why don't the free applications get this feature? For example Amnesia: The Dark ...
13
votes
4answers
42k views

Do Dpkg and apt-get install dependencies?

I've been wondering, is there a way to tell dpkg or apt-get that when I want to install a package also install all the dependencies it requires? I installed a package using dpkg but it complained ...
13
votes
1answer
1k views

How to upload package with dependencies to my PPA?

I made a package for my PPA and uploaded it. It built without any problems. Then I made another package that depended on the first and uploaded it. It failed because it couldn't find the files in the ...
13
votes
1answer
788 views

Why is plymouth required?

Why is plymouth so important that cannot be removed on ubuntu desktop 11.04? It has priority required and mountall and cryptsetup depend on it. I do not have really any need to remove it, but a ...
12
votes
18answers
41k views

How do I install Draftsight CAD?

I've installed the 11.04 64bit version and now i can't install Draftsight (32bit with force architecture option) because there is an error with the library libexpat1.. anyone know how solve? ...
12
votes
2answers
8k views

How can I downgrade packages without removing their dependants?

I have a number of mesa packages that I had upgraded to a PPA version, before purging the PPA so I could upgrade my system. The differences in the versions are minor (they are technically the same, ...
12
votes
1answer
144 views

How to add dependency after submitting a proprietary app to USC?

I submitted my app "Brightness Controller" under proprietary license and it has been published. It contains an executable .py file. But the app depends on python-wxgtk2.8 I wrote it in the comments ...
11
votes
4answers
12k views

Can't install libglew-dev because libcheese and libclutter don't have the required versions

I'm getting the following error message when attempting to install libglew-dev, Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not ...
11
votes
2answers
3k views

How Can I Remove Epiphany Without Removing Gnome?

I have Gnome Shell installed, and I want to remove the Epiphany browser. But when I click uninstall in the software center its says that Gnome-core is a dependency of Epiphany, so it will be ...
10
votes
1answer
568 views

Not able to install VLC and other programs due to strange dependency problems [duplicate]

The following packages have unmet dependencies: vlc : Depends: vlc-nox (= 2.1.4+git20150226+r54594+19+11~ubuntu14.04.1) but it is not going to be installed Depends: libsdl-image1.2 (>= ...
10
votes
1answer
4k views

Dependency Walker for ubuntu

Is there a tool like Windows DependencyWalker for Ubuntu ? I would like to see all shared libraries my executable depends on.
10
votes
2answers
2k views

Installing particular versions when repo has newer versions?

Let's have a metapackage which depends on the following packages Depends: A (=2), B (=2), C (=2) Note the '=' - I want to install these particular versions, not the most recent ones. ...
10
votes
2answers
205 views

Ubuntu source package dependency tree

I have some packages. Let's call them A.deb, B.deb and C.deb. Each package has a corresponding source package A.dsc and A.tar.gz, B.dsc and B.tar.gz, C.dsc and C.tar.gz. The packages depend on each ...
10
votes
1answer
162 views

Why does Virtual Box uninstall gnome-terminal?

For some reason, virtual box 5 after installing it from their website uninstalls gnome-terminal, and when I reinstall gnome-terminal, it uninstalls virtual box. What's going on? Also, installing ...
9
votes
3answers
12k views

Ubuntu 14.04, problem when install gstreamer1.0-libav, unmet dependencies

Suddenly my Ubuntu stopped playing video. When I open a video, the player suggests that I install gstreamer1.0-libav. However, it fails to install. I tried installing it manually, here is the error ...
9
votes
5answers
11k views

Cannot install icaclient due to problem with ia32-libs

Finally, Citrix released a new version and Ubuntu updated their guide HERE (apparently, it were the dependecy changes as we found out). It should work now kind of out of the box. I have a problem ...
8
votes
3answers
11k views

Adobe reader x64 missing dependencies

I get the error after executing acroread: acroread: error while loading shared libraries: libxml2.so.2: cannot open shared object file: No such file or directory
8
votes
2answers
17k views

“Depends: ia32-libs-multiarch but it is not installable” - Solution

I noticed this on 12.10 trying to get the Android SDK working. For 64 bit versions, it is required to install: sudo apt-get install ia32-libs However, under 64bit 12.10, I got the following error: ...
8
votes
1answer
13k views

I cannot install any package (linux-image-server, linux-server dependencies errors) [duplicate]

I'm very new to Ubuntu and I messed up something and I cannot install any packages with apt-get install. Initially I got this error: The following packages have unmet dependencies: ...
8
votes
3answers
15k views

Dependency Problems installing Google Chrome package due to xdg-utils error

Trying to install Google Chrome on my fresh Ubuntu 12.04 install. I have run a full apt-get upgrade and apt-get update on this system before installing Chrome. I downloaded the 32-bit deb package from ...
8
votes
2answers
5k views

FGLRX won't install: Unable to correct problems, you have held broken packages

When I run sudo apt-get install fglrx, I get the following output: Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be ...
7
votes
2answers
3k views

Unable to install Springseed 2 on Ubuntu 15.04

I've downloaded Springseed 2 deb file and when I open it by Ubuntu Software Center, it shows this error: Dependency is not satisfiable: libgcrypt11 I've looked for this package in my Synaptic ...
7
votes
3answers
5k views

How can I determine why apt-get will install a package?

This question is similar to How can I find out why a package was installed?, but in my case I'd like to know before actually installing a package, why it will install a particular dependency. So for ...
7
votes
2answers
8k views

I downloaded Dwarf Fortress. Why won't it run?

I downloaded the version of Dwarf Fortress for Linux onto my computer, but when I click on the df file, it doesn't do anything. When I run it in a terminal, it gives me this message: error while ...
7
votes
2answers
176 views

How can I specify a dependency between 2 versions of a package?

In a debian/control file, how do I specify a dependency on a package between 2 versions of that package? For example: python 2.5 or higher but lower than python 2.7. Depends: python ...
7
votes
1answer
37 views

Question regarding removing source files after building

I've been building a lot of software from source as I've been wanting to learn it for quite a while now. The following happens: Download source files (normally a tarball file) Install dependencies ...
7
votes
2answers
790 views

How do I build Nautilus 3.70/3.80 from source?

I've upgraded nautilus on my PC to 3.60 with the nice sidebar, but I'm finding the lack of recursive search difficult. I've downloaded Nautilus 3.7.5 and 3.7.1 which have replaced the recursive search ...
6
votes
4answers
466 views

Is it safe to change my Lucid sources to Maverick, to get one app, then revert to Lucid?

I am considering to temporarily change my repositories to Maverick, on a Lucid system. I want to install a newer version of Evolution because it has a particular feature I want. I don't want to ...
6
votes
3answers
663 views

Why do many GNOME application packages depend on `libunity9`?

When investigating this question, I discovered that many GNOME applications' packages depend on the libunity9 package. If I try to uninstall libunity9 on Precise, it tries to uninstall lots of ...
6
votes
3answers
11k views

How do I install Steam 64-bit when package dependencies cannot be resolved?

I'm currently running Ubuntu 12.10 on Wubi, and am trying to install Steam. Notably, when I am trying to "buy" steam from the store, it reads Package Dependencies cannot be resolved This ...
6
votes
3answers
718 views

meta-package dependencies

I've got a pure vanilla Lucid Desktop installation on a severely RAM limited laptop (with a slow drive for extra happy swapping). I'm trying to remove packages that snuck in on ubuntu-desktop which I ...