Questions concerning software and package dependencies.

learn more… | top users | synonyms (1)

2
votes
1answer
338 views

Update Manager crashes, says it needs 3.2.0.58.69 but linux-image-generic on system is 3.2.0.59.70 [duplicate]

Recently Update Manager ceased working. Ubuntu Software Centre, when I enter it instead, offers to repair, then fails and offers to repair again, and so on. This is the key sentence I keep getting ...
2
votes
1answer
1k views

Unable to resolve missing qt4 dependecies after installing Armory and PPAs for Bitcoins

I've decided to make a wallet trough Armory so I can transfer Bitcoins to cold storage, so I went to install Armory. Now, Armory installed all well and good and than asked me to install PPAs, which I ...
2
votes
2answers
523 views

Adding KDE Backports PPA has caused unmet dependencies. How to fix?

I added ppa:kubuntu-ppa/backports in the usual way, then performed a dist-upgrade. It needed to download over gigabyte of files, so I left if for the afternoon. Upon my return, I found that the system ...
2
votes
1answer
297 views

Cannot install libgtkmm-2.4-dev in Kubuntu 13.10 - unmet dependencies

I'm trying to install grub-customizer in Kubuntu 13.10. After a lot of fiddling, following various online advice, I got to the point where I needed to install libgtkmm-2.4-dev (which I know nothing ...
2
votes
1answer
2k views

Installing Cinnamon 2 on Ubuntu 13.04

I recently upgraded to Ubuntu 13.04, from 12.04 (via 12.10) where I had been using Cinnamon 1.8. Post-upgrade I have tried unsuccessfully to re-install Cinnamon. I have tried: From the 13.04 ...
2
votes
1answer
628 views

Unmet Dependencies for handbrake-gtk

I have reviewed the suggestions at [How do I resolve unmet dependencies?]. As yet, my issue remains. Here's hoping the good folk here can help me. sudo apt-get install handbrake-gtk ...
2
votes
1answer
781 views

I cannot run DOSBox SVN-Daum on Ubuntu 12.04

I've got the DOSBox SVN-Duam from its homepage. Maybe I have solved the dependency problems, $ ldd ./dosbox linux-gate.so.1 => (0xb776d000) libSDL_sound-1.0.so.1 => ...
2
votes
1answer
812 views

Old ubuntu 10.10 [closed]

Explanation: I have a VPS that comes with ubuntu 10.10. I'm using it for a webserver that runs a bunch of sites. My problem is that I cannot upgrade the distribution (which I really want) . I ...
2
votes
1answer
333 views

Dependency errors on installing Banshee

I just installed Ubuntu 12.10 (Verified the ISO hash as well). The VERY first thing I did was open the software centre and try to install banshee. I am met with the following error: The following ...
2
votes
1answer
4k views

How to install iodbc in Ubuntu 12.10

I need to install the library iodbc (depends on libodbc2) in my Quantal machine. Yet there is creepy dependency problem. This was replaced somehow by unixodbc which I don't have, installed. Here is ...
2
votes
1answer
866 views

Problems updating and re-installing VLC in Ubuntu 11.10

I can't seem to fix or update, upgrade VLC at all; this is what I get when trying to install, I had VLC before, but was not working properly so I uninstalled it; then I tried to install it again to ...
2
votes
2answers
17k views

Missing /lib/libc.so.6

Software that I'm installing requires /lib/libc.so.6, but it's not in place: $> ls -l /lib/libc* lrwxrwxrwx 1 root root 14 2011-10-09 06:02 /lib/libcap.so.2 -> libcap.so.2.20 -rw-r--r-- 1 ...
2
votes
2answers
111 views

dpkg dependencies for a custom Ubuntu CD

Recently I have been working on some projects where I need to add extra packages to default Ubuntu install CDs. I have managed to add these packages successfully and make their icons show up on the ...
2
votes
3answers
2k views

Graphics corrupt after upgrade from 11.10 to 12.04

I'm stuck at the moment with an ubuntu that boots into an unusable white screen after upgrading from 11.10 to 12.04. I've tried booting into safe X mode but it just throws me back to the safe menu ...
2
votes
1answer
4k views

Canot resolve package dependencies

Ive fresh installed ubuntu 12.04 and wanted to look for updates. An error occurred and asked if i want to repair dependencies. So I did what it asked for but it failed again and again and again. Same ...
2
votes
1answer
2k views

Folding@Home missing dependency for libssl.so.1.0.0 et alii

I'm trying to run F@H on my Maverick machine. I've downloaded and installed the three .deb files from their official download page (fahclient_7.1.52_i386.deb, fahcontrol_7.1.52-1_all.deb and ...
2
votes
1answer
706 views

Help finding missing mumble-server dependencies

I'm trying to install the mumble-server package using apt-get install mumble-server on Ubuntu 11.10 Server Edition on Rackspace Cloud. Problem is it can't find dependencies it should have found ...
2
votes
1answer
715 views

Adding apt-get packages to a usb boot drive (and storing them on the drive)?

I want to compile some 3rd party software and install it on a bootable usb drive...there are several packages that I need to install with apt-get before I compile it. How could I store the apt-get ...
2
votes
2answers
824 views

How do I install TweetDeck?

See question here: ===============> http://superuser.com/questions/218868/tweetdeck-adobe-air-on-ubuntu-10-10 Getting the issue: sudo apt-get install Reading package lists... Done Building ...
2
votes
1answer
50 views

How can I repair broken softwares?

I want to install ffmpeg as Documented here . but some errors are accurates when I want install on terminal: The following packages have unmet dependencies: libfaac-dev : Depends: libfaac0 (= ...
2
votes
1answer
174 views

Downloading DeSmuME (Gtk) Error

I went to install DeSmuME (Gtk) (Nintendo Ds Emulator) and I encountered error message. $ sudo apt-get install desmume The following packages have unmet dependencies: desmume: Depends: libasound2 ...
2
votes
0answers
29 views

Monodevelop installation issues [closed]

I am unable to install monodevelop on ubuntu 12.10. I am getting the following error. any help is appreciated. revathi@revathi-AcerLaptop:~$ sudo apt-get install monodevelop-current [sudo] password ...
2
votes
1answer
147 views

Why doesn't “apt-get autoremove” remove all installed dependencies?

Installing libav-tools and ubuntu-restricted-extras also installs these new packages: cabextract chromium-codecs-ffmpeg-extra freepats gstreamer0.10-fluendo-mp3 gstreamer0.10-plugins-bad ...
2
votes
3answers
277 views

Can't install anything from the terminal of software center in 15.04

A while back I installed some software (I think it was some SDK software) and it didn't work so I removed it. Ever since I have been having problems with Ubuntu. That was back in 14.10 and I was ...
2
votes
0answers
399 views

Still can't install wine since Ubuntu 14.04

I have been reading countless questions regarding issues about Wine on 14.04, and despite all that, I still can't install/compile it on my machine. While you do have a lot of duplicate questions about ...
2
votes
0answers
1k views

fresh install, python-software-properties unmet dependencies

attention: This might be more a question for "gis.stackexchange" but it is Ubuntu-related Geonode 2.0 is available for Ubuntu 12.04 but not for Ubuntu 14.04. According to the docs it should be ...
2
votes
3answers
6k views

How to install needed Qt packages to build kernel on 14.04?

I'm going to compile kernel on Ubuntu 14.04 64-bit, so I start with installing packages that I need: sudo apt-get install build-essential bin86 kernel-package libqt3-headers libqt3-mt-dev wget ...
2
votes
0answers
139 views

“Depends: ___ but ___-saucy is to be installed” type broken dependencies after Trusty upgrade

The installer threw an error near the end of the 14.04 Trusty upgrade. unity-control-center is not installed and upon trying to install it I now have a chain of broken dependencies which, after going ...
2
votes
0answers
395 views

After updating the system to 14.04, an application fails due to lack of libpng15. How do i obtain it?

After updating my Kubuntu to 14.04, one of applications (the "King Arthur's Gold" indie game) would fail due to lack of libpng15 in the system. The error message is: [13:47:13] PNG warning: ...
2
votes
0answers
587 views

Broken package problem while installing open source AMD ATI drivers in 14.04

After purging the fglrx* packages, I tried this - ankit@ubuntu:~$ sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:amd64 ...
2
votes
1answer
902 views

How to remove acroread [duplicate]

After trying to install Acroread I did try to to remove it, with no success, the message follows. Please help me because the software center was disabled as the result sudo apt-get remove acroread ...
2
votes
1answer
524 views

upgrade from 13.04 to 13.10 failed and broken dependencies

I tried running the upgrade from my Ubuntu 13.04 to 13.10 but it failed to upgrade a latex package with the error from [here] (Upgrading from 13.04 to 13.10 stops) and calmed to try to roll back. ...
2
votes
0answers
272 views

dpkg Unmet dependency linux-image-generic 13.10

I've upgraded a few of my boxes to 13.10 and have started to see the following error on them when running apt-get update and apt-get upgrade: Setting up linux-image-3.11.0-13-generic (3.11.0-13.20) ...
2
votes
2answers
5k views

Depends on lib32gcc1 , libc6-i386 , can't install neither [duplicate]

I tried to install catalyst for my Radeon Graphics on 13.10 , but looks like everything went wrong . Now I can't install any software , and the software center says : The following packages have ...
2
votes
1answer
3k views

Try to install gnome shell in saucy

I try to install gnome-shell in saucy but it won't work. And I installed the 13.10 in parallels desktop on a Mac. sudo apt-get install gnome-shell Reading package lists... Done Building dependency ...
2
votes
0answers
357 views

“Package 'build-essential' has no installation candidate” while installing build-essential [closed]

I have tried following command and it is showing me error: sudo apt-get install build-essential Results: Reading package lists... Done Building dependency tree Reading state information... ...
2
votes
1answer
331 views

Error installing Ubuntu software - Package dependencies cannot be resolved

I switched to Ubuntu from Windows, but I am not able to install any software on it. Whenever I install it gives the following error : Package dependencies cannot be resolved This error could be ...
2
votes
1answer
2k views

Problem installing vlc 12.04 broken dependencies

I am trying to install vlc on my Gateway netbook running 12.04 through wubi but whether I try using terminal or the software center I get this error message. The following packages have unmet ...
2
votes
2answers
2k views

Kolab groupware(Mail Server) fails to install because of dependency problems

I need some help. I'm trying to setup a kolab sever to be used by computer science students at my college, starting this fall. I had a bit of some trouble setting up ldap, bur after some experimenting ...
2
votes
1answer
281 views

How to update Twidge 1.0.8 form repositories to 1.1.0 from GitHub?

I would like to install Twidge 1.1.0, but only 1.0.8 is available in repositories and this version is not compatible with new Twitter API and it's not usable anymore. 1.1.0 is available in Debian sid, ...
2
votes
1answer
570 views

How to make a dependency to the latest version of boost?

I'm packaging a couple of libraries that have some dependencies with one-another. To simplify, let's say I have: libA and libB. libB depends on libA for both building and installing. libA depends ...
2
votes
0answers
17 views

Unmet dependencies (libgssapi-krb5-2: Depends: libkrb5-3 (= 1.10.1 + dfsg-4) but 1:10 + dfsg ~ beta1-2 is installed) [duplicate]

How do I solve this dependency? root @ server :/ # apt-get upgrade Reading package lists ... ready Building dependency tree Reading state information ... ready You might want to run `apt-get-f ...
2
votes
0answers
292 views

declaring dependencies in upstart

It seems as if the accepted way to specify a dependency of service A on service B in upstart is to work in the reverse dependency direction: give service B a start on starting A stanza. I'd like to ...
2
votes
2answers
7k views

How to solve unmet dependencies when installing Nvidia drivers?

I keep getting this error when I try running sudo apt-get install nvidia-current: Reading package lists... Done Building dependency tree Reading state information... Done Some packages could ...
2
votes
1answer
249 views

Building debian package - How do dependencies work?

I'm in the process of building a debian package. The goal is to package up a directory into a .deb that will have 2 dependencies that are other packages I created. When installing the .deb package, ...
2
votes
0answers
27 views

Ubuntu server 12.04 dependency issues when attempting update [duplicate]

I'm having issues updating packages on an Ubuntu Server instance running 12.04. When running apt-get upgrade: Reading package lists... Done Building dependency tree Reading state ...
2
votes
0answers
597 views

Cannot install libglade2-ruby dependency for Grism

Hey Guys I'm trying to install Grism. I've followed installation steps from http://www.grism.org/install.html, which are fairly simple, just need to install dependencies and than install the deb ...
2
votes
1answer
664 views

apt tells me I have “held broken packages”: please help me reinstall skype [duplicate]

Ubuntu version: up to date 12.04 I recently uninstalled Skype so that I could reinstall the most recent version; I was getting the "packages held back" message whenever I updated the software on my ...
2
votes
0answers
326 views

libetpan15 not installable when trying to install Cairo dock

When adding Cairo dock to Ubuntu 12.04, i get this message telling me i need a dependency. What do i do now to proceed with the install? The following packages have unmet dependencies: ...
2
votes
2answers
2k views

Cannot install Crossover

I can't install crossover from the package, ".deb". Here is a screenshoot of it : Here is what I got when I was trying to install with terminal: `young@jianyue:~$ cd /home/young/Desktop ...