Questions concerning software and package dependencies.

learn more… | top users | synonyms (1)

3
votes
1answer
136 views

How to make Photofilmstrip work on Ubuntu 15.04

I wanted to install Photofilmstrip on Ubuntu 15.04 unfortunately it was removed from the repos. I managed to install it based on how to install mencoder in ubuntu 14.10?. Unfortunately mencoder ...
1
vote
0answers
203 views

Installing KDE alongside Unity

I am using Ubuntu 15.10 and i would like to install Plasma 5.4.I did the following steps: sudo add-apt-repository ppa:kubuntu-ppa/backports sudo apt-get update && sudo apt-get dist-upgrade ...
0
votes
2answers
362 views

How to install dependencies not found in the repositories for JHBuild?

I have been following this guide in order to set up JHBuild. And I have got up to the bit which says to execute: jhbuild sysdeps --install However there is a slight problem because upon running ...
0
votes
1answer
117 views

Apt-Get Dependencies Won't Install

OK I'm kind of confused here. After I installed Code::Blocks from the website, a little error popped up the top bar. It said that "Error: BrokenCount > 0", and that one of my packages had unmet ...
1
vote
1answer
69 views

dpkg is in an unresolvable dependency loop

I ran apt-get build-dep wine1.6, because I wanted to install wine but apt install wine1.6 said that too many packages were not installed. After the build dependencies were downloaded, dpkg returned ...
0
votes
1answer
178 views

Having trouble with apt-get upgrade and removing KDE Plasma

I am running Ubuntu 15.10 with Gnome DE. I installed KDE plasma to try it out but sudo apt-get upgrade started giving me errors so I ppa-purged the kde ppa and removed kubuntu desktop with the ...
0
votes
0answers
14 views

14.04, fresh install/encrypted, dependencies not meet, including mount libraries

having a dependency problem can be infuriating. Having my machine down a couple of days, I finally had it all and stuck in a network install, I believe for 14.04. I do this: jack@Kilo:~$ echo ...
1
vote
0answers
56 views

Package gvfs-common is not configured yet?

I am having trouble getting into Synaptic Package Manager. When I run sudo dpkg --configure -a as it suggests I get: dpkg: error processing package gvfs-common (--configure): package is in a very ...
1
vote
0answers
273 views

Cannot install bomi (CMPlayer) on Ubuntu 15.10

I was a fan of bomi player on ubuntu, but cannot install it on the latest version, anybody got a solution? usr@host: ~$ sudo apt-get install bomi [sudo] password for usr: Reading package lists... ...
1
vote
1answer
139 views

broken packages with PgAdmin3 version 1.20 in Ubuntu 14 LTS

My pgadmin3 was perfect, working with PostgreSQL 9.3 (pg9.3)... Them I upgraded to pg9.4... And start the problems... Old pgAdmin3 not runs with new pg9.4, so pgAdmin3 needs also upgrade. With ...
1
vote
0answers
70 views

While resolving dependency: node-clean-css encountered following error

While resolving "dependency not satisfiable:node-clean-css" I was executing following set of commands: sudo apt-get install nodejs sudo apt-get install npm sudo npm install -g less sudo npm install ...
0
votes
1answer
64 views

upgrade requires 525M free disk space on /boot while boot is only 230M in total there are also dependencies with previous kernels

I was having problems installing the latest kernel due to lack of free space in the /boot partition. Finally I managed to force delete the old kernel files, but when I tried sudo apt-get -f install it ...
0
votes
1answer
98 views

mysql dependencies installation problem

I am reinstalling mysql on a test server with Ubuntu 14.04 before I hadn't had any problems reinstalling it. When I reinstall it I do the following: use apt-get purge and remove on mysql-server-5.5 ...
1
vote
1answer
580 views

problem installing Collada-dom 2.4.4 headers and build tools

I got a notification that I need to install updates, and I clicked yes, but since then I am getting this stop sign on the top right corner because of unmet dependencies. when i run: sudo apt-get ...
1
vote
2answers
57 views

Why does apt-get marks packages I dont want directly?

If I try to install metapackage apt-get install lubuntu-desktop and then see the output of apt-mark showmanual | grep lubuntu I see much more than just lubuntu-desktop: lubuntu-artwork lubuntu-core ...
0
votes
1answer
97 views

Unable to install any package or software [duplicate]

I am a new user on Ubuntu. Currently, i am running Ubuntu 14.04 32-bit on my PC. Lately, I've been facing problem in installing any software or package using terminal. I've also tried the following ...
0
votes
1answer
139 views

Warning on installing CUTORCH about missing dependency files that are there

I am trying to install cuda, torch, cutorch and cudnn on Ubuntu. Cuda and Torch are installed by when I attempt to do luarocks install cutorch. I get a ton of errors. Primarily a stream of this: ...
0
votes
1answer
111 views

sudo apt-get -f install error, how to remove or reinstall corrupted packages [duplicate]

I need to install libgl1-mesa-dev lib on Ubuntu 14.0.4, because QT 5.5 depends on this lib. I run following command and gets error, How can i fix this error: $ sudo apt-get install build-essential ...
0
votes
0answers
153 views

Skype unmet dependencies & conflict in kubuntu 14.04 LTS

I am having unmet conflicting dependancies. The log is too long to paste here so I have made a pastebin. http://pastie.org/10651012 But these are the most relevant lines: $ sudo apt-get install ...
0
votes
1answer
50 views

i want to convert Ubuntu to Xubuntu but I get this problem

Using this command apt-get install xubuntu-desktop i get this: Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable ...
0
votes
0answers
735 views

Packages have unmet dependencies when trying to install anything

I'm running Ubuntu 14.04 LTS. I've recently run into this problem with several applications, it seems to happen to anything I need to update or install. I just gave up the first 2 or 3 times this ...
2
votes
1answer
168 views

How to resolve a missing libproxy1 dependency on Wily

I'm installing the Citrix VPN client using the installer nsgclient.deb on Wily and I get the error Dependency is not satisfiable: libproxy1. I tried apt-get with this result: $ sudo apt-get install ...
1
vote
0answers
74 views

libldap & dpkg errors

I seem to have a problem with my install after removing Wine 1.8: [installArchives() failed: (Reading database ... (Reading database ... 5% (Reading database ... 10% (Reading database ... 15% ...
0
votes
0answers
327 views

unable to launch gnome-session --session=ubuntu

I used xkill command in terminal then clicked on the top bar(by mistake). after rebooting i got this message : : unable to launch "gnome-session --session=ubuntu" X session --- "gnome-session ...
6
votes
6answers
2k views

Unmet dependencies

While updating Ubuntu 14.04, I came across the following error message: The following packages have unmet dependencies: collada-dom-dev : Depends: collada-dom2.4-sp-dev but it is not installed ...
0
votes
0answers
19 views

Error installing packing on Ubuntu

I'd like to install libjbig-dev on Ubuntu 14.04 LTS. So I run sudo apt-get install libjbig-dev which returns Reading package lists... Done Building dependency tree Reading state ...
4
votes
1answer
35 views

Is a dependency used by many packages?

Can a dependency be used by many packages? If this is true, for example, packages A and B use a common package C as a dependency, and now I remove package A using the apt-get command, will the ...
0
votes
0answers
67 views

Odoo installation

I was trying to install "odoo" from the .deb file I downloaded. It opened up in Ubuntu software centre displaying following message: dependency not satisfiable: node-clean-css enter image ...
0
votes
0answers
31 views

Installation of Steam Related

The following packages have unmet dependencies: libgl1-mesa-glx:i386 : Depends: libglapi-mesa:i386 (= 10.1.3-0ubuntu0.5) Depends: libudev1:i386 but it is not going to be ...
0
votes
0answers
118 views

Two OpenCV's are installed (with different versions) and I can't delete all traces of the past one, please help!

I am new to Linux systems but I really need this for my project, so I really need your help. Here is what happened: I have had OpenCV 2.4 on a linux system and I also installed another library called ...
0
votes
0answers
37 views

virtualbox-guest-x11 dependencies on xubuntu 14.04.03 LTS

I have freshly installed XUbuntu 14.04.03 LTS (in virtualbox). When I try to install virtualbox-guest-x11, I get dependency error. Here is screenshot: error screenshot And here is attempt with ...
0
votes
0answers
342 views

Unable to install Plasma desktop on Ubuntu 15.10

I have followed the following steps to install the plasma desktop on Ubuntu 15.10: sudo add-apt-repository ppa:kubuntu-ci/stable sudo apt-get update sudo apt-get dist-upgrade sudo apt-get install ...
1
vote
0answers
62 views

gvfs-backends unmet dependency

I by mistake un-installed ubuntu software center and gvf packages, when i am trying to install gvf packages i get this error. I ran sudo apt-get install gvfs-backends Reading package lists... Done ...
0
votes
1answer
127 views

Removing boot packages while ignoring dependencies

My boot folder is full, and according to this question one simple solution is to remove old Linux image packages. Unfortunately, I can't do this because apt tells me that some of my packages have ...
2
votes
0answers
93 views

3 Broken Package that will not be removed; so that I can update Ubuntu 14.04

I have done sudo apt-get update && sudo apt-get upgrade. After that it gives me the following error message You might want to run 'apt-get -f install' to correct these. The following ...
10
votes
1answer
191 views

Why does Virtual Box uninstall gnome-terminal?

For some reason, virtual box 5 after installing it from their website uninstalls gnome-terminal, and when I reinstall gnome-terminal, it uninstalls virtual box. What's going on? Also, installing ...
0
votes
1answer
41 views

unmet dependency error on ubuntu 14.04 while installing

whenever I am trying to install php5 or my-sql I am getting below error. The following packages have unmet dependencies: mysql-server : Depends: mysql-server-5.5 but it is not going to be ...
0
votes
1answer
172 views

QGIS not working with Python installation on Wily 15.10: broken paths/dependencies

When I try to run QGIS, I get the following errors at startup: An error occured during execution of following code: import pyplugin_installer Traceback (most recent call last): File "", line 1, ...
0
votes
0answers
79 views

Error when installing Apache on fresh install of Ubuntu 12.04.5

When I run sudo apt-get install apache2 I get the following error The following packages have unmet dependencies: apache2: Depends: apache2-mpm-worker (= 2.2.22-1ubuntu1) but ...
3
votes
0answers
89 views

Install multiple deb files while respecting their dependencies

To support offline installation of multiple .deb files, I'm using: sudo dpkg -i dependencies/*.deb I've noticed some packages fail using this method because of the order they installed For ...
8
votes
1answer
387 views

How to debug an unmet dependencies problem?

Note about possible duplicate: AFAIK, This is not a duplicate of How do I resolve unmet dependencies after adding a PPA? otherwise please prove it by solving the test problem I mention below using ...
0
votes
0answers
11 views

How to force-remove dependencies even if package manager is complaining? [duplicate]

I can't seem to find a question for this, which seems rather weird, but anyway: How can I force-remove a dependency from my system, ignoring all errors and wiping it from existence? A solution that ...
0
votes
1answer
61 views

Steam will not run (missing libGL.so.1)

I'm trying to install Steam on the laptop my son is getting for christmas (running Ubuntu 14.04.3 LTS), however when I try to run Steam for the first time (via the "Steam" desktop icon it creates), a ...
0
votes
1answer
25 views

Package dependendency error, even though the package is the correct version

Okay, I'm trying to install bsdtar, but it won't let me, it marks a package dependency error, even though the the package it marks the error for is on the same version as required. Here's the result ...
0
votes
0answers
20 views

Unmet dependencies for khelpcenter4 when installing Tellico and Eqonomize!

I have installed Ubuntu 15.04. When installing software packages such as Tellico or Eqonomize! I get the message saying that there are unmet dependencies for khelpcenter4. dilan@dilan-desktop:~$ sudo ...
0
votes
1answer
56 views

Broken packages - wine

i can't install wine on my linux(xUbuntu 14.04 x64) The following packages have unmet dependencies: wine1.6 : Depends: wine1.6-amd64 (= 1:1.6.2-0ubuntu4) Depends: wine1.6-i386 (= ...
1
vote
0answers
65 views

Perf tool installation (unable to find package) [closed]

Referring to the post How to install "perf" monitoring tool?, I tried installing the Linux tools for my version of the kernel. But I am running Linux on and embedded board where the version ...
1
vote
1answer
132 views

Install readr in R and met dirty dependency tree

My Ubuntu and R versions: alvas@ubi:~$ lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 14.04.2 LTS Release: 14.04 Codename: trusty alvas@ubi:~$ R > ...
0
votes
0answers
29 views

installing and removing libnspr4

I have installed libnspr4 2:4.11-1 and should have install libnspr4-dev. With out the dev I can not compile synchronet bbs software. When I try to remove libnspr4 2:4.11-1 i get the following ...
1
vote
0answers
65 views

Dependency problem 15.10 (wily)

I am getting following output when I do: sudo apt-get install vlc also I get similar type of message when I do: sudo apt-get install chromium-browser I just freshly installed ubuntu 15.10. I ...