Questions concerning software and package dependencies.

learn more… | top users | synonyms (1)

0
votes
1answer
100 views

Issue related with unmet dependencies after installing new libraries

After upgrading from Ubuntu 15.04 to 15.10, I had an issue with my scanner on Canon PIXMA MX870 that was not recognized by Simple Scan or Xsane. I've found my answer on how to make it work: Original ...
1
vote
3answers
81 views

How to solve package conflicts?

I would like to install both packages libsigc++-2.0-0c2a and libsigc++-2.0-0v5 at the same time, in order to run certain software. Apparently, however, the packages are conflicting and sudo apt-get ...
0
votes
2answers
190 views

Can't install 'libqt4-dev:i386' for skype

I'm using an Ubuntu 14.04 system and I'm trying to install skype on my system. I followed the steps given in the following link to install here. I first tried installing the .deb package from their ...
1
vote
0answers
43 views

Trying to install mtrack, but get unmet dependencies

I recently installed Ubuntu 14.04.4 on my Macbook Air (late 2015). I want to fix the horrendous touchpad configuration that comes by default. So I searched and found that mtrack does that. So I tried ...
1
vote
1answer
68 views

Is there an easy way to determine what dependencies of dependencies I'll need to install for a custom server ISO?

I'm installing packages into my custom ubuntu server ISO for a complete offline install via this guide: How to create a Customized Ubuntu Server ISO?. The only option for the install is a single dvd. ...
1
vote
0answers
24 views

How do I download a package AND all of its dependencies for offline use later? [duplicate]

I understand how to only download a package with: apt-get download blah ...but how do I download all of its dependencies easily as well for an offline install later? Specifically I'll be placing ...
0
votes
0answers
31 views

Unmet Dependencies Problem

I have installed Ubuntu 14.04 LTS. During installing many applications like vlc, synaptic packet manager, etc, from terminal (or from Ubuntu software center) using the command sudo apt-get install ...
1
vote
0answers
77 views

unmet dependency and debconf: Problem setting up the database defined by stanza 3 of /etc/debconf.conf

everyone! I've been searching for a solution to this problem for weeks now, but nothing I've tried has worked. I am running a ARM version of Ubuntu 14.04 Server on an Odroid XU4. I'm not doing much ...
0
votes
1answer
67 views

Alienware-kbl is not installing due to python3-usb

I am pretty new to Ubuntu and I am trying to install alienware-kbl on my laptop to fix the lights on the keyboard. I have used it in the past with Ubuntu 14.04 and everything worked fine until a few ...
0
votes
1answer
68 views

Installing spotify-client on lubuntu 15.10

I am trying to install Spotify on my Sony Vaio laptop running Lubuntu 15.10. However, whenever I run sudo apt-get install spotify-client, apt-get says that I have held broken packages. Here is the ...
0
votes
1answer
158 views

Can't install apache2 for the first time

I am trying to install local server but cannot seem to get past this error where i install apache. On my terminal i run sudo apt-get install apache2 and on pressing enter i get this: Reading package ...
0
votes
0answers
13 views

12.04 Breaks dependency

when I try to install 'Embedded GNU C Library: Shared libraries' I get error Breaks existing package 'libnih1' dependency libc6(<2.16) Any ideas how to buypass this dependency?
0
votes
0answers
18 views

Struggling to share folders with new install of 14.04 LTS

Very much a beginner and I need help, please. I decided to install Ubuntu 14.04 on an elderly PC which does meet the system spec and have it join my Windows network. I tried the idea with a netbook ...
1
vote
1answer
48 views

installing dependencies always abort

When I install any dependency and when it asks yes/no and I say yes it aborts: hassan@hassan-VirtualBox:~/Downloads/Python-2.7.11$ sudo apt-get install libx11-dev:i386 Reading package lists... Done ...
0
votes
0answers
156 views

Got error E: Unable to correct problems, you have held broken packages. while installing Ruby

Command used: sudo apt-get install git-core curl zlib1g-dev build-essential libssl-dev libreadline-dev libyaml-dev libsqlite3-dev sqlite3 libxml2-dev libxslt1-dev libcurl4-openssl-dev python-software-...
0
votes
2answers
264 views

How to install libsystemd-journal-dev on Wily (JHBuild issue)

I'm trying to build gnome apps using JHBuild. But this is what I get $ jhbuild build gnome-music Required packages: System installed packages which are too old: (none) No matching system ...
3
votes
1answer
223 views

Ubuntu 14.04.3 libsdl2-2.0-0:i386 wants to downgrade xorg

Ubuntu 14.04.4 LTS kernel 3.19, xorg 1.17 (vivid HWE stack) sudo apt-get install libsdl2-2.0-0:i386 gives the following output. This can't be right! I need this for pcsx2 1.4.0 Reading package ...
1
vote
1answer
206 views

Unable to install libpcre3-dev in ubuntu 14.10

I am trying to install libpcre3-dev in ubuntu 14.10 and sudo apt-get install libpcre3-dev gives me the following error : The following packages have unmet dependencies: libpcre3-dev : Depends: ...
0
votes
0answers
33 views

The following packages have unmet dependencies: libcurses-ui-perl : Depends: libcurses-perl but it is not going to be installed

I have added below mirrors in source.list deb deb deb-src deb deb-src While trying to install "sysv-rc-conf" am getting below error The following packages have unmet dependencies: libcurses-...
1
vote
1answer
52 views

couchdb : Depends: couchdb-bin (>= 1.6.1-0ubuntu4) broken packages

I encountered a problem trying to install couchdb on my Ubuntu 14.10 (GNU/Linux 3.10.23-xxxx-std-ipv6-64 x86_64) server. When I run apt-get install couchdb, I've got the following mistakes : The ...
0
votes
0answers
32 views

libode-dev : Depends: libode2 (= 3:0.11.1-tbb-1trusty2) but 3:0.11.1-tbb-1trusty3 is to be installed

I have already read earlier posts but couldn't find the answer. I want to install Simspark simulator on ubuntu 14.04 according to installation guide but I face the following error during installation: ...
0
votes
0answers
115 views

E: Unable to correct dependencies

I am running ubuntu 14.04. My wifi and ethernet stopped working , so I have installed libnl-3-200, libnl-route-3-200 and libnl-genl-3-200. Now wifi and ethernet is working but connection icon is not ...
0
votes
2answers
83 views

Dependency problem installing dell osam on Ubuntu 15.10

I have a simple problem with dependencies. I want to install a Server management package from Dell called OSAM on Ubuntu 15.10. For the installation I added an old repo provided by the dell community....
0
votes
1answer
60 views

No luck installing Mono 3 on Ubuntu 12.04

I am running Ubuntu 12.04 on two older Dell towers and a Mac G5. After much research I got Mono 3.12.0 to install on one of the Dells but not the other one. Wanted to move my 3D printing software (...
2
votes
0answers
75 views

libtirpc1 have unmet dependencies

sudo apt-get -f install Reading package lists... Done Building dependency tree Reading state information... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. sudo dpkg --...
0
votes
1answer
136 views

How to remove conflict package in ubuntu?

punit@punit-Compaq-420:~$ apt-cache depends python2.7-dev python2.7-dev Depends: python2.7 Depends: libpython2.7-dev Depends: libpython2.7 Depends: libexpat1-dev |Recommends: libc6-dev ...
0
votes
0answers
209 views

Dependency problems after faulty Ubuntu upgrade ( `gcc-5-base` )

I tried upgrading from 14.02 to the newest available version. I package froze the installation progress and I was left with a broken system. Many important packages ( including all of the apt packages ...
1
vote
0answers
35 views

unmet dependencies while installing ns-allinone2.29.2 on Ubuntu 14.04?

I'm installing ns2-allinone-2.29.2 (not the latest, I needed this to test st) on Ubuntu 14.04 and got the above problem. Even though the dependencies are installed it cannot recognize it. Please help! ...
0
votes
1answer
113 views

Installing java

When I am installing java I am getting this problem how can I resolve it? Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be ...
0
votes
0answers
144 views

samba installation Error on Ubuntu 15.04

I am began to use Ubuntu. I can not enable file sharing. It show samba package required Error. So, I try to install samba by apt-get install samba The following errors are shown. Some packages ...
0
votes
0answers
23 views

why build-essential failed

Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or ...
0
votes
0answers
136 views

sdl2 problem: no such file, but it's there; also, how does ldd work?

got a Problem on my 64bit Ubuntu 14.04 with SDL2. I am trying to run a game (unrealworld): /urw3-bin: error while loading shared libraries: libSDL2-2.0.so.0: cannot open shared object file: No ...
0
votes
0answers
39 views

Problem istalling wine. Dependancies not met

Ok, guys I have a big problem installing wine. I gave read every ask ubuntu I could find on the matter I have not found a solution to my problem. Is there anything else I can do? user@user:~$ sudo ...
0
votes
1answer
46 views

Few errors while apt-get upgrade and apt-get install?

When i try to install libgl1-mesa-dev and libsdl1.2-dev, I get the following error The following information may help to resolve the situation: The following packages have unmet dependencies: gnome-...
0
votes
0answers
79 views

libboost-all-dev

I am trying to install dependencies: with this command; sudo apt-get install -f libboost-all-dev But; there are dependencies: Some packages could not be installed. This may mean that you have ...
1
vote
1answer
32 views

Dependecies error when trying to insatll wine

When I do sudo apt-get install wine I get all this errors Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. ...
1
vote
0answers
54 views

Unmet dependencies, install -f looks scary

Ubuntu 12.04 LTS, 64-bit I tried to install Lazarus (1.4.4) by downloading the .deb files and using sudo dpkg -i. However I think it tried to install them in the wrong order and I now get "unmet ...
2
votes
1answer
126 views

How to install Octave in Ubuntu 14.04 using terminal

sudo apt-get build-dep octave is not working. The error message is E: Build-Depends dependency for octave cannot be satisfied because the package automake cannot be found I have modified the /etc/...
0
votes
1answer
180 views

How to install libc6 2.17 on 12.04

I am attempting to install the video editor Lightworks using dpkg. When I try, it says Errors occured when installing. I used the graphical package installer instead, and it said that the dependency ...
0
votes
1answer
191 views

Dependancy issues breaking apt-get

I believe I may have some dependancies installed of the wrong version for my system, because I keep getting errors whenever I try to use apt-get. For instance: sudo apt-get install minicom results ...
0
votes
1answer
204 views

Gparted not installable in Ubuntu 15.10 due to unmet dependencies

Gparted worked fine in Ubuntu 14.04 and 14.10 (I'm not sure about 15.04)) but I'm having trouble installing it in 15.10 from the software center. It gives the error: “Package dependencies cannot be ...
0
votes
0answers
161 views

apt-get -f install fails due to dependency issues

Attempting to upgrade from ubuntu 14.04 to ubuntu 15.10, I seem to have broken dependencies and the typical answer of sudo apt-get -f install and sudo apt-get update aren't working. I think I deleted ...
0
votes
1answer
113 views

Google earth dependancy problems

~$ sudo apt-get install libfontconfig1:i386 libx11-6:i386 libxrender1:i386 libxext6:i386 libgl1-mesa-glx:i386 libglu1-mesa:i386 libglib2.0-0:i386 libsm6:i386 Reading package lists... Done Building ...
1
vote
1answer
78 views

unmet dependencies for uuid-dev

I tried apt-get update, apt-get upgrade, apt-get install -f but still cannot get past this dependency. I am running 14.04. How do I get rid of this so I can install uuid-dev. $ sudo apt-get ...
0
votes
0answers
360 views

Linux generic-lts-trusty depends: linux-generic but it is not installed

I am using Ubuntu 14.04.3 LTS and the kernel is "3.13.0-76-generic". But when I am trying to upgrade it by the following command: sudo apt-get upgrade I get the following dependency related error: ...
0
votes
0answers
34 views

MySql installation error

I am a newbie Ubuntu user. I am using Ubuntu 14.04. The problem is when I try to install MySql using this command sudo apt-get install mysql-server php5-mysql I got this error message. Reading ...
0
votes
1answer
101 views

Ubuntu 15.10 - problem with installing wine

I wanted to install wine to run photoshop and office, but came across these problems when I run this code: sudo add-apt-repository ppa:ubuntu-wine/ppa and I get gpg: keyring `/tmp/tmpxjwf8eb2/...
0
votes
0answers
105 views

Error dependency with teamviewer installation

When I try to install Teamviewer, I get this error message: teamviewer:i386 depends on libc6 (>= 2.4); however: Package libc6:i386 is not installed. teamviewer:i386 depends on libgcc1; however: ...
1
vote
0answers
86 views

Any suggestions on installing the haskell-platform or stack in ubuntu?

I tried to install haskell-platform and I am getting the following unmet dependencies. Reading package lists... Building dependency tree... Reading state information... Some packages could not be ...
0
votes
0answers
49 views

Steam requires additional packages, which will not install

When I start my Steam I get the following error message: Steam needs to install these additional packages: libgl1-mesa-dri:i386, libgl1-mesa-glx:i386 When I accept, the following ...