Questions concerning software and package dependencies.

learn more… | top users | synonyms (1)

0
votes
0answers
215 views

Can't install debian package

I'm trying to create and install my own deb package: fotorator_1.0-1.deb. When I try to use gdebi fotorator_1.0-1.deb, I get following error: root@kiosk-HP:~/Desktop# gdebi fotorator_1.0-1.deb ...
0
votes
0answers
13 views

System Crashing

I have been trying to install pure data 'pd-extended' and I got this error: unknown error:<clas 'SystemError''>'(E:Malformed line 58 in source list/etc/apt/sources.list.(distparse))'.This ...
1
vote
1answer
187 views

can't install software, apparently installed packages have unmet dependencies

I've got a DELL n5110 laptop, with intel i3-2330m cpu @ 2.20GHz x 4, 64 bit OS system, ubuntu 14.04 LTS operating system. The error that comes up is upon start up, and it gives me the option of ...
1
vote
0answers
98 views

dpkg dependency problems due to different installed versions

Can someone help me to solve this problem? Below is the output when performing sudo dpkg --configure -a Output: sudo dpkg --configure -a dpkg: dependency problems prevent configuration of libapt-pkg4....
1
vote
2answers
351 views

apt-get broken after version update (unmet dependencies)

I did an upgrade for 14.04-->15.10 with the software update tool. I logged back in and tried to upgrade/update. I'm met with error messages about unmet dependencies have to do with TeXlive which are ...
0
votes
0answers
40 views

dependency problems prevent configuration of linux-generic-pae

ok I am a turn key operator I need things in step by step I can do apt-get update apt-get dist-upgrade apt-get-remove more I have 12.04.5 LTS set up by my now deceased husband I want to update php ...
0
votes
0answers
85 views

dpkg: error processing archive /var/cache/apt/archives/linux-image-3.16.0-43-generic_3.16.0-43.58_amd64.deb

I would love to be more descriptive, but honestly I have no idea what is wrong here. When I try to install htop I get Reading package lists... Done Building dependency tree Reading state ...
0
votes
4answers
100 views

Cant install VLC

I am new to Ubuntu. while trying to update the vlc in order to be able to play certain videos, I screwed up and now im unable to install a new version of the VLC media player. while doing this, I was ...
-1
votes
1answer
79 views

Eclipse - Package dependencies cannot be resolved

I know there are a lot of questions on this topic, and I tried a lot of options that worked for some people, but I just cannot get this done. I am trying to install Eclipse on my Ubuntu 14.04 LTS, and ...
-1
votes
1answer
47 views

How to install dependencies of a program

I am trying install a program named Teletalk 3G in my ubuntu 15.10. However there seems to be some dependencies missing, so i ran the "ldd" command to see which dependencies were missing. I got these ...
1
vote
1answer
74 views

Error with vlc installation, dependency

I recently updated Ubuntu 14.04 from software updater. After update some packages were removed. after that I found that vlc has been also removed from my system. So I tried to install vlc and its ...
0
votes
0answers
54 views

apt-get upgrade Unmet dependencies

I'm using an Ubuntu 14.04 system. I tried to upgrade my repositories using apt-get upgrade but I got this error. Building dependency tree Reading state information... Done You might want to ...
0
votes
0answers
51 views

Ubuntu giving issues after installing wine - unmet dependencies

First I got an error on my taskbar saying that I have unmet dependencies So, I sequentially tried the following. sudo -i apt-get autoclean apt-get clean apt-get update got following error .........
0
votes
1answer
70 views

Trouble installing freeglut package

Here are the outputs from running the respective commands: sudo apt-get update results http://paste.ubuntu.com/15291163/ sudo apt-get install build-essential results http://paste.ubuntu.com/...
0
votes
0answers
138 views

Install packages by itself

Did some research, now I hit a brick wall... I want to install mopidy to stream music from an old pc running ubuntu 12.04.5 server lts 32bit. When I set it up as told from their website I get this ...
1
vote
1answer
178 views

“unmet dependencies” while installing gtk +3 [duplicate]

Trying to install GTK as it was required by a another package. So I ran apt-get install libgtk-3-dev But getting unmet dependencies error. Output Reading package lists... Done Building ...
3
votes
1answer
141 views

“unmet dependencies” after upgrading to Ubuntu 15.10

I upgraded ubuntu to 15.10, then I tried to compile a gtk app and found out I had no GTK installed. So I ran sudo apt-get install libgtk-3-dev but this is the output Reading package lists... Done ...
0
votes
0answers
28 views

Unmet ruby dependency, but ruby installed

In an Ubuntu 14.04 server, I needed a recent version of ruby-passenger. The version I need is not available in the repositories yet (4.0.53-1). I obtained a deb and trying installing it with dpkg. ...
0
votes
0answers
47 views

LightDm fail - I can't get the login screen - Some packages can not be installed Depends libcheese7 and libcheese-gtk23

I can not get the login screen. I have tried the suggestions given in the forums, such as uninstall lightDm or gdm and install again, but it does not work. I get the following message when I try to ...
0
votes
0answers
19 views

Dependency during MagicQ Installation

I'm trying to install MagicQ, a lighting control program, on my Ubuntu 15 distro. However, when installing, I get Depends: libxcb-util0 but it is not installable I could really use this program for ...
0
votes
0answers
109 views

Unable to install qtbase5-dev dependencies

I am trying to compile KDevelop5 on my Ubuntu 14.04 x64, getting following error when I execute sudo apt-get build-dep qtbase5-dev command. Reading package lists... Done Building dependency tree ...
1
vote
2answers
204 views

Unable to install miam-player [closed]

I added the following repository ppa:noobslab/apps Then I updated Then I tried to install miam-player: aptitude install miam-player it gives me the following output: The following packages ...
0
votes
2answers
76 views

the package linux-firmware does not install…see below.please help

sudo apt-get -f install linux-firmware Reading package lists... Done Building dependency tree Reading state information... Done The following packages were automatically installed and are no ...
0
votes
0answers
169 views

Unmet dependencies installing WineHQ in Kubuntu

Probably you are already hurrying to flag this as a duplicate of some question, however I have tried things from a lot of posts and I have no way to solve my issue. Basically, I am trying to install ...
0
votes
0answers
23 views

Not able to install anything on Ubuntu 14.10 [duplicate]

Output after executing sudo apt-get install truecrypt:
0
votes
0answers
39 views

Unifi video software dependency is not satisfiable

I am trying to install the following unifi video software and I am getting the following issue Dependency is not satisfiable:mongodb-10gen(<=2.4.10)[mongodb-org-server(>2.6.0)]mongodb-server(>=2.4....
0
votes
1answer
89 views

Unable to correct dependencies: libc6

After installing a software, Ubuntu boots correctly but Unity does not show up (only desktop icons appear). I tried: sudo apt-get -f install user@pc:~$ sudo apt-get -f install [sudo] password for ...
0
votes
1answer
88 views

Issue related with unmet dependencies after installing new libraries

After upgrading from Ubuntu 15.04 to 15.10, I had an issue with my scanner on Canon PIXMA MX870 that was not recognized by Simple Scan or Xsane. I've found my answer on how to make it work: Original ...
1
vote
3answers
69 views

How to solve package conflicts?

I would like to install both packages libsigc++-2.0-0c2a and libsigc++-2.0-0v5 at the same time, in order to run certain software. Apparently, however, the packages are conflicting and sudo apt-get ...
0
votes
2answers
154 views

Can't install 'libqt4-dev:i386' for skype

I'm using an Ubuntu 14.04 system and I'm trying to install skype on my system. I followed the steps given in the following link to install here. I first tried installing the .deb package from their ...
1
vote
0answers
43 views

Trying to install mtrack, but get unmet dependencies

I recently installed Ubuntu 14.04.4 on my Macbook Air (late 2015). I want to fix the horrendous touchpad configuration that comes by default. So I searched and found that mtrack does that. So I tried ...
1
vote
1answer
56 views

Is there an easy way to determine what dependencies of dependencies I'll need to install for a custom server ISO?

I'm installing packages into my custom ubuntu server ISO for a complete offline install via this guide: How to create a Customized Ubuntu Server ISO?. The only option for the install is a single dvd. ...
1
vote
0answers
24 views

How do I download a package AND all of its dependencies for offline use later? [duplicate]

I understand how to only download a package with: apt-get download blah ...but how do I download all of its dependencies easily as well for an offline install later? Specifically I'll be placing ...
0
votes
0answers
30 views

Unmet Dependencies Problem

I have installed Ubuntu 14.04 LTS. During installing many applications like vlc, synaptic packet manager, etc, from terminal (or from Ubuntu software center) using the command sudo apt-get install ...
1
vote
0answers
70 views

unmet dependency and debconf: Problem setting up the database defined by stanza 3 of /etc/debconf.conf

everyone! I've been searching for a solution to this problem for weeks now, but nothing I've tried has worked. I am running a ARM version of Ubuntu 14.04 Server on an Odroid XU4. I'm not doing much ...
0
votes
1answer
58 views

Alienware-kbl is not installing due to python3-usb

I am pretty new to Ubuntu and I am trying to install alienware-kbl on my laptop to fix the lights on the keyboard. I have used it in the past with Ubuntu 14.04 and everything worked fine until a few ...
0
votes
1answer
57 views

Installing spotify-client on lubuntu 15.10

I am trying to install Spotify on my Sony Vaio laptop running Lubuntu 15.10. However, whenever I run sudo apt-get install spotify-client, apt-get says that I have held broken packages. Here is the ...
0
votes
1answer
112 views

Can't install apache2 for the first time

I am trying to install local server but cannot seem to get past this error where i install apache. On my terminal i run sudo apt-get install apache2 and on pressing enter i get this: Reading package ...
0
votes
0answers
13 views

12.04 Breaks dependency

when I try to install 'Embedded GNU C Library: Shared libraries' I get error Breaks existing package 'libnih1' dependency libc6(<2.16) Any ideas how to buypass this dependency?
0
votes
0answers
18 views

Struggling to share folders with new install of 14.04 LTS

Very much a beginner and I need help, please. I decided to install Ubuntu 14.04 on an elderly PC which does meet the system spec and have it join my Windows network. I tried the idea with a netbook ...
1
vote
1answer
48 views

installing dependencies always abort

When I install any dependency and when it asks yes/no and I say yes it aborts: hassan@hassan-VirtualBox:~/Downloads/Python-2.7.11$ sudo apt-get install libx11-dev:i386 Reading package lists... Done ...
0
votes
0answers
130 views

Got error E: Unable to correct problems, you have held broken packages. while installing Ruby

Command used: sudo apt-get install git-core curl zlib1g-dev build-essential libssl-dev libreadline-dev libyaml-dev libsqlite3-dev sqlite3 libxml2-dev libxslt1-dev libcurl4-openssl-dev python-software-...
0
votes
2answers
251 views

How to install libsystemd-journal-dev on Wily (JHBuild issue)

I'm trying to build gnome apps using JHBuild. But this is what I get $ jhbuild build gnome-music Required packages: System installed packages which are too old: (none) No matching system ...
3
votes
1answer
200 views

Ubuntu 14.04.3 libsdl2-2.0-0:i386 wants to downgrade xorg

Ubuntu 14.04.4 LTS kernel 3.19, xorg 1.17 (vivid HWE stack) sudo apt-get install libsdl2-2.0-0:i386 gives the following output. This can't be right! I need this for pcsx2 1.4.0 Reading package ...
1
vote
1answer
167 views

Unable to install libpcre3-dev in ubuntu 14.10

I am trying to install libpcre3-dev in ubuntu 14.10 and sudo apt-get install libpcre3-dev gives me the following error : The following packages have unmet dependencies: libpcre3-dev : Depends: ...
0
votes
0answers
30 views

The following packages have unmet dependencies: libcurses-ui-perl : Depends: libcurses-perl but it is not going to be installed

I have added below mirrors in source.list deb deb deb-src deb deb-src While trying to install "sysv-rc-conf" am getting below error The following packages have unmet dependencies: libcurses-...
1
vote
1answer
49 views

couchdb : Depends: couchdb-bin (>= 1.6.1-0ubuntu4) broken packages

I encountered a problem trying to install couchdb on my Ubuntu 14.10 (GNU/Linux 3.10.23-xxxx-std-ipv6-64 x86_64) server. When I run apt-get install couchdb, I've got the following mistakes : The ...
0
votes
0answers
29 views

libode-dev : Depends: libode2 (= 3:0.11.1-tbb-1trusty2) but 3:0.11.1-tbb-1trusty3 is to be installed

I have already read earlier posts but couldn't find the answer. I want to install Simspark simulator on ubuntu 14.04 according to installation guide but I face the following error during installation: ...
0
votes
0answers
107 views

E: Unable to correct dependencies

I am running ubuntu 14.04. My wifi and ethernet stopped working , so I have installed libnl-3-200, libnl-route-3-200 and libnl-genl-3-200. Now wifi and ethernet is working but connection icon is not ...