Questions concerning software and package dependencies.

learn more… | top users | synonyms (1)

0
votes
0answers
113 views

Got error E: Unable to correct problems, you have held broken packages. while installing Ruby

Command used: sudo apt-get install git-core curl zlib1g-dev build-essential libssl-dev libreadline-dev libyaml-dev libsqlite3-dev sqlite3 libxml2-dev libxslt1-dev libcurl4-openssl-dev ...
0
votes
2answers
216 views

How to install libsystemd-journal-dev on Wily (JHBuild issue)

I'm trying to build gnome apps using JHBuild. But this is what I get $ jhbuild build gnome-music Required packages: System installed packages which are too old: (none) No matching system ...
3
votes
1answer
186 views

Ubuntu 14.04.3 libsdl2-2.0-0:i386 wants to downgrade xorg

Ubuntu 14.04.4 LTS kernel 3.19, xorg 1.17 (vivid HWE stack) sudo apt-get install libsdl2-2.0-0:i386 gives the following output. This can't be right! I need this for pcsx2 1.4.0 Reading package ...
1
vote
1answer
124 views

Unable to install libpcre3-dev in ubuntu 14.10

I am trying to install libpcre3-dev in ubuntu 14.10 and sudo apt-get install libpcre3-dev gives me the following error : The following packages have unmet dependencies: libpcre3-dev : Depends: ...
0
votes
0answers
24 views

The following packages have unmet dependencies: libcurses-ui-perl : Depends: libcurses-perl but it is not going to be installed

I have added below mirrors in source.list deb deb deb-src deb deb-src While trying to install "sysv-rc-conf" am getting below error The following packages have unmet dependencies: ...
1
vote
1answer
42 views

couchdb : Depends: couchdb-bin (>= 1.6.1-0ubuntu4) broken packages

I encountered a problem trying to install couchdb on my Ubuntu 14.10 (GNU/Linux 3.10.23-xxxx-std-ipv6-64 x86_64) server. When I run apt-get install couchdb, I've got the following mistakes : The ...
0
votes
0answers
28 views

libode-dev : Depends: libode2 (= 3:0.11.1-tbb-1trusty2) but 3:0.11.1-tbb-1trusty3 is to be installed

I have already read earlier posts but couldn't find the answer. I want to install Simspark simulator on ubuntu 14.04 according to installation guide but I face the following error during installation: ...
0
votes
0answers
82 views

E: Unable to correct dependencies

I am running ubuntu 14.04. My wifi and ethernet stopped working , so I have installed libnl-3-200, libnl-route-3-200 and libnl-genl-3-200. Now wifi and ethernet is working but connection icon is not ...
0
votes
2answers
62 views

Dependency problem installing dell osam on Ubuntu 15.10

I have a simple problem with dependencies. I want to install a Server management package from Dell called OSAM on Ubuntu 15.10. For the installation I added an old repo provided by the dell ...
0
votes
1answer
45 views

No luck installing Mono 3 on Ubuntu 12.04

I am running Ubuntu 12.04 on two older Dell towers and a Mac G5. After much research I got Mono 3.12.0 to install on one of the Dells but not the other one. Wanted to move my 3D printing software ...
2
votes
0answers
60 views

libtirpc1 have unmet dependencies

sudo apt-get -f install Reading package lists... Done Building dependency tree Reading state information... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. sudo dpkg ...
0
votes
1answer
87 views

How to remove conflict package in ubuntu?

punit@punit-Compaq-420:~$ apt-cache depends python2.7-dev python2.7-dev Depends: python2.7 Depends: libpython2.7-dev Depends: libpython2.7 Depends: libexpat1-dev |Recommends: libc6-dev ...
0
votes
0answers
151 views

Dependency problems after faulty Ubuntu upgrade ( `gcc-5-base` )

I tried upgrading from 14.02 to the newest available version. I package froze the installation progress and I was left with a broken system. Many important packages ( including all of the apt packages ...
1
vote
0answers
35 views

unmet dependencies while installing ns-allinone2.29.2 on Ubuntu 14.04?

I'm installing ns2-allinone-2.29.2 (not the latest, I needed this to test st) on Ubuntu 14.04 and got the above problem. Even though the dependencies are installed it cannot recognize it. Please help! ...
0
votes
1answer
87 views

Installing java

When I am installing java I am getting this problem how can I resolve it? Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be ...
0
votes
0answers
100 views

samba installation Error on Ubuntu 15.04

I am began to use Ubuntu. I can not enable file sharing. It show samba package required Error. So, I try to install samba by apt-get install samba The following errors are shown. Some packages ...
0
votes
0answers
23 views

why build-essential failed

Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or ...
0
votes
0answers
81 views

sdl2 problem: no such file, but it's there; also, how does ldd work?

got a Problem on my 64bit Ubuntu 14.04 with SDL2. I am trying to run a game (unrealworld): /urw3-bin: error while loading shared libraries: libSDL2-2.0.so.0: cannot open shared object file: No ...
0
votes
0answers
39 views

Problem istalling wine. Dependancies not met

Ok, guys I have a big problem installing wine. I gave read every ask ubuntu I could find on the matter I have not found a solution to my problem. Is there anything else I can do? user@user:~$ sudo ...
0
votes
1answer
43 views

Few errors while apt-get upgrade and apt-get install?

When i try to install libgl1-mesa-dev and libsdl1.2-dev, I get the following error The following information may help to resolve the situation: The following packages have unmet dependencies: ...
0
votes
0answers
47 views

libboost-all-dev

I am trying to install dependencies: with this command; sudo apt-get install -f libboost-all-dev But; there are dependencies: Some packages could not be installed. This may mean that you have ...
1
vote
1answer
32 views

Dependecies error when trying to insatll wine

When I do sudo apt-get install wine I get all this errors Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. ...
0
votes
0answers
38 views

Unmet dependencies, install -f looks scary

Ubuntu 12.04 LTS, 64-bit I tried to install Lazarus (1.4.4) by downloading the .deb files and using sudo dpkg -i. However I think it tried to install them in the wrong order and I now get "unmet ...
2
votes
1answer
95 views

How to install Octave in Ubuntu 14.04 using terminal

sudo apt-get build-dep octave is not working. The error message is E: Build-Depends dependency for octave cannot be satisfied because the package automake cannot be found I have modified the ...
0
votes
1answer
99 views

How to install libc6 2.17 on 12.04

I am attempting to install the video editor Lightworks using dpkg. When I try, it says Errors occured when installing. I used the graphical package installer instead, and it said that the dependency ...
0
votes
1answer
129 views

Dependancy issues breaking apt-get

I believe I may have some dependancies installed of the wrong version for my system, because I keep getting errors whenever I try to use apt-get. For instance: sudo apt-get install minicom results ...
0
votes
1answer
160 views

Gparted not installable in Ubuntu 15.10 due to unmet dependencies

Gparted worked fine in Ubuntu 14.04 and 14.10 (I'm not sure about 15.04)) but I'm having trouble installing it in 15.10 from the software center. It gives the error: “Package dependencies cannot be ...
0
votes
0answers
139 views

apt-get -f install fails due to dependency issues

Attempting to upgrade from ubuntu 14.04 to ubuntu 15.10, I seem to have broken dependencies and the typical answer of sudo apt-get -f install and sudo apt-get update aren't working. I think I deleted ...
0
votes
1answer
96 views

Google earth dependancy problems

~$ sudo apt-get install libfontconfig1:i386 libx11-6:i386 libxrender1:i386 libxext6:i386 libgl1-mesa-glx:i386 libglu1-mesa:i386 libglib2.0-0:i386 libsm6:i386 Reading package lists... Done Building ...
1
vote
0answers
44 views

unmet dependencies for uuid-dev

I tried apt-get update, apt-get upgrade, apt-get install -f but still cannot get past this dependency. I am running 14.04. How do I get rid of this so I can install uuid-dev. $ sudo apt-get ...
0
votes
0answers
343 views

Linux generic-lts-trusty depends: linux-generic but it is not installed

I am using Ubuntu 14.04.3 LTS and the kernel is "3.13.0-76-generic". But when I am trying to upgrade it by the following command: sudo apt-get upgrade I get the following dependency related error: ...
0
votes
0answers
32 views

MySql installation error

I am a newbie Ubuntu user. I am using Ubuntu 14.04. The problem is when I try to install MySql using this command sudo apt-get install mysql-server php5-mysql I got this error message. Reading ...
0
votes
1answer
89 views

Ubuntu 15.10 - problem with installing wine

I wanted to install wine to run photoshop and office, but came across these problems when I run this code: sudo add-apt-repository ppa:ubuntu-wine/ppa and I get gpg: keyring ...
0
votes
0answers
78 views

Error dependency with teamviewer installation

When I try to install Teamviewer, I get this error message: teamviewer:i386 depends on libc6 (>= 2.4); however: Package libc6:i386 is not installed. teamviewer:i386 depends on libgcc1; however: ...
1
vote
0answers
72 views

Any suggestions on installing the haskell-platform or stack in ubuntu?

I tried to install haskell-platform and I am getting the following unmet dependencies. Reading package lists... Building dependency tree... Reading state information... Some packages could not be ...
0
votes
0answers
49 views

Steam requires additional packages, which will not install

When I start my Steam I get the following error message: Steam needs to install these additional packages: libgl1-mesa-dri:i386, libgl1-mesa-glx:i386 When I accept, the following ...
1
vote
0answers
27 views

Error loading libQt3Support.so.4

I am trying to install this software called Vlab. Its a Plant modelling software. I am following their instruction to install their software. After that if i run the command vlab-splash which ...
3
votes
0answers
28 views

How to get alerted when the dependency of a program is updated and the program needs to restart?

It just occurred to me that often when I upgrade software (through the usually repository apt-get means) I am upgrading software which another program has as one of its dependencies, and though I can ...
0
votes
1answer
57 views

Can't log into ubuntu-desktop Ubuntu 14.04 but other DE's okay

Just as a warning, I am pretty new to linux and using terminal but hey so far linux has been too much fun learning to just turn around and go back to Windows. Any way I will try to provide the most ...
0
votes
1answer
48 views

Broken dependencies issue is faced immediately after the first install of Ubuntu 14.04.3?

I followed these steps just to get rid of broken dependencies issue but to no avail. A fresh install of ubuntu 14.04.3 LTS Tried to install g++ by sudo apt-get install g++ BOOM... Broken ...
0
votes
0answers
41 views

Unity failed in ubuntu 14.04 after installing libldap-2.4-2:i386 URGENT

When i tried to install wine i get some unmet dependencies so what i did is to install them manually But when i arrive to this package sudo apt-get install libldap-2.4-2:i386 I didn't notice that ...
0
votes
2answers
90 views

Unable to install updates apt-get install -f

I am unable to install updates over my ubuntu 14.04 machine, due to unmet dependencies for katepart, machine is suggesting me to use apt-get install -f to fix it after which it is showing the ...
0
votes
0answers
30 views

package dependencies cant be resolved when installing wine windows program

i tried to install wine through both terminal n software centre. i had encountered error of software conflict. i tried all possible step specified in net but none worked.
1
vote
0answers
76 views

Unable to fix unmet dependencies ubuntu server

i am not able to install some packages, i got this error, i already tried all clean and -f options with apt-get. also tried this Unable to fix unmet dependencies but it did not work for me. Running ...
0
votes
0answers
37 views

Help installing Steam

When I try to open Steam I get the following message: Steam needs to install these additional packages: libgl1-mesa-dri:i386, libgl1-mesa-glx:i386 [sudo] password for mattpugs08: I enter my ...
0
votes
2answers
278 views

Package errors on every install

SO I just installed Ubuntu 15.10 on my mid-2014 Macbook Pro Retina as a standalone partition. Everything works fine and every applications I installed are working too, but I still get a few errors ...
2
votes
1answer
236 views

sudo apt get-install g++ unmet dependencies

Looked through a few questions with similar issues and none of the solutions have worked. The issue is: $ sudo apt-get Install g++ The following packges have unmet dependencies: g++ : Depends:g++-4.8 ...
0
votes
1answer
67 views

Problems after git installation from source [duplicate]

I have the following problem. I have installed latest git version from source, but maybe I have done something wrong, because now when I am trying to install/uninstall any stuff using apt-get I get ...
0
votes
0answers
48 views

How to solve the NetGen dependancy when compiling FreeCAD?

I am trying to compile FreeCAD form scratch, even though NetGen is installed using the command line: sudo apt-get install NetGen the compiler does not recognize it and does not compile FreeCAD with ...
0
votes
0answers
54 views

Unable to install Skype on Ubuntu 14.04 [duplicate]

These are the errors that I receive while trying to install Skype (from the terminal as well as from the Ubuntu Software Center). While trying to install it fro the Software Center, the error I get ...