Questions concerning software and package dependencies.

learn more… | top users | synonyms (1)

3
votes
1answer
283 views

apt-get install is removing a LOT of packages when installing libsdl2-dev, 14.04.2 with HWE

I have a 14.04.2 x86_64 system with HWE installed. I am wanting to install the package libsdl2-dev. Initially I got the following error: $:~/programming/SMD/dgen/dgen-sdl-1.33$ sudo apt-get ...
3
votes
1answer
3k views

Unable to re install mysql on Ubuntu 14.04: Dependency problems

Ubuntu Unity 14.04 LTS with all lenses removed, except files. (Hate the dash.) I have a LAMP system for web site development. I want to put all my data files in a particular partition that I can ...
3
votes
1answer
3k views

How to install Skype on 64bit Ubuntu 13.10 (broken dependencies)

I'm sure this is a duplicate candidate, but I have looked at the answer for 64bit 12.10, but it doesn't seem to work for my 13.10 installation. I have enabled 32bit architecture, ie. sudo dpkg ...
2
votes
1answer
29 views

How can I repair broken softwares?

I want to install ffmpeg as Documented here . but some errors are accurates when I want install on terminal: The following packages have unmet dependencies: libfaac-dev : Depends: libfaac0 (= ...
2
votes
1answer
51 views

Downloading DeSmuME (Gtk) Error

I went to install DeSmuME (Gtk) (Nintendo Ds Emulator) and I encountered error message. $ sudo apt-get install desmume The following packages have unmet dependencies: desmume: Depends: libasound2 ...
2
votes
1answer
71 views

Why doesn't “apt-get autoremove” remove all installed dependencies?

Installing libav-tools and ubuntu-restricted-extras also installs these new packages: cabextract chromium-codecs-ffmpeg-extra freepats gstreamer0.10-fluendo-mp3 gstreamer0.10-plugins-bad ...
2
votes
1answer
512 views

upgrade from 13.04 to 13.10 failed and broken dependencies

I tried running the upgrade from my Ubuntu 13.04 to 13.10 but it failed to upgrade a latex package with the error from [here] (Upgrading from 13.04 to 13.10 stops) and calmed to try to roll back. ...
2
votes
1answer
3k views

Try to install gnome shell in saucy

I try to install gnome-shell in saucy but it won't work. And I installed the 13.10 in parallels desktop on a Mac. sudo apt-get install gnome-shell Reading package lists... Done Building dependency ...
2
votes
1answer
323 views

Error installing Ubuntu software - Package dependencies cannot be resolved

I switched to Ubuntu from Windows, but I am not able to install any software on it. Whenever I install it gives the following error : Package dependencies cannot be resolved This error could be ...
2
votes
1answer
1k views

Problem installing vlc 12.04 broken dependencies

I am trying to install vlc on my Gateway netbook running 12.04 through wubi but whether I try using terminal or the software center I get this error message. The following packages have unmet ...
2
votes
1answer
278 views

How to update Twidge 1.0.8 form repositories to 1.1.0 from GitHub?

I would like to install Twidge 1.1.0, but only 1.0.8 is available in repositories and this version is not compatible with new Twitter API and it's not usable anymore. 1.1.0 is available in Debian sid, ...
2
votes
1answer
1k views

Error: brokencount > 0

I am getting the following error in the top menu bar: An error occurred. Please run the Package Manager from the right-click menu or apt-get in a terminal to see what is wrong. The error message ...
2
votes
1answer
524 views

How to make a dependency to the latest version of boost?

I'm packaging a couple of libraries that have some dependencies with one-another. To simplify, let's say I have: libA and libB. libB depends on libA for both building and installing. libA depends ...
2
votes
1answer
399 views

Software center crashes; fieldrunners need to be reinstalled; can't find achive

Could not initialize the package information. An unresolvable problem occurred while initializing the package information. Please report this bug against the 'update-manager' package and ...
1
vote
1answer
43 views

Debian's Depend: tag doesn't work with apt-get

Package A_0.0_all.deb's control file contains a dependency on Package B 0.0: Depends: B (= 0.0) Package B_0.0_all.deb's control file has the version 0.0: Version: 0.0 Sitting in the same Debian ...
1
vote
1answer
119 views

Broken libgcrypt11 dependency

I've run a casual apt-get update && apt-get upgrade command. The process completed (with an error): You might want to run 'apt-get -f install' to correct these. The following packages have ...
1
vote
1answer
37 views

Software Center crashes and I can not install any packages anymore

After I tried to install Skype (in order to do that I typed in some commands that I cant remember that I got from this forum) my software center is closing right after opening it and I can not install ...
1
vote
1answer
45 views

How does apt handle circular dependencies?

When I installing .deb packages by hand I often encounter circular dependencies. I, then, install it with dpkg -i --force-depends ... and hope it works. How does apt handle circular dependencies?
1
vote
1answer
553 views

How to resolve locales dependency on 12.04

sudo apt-get check Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these. The following packages ...
1
vote
1answer
619 views

hplip 3.14.10, no python-devel

Tech specs: Intel® Xeon(R) CPU E5420 @ 2.50GHz × 8 , 32GB Memory, ubuntu 14.04 (64bit). HP 5660 envy aio richard@Doc:~$ cd Desktop richard@Doc:~/Desktop$ sh hplip-3.14.10.run Creating directory ...
1
vote
1answer
64 views

How to get out of dependency hell

I am doing this from memory from work. Basically, I have libjpeg-turbo8 installed. But I have libjpeg-turbo8:i386 installed at version xxx4.4 and libjpeg-turbo8:amd64 installed at version xxx4.3. I ...
1
vote
1answer
65 views

cannot upgrade Catfish file searching tool

I receive the following error messages attempting to upgrade the Catfish file searching tool: The following packages have been kept back: catfish The following packages have unmet dependencies: ...
1
vote
1answer
328 views

How do I install the latest empathy 3.11+ in Ubuntu

I was wondering if someone could give me brief answer regarding if this is possible or not. I have tried to follow these instructions I downloaded the latest source file, but I seem to have unmet ...
1
vote
1answer
786 views

Trying to install CUDA on Ubuntu 13.10 Amazon g2.2xlarge GPU Cluster

Does anybody know a way to do this? I have tried the following from... http://vasir.net/blog/opencl/installing-cuda-opencl-pyopencl-on-aws-ec2 ...
1
vote
1answer
420 views

Can't install Python2.7 on Ubuntu 13.04

I'm trying to install Python 2.7 on my Ubuntu 13.04 VPS. I'm issuing; sudo apt-get install python=2.7.4-0ubuntu1 and getting this in return Reading package lists... Done Building dependency tree ...
1
vote
1answer
987 views

Network-manager cannot install, dependency issue

I accidently installed connmanager, it removed my network-manager and network-manager-gnome. Now I cannot connect to my wifi and ethernet connection. I tried to install network-manager from source ...
1
vote
1answer
505 views

apt-get install -f seems to purge too much

I've been trying to install skype to the 12.04 64bit. Installing ai32-libs doesnt work at all (something about held packages and none of recommendations hasn't helped). I've installed package ...
1
vote
1answer
193 views

Unmet dependencies while installing fbreader

I was installing fbreader in Ubuntu 12.04, but it showed that some packages are broken and have unmet dependencies, so fbreader wasn't installed. Moreover, software center started to show repair ...
0
votes
0answers
33 views

No SDLIMAGE found while running ./configure file

recently i installed libsdl1.2-dev to install a game, after installing it in system. I run ./configure file and I am getting new error checking for sdl-config... /usr/bin/sdl-config checking for SDL ...
0
votes
0answers
300 views

Freeradius installation on ubuntu 12.0.4 LTS

I'm new to ubuntu and just set up today a server with ubuntu 12.0.4 LTS on a 32-bit VM. I'm trying to install freeradius but I keep getting the following error: root@RadiusServer:/home/hisham# sudo ...
0
votes
0answers
180 views

Unmet dependencies that cannot be fixed

I've been trying to fix theese for 2 days now, but none of "trafitional" methods work. What methods? Well… For example I tried running sudo apt-get update sudo apt-get upgrade First command works ...
0
votes
0answers
2k views

Installing PCSX2 on trusty with gregory ppa has dependency error with libsoundtouch0

I executed the following commands: sudo apt-add-repository ppa:gregory-hainaut/pcsx2.official.ppa sudo apt-get update sudo apt-get install pcsx2 Running the last command gives Reading package ...
0
votes
0answers
661 views

gameranger client for linux

I found this gameranger client made for linux!! But sadly it's not working because of dependencies since it dates back to 2005 and hasn't been been developed since. or so they say! Is there a way ...
0
votes
0answers
211 views

Apt-get unmet dependencies

I´m using Ubuntu Server 12.04 and MySQL 5.5. When I try to install libsml2-dev I get the following message : root@myserver:/usr/local/php5516/php-5.5.16# apt-get install libxml2-dev Reading package ...
0
votes
0answers
75 views

How to upgrade a repository package from source without also upgrading its dependencies?

I tried to upgrade python3-sip from 4.15.5 (latest version in Ubuntu 14.04 repository) to 4.16.2 (latest version from source). However, the version being imported in python3 is still the old version: ...
0
votes
0answers
69 views

My systems a mess.. multiple dpkg problems

Sorry in advance, my first post so not sure how much to elaborate. Also novice bioubuntu user. Our Machine 64bit Ubuntu 12.04.4 LTS Linux version 2.6.32-57-generic (buildd@brownie) (gcc version 4.4.3 ...
0
votes
0answers
71 views

unable to fix dependency error

I cannot update and install any software. I've tried apt-get -f install and some other methods as suggested in this site but none of them worked. prios@shrsth:~$ sudo apt-get -f install Reading ...
0
votes
0answers
8 views

Status of dependencies upon update

I'm currently running 12.04.5, the 64 bit version. Now, I have a few projects and for them I have a number of dependencies installed. I'm thinking of an upgrade to 14.04, but I'm worried about the ...
0
votes
0answers
329 views

Unable to reinstall apache on Ubuntu 12.04.5 LTS

Unfortunately, What I did: Updated apt repository to install apache244 and installed it. Uninstalled apache2.4 using following commands: apt-get remove apache* apt-get purge apache* apt-get clean ...
0
votes
0answers
186 views

Depending on postgresql-plpython for every installed version of postgresql

I'm working on a project which gets installed as an Ubuntu package. This is part of the code for generating the database (modified): CREATE EXTENSION plpythonu; CREATE FUNCTION foo (str text) ...
0
votes
0answers
119 views

why when I'm removing package, apt trying to install 40 extra

Removing pulseaudio because alsa can work without it. And I want to make things simpler. Those not Suggested nor Recommended. Why apt wants them installed and how to avoid that? ... Suggested ...
0
votes
0answers
277 views

dpkg: error processing package mariadb-server-5.5

Ok, I think I royally screwed up my laptop. I was trying to replace MySQL with MariaDB and accidentally installed MariaDB v10.1 (I should've used MariaDB v5.5). I decided I'd just "downgrade" to ...
0
votes
0answers
114 views

apt-get won't install dependency

File A, version 12, has a dependency on file B, version 12. However, in the repo, there exists a B_12_all.deb and B_13_all.deb. The dependency in A_12_all.deb's control file is the following: ...
0
votes
0answers
125 views

Checking for dependencies when creating a .deb

I'm working my way through the documentation on how to build a .deb package and I've hit something of a snag. When I need to spell out the dependencies for the package (dillo right now, just for a ...
0
votes
0answers
101 views

Dependency problems with initramfs-tools please help I'm new at this and lost

I'm using Ubuntu server 12.04 no GUI, I'm been using just a terminal for the entire time I've had this server installed. I did install webmin. Webmin wanted me to do some updates and while in the ...
0
votes
0answers
117 views

Broken packages and unmet dependencies installing htk

I'm trying to install HTK 3.4.1 on Ubuntu 12.04, 64-bit machine. The ./configure command executes without any errors, but when I try to build using the make all command, it shows the following error: ...
0
votes
0answers
117 views

Problems in downloading and installing packages

I am a newbie in Ubuntu. I have installed 12.04 LTS in my laptop and it was moreover all fine. I want to install packages like wine,VLC,Chromium Browser,etc I was getting various error messages. 1). ...
0
votes
0answers
319 views

Update Manager and software centre not working

I tried to update Ubuntu 12.04 through the update manager. After downloading all the updates, it asked me to restart the system for the installation of the downloaded packages, after which neither the ...
-1
votes
0answers
19 views

fresh re installation of ckan, jetty, solr

I am trying to install ckan on my ubuntu 14.04, but i got into some errors that i cant fix, so i decided to do a fresh installation after i remove everything from my computer. I am getting some errors ...
-1
votes
0answers
32 views

Scribus-trunk missing dependencies on 15.04

I can't install Scribus-trunk on 15.04. If I add the available 14.10 sources.list to 15.04 i get this: scribus-trunk: Depends: libgraphicsmagick3 but it is not going to be installed Depends: ...