Questions concerning software and package dependencies.

learn more… | top users | synonyms (1)

0
votes
1answer
96 views

Error You might want to run 'apt-get -f install'

I have the next error when I try to install Google Chrome or LibreOffice or any software I want. Error console: Reading package lists... Done Building dependency tree Reading state ...
0
votes
0answers
18 views

I can't install libosmesa6-dev on Ubuntu trusty [duplicate]

I tried sudo apt-get install libosmesa6-dev , but it had dependency issue. This is the error I get after running this command: Reading package lists... Done Building dependency tree ...
3
votes
2answers
207 views

Cannot update/install other software after failing to install LibreOffice

I tried to install LibreOffice through the software centre but an error occurred and the installation failed. Now it is shown as "installed" in software centre while it's actually not. I realised it ...
0
votes
0answers
19 views

problem with unmet dependencies while installing libgdal1-1.5.0 and odbcinst1debian1

I am trying to install flightgear 1.9.1 in Ubuntu 15.04. My computer is not very fast and a version that could work is flightgear 1.9.1 I installed odbcinst1debian1 but when I try to install ...
0
votes
0answers
187 views

Unmet dependencies of cuda-drivers

I am not able to re-install Cuda 7 properly on Ubuntu 14.04 (and now I am trying to remove it). But it's showing "unmet dependencies" error: sudo apt-get -f install gives : Reading package lists... ...
0
votes
0answers
163 views

Error updating gstreamer1.0-plugins-bad

Rhythmbox require update but while updating it fails...! It gives the following errors: The following packages have unmet dependencies: gstreamer1.0-plugins-bad: Depends: libc6 (>= 2.15) but ...
0
votes
0answers
66 views

m64py Front end for Mupen64Plus Error: Dependency is not satisfiable: libsdl2-dev

I am trying to install m64py Found here and I am experiencing an error Error: Dependency is not satisfiable: libsdl2-dev when trying to install the .deb I have tried to use sudo apt-get install ...
1
vote
1answer
354 views

Installing QtCurve on 15.04 with KDE5

I installed Ubuntu 15.04 with KDE5. Now I really want to install a new theme: The Hex Kde theme. Unfortunately there is no QtCurve option within System Settings. I tried installing QtCurve with this ...
1
vote
2answers
53 views

Why would removing a couple of modules remove lots of packages?

I ran the following: sudo apt-get remove postfix mailutils libsasl2-2 ca-certificates libsasl2-modules Why would that command do the following and what's the best way to undo it? Reading package ...
0
votes
1answer
78 views

New to UBUNTU, problems installing steam

Distributor ID: Ubuntu Description: Ubuntu 14.04.2 LTS Release: 14.04 Codename: trusty firefox Steam needs to install these additional packages: libgl1-mesa-dri:i386, libgl1-mesa-glx:i386, ...
0
votes
0answers
19 views

haskell-platform doesn't contain cabal

I installed haskell on Ubuntu 14 by: sudo apt-get install haskell-platform But cabal hasn't been installed for some reason: $ cabal --version -bash: /home/me123/.cabal/bin/cabal: No such file or ...
0
votes
1answer
125 views

Unmet dependencies Pipelight

I am trying to install pipelight onto my notebook. Sadly I can't manage to get it installed. Every try to install it ends up with: Some packages could not be installed. This may mean that you have ...
0
votes
0answers
62 views

Problem installing Mod_Mono on Ubuntu

I am trying to install mod_mono on Ubuntu (Ubuntu 14.4 LTS, Monodevelop 5.9, Mono JIT compiler version 4.0.1). I tried below command as per this article and this question: sudo apt-get install ...
0
votes
0answers
89 views

New to Linux. Cannot install anything; missing dependencies

I am on a new installation of Ubuntu and I'm trying to download programs like Synaptic and Gparted but whenever I try and download through the terminal I get: The following packages have unmet ...
2
votes
1answer
59 views

How can I repair broken softwares?

I want to install ffmpeg as Documented here . but some errors are accurates when I want install on terminal: The following packages have unmet dependencies: libfaac-dev : Depends: libfaac0 (= ...
1
vote
1answer
97 views

Mysql workbench installation failed?

I am unable to install mysql workbench community addition on ubuntu 14.04 I am installing latest version by debian file downloaded from server 1. sudo apt-get install gdebi-core 2. sudo gdebi ...
0
votes
1answer
50 views

I have had this red circle with the white icon

I have had this red circle with the white icon in the top right corner for a while now, and the specific message is: An error occurred. Please run Application Manager from the Right Click Menu or ...
0
votes
0answers
71 views

Unable to install java on ubuntu

I am new to ubuntu so I have a very limited knowldege of it. I want to install java into my Ubuntu system. Running sudo apt-get install default-jre gives me the following error message: You might ...
0
votes
0answers
57 views

GDB can not be installed because of dependency on libpython3.4.2

I am on 14.04.1 64bit and trying to install GDB version 7.9. First I tried to build from source but I got errors all over the place. Now I got the deb package and it also can not be installed because ...
0
votes
1answer
67 views

Unable to install anything

I wonder if someone can help me , when I try install or remove a package , this is the error I get dpkg: error processing package libdrm-nouveau2:i386 (--configure): package is in a very bad ...
4
votes
2answers
861 views

Unable to install Springseed 2 on Ubuntu 15.04

I've downloaded Springseed 2 deb file and when I open it by Ubuntu Software Center, it shows this error: Dependency is not satisfiable: libgcrypt11 I've looked for this package in my Synaptic ...
0
votes
1answer
128 views

How to repair my apt-get

I am using Ubuntu 14.04 with HWE stack (kernel 3.16) on a Dell Inspiron 15-5547, AMD Radeon HD R7 M265. I've been trying to install the proprietary drivers fglrx drivers in order to be able to switch ...
0
votes
1answer
49 views

How to I install Bastion in Ubuntu 15.04?

I downloaded Bastion quite a while ago from the Humble Indie Bundle. I still have the .deb file and would like to install it in Ubuntu 15.04. Unfortunately, the installation fails: [me@ubuntu debs]$ ...
0
votes
1answer
109 views

fresh re installation of ckan, jetty, solr

I am trying to install ckan on my ubuntu 14.04, but i got into some errors that i cant fix, so i decided to do a fresh installation after i remove everything from my computer. I am getting some errors ...
0
votes
2answers
92 views

Dependency problem in Trusty [duplicate]

shakil@shakil-Aspire-5733Z:~$ sudo apt-get -f install [sudo] password for shakil: Reading package lists... Done Building dependency tree Reading state information... Done Correcting ...
1
vote
1answer
44 views

Dependency problems [duplicate]

I am not able to install anything because I get the follworing dependecy issues: dpkg: dependency problems prevent configuration of locales: libc6 (2.19-18) breaks locales (<< 2.19) and is ...
1
vote
0answers
78 views

How to get unity build dependencies after apply the LTS Enablement Stacks?

I have a Ubuntu 14.04.2 installation with the LTS Enablement Stacks (https://wiki.ubuntu.com/Kernel/LTSEnablementStack). I would like to build the Unity package from source to apply some custom ...
1
vote
2answers
49 views

Damaged and locked dependencies

First of all I point out I'm not expert so sorry if I don't understand something or I write some silly stuff. I downloaded the TLP for power saving while using my laptop with the battery, even though ...
5
votes
5answers
460 views

Unable to insall libgtk2.0-dev on ubuntu 12.04

I am using opencv 3 on ubunut 12.04 and while displaying an image the error message asks me to build the library with libgtk2.0-dev. I tried sudo apt-get install libgtk2.0-dev but I get the following ...
1
vote
0answers
233 views

Ubuntu 14.04 OpenCV3 ffmpeg or libav dependencies

I need to install OpenCV on Ubuntu 14.04 to work with Python3 but the only version that is compatible is OpenCV3 which is at 3.0 RC1 http://opencv.org/downloads.html Following installation ...
1
vote
3answers
1k views

Why am I getting an error related to linux-image-3.13.0-53-generic (3.13.0-53.88)?

Every time I install or remove existing software I get the following error. isuru@isuru-Inspiron-3420:~$ sudo apt-get autoremove Reading package lists... Done Building dependency tree Reading ...
0
votes
0answers
27 views

Error 2 : Building dependencies problem in ubntu 14.04

(synaptic:4696): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed Can't exec "locale": No such file or directory at /usr/share/perl5/Debconf/Encoding.pm line 16. Use of ...
0
votes
0answers
43 views

How can I make umet dependencies correct? in ubuntu 14.04 while update and upgrade with sudo commands

dhanesh@HP2000-Notebook:~$ sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct ...
1
vote
1answer
61 views

Debian's Depend: tag doesn't work with apt-get

Package A_0.0_all.deb's control file contains a dependency on Package B 0.0: Depends: B (= 0.0) Package B_0.0_all.deb's control file has the version 0.0: Version: 0.0 Sitting in the same Debian ...
0
votes
1answer
71 views

Installing Dependencies for Building Unity 8

If somebody could please tell what I can do to fix this that would be great, because I've tried clearing the build by deleting the cache file and many other desperate attempts. I've searched for every ...
0
votes
1answer
114 views

How to know from ldd command which library is missing?

When I run ldd -r binary_file I get something like this: libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf6d7a000) and this seems ok. However, I don't know what this line means, do I have the ...
1
vote
3answers
2k views

How can I install Wine in 15.04 when there are unmet dependencies?

When I try to install Wine in Ubuntu 15.04, I get the following message: >sudo apt-get install wine Reading package lists... Done Building dependency tree Reading state information... Done ...
2
votes
1answer
285 views

Downloading DeSmuME (Gtk) Error

I went to install DeSmuME (Gtk) (Nintendo Ds Emulator) and I encountered error message. $ sudo apt-get install desmume The following packages have unmet dependencies: desmume: Depends: libasound2 ...
2
votes
0answers
35 views

Monodevelop installation issues [closed]

I am unable to install monodevelop on ubuntu 12.10. I am getting the following error. any help is appreciated. revathi@revathi-AcerLaptop:~$ sudo apt-get install monodevelop-current [sudo] password ...
0
votes
1answer
31 views

unmet dependecies problem

When I try to install libxinerama-dev, I get this error: The following packages have unmet dependencies: libxinerama-dev : Depends: libxinerama1 (= 2:1.1.3-1) but 2:1.1.3-1+b1 is to be installed E: ...
0
votes
1answer
133 views

Linux mint 17.1 libgtk [closed]

Hi i have problem while i want install gnome shell in linux mint ,iam using this command: sudo apt-get install gnome-shell gnome-shell-extensions gnome-tweak-tool and its display this: The ...
1
vote
0answers
24 views

package dependencies [duplicate]

While installing ubuntu from ubuntu software center, i got the following error: package dependencies could not be resolved After clicking detail button, shows the following error: The ...
0
votes
1answer
84 views

Ubuntu 12.04 LTS server in Virtualbox - problems with apt-get update and Prosody

Playing around with learning how to run an Ubuntu server (specifically, trying to set up Prosody as per a video on ArsTechnica, and a Linode guide), using Virtualbox. I've got it up and running, ...
6
votes
3answers
261 views

Uninstalling Dependencies. Is This a Good Practice?

As far as I know I can uninstall a program from Ubuntu using this command... $ sudo dpkg -r packagename But this does not remove the dependencies while the packagename installed. To remove all ...
0
votes
0answers
21 views

Having Trouble Installing DeSmuME from the Software center [duplicate]

I tried installing DeSmuME on 14.04.2 LTS. But I keep getting this error: "Package dependencies cannot be resolved..." How can I fix this and install DeSmuME?
1
vote
0answers
71 views

Unable to install Virtualmin

I am using Ubuntu 12.04.5 LTS Release: 12.04 Codename: precise I want to install Virtualmin on my VPS, but I am getting errors while installating. Check the below errors: INFO - ...
1
vote
2answers
974 views

“Unmet dependencies” When trying to install KDE Plasma 5.3 on Ubuntu 15.04

I'm trying to install the latest KDE Plasma here but I'm getting You might want to run 'apt-get -f install' to correct these. The following packages have unmet dependencies: kde-telepathy-minimal: ...
0
votes
0answers
29 views

libgles2-mesa:i386 unmet dependencies

I am trying to install libgles2-mesa:i386 on my ubuntu 14.04. It does not install, I get the following error: sudo apt-get install libgles2-mesa:i386 Reading package lists... Done Building dependency ...
0
votes
0answers
28 views

How to install gcc? [duplicate]

I tried to install gcc, but couldn't install because of dependency on gcc-4.4, which in turn depends on list of so many packages. gcc-4.4 : Depends: cpp-4.4 (= 4.4.3-4ubuntu5.1) but it is not going ...
1
vote
1answer
104 views

Cant install libsdl2-dev or cmake glfw.. (libxinerama-dev problem)

So I was going to continue learning Opengl after switching to Ubuntu, I tried this explanation to compile glfw and use it, but I got this: -- Using X11 for window creation -- Using GLX for context ...