Questions concerning software and package dependencies.

learn more… | top users | synonyms (1)

1
vote
3answers
311 views

problems installing gfortran

When I try to sudo apt-get install gfortran, the following error message pop up, it seems that there are some broken packages, how do I fix that? Reading package lists... Done Building dependency ...
0
votes
1answer
322 views

How to install ubuntu-device-flash in Ububtu 14.04?

I m trying to install ubuntu-device-flash on Ubuntu 14.04 (64 bits). I'm following the instructions here: Prepare your Ubuntu desktop I do: sudo add-apt-repository ppa:ubuntu-sdk-team/ppa sudo add-...
0
votes
0answers
20 views

Broken Packages Issue

I have Ubuntu 12.04 LTS in VM on Windows. I am trying to install OpenGL. I am getting the following error: vinayak@Vinayak:~/VinGL$ sudo apt-get install freeglut3 freeglut3-dev [sudo] password for ...
1
vote
1answer
123 views

How can I solve this dependency problem installing Chrome on Ubuntu 12.04?

I need to install the current version of Chrome on my 64-bit Intel box running Ubuntu 12.04. When I follow the steps at: http://www.ubuntuupdates.org/ppa/google_chrome everything goes fine until the ...
0
votes
1answer
99 views

IcedTea and OpenJDK-8 packages errors after upgrading to 16.04

I just upgraded from 15.10 to 16.04 on my laptop and now I have errors with IcedTea and OpenJDK-8 related packages. There seems to be a problem with dependencies. Can someone tell me how to get rid of ...
-1
votes
1answer
160 views

Can't install aptitude on Ubuntu Gnome 16.04 LTS

Where I try to install aptitude, i get this: Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct ...
0
votes
0answers
29 views

libode-dev : Depends: libode2 (= 3:0.11.1-tbb-1trusty2) but 3:0.11.1-tbb-1trusty3 is to be installed

I have already read earlier posts but couldn't find the answer. I want to install Simspark simulator on ubuntu 14.04 according to installation guide but I face the following error during installation: ...
1
vote
1answer
27 views

apt-get autoremove does not see dependencies of a removed package?

I had ubuntu-sdk installed, /var/log/apt/history.log has to say this about it: Commandline: apt --no-install-recommends install ubuntu-sdk Install: python3-simplejson:i386 (3.3.1-1ubuntu6, automatic),...
0
votes
1answer
127 views

Samba won't install becuase of broken packages

I am running Ubuntu Server 14.04.4 and I didn't install Samba with the original OS setup. I would like to install it now but I keep getting a error about broken packages. It appears that the main ...
1
vote
3answers
635 views

Just installed Ubuntu 16.04 but no software center

Installed Ubuntu 16.04 here are my specs: OS: Ubuntu 16.04 LTS x86_64 Kernel: 4.4.0-21-generic Uptime: up 17 hours, 39 minutes Packages: 3268 Shell: /usr/bin/fish Resolution: 1366x768 Desktop ...
0
votes
1answer
27 views

How to make Apt/Aptitude prefer a more recent virtual package over a real one

I've recently built a package which provides multiple virtual ones, more specifically snmp which provides libsnmp-base, libsnmp30 and so on: Version: 5.8~git20160427.8d07349f-14 Depends: ... ...
0
votes
1answer
324 views

Error while installing libqt4-core on Ubuntu 16.04

I'm trying to install libqt4-core, but it seems that for the dependencies, I have more recent versions than are compatible with this package. When I use sudo apt-get install libqt4-core my output is ...
0
votes
2answers
43 views

add dependency to cuurent kernel version

I want to depend my deb package to current kernel version that is installed on machine. for example if my kernel version is 3.13.0-77 my deb file depends on linux-headers-3.13.0.77-generic if I add "...
0
votes
0answers
24 views

How to make pre-depends install packages in debian packaging

I am building a package that depends on package X, Y, Z. So i put them into the control file und der Pre-Depends: X, Y, Z However, this doesn't install the packages it just says my package can't ...
0
votes
3answers
919 views

After Ubuntu 16.04 installation can't install almost anything

I fresh installed Ubuntu 16.04 to my laptop recently and since that I can't install lots of things. I know there is a bug in the Software Center but the problem is not limited to that. I can't install ...
0
votes
1answer
34 views

Version range in debian/control

When declaring dependencies in debian/control to create a package, I can specify a lower or upper bound on the version. For example, if I depend on libvtk6-dev being at least version 6.0.0 I can write ...
0
votes
4answers
5k views

How Do I Fix Unmet dependencies Linux-Image-Generic etc

My battery died on an upgrade and now I have this problem when I try to install updates. How do I fix it? The following packages have unmet dependencies: linux-generic: Depends: linux-image-generic (=...
0
votes
0answers
17 views

Error on installing python-egenix-mxdatetime

I get an error on installing python-egenix-mxdatetime specific the 3.1.3 version. First I downloaded the package from egenix site, then tried to install python-egenix-mxdatetime using the below ...
1
vote
0answers
37 views

Error:dependency is not satisfiable

I'm a new Ubuntu user, and I don't know so much about this system. So, when I tried to install a game (Lonely Survivor) I got this error: "Error: dependency is not satisfiable: ia32-libs(>=...
3
votes
3answers
163 views

code::blocks on Xenial Beta

Attempting to install code::blocks through the PPA with apt-get and not having much luck. I keep receiving these errors: The following packages have unmet dependencies. libcodeblocks0 : Depends: ...
0
votes
0answers
13 views

“dependency is not satisfiable: libicu42”

Trying to install McAfee on Ubuntu 12.4 got the message,"dependency is not satisfiable: libicu42" How to get past this?
1
vote
0answers
60 views

Apt-get install -f and apt-get autoremove error

I've tried to install new software on Ubuntu and it told me to use that command apt-get install -f, but I get back an error message and I have no idea how to fix it. After that, I tried to use apt-...
0
votes
0answers
61 views

Unmet dependencies error

When I try to install gparted Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have ...
1
vote
0answers
179 views
0
votes
1answer
71 views

Unable to install npm on ubuntu 14.04 due to broken packages error

Tried installing npm on ubuntu 14.04 however the following error has occurred gwt@gwt-Aspire-E1-571:~$ sudo apt-get install npm Reading package lists... Done Building dependency tree Reading ...
0
votes
0answers
24 views

Dependency problem

I use Ubuntu on my offline laptop. Since I want to install python, I have to install a lot of dependencies as well, and to install those dependencies I need even more dependencies of the dependencies....
0
votes
0answers
47 views

Cant install skype on ubuntu 14.04 LTS

I am getting the below error while trying to install skype. :~$ sudo apt-get install skype Reading package lists... Done Building dependency tree Reading state information... Done Some ...
1
vote
2answers
301 views

Problem installing Dolphin-emu, Unmet dependencies

When attempting to install Dolphin-Emu, I have come across a un-met dependences that are preventing the installation. I installed Dolphin-Emu as a PPA, so I could manually install the package. Every ...
0
votes
1answer
40 views

Gnome dependency problems with Nvidia drivers

I am running Ubuntu 14.04. I once installed the nvidia drivers (nvidia-355) and then after a few days I installed Gnome 3.10. It kept complaining about some dependency problem so I figured it'd be ...
1
vote
1answer
145 views

How do I reinstall shared dependencies after upgrade to 16.04?

I just upgraded to 16.04. When I tried to launch Emacs from the command line, I get the following error emacs/src/emacs: error while loading shared libraries: libgif.so.4: cannot open shared ...
0
votes
1answer
111 views

Launchpad Build Recipes: How do I correctly specify build dependencies for packages in the same PPA?

I am trying to build Code::Blocks IDE on Ubuntu 16.04 using this recipe: https://code.launchpad.net/~damien-moore/+recipe/codeblocks-16.01-release It needs libwxgtk2.8-dev, which isn't in the 16.04 ...
0
votes
0answers
16 views

“Error: Opening the cache …installed packages have unmet dependencies” [duplicate]

I recently started using Ubuntu, and today I got the following error and am unsure how to proceed. I would appreciate any input. An error occurred, please run Package Manager from the right-click ...
2
votes
1answer
680 views

Can not install openssh-server on Ubuntu 16.04

As a fresh new install of Ubuntu 16.04 sudo apt-get install openssh-server outputs Also it is a fress install I could not understand why this happens. dpkg -l openssh\* Output is If ...
0
votes
0answers
38 views

Epson WF 36xx series shooting blanks driver not installing 16.04

As the title states, my printer isn't working right and things aren't installing easily. I have this networked on wireless. The test pages printed directly from the printer were fine. I am using the ...
2
votes
1answer
201 views

How to resolve a missing libproxy1 dependency on Wily

I'm installing the Citrix VPN client using the installer nsgclient.deb on Wily and I get the error Dependency is not satisfiable: libproxy1. I tried apt-get with this result: $ sudo apt-get install ...
0
votes
0answers
64 views

Dependency problem in install filezilla in ubuntu 14.04 from ubuntu software center

i use Ubuntu 14.04 when i try to install filezilla from ubuntu software center so it return dependency error like "The following packages have unmet dependencies: filezilla: Depends: libgcc1 (>= 1:...
0
votes
0answers
15 views

Getting Dependencies error anytime while trying to install any package

I am getting the following error while removing or adding any new software, rfc5766-turn-server:i386: Depends: libc6 (>= 2.7) but 2.19-0ubuntu6.7 is installed Depends: ...
0
votes
2answers
871 views

Cannot install build-essential on ubuntu 16.04 [closed]

I am trying to install build-essential package on Ubuntu 16.04 (Xenial Xerus) but there is a dependency issue. root@server:~# apt-get install build-essential Reading package lists... Done Building ...
0
votes
0answers
147 views

Upgrading to 16.04 failed due to unmet dependencies

Upgrading 15.10 -> 16.04 produced errors, but the upgrade went on. Now I can't install new packages, due to unmet dependencies. Libreoffice, PHP and probably other programs don't work now. Updating ...
0
votes
0answers
12 views

How to add two alternative dependencies in control file? [duplicate]

The software depends on any of python-wxgtk2.8 or python-wxgtk3.0. What should be in the dependency field in the control file so that any one (which is available) of them is installed? python-wxgtk2....
1
vote
1answer
748 views

Cant install libsdl2-dev or cmake glfw.. (libxinerama-dev problem)

So I was going to continue learning Opengl after switching to Ubuntu, I tried this explanation to compile glfw and use it, but I got this: -- Using X11 for window creation -- Using GLX for context ...
0
votes
0answers
42 views

following packages have unmet dependencies

I want to update codelite on my computer, but when I download the new version and uninstall my previous one. However, when I add the deb file, the terminal said: The following packages have unmet ...
0
votes
0answers
93 views

Installing KDE in Ubuntu GNOME 15.10

I'm trying to install KDE on Ubuntu GNOME 15.10, but I cannot get it to work. I'm trying to install it through the command line, using sudo apt-get install kubuntu-desktop but it doesn't work. It ...
0
votes
0answers
100 views

Multiple points of failure running World of Warcraft with Wine 1.8?

I am trying to get World of Warcraft 6.2.4 to run on Ubuntu 16.04. I've solved a couple of problems already by updating Wine to 1.8. I have tried using Wine in XP and Windows 7 "compatibility" mode. ...
0
votes
1answer
129 views

pkgProblemResolver::Resolve generated breaks Ubuntu 15.10

When I try to install something I received an error of dependencies and a incorrect gcc-5-base version installed. When I put sudo apt-get install anyprogram: Reading package lists... Building ...
0
votes
0answers
64 views

Package dependency is not going to be installed

I try to install ROS, but it does not work properly, so they write I should install libgl1-mesa-dev-lts-utopic first. This produces this error, for which I can't find the solution. Why doesn't apt-get ...
1
vote
1answer
144 views

How to install odbcinst and odbcinst1debian2 via dpkg -i, when they depend on each other?

Using Ubuntu 12.04 LTS 64bit. Host is offline, and of necessity must stay that way. I need to install odbc to talk with a remote database from a C++ application running on the system. I have ...
0
votes
1answer
51 views

cannot install qtbase5-dev due to unmet dependencies

I need to install qtbase5-dev but $> sudo apt-get install qtbase5-dev Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be ...
0
votes
0answers
201 views

Error unmet dependencies can't install or remove software

I can't use software center or terminal to install or remove software (always render unmet dependencies error). I fix follow guest in software center: It fails with: installArchives() failed: W: ...
1
vote
2answers
93 views

Can multiple versions of the same package co-exist on the same system?

In order to install tmux 2.1, I needed to install libtinfo5 version 6, I did this by downloading a .deb archive containing libtinfo5 and installing directly with command: sudo dpkg -i libtinfo5_6.0+...