Questions concerning software and package dependencies.

learn more… | top users | synonyms (1)

0
votes
0answers
29 views

Blocked upgrades after upgrade 15.10 to 16.04

So I upgraded my system from 15.10 to 16.04 and I've got several items that can't upgrade. The following packages have been kept back: findutils gcc-5-base initramfs-tools initramfs-tools-bin ...
0
votes
0answers
24 views

hplip missing dependencies after hp-doctor

I encountered problems with my printer HP Laserjet 6p. I run XUbuntu 16.04 So I downloaded the latest hplip, and I installed it. Unfortunatelly when I run hp-doctor and hp-check, I have 2 errors : ...
0
votes
2answers
46 views

How do I install a specific lower minor version of gcc using package manager?

I am running an Ubuntu 14.04-4 64bit. gcc --version returns (Ubuntu 4.8.4-2ubuntu1~14.04.1) 4.8.4 Yet, I need version 4.8.2-10. What I tried: I found the specific gcc version in a debian snapshot ...
1
vote
1answer
44 views

How to fix/repair/remove/disable/install/uninstall 'Broken Packages' on Ubuntu 14.04 LTS?

I'm using a machine that runs on 64-bit Ubuntu 14.04 LTS I run regular 'System Updates'. On one day after performing such regular 'System Update' my system stopped detecting wireless and wired ...
1
vote
0answers
31 views

What does the aptitude `why` and `why-not` mean?

From the manuals: The command why finds a dependency chain that installs the package named on the command line, as above. Note that the dependency that aptitude produced in this case is only a ...
0
votes
0answers
48 views

Can't install package: dependends on gcc-4.8-base 14.04.01

I'm trying to install all the dependencies to run ASP.Net Core applications on a linux system. I basically have no experience with linux or the linux platform. I found a tutorial explaining the ...
0
votes
0answers
50 views

dpkg: error processing archive - kmod (--unpack)

I am trying to upgrade an old debian system (Ubuntu squeeze) to 14.04. I updated the /etc/apt/sources.list with the sources for ubuntu trusty. I have some troubles installing the package kmod where a ...
2
votes
1answer
1k views

Dependency Is not satisfiable : libstdc++6 (>=4.8.0) [duplicate]

When I try to install Chrome through the Ubuntu Software Center, I get the message Dependency Is not satisfiable : libstdc++6 (>=4.8.0) How can I fix this? I am running Ubuntu 12.04.
-3
votes
2answers
34 views

Steam Install Problems

No matter how many times I try, I just CANNOT install steam. I've tried installing, uninstalling, installing random dependencies, typing all kinds of commands in the terminal, and even using Wine to ...
0
votes
1answer
182 views

Installing brackets needed libgcrypt11 on Ubuntu 16.04

I was trying to install Brackets on Ubuntu 16.04. It seeks the dependency on libgcrypt11. I installed that as well from the link. Now everything is working fine. But I just wanted to know if I can ...
0
votes
1answer
86 views

Could not install GNU Octave

I am getting below error while installing ocatve. Command I run: sudo apt-get update && sudo apt-get install octave Error: The following packages have unmet dependencies: octave: Depends:...
0
votes
2answers
116 views

Unable to install libmotif4

While installing dependencies for Oracle 11g setup on Ubuntu, I got the following error: Package libmotif4 is not available, but is referred to by another package. This may mean that the package is ...
0
votes
1answer
257 views

How can I fix dependency problems in Ubuntu 16.04?

I'm trying to install Ring and have run into dependency problems. I have no idea how to fix this. Would you have any ideas about how to approach this problem? I have attempted sudo apt-get update, ...
0
votes
0answers
29 views

Unable to install wine1.7 due to broken packages

I'm using an Ubuntu 14.04 system. I'm trying to install wine1.7 on my computer but sudo apt-get install wine1.7 but I get these errors : - sidhu@sidhu-Inspiron-5521:~$ sudo apt-get install wine1.7 ...
2
votes
1answer
87 views

Can't purge old kernels (dependency problems), but /boot is out of space

I'm running Ubuntu 14.04.4 LTS, and I'm trying to install a new package using apt-get. Unfortunately, whenever I try I get messages like: The following packages have unmet dependencies: linux-image-...
0
votes
1answer
69 views

Erlang error: while loading shared libraries: libncursesw.so.6

After installing Elrang/OTP on a server with Ubuntu 15.10, sudo apt-get install build-essential sudo apt-get --fix-missing -y install build-essential m4 libncurses5-dev libssh-dev unixodbc-dev ...
0
votes
2answers
93 views

Gnome-shell can't install - broken packages [duplicate]

I am trying to install gnome-shell but it shows me an error: $ sudo apt-get install gnome-shell ... Some packages could not be installed. This may mean that you have requested an impossible ...
0
votes
0answers
20 views

Broken Packages Issue

I have Ubuntu 12.04 LTS in VM on Windows. I am trying to install OpenGL. I am getting the following error: vinayak@Vinayak:~/VinGL$ sudo apt-get install freeglut3 freeglut3-dev [sudo] password for ...
1
vote
1answer
123 views

How can I solve this dependency problem installing Chrome on Ubuntu 12.04?

I need to install the current version of Chrome on my 64-bit Intel box running Ubuntu 12.04. When I follow the steps at: http://www.ubuntuupdates.org/ppa/google_chrome everything goes fine until the ...
0
votes
0answers
56 views

Installing libpoppler.so.28

I'm so new to this and I know I'm going to ask this all wrong. I'm also scared that I've missed the correct answer somewhere already posted, and I'm very sorry if that's the case! I've been trying to ...
0
votes
1answer
102 views

IcedTea and OpenJDK-8 packages errors after upgrading to 16.04

I just upgraded from 15.10 to 16.04 on my laptop and now I have errors with IcedTea and OpenJDK-8 related packages. There seems to be a problem with dependencies. Can someone tell me how to get rid of ...
0
votes
1answer
210 views

how to resolve dependencies building caffe on ubuntu 16.04

I am trying to build caffe from a git checkout on ubuntu 16.04. If found the gcc5 workaround and have sorted the hf5 issues but am now stuck. I've resolved most of the dependencies but am stuck ...
1
vote
1answer
30 views

apt-get autoremove does not see dependencies of a removed package?

I had ubuntu-sdk installed, /var/log/apt/history.log has to say this about it: Commandline: apt --no-install-recommends install ubuntu-sdk Install: python3-simplejson:i386 (3.3.1-1ubuntu6, automatic),...
-1
votes
1answer
57 views

New software can't be installed because there is a problem with the software currently installed--trying to install Loggerpro for Ubuntu

When I try to install loggerpro, this is the message I get. I looked on the forum and tried the following commands: sudo apt-get install --reinstall deconf and then it says: unable to access ...
0
votes
1answer
28 views

How to make Apt/Aptitude prefer a more recent virtual package over a real one

I've recently built a package which provides multiple virtual ones, more specifically snmp which provides libsnmp-base, libsnmp30 and so on: Version: 5.8~git20160427.8d07349f-14 Depends: ... ...
0
votes
1answer
135 views

Samba won't install becuase of broken packages

I am running Ubuntu Server 14.04.4 and I didn't install Samba with the original OS setup. I would like to install it now but I keep getting a error about broken packages. It appears that the main ...
0
votes
0answers
24 views

How to make pre-depends install packages in debian packaging

I am building a package that depends on package X, Y, Z. So i put them into the control file und der Pre-Depends: X, Y, Z However, this doesn't install the packages it just says my package can't ...
0
votes
1answer
34 views

Version range in debian/control

When declaring dependencies in debian/control to create a package, I can specify a lower or upper bound on the version. For example, if I depend on libvtk6-dev being at least version 6.0.0 I can write ...
0
votes
2answers
44 views

add dependency to cuurent kernel version

I want to depend my deb package to current kernel version that is installed on machine. for example if my kernel version is 3.13.0-77 my deb file depends on linux-headers-3.13.0.77-generic if I add "...
0
votes
0answers
17 views

Error on installing python-egenix-mxdatetime

I get an error on installing python-egenix-mxdatetime specific the 3.1.3 version. First I downloaded the package from egenix site, then tried to install python-egenix-mxdatetime using the below ...
1
vote
2answers
141 views

“Package dependencies cannot be resolved” - R project

I use R statistics ("r-base") on my computer and recently, by mistake, I ran the following command in terminal: sudo apt-get remove r-base-core Of course this removed R from my computer. To undo ...
1
vote
0answers
38 views

Error:dependency is not satisfiable

I'm a new Ubuntu user, and I don't know so much about this system. So, when I tried to install a game (Lonely Survivor) I got this error: "Error: dependency is not satisfiable: ia32-libs(>=...
-1
votes
1answer
167 views

Can't install aptitude on Ubuntu Gnome 16.04 LTS

Where I try to install aptitude, i get this: Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct ...
0
votes
0answers
13 views

“dependency is not satisfiable: libicu42”

Trying to install McAfee on Ubuntu 12.4 got the message,"dependency is not satisfiable: libicu42" How to get past this?
1
vote
0answers
60 views

Apt-get install -f and apt-get autoremove error

I've tried to install new software on Ubuntu and it told me to use that command apt-get install -f, but I get back an error message and I have no idea how to fix it. After that, I tried to use apt-...
0
votes
0answers
66 views

Unmet dependencies error

When I try to install gparted Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have ...
2
votes
3answers
67 views

Azureus runs fine on latest java but its dependency check asks for dated version of JRE. How to tell Ubuntu to stop naggin me for “unmet dependency”?

So I force installed Vuze (and its dependency Azureus) via apt-get, and it is working fine on default-jre. Even though the default-jre works as a dependency for Azureus (at least for my use-case ...
0
votes
0answers
48 views

Cant install skype on ubuntu 14.04 LTS

I am getting the below error while trying to install skype. :~$ sudo apt-get install skype Reading package lists... Done Building dependency tree Reading state information... Done Some ...
0
votes
1answer
74 views

Unable to install npm on ubuntu 14.04 due to broken packages error

Tried installing npm on ubuntu 14.04 however the following error has occurred gwt@gwt-Aspire-E1-571:~$ sudo apt-get install npm Reading package lists... Done Building dependency tree Reading ...
0
votes
1answer
264 views

Error Code E: Sub-process /usr/bin/dpkg returned an error code (1)

I've been using Ubuntu for a few years now, but I just installed Version 16.04, and I've been having a lot of issues. I'm not a command line programmer, but I tried to install some software last night,...
0
votes
3answers
940 views

After Ubuntu 16.04 installation can't install almost anything

I fresh installed Ubuntu 16.04 to my laptop recently and since that I can't install lots of things. I know there is a bug in the Software Center but the problem is not limited to that. I can't install ...
0
votes
0answers
24 views

Dependency problem

I use Ubuntu on my offline laptop. Since I want to install python, I have to install a lot of dependencies as well, and to install those dependencies I need even more dependencies of the dependencies....
1
vote
0answers
180 views

Open365 not working with Ubuntu Mate 16.04

Installer cannot install dependency libqt4-core
0
votes
1answer
113 views

Launchpad Build Recipes: How do I correctly specify build dependencies for packages in the same PPA?

I am trying to build Code::Blocks IDE on Ubuntu 16.04 using this recipe: https://code.launchpad.net/~damien-moore/+recipe/codeblocks-16.01-release It needs libwxgtk2.8-dev, which isn't in the 16.04 ...
0
votes
0answers
16 views

“Error: Opening the cache …installed packages have unmet dependencies” [duplicate]

I recently started using Ubuntu, and today I got the following error and am unsure how to proceed. I would appreciate any input. An error occurred, please run Package Manager from the right-click ...
0
votes
1answer
86 views

How to get this game to run by fixing this list of issues it displayed?

Screenshot with errors on left monitor: So I installed Witcher (game) from a .sh file, and when I try to run the game,it gives me that screen on the left in the image. I wanted to install the intel ...
0
votes
1answer
332 views

Error while installing libqt4-core on Ubuntu 16.04

I'm trying to install libqt4-core, but it seems that for the dependencies, I have more recent versions than are compatible with this package. When I use sudo apt-get install libqt4-core my output is ...
0
votes
0answers
38 views

Epson WF 36xx series shooting blanks driver not installing 16.04

As the title states, my printer isn't working right and things aren't installing easily. I have this networked on wireless. The test pages printed directly from the printer were fine. I am using the ...
0
votes
0answers
64 views

Dependency problem in install filezilla in ubuntu 14.04 from ubuntu software center

i use Ubuntu 14.04 when i try to install filezilla from ubuntu software center so it return dependency error like "The following packages have unmet dependencies: filezilla: Depends: libgcc1 (>= 1:...
0
votes
0answers
15 views

Getting Dependencies error anytime while trying to install any package

I am getting the following error while removing or adding any new software, rfc5766-turn-server:i386: Depends: libc6 (>= 2.7) but 2.19-0ubuntu6.7 is installed Depends: ...