Questions concerning software and package dependencies.

learn more… | top users | synonyms (1)

3
votes
1answer
1k views

Cannot install Eclipse in Ubuntu 14.04 64-bit

I cannot install Eclipse from the Ubuntu Software Center. I get error: The following packages are not yet satisfied with dependencies: eclipse-platform: Depends: eclipse-platform-data (> = 3.8.1-...
5
votes
1answer
5k views

Unable to re install mysql on Ubuntu 14.04: Dependency problems

Ubuntu Unity 14.04 LTS with all lenses removed, except files. (Hate the dash.) I have a LAMP system for web site development. I want to put all my data files in a particular partition that I can ...
1
vote
1answer
5k views

Unable to install libssl1.0.0:i386 due to “unmet dependencies”?

I have read and followed the advice in this question to no avail. I am attempting to install libssl1.0.0:i386 on my 14.04 box (amd64), but when I try to do this via APT, I receive the following error ...
0
votes
1answer
1k views

Compile evolution development snapshot 3.13.1

I have downloaded evolution development snapshot from this link: https://wiki.gnome.org/Apps/Evolution and now I have trouble compiling the source code. I am using ubuntu 14.04 and this version of ...
1
vote
2answers
1k views

Package dependencies cannot be resolved when installing totem [duplicate]

Package dependencies cannot be resolved when installing totem and I get this in details: totem: Depends: python:any (>= 2.7.1-0ubuntu2) but it is a virtual package Depends: libnautilus-...
0
votes
0answers
15 views

uninstalled libgconf2-4 by mistake now i cant reinstall it, need help [duplicate]

You might want to run apt-get -f install to correct these: The following packages have unmet dependencies: aisleriot : Depends: libgconf-2-4 (>= 2.31.1) but it is not going to be installed gconf-...
6
votes
3answers
22k views

Can't install wine on Ubuntu 14.04 [duplicate]

I cannot install Wine on Ubuntu 14.04. When I try to install it on the Ubuntu Software Center I always get a message that says I have unmet dependencies. I tried installing Wine through the terminal ...
2
votes
1answer
4k views

what is sudo apt-get -f install

what is the usage of apt-get -f install . when I run sudo apt-get update I got some errors at the end It says try apt-get -f install. What is this command? the last part of my error is : . . . ...
3
votes
1answer
13k views

dependency problems running apt-get -f install on Ubuntu

ON MY UBUNTU RACKSPACE SERVER UNAME -A # uname -a Linux myserver.com 3.2.0-24-virtual #39-Ubuntu SMP Mon May 21 18:44:18 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux APT-GET -F INSTALL /home# apt-get -...
0
votes
1answer
513 views

Canon pixma ip 4850 driver problem on 14.04 64

when installing driver I get dependences problems libtiff4 missing. Drivers downloaded from Canon: ip4800_redhat_debian_guide.tar, including cnijfilter-common_3.40-1_amd64.deb and ...
2
votes
0answers
488 views

After updating the system to 14.04, an application fails due to lack of libpng15. How do i obtain it?

After updating my Kubuntu to 14.04, one of applications (the "King Arthur's Gold" indie game) would fail due to lack of libpng15 in the system. The error message is: [13:47:13] PNG warning: ...
2
votes
2answers
5k views

How to solve missing libmng.so.1 in Trusty (14.04) Package is no more available

I would like to run SoulseekQT. However unfortunately one of the dependencies is libmng1, which is no more included in Trusty. sudo apt-get install libmng.so.1 or libmng1 or libmng1:i386 in Trusty (14....
3
votes
1answer
1k views

Vanished dependency: gir1.2-launchpad-integration-3.0

I'm trying to install a facebook-webapp but the dependency gir1.2-launchpad-integration-3.0 is not found and listed as uninstallable. I have been unable to locate it anywhere except for references to '...
0
votes
1answer
1k views

dependency not satisfiable fuse-utils

I have looked around and the answers for dependency problems seem to be specific but I am sorry if this has already been answered. I am trying to install storage made easy desktop client but when I ...
2
votes
2answers
2k views

libc6-amd64 dependency problem

I'm trying to install fglrx manually from the AMD website however it keeps complaining that it's missing the dependency "libc6-amd64". When I run the fglrx package through gdebi I get this message: ...
0
votes
1answer
1k views

unable to install mediaelch on Ubuntu 14.04

I am trying to install MediaElch after the upgrade from 13.XX removed it. I followed the instructions from the MediaElch website (http://www.kvibes.de/en/mediaelch/download/) sudo add-apt-...
2
votes
1answer
2k views

Update manager not worknig and Red icon on my menu panel

I've been upgrading my ubuntu 13.10 to 14.04 LTS,during the installation process, I accidentally lost power after this i try to turnon my machine, it shows red icon with Error message Here is the ...
4
votes
1answer
8k views

Broken dependency after upgrading ubuntu 14.04

I recently upgraded to ubuntu 14.04 LTS but few packages are broken. I tried to run the command apt-get -f install and dpkg --configure -a but nothing worked for me. Please help .. here is the output ...
0
votes
1answer
291 views

Can't upgrade past 11.10 - libc6 dependency errors [closed]

Since upgrading to 11.10 I can't upgrade any further (trying to get my web server to latest version.) I'm aware of How do I resolve unmet dependencies? and have tried up to the point of running this: ...
2
votes
0answers
1k views

Broken package problem while installing open source AMD ATI drivers in 14.04

After purging the fglrx* packages, I tried this - ankit@ubuntu:~$ sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:...
0
votes
1answer
13k views

In Ubuntu 13.04, cannot install libssl-dev [duplicate]

How can I get around the dependency problem when installing libssl-dev? The problem: $ sudo apt-get install libssl-dev Reading package lists... Done Building dependency tree Reading state ...
0
votes
1answer
333 views

Dependencies problem with x2go

I need help with my Ubuntu Server 12.04 64-bit. I can't update Ubuntu, because I always have problems with x2go. See message below: dependency problems prevent configuration of openssh-server: ...
0
votes
1answer
174 views

e17 installation and unmet dependencies

Every which way I try to correct unmet dependencies it gives me some long error. Trying to install packages I get evas-loaders : Depends: libefl (>= 201312241217) but it is not going to be ...
0
votes
1answer
376 views

dependency problems prevent configuration

I've gotten my Ubuntu server into an inconsistent state. I've read through a thread on a similar issue but am still unsure how best to proceed. Here is some info: # dpkg --print-architecture amd64 #...
0
votes
2answers
125 views

How to resolve depedancy issues with software not obtained from a repository

Ok so i have found that the Ubuntu software centre has excessively outdated builds posted for nearly every piece of software i attempt to install. The only solution i can think of is to download the ...
1
vote
1answer
119 views

cannot upgrade Catfish file searching tool

I receive the following error messages attempting to upgrade the Catfish file searching tool: The following packages have been kept back: catfish The following packages have unmet dependencies: ...
1
vote
0answers
731 views

Cannot install Openssh-server or client

When I go to install, I get this error: sudo apt-get install openssh-server Reading package lists... Done Building dependency tree Reading state information... Done Some packages could ...
0
votes
1answer
145 views

Problems when trying to upgrade from 10.04 to 12.04 [duplicate]

When I was trying to upgrade my server from ubuntu 10.04 to 12.04 I was facing problems with some packages. It was saying, sudo apt-get dist-upgrade Reading package lists... Done Building dependency ...
1
vote
1answer
147 views

Dependency is not satisfiable error

I am a new user to Ubuntu and seeking for help on installing a mod for Nautilus. I am running 12.04 on 32 bit machine. I do not know hot to compile all these files or what I am doing wrong. I ...
1
vote
3answers
6k views

Install older version of software and dependencies [duplicate]

I need to install R 3.0.2 because a needed library isn't compatible with 3.0.3 yet (the latest). I can install the older version of R like so: sudo apt-get install r-base=3.0.2-1precise0 However ...
2
votes
1answer
358 views

Update Manager crashes, says it needs 3.2.0.58.69 but linux-image-generic on system is 3.2.0.59.70 [duplicate]

Recently Update Manager ceased working. Ubuntu Software Centre, when I enter it instead, offers to repair, then fails and offers to repair again, and so on. This is the key sentence I keep getting ...
0
votes
1answer
1k views

Unable to install ccmake [duplicate]

[Preface: I have seen similar questions, but that did not help me and so this new question. To explain in more detail, I followed the steps in How do I resolve unmet dependencies?, without rectifying ...
1
vote
1answer
863 views

I want to install cudaminer but compile fails due to libcurl

~/CudaMiner/./configure checking build system type... x86_64-unknown-linux-gnu checking host system type... x86_64-unknown-linux-gnu checking target system type... x86_64-unknown-linux-gnu checking ...
0
votes
2answers
43 views

Remove config files of any package

How would I remove the config files of any package, or do apt-get purge and re-install it without removing any of its dependencies? Thanks!
0
votes
1answer
877 views

Cannot install libgles2-mesa-dev

When I try this following commands on Ubuntu 12.04: sudo apt-get install libgles2-mesa-dev-lts-raring I get the following output: The following packages have unmet dependencies: libgles2-mesa-dev-...
28
votes
4answers
42k views

Replace openjdk with oracle-jdk on Ubuntu

I have an ubuntu system and I want to replace my openjdk with oracle-jdk. However if I remove my open-jdk and then install oracle-jdk, when I try to install some packages they want to install ...
1
vote
2answers
288 views

can't update wine

I'm using wine 1.6.1 and want to upgrade to 1,7,13 but it always every time want update: The following packages have unmet dependencies: wine1.7 : Depends: wine1.7-amd64 (= 1:1.7.13-0ubuntu1~...
0
votes
1answer
2k views

Trying to make Install zulucrypt but cannot find packages

I have downloaded the source code of zulucrypt from http://code.google.com/p/zulucrypt/ because there is no .deb file. This is my first time to install from source and i need a little help by doing ...
-1
votes
2answers
2k views

TeamViewer on Ubuntu 13.10 dependency install problem

This is my first time using this forum and I am relatively new to ubuntu. I installed TeamViewer on another machine running 12.04 no problem. I have the same errors as the OP in this post: '...
0
votes
0answers
28 views

Unmet dependencies when trying to install curl [duplicate]

I have been struggling to fix this problem for 3 hours by now.I have searched for solution on this forum but so far anything that i have tried didn't help. When I try to run the following command: ...
0
votes
2answers
3k views

Cannot install gcc-4.8 because of unmet dependencies

I was trying to upgrade gcc-4.8.1 to gcc-4.8.2 using Synaptic from this PPA. The installation executed with no problem, but suddenly I had no gcc-4.8 at all. I was using gcc-4.7 and gcc-4.8 together, ...
1
vote
0answers
177 views

Can not install X11-Basic on Ubuntu 13.10

Trying to install X11-basic on Ubuntu 13.10 creates an error with following details: (Reading database ... (Reading database ... 5% (Reading database ... 10% (Reading database ... 15% (Reading ...
0
votes
0answers
260 views

Can't Install anything due to unmet dependencies Libre Office [duplicate]

I had libre office, but uninstalled it to install open office. It worked fine. Yesterday, as I was trying to install new software from ubuntu software center, it gave me an error message, first ...
1
vote
0answers
223 views

How to find top-level dependencies in a list of deb packages?

Suppose I have a list of packages: foo libfoo bar baz quux And suppose foo requires libfoo and bar, and baz requires quux. I want a way to put in that list, and get out this list: foo baz I.e. -...
2
votes
1answer
2k views

Unable to resolve missing qt4 dependecies after installing Armory and PPAs for Bitcoins

I've decided to make a wallet trough Armory so I can transfer Bitcoins to cold storage, so I went to install Armory. Now, Armory installed all well and good and than asked me to install PPAs, which I ...
1
vote
1answer
916 views

apt-get: you have held broken packages

Everything was working normally, but now libstdc++ seems to be broken. So I try to reinstall it. Things like: sudo apt-get remove stdc++ sudo apt-get autoclean sudo apt-get -f install sudo apt-get -u ...
0
votes
2answers
235 views

Installing generic headers without internet in ubuntu 13.04

I tried to install generic Linux headers without Internet by downloading them in .deb formats .. Based on the dependencies I installed one by one, then I encountered this .libc6:i386 depends on ...
0
votes
1answer
165 views

Ubuntu randomly freezes during boot [duplicate]

I recently partitioned my hard drive to create an empty 43 GB drive on my Windows 7 64-bit Compaq Presario. After the partition was complete, I used the Windows Installer from the Ubuntu website (...
0
votes
1answer
147 views

Issues with dependencies when installing Geary [duplicate]

I've just done a fresh install of Ubuntu Gnome 13.10 and I'm trying to install Geary after adding the Yorba ppa. I'm getting the following returned every time with sudo apt-get install geary : [sudo] ...
0
votes
1answer
3k views

Error while installing packages

I'm using Ubuntu 12.04. I'm encountering error in installing any package using apt-get. I've tried steps given in various forums, but couldn't resolve the error. For example, if I install kcachegrind, ...