Questions concerning software and package dependencies.

learn more… | top users | synonyms (1)

0
votes
0answers
8 views

When I attempt to install VLC i get this: [duplicate]

The following packages have unmet dependencies: vlc: Depends: vlc-nox (= 2.1.4-0ubuntu14.04.1) but 2.1.4-0ubuntu14.04.1 is to be installed Depends: libc6 (>= 2.15) but 2.19-0ubuntu6 is to be ...
0
votes
2answers
1k views

Installing crossvc is giving broken packages error [duplicate]

I am having Ubuntu 14.04 LTS. While trying to install crossvc, I am getting broken package error. I tried to find solutions and tried all the suggested steps in different posts. But no success. ...
0
votes
1answer
303 views

Ubuntu dependency problems

My ubuntu 12.4 box has been off for 10 days. Upon returning to it I have found that there's no sound and steam games (for linux) won't start. There is a dependancy problem. I'm guessing is causing ...
0
votes
1answer
157 views

cant install libqt4-sql-psql on ubuntu precise unmet dependencies

could someone help me resolve this ? I tried most of the commands here .. but none of them worked How do I resolve unmet dependencies? apt-get install The following packages have unmet ...
0
votes
1answer
844 views

Problem with installing libtiff5-dev

I am new to the whole Linux OS, and I have been having trouble installing some packages, including libtiff5-dev, libtiff5 , libjbig-dev and libmagickcore-dev. I keep getting the following message: ...
3
votes
2answers
3k views

PostGIS dependency conflicts (ubuntu 14)

I asked this over on SO, but now I'm thinking the problem is mainly package management and belongs here. Subsequent to all the detail that can be found in the original post, I have tried (sudo ...
0
votes
1answer
887 views

“Package dependencies cannot be resolved” when installing codecs

I'm trying to install some additional codecs, but it always throws the following error: The following packages have unmet dependencies: gstreamer1.0-libav:i386: Depends: libavcodec-extra-54 (>= ...
0
votes
1answer
1k views

What does ' but it is not installable' mean?

I noticed when I try some packages, I get sometimes this error: <pkg_name> Depends: <an_other_pkg> (>= version X.X.X) but it is not installable. What does is mean ' but it is not ...
0
votes
1answer
427 views

How to get appropriate lib package name for a specific header file [duplicate]

It's common problem that we get some error like "abc.h no such file" when compile source. Only way to find the solution(as i know) is search in internet. What i need to do, compile the source, it will ...
1
vote
0answers
45 views

Cannot login after Clam AV removal purge mistake

I would like some help repairing my Ubuntu installation please, I am having problems logging in after a mistake trying to uninstall Clam AV. I accidentally deleted some files / libraries whilst ...
1
vote
3answers
3k views

Unable to install most major packages; Unmet dependencies and cannot be fixed [duplicate]

I just did a fresh install of Ubuntu 14.04 64-bit, and it seems that most major packages I attempt to install (among them being Skype, Steam/Steam-Launcher, WINE, etc.), give an "unmet dependencies" ...
0
votes
1answer
160 views

gstreamer bad plugin of file .dep are not allowing me to install any software

For any install in ubuntu It is giving the same error. How can I remove all these gstreamer package errors? The error is installArchives() failed: dpkg: dependency problems prevent configuration ...
5
votes
3answers
9k views

why build-essential failed?

I cannot found solution for this problem: constantia@constantia:~$ sudo apt-get install build-essential Reading package lists... Done Building dependency tree Reading state information... Done ...
0
votes
1answer
6k views

mysql-server-5.5 has unmet dependencies

Every time I open the software center I get this message: Item can not be installed or removed until package catalog is repaired I click repair then I get Package operation failed I tried to ...
0
votes
1answer
51 views

Debian Packaging Dependencies Checking [closed]

How to force a debian package to check some dependency installed?
0
votes
1answer
143 views

Lost power during update and now i cannot install any packages or even update/repair update

I lost power during and update and now i cannot install or update any packages. I'm currently running Ubuntu 14.04 32bit. on terminal I get this message: dpkg: error processing package ...
0
votes
2answers
340 views

Error while installing Nokia Suite

Dependency is not satisfiable gambas2-runtime (>=1.9.48) error while installing Nokia Suite. What should I do? I am using Ubuntu 13.10. Please recommend me a software application similar to Nokia PC ...
0
votes
1answer
95 views

Help with held broken packages

Please help I get the following message below after trying to install synaptic.... perkins@perkins-HP-2000-Notebook-PC:~$ sudo apt-get install synaptic Reading package lists... Done Building ...
0
votes
1answer
810 views

How to solve unmet linux-headers dependencies? [duplicate]

Whenever I want to install or remove a package I get this message: The following packages have unmet dependencies. linux-headers-generic-lts-saucy : Depends: linux-headers-3.11.0-22-generic but it ...
1
vote
2answers
3k views

How do I install Peazip? [dependencies not satisfiable]

I want to try this archiver, since I cant seem to drag srt files to VLC from file roller. But I get this error when trying to install the .deb I use Lubuntu 14.04 LTS I tried installing QT version ...
0
votes
2answers
441 views

Should I forcefully uninstall ubuntu-minimal: Depends: resolvconf as it has unmet dependencies

My ubuntu software center was not working and I was trying to fix it. I ran the following series of commands: sudo apt-get update This one failed and this was the result Err ...
0
votes
1answer
204 views

update manager gives unmet dependency error

Can anyone please help me to solve the issue? While updating update manager gives the following error: The following packages have unmet dependencies: **libqt4-declarative:** Depends: ...
0
votes
1answer
633 views

Grub2 mutual dependency issue

For various reasons I am installing .deb dependencies for grub2 using dpkg directly (rather than apt-get). root@ubuntu:/dl# dpkg -i grub-gfxpayload-lists_0.6_amd64.deb Selecting previously ...
3
votes
1answer
1k views

Cannot install Eclipse in Ubuntu 14.04 64-bit

I cannot install Eclipse from the Ubuntu Software Center. I get error: The following packages are not yet satisfied with dependencies: eclipse-platform: Depends: eclipse-platform-data (> = ...
5
votes
1answer
5k views

Unable to re install mysql on Ubuntu 14.04: Dependency problems

Ubuntu Unity 14.04 LTS with all lenses removed, except files. (Hate the dash.) I have a LAMP system for web site development. I want to put all my data files in a particular partition that I can ...
1
vote
1answer
5k views

Unable to install libssl1.0.0:i386 due to “unmet dependencies”?

I have read and followed the advice in this question to no avail. I am attempting to install libssl1.0.0:i386 on my 14.04 box (amd64), but when I try to do this via APT, I receive the following error ...
0
votes
1answer
1k views

Compile evolution development snapshot 3.13.1

I have downloaded evolution development snapshot from this link: https://wiki.gnome.org/Apps/Evolution and now I have trouble compiling the source code. I am using ubuntu 14.04 and this version of ...
1
vote
2answers
1k views

Package dependencies cannot be resolved when installing totem [duplicate]

Package dependencies cannot be resolved when installing totem and I get this in details: totem: Depends: python:any (>= 2.7.1-0ubuntu2) but it is a virtual package Depends: ...
0
votes
0answers
15 views

uninstalled libgconf2-4 by mistake now i cant reinstall it, need help [duplicate]

You might want to run apt-get -f install to correct these: The following packages have unmet dependencies: aisleriot : Depends: libgconf-2-4 (>= 2.31.1) but it is not going to be installed ...
6
votes
3answers
22k views

Can't install wine on Ubuntu 14.04 [duplicate]

I cannot install Wine on Ubuntu 14.04. When I try to install it on the Ubuntu Software Center I always get a message that says I have unmet dependencies. I tried installing Wine through the terminal ...
2
votes
1answer
4k views

what is sudo apt-get -f install

what is the usage of apt-get -f install . when I run sudo apt-get update I got some errors at the end It says try apt-get -f install. What is this command? the last part of my error is : . . . ...
3
votes
1answer
12k views

dependency problems running apt-get -f install on Ubuntu

ON MY UBUNTU RACKSPACE SERVER UNAME -A # uname -a Linux myserver.com 3.2.0-24-virtual #39-Ubuntu SMP Mon May 21 18:44:18 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux APT-GET -F INSTALL /home# apt-get ...
0
votes
1answer
508 views

Canon pixma ip 4850 driver problem on 14.04 64

when installing driver I get dependences problems libtiff4 missing. Drivers downloaded from Canon: ip4800_redhat_debian_guide.tar, including cnijfilter-common_3.40-1_amd64.deb and ...
2
votes
0answers
481 views

After updating the system to 14.04, an application fails due to lack of libpng15. How do i obtain it?

After updating my Kubuntu to 14.04, one of applications (the "King Arthur's Gold" indie game) would fail due to lack of libpng15 in the system. The error message is: [13:47:13] PNG warning: ...
2
votes
2answers
5k views

How to solve missing libmng.so.1 in Trusty (14.04) Package is no more available

I would like to run SoulseekQT. However unfortunately one of the dependencies is libmng1, which is no more included in Trusty. sudo apt-get install libmng.so.1 or libmng1 or libmng1:i386 in Trusty ...
3
votes
1answer
1k views

Vanished dependency: gir1.2-launchpad-integration-3.0

I'm trying to install a facebook-webapp but the dependency gir1.2-launchpad-integration-3.0 is not found and listed as uninstallable. I have been unable to locate it anywhere except for references to ...
0
votes
1answer
1k views

dependency not satisfiable fuse-utils

I have looked around and the answers for dependency problems seem to be specific but I am sorry if this has already been answered. I am trying to install storage made easy desktop client but when I ...
2
votes
2answers
2k views

libc6-amd64 dependency problem

I'm trying to install fglrx manually from the AMD website however it keeps complaining that it's missing the dependency "libc6-amd64". When I run the fglrx package through gdebi I get this message: ...
0
votes
1answer
1k views

unable to install mediaelch on Ubuntu 14.04

I am trying to install MediaElch after the upgrade from 13.XX removed it. I followed the instructions from the MediaElch website (http://www.kvibes.de/en/mediaelch/download/) sudo ...
2
votes
1answer
2k views

Update manager not worknig and Red icon on my menu panel

I've been upgrading my ubuntu 13.10 to 14.04 LTS,during the installation process, I accidentally lost power after this i try to turnon my machine, it shows red icon with Error message Here is the ...
4
votes
1answer
8k views

Broken dependency after upgrading ubuntu 14.04

I recently upgraded to ubuntu 14.04 LTS but few packages are broken. I tried to run the command apt-get -f install and dpkg --configure -a but nothing worked for me. Please help .. here is the output ...
0
votes
1answer
289 views

Can't upgrade past 11.10 - libc6 dependency errors [closed]

Since upgrading to 11.10 I can't upgrade any further (trying to get my web server to latest version.) I'm aware of How do I resolve unmet dependencies? and have tried up to the point of running this: ...
2
votes
0answers
1k views

Broken package problem while installing open source AMD ATI drivers in 14.04

After purging the fglrx* packages, I tried this - ankit@ubuntu:~$ sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:amd64 ...
0
votes
1answer
13k views

In Ubuntu 13.04, cannot install libssl-dev [duplicate]

How can I get around the dependency problem when installing libssl-dev? The problem: $ sudo apt-get install libssl-dev Reading package lists... Done Building dependency tree Reading state ...
0
votes
1answer
330 views

Dependencies problem with x2go

I need help with my Ubuntu Server 12.04 64-bit. I can't update Ubuntu, because I always have problems with x2go. See message below: dependency problems prevent configuration of openssh-server: ...
0
votes
1answer
165 views

e17 installation and unmet dependencies

Every which way I try to correct unmet dependencies it gives me some long error. Trying to install packages I get evas-loaders : Depends: libefl (>= 201312241217) but it is not going to be ...
0
votes
1answer
371 views

dependency problems prevent configuration

I've gotten my Ubuntu server into an inconsistent state. I've read through a thread on a similar issue but am still unsure how best to proceed. Here is some info: # dpkg --print-architecture amd64 ...
0
votes
2answers
124 views

How to resolve depedancy issues with software not obtained from a repository

Ok so i have found that the Ubuntu software centre has excessively outdated builds posted for nearly every piece of software i attempt to install. The only solution i can think of is to download the ...
1
vote
1answer
115 views

cannot upgrade Catfish file searching tool

I receive the following error messages attempting to upgrade the Catfish file searching tool: The following packages have been kept back: catfish The following packages have unmet dependencies: ...
1
vote
0answers
725 views

Cannot install Openssh-server or client

When I go to install, I get this error: sudo apt-get install openssh-server Reading package lists... Done Building dependency tree Reading state information... Done Some packages could ...