Questions concerning software and package dependencies.

learn more… | top users | synonyms (1)

0
votes
1answer
354 views

how to install websocket++ dependencies?

I'm trying to develop websocket applications in c++. I've chosen to use websocket++ since it's a no-nonsense #include that doesn't try to fallback to ajax and could potentially be used with any other ...
0
votes
1answer
2k views

can't install steam on Ubuntu 12.04

I am not able to install steam. Firstly, from the Ubuntu Software Centre it fails to install and I get the following; The following packages have unmet dependencies: steam64: Depends: steam (= ...
0
votes
3answers
1k views

I am unable to install Wine due to issues with multiarch support. What can I do to resolve this issue?

I cant install wine. Cant do anything with this. sudo aptitude install wine1.5 The following NEW packages will be installed: libasn1-8-heimdal:i386{a} libasound2:i386{a} libasyncns0:i386{a} ...
0
votes
1answer
501 views

I can not install wine on Ubuntu 12.10 [duplicate]

Can anyone help me to install Wine? I can not install it on Ubuntu 12.10. I always get the following message in the terminal: The following packages have unmet dependencies: wine1.5 : Depends: ...
0
votes
2answers
2k views

aptitude cant install ia32-libs

When I run aptitude install ia32-libs it gives me this output (on Pastebin due to length constraints of StackExchange). The install fails, as it leaves ia32-libs in a Not Installed state. All other ...
0
votes
1answer
2k views

How to install cndrvcups-common v.2.3 in Quantal?

Trying to install a Canon printer, and getting into trouble at some point (see this question, regarding the 12.10 part) I noticed that I had not followed exactly what Ubuntu Documentation recommended ...
0
votes
0answers
56 views

Software center requires qt4, I have qt 5 [duplicate]

Possible Duplicate: Why does Software Center report qt4 as unmet dependency, when I already have qt5 installed? i have installed qtspim which depends upon qt4. I have already installed qt5 ...
0
votes
1answer
203 views

Unmet dependencies - what to do? [duplicate]

Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these. The following packages have unmet ...
0
votes
1answer
419 views

Package dependency problems with wine

I am running Ubuntu and trying to install Wine. When I run sudo apt-get install wine, it gives the following error: The following packages have unmet dependencies: wine : Depends: wine1.4 but it is ...
0
votes
1answer
93 views

Wine has dependency issues [duplicate]

Okay, I like to use Aptitude for most of my program installation, due to its exceptional handling of dependencies (it's very diligent about removing unused libraries.) Unfortunately, it appears not ...
0
votes
2answers
632 views

Can't install libpcap0.8-dev:i386 to compile 32bit App under 64bit environment [closed]

I am writing a little program which uses libpcap and my target machine is i386, while my dev machine is x86_64. Now, when I install libpcap0.8:i386, which works, I get under /usr/lib/i386_linux_gnu/ ...
0
votes
3answers
310 views

I can't install any package, dependency problems

The apt-get command doesn't work. When I try this sudo dpkg --configure -a, I get this: dpkg: dependency problems prevent configuration of libc6:amd64: libc6:amd64 depends on libgcc1; however: ...
0
votes
1answer
672 views

Software center is broken and can not be repaired or reinstalled

When I open the software center, I am told that I can not use it, for it is broken, and needs to be repaired. First I try to do this automatically, as I was offered. I enter a root password, and then ...
0
votes
1answer
540 views

Downgrading a package and dependencies

I want to downgrade libcairo2 to the version from Precise (I'm running Quantal). I've added the precise source to my sources.list and can do 'apt-get install libcairo2=', but it's going to remove some ...
0
votes
0answers
30 views

unable to install anything from software center - package issues in 12.10 - fresh intallation [duplicate]

Possible Duplicate: Trouble downloading updates due to “Hash sum mismatch” error i was having 12.04.1 LTS till now, and decided to install 12.10. I did a "new installation" by choosing to ...
0
votes
0answers
15 views

An error occurred - help please [duplicate]

Possible Duplicate: How do I fix a “Problem with MergeList” error when trying to do an update? E: Encountered a section with no Package: header E: Problem with MergeList ...
0
votes
1answer
1k views

Unmet dependencies error when installing wine [duplicate]

Possible Duplicate: Why is Wine not installable on my system? The following packages have unmet dependencies: wine1.5 : Depends: wine1.5-i386 (= 1.5.16-0ubuntu1) but it is not installable ...
0
votes
1answer
628 views

Cannot installs Gnome in 12.10

when I try to install gnome DE, i get dependency issues. the command apt-get install ubuntu-gnome-desktop ubuntu-gnome-default-settings gives the error message - ~$ sudo apt-get install ...
0
votes
1answer
35 views

Packaging a header library, header dependencies

When packaging a library A that contains of headers (similar to boost), those headers may have include statements to another header library B in them. Consequently, when building an application with ...
0
votes
1answer
1k views

Transmission dependencies are not in repository

I'm running Ubuntu 12.04 using Gnome3 through their ppa in launchpad. Went good until now. Today Ubuntu wanted to make some updates and I thought okay. But it didn't want to install all of them. ...
0
votes
0answers
311 views

Unmet dependencies when trying to install openssh-server [duplicate]

Possible Duplicate: How do I resolve unmet dependencies? I am running sudo-apt get install openssh-server on Ubuntu 12.04 64 bit system. It is giving me the following output. $ sudo ...
0
votes
1answer
339 views

Unmet Dependencies with kdelibs5-data [duplicate]

Possible Duplicate: How do I resolve unmet dependencies? I was trying to install Amarok 1.4 on Ubuntu 12.04 (Gnome-classic), by following this instructions. Problem started after giving ...
0
votes
2answers
356 views

Dependency problems installing eViacam on 12.04

I used eViacam in windows, but now I'm using (L)ubuntu 12.04, and I fail to install. I found a guide to install it on ubuntu 11.10, but I have unsolved dependencies. Error runing "sudo apt-get ...
0
votes
1answer
122 views

Installing from Local Dependencies?

I have a folder with all dependencies needed for my program (gimp) in a folder. I don't have internet connection on that System. How can i install Gimp Dependencies from that Folder. Note: All ...
0
votes
2answers
421 views

Issue with dependencies when trying to install Wine and Synaptic

I am running 12.04 ubuntu on a dual-boot with win 7 and i have been trying to install Wine however I had a bunch of dependency issues. So I then tried using Synaptic which will not install either ...
0
votes
0answers
59 views

Quantal: Broken apt-index, cant fix dependencies [duplicate]

Possible Duplicate: There's an issue with an Alpha/Beta Release of Ubuntu, what should I do? I can't seem to add/remove/update packages Ubuntu software update has a notice about partial ...
0
votes
0answers
3k views

“Package dependencies cannot be resolved” while installing Chromium browser [duplicate]

Possible Duplicate: “Package dependencies cannot be resolved” error when installing software I installed 12.04 in my system. While trying to install Chromium, I get the following error: ...
0
votes
1answer
1k views

apt-get install fails due to dependency issues but apt-get -f install won't fix it

I've just installed Ubuntu 12.04 and was about to manually install Rawstudio with the packages from SourceForge repo, but I've been stuck with dependency issues and I am short on apt command lines to ...
0
votes
1answer
2k views

Can't install libssl-dev, dependency problem

I'm trying to install the package libssl-dev, but I get the following error: libssl-dev: Depends: libssl1.0.0 (= 1.0.1-4ubuntu3) but 1.0.1-4ubuntu5 is to be installed the package libssl1.0.0 is ...
0
votes
1answer
2k views

Ubuntu-restricted-extras conflict: feature or bug?

On a fresh 12.04 installation I wanted to install the ubuntu-restricted-extras. Therefore it needs to remove libavutil51 and libavcodec53. So, as there will be installed libavutil-extra-51 and ...
0
votes
1answer
332 views

How to enable packages from older ubuntu releases?

There's a time I'm wanting to enable MSN with empathy (as you can see on my other question Did Empathy lose support to Windows Live in 12.04?) but I always get problems with dependencies while ...
0
votes
0answers
83 views

Totem was deleted in upgrade process and now it have unmet dependencies [duplicate]

Possible Duplicate: How do I resolve unmet dependencies? What can I do to solve this problem? Error: totem: Depends: libnautilus-extension1a (>= 1:2.91) but 1:3.4.1-0ubuntu1 must be ...
0
votes
0answers
517 views

Unmet dependencies while installing imagemagick on Ubuntu 10.04 [duplicate]

Possible Duplicate: How do I resolve unmet dependencies? I was trying to install imagemagic on 10.04 $ sudo apt-get -f install imagemagick Go the below error Reading package lists... ...
0
votes
1answer
403 views

10.10 to 11.04 upgrade unmet dependencies

I was trying to upgrade my system from 10.10 to 11.04. The following packages have unmet dependencies: plymouth : Depends: libdrm-nouveau1a (>= 2.4.23) but it is not installed ...
0
votes
1answer
89 views

vtg-plugin dependencies not met

I am trying to compile the vtg-plugin from source however I am getting the error "vtg-dependencies not met" which complains about libpeas and gedit. The version of gedit it is asking for is 2.91.0, ...
0
votes
2answers
825 views

Do I need to install Japanese TrueType font, Ume-font

I have an English Ubuntu. Today suddenly the update manager asks me to download 48 MB of "Japanese TrueType font, Ume-font". It says it is a new install. Do I really need this for something? I can not ...
0
votes
1answer
124 views

Trying to install ncview on Ubuntu 12.04 [duplicate]

The package ncview requires X development headers and headers. On Ubuntu 12.04 I tried the following command sudo apt-get install xorg-dev and I got the below error message. This looks like a very ...
0
votes
1answer
106 views

How can I fix “The package system is broken”? [duplicate]

These are the updates: -Safe and easy web browser from Mozilla firefox -Safe and easy web browser from Mozilla- Unity menubar integration firefox-gobalmenu -Safe and easy web browser from ...
-1
votes
1answer
215 views

apt returns “E: Unmet dependencies” when I try to install a package, how can I diagnose the issue and find out why it occurs?

I'm trying to install a package, but the package manager (apt-get, software center, etc.) refuses to install it due unmet dependencies. Are my attempts to install the package causing the ...
-1
votes
1answer
149 views

Launchpad: Missing build dependencies even though dependency should be contained in uploaded package

I want to backport gcc-4.7 from raring to precise. So I ran backportpackage and uploaded gcc-4.7 to my PPA. However, when Launchpad tries to build it it complains about a missing dependency: ...
-1
votes
1answer
41 views

How to remove unresolved packages (youtube-to-mp3 app)

I am aware that it's a common problem but i am quite new with linux systems and I would like to know how to exactly fix my problem. The following packages have unmet dependencies: youtube-to-mp3: ...
-1
votes
2answers
54 views

How to download and install unmet dependencies automatically

Is there any method on command line or a software that will download and upgrade/install all unmet(missing or outdated) dependencies for a package automatically. There are some packages that have ...
-1
votes
1answer
94 views

How to build dependency list for deb package

I want to pack my qt application to deb. During investigation dependencies with ldd i got ~50 libraries. Full list below: libgstreamer-plugins-base0.10-0, libgstreamer0.10-0, libglib2.0-0, ...
-1
votes
3answers
70 views

How do I get the latest software version without worrying about dependencies?

So I'm using Ubuntu 12.04 and glabels 2.2.8. The only problem is that glabels 3.0+ have been available for a loooooong time now. I want to install glabels 3.0 just by downloading the deb and ...
-1
votes
3answers
346 views

trying to overwrite 'file' which is also in package 'name' [duplicate]

After I added this ppa ppa:thopiekar/darling and tried to install darling without success, I can't fix anything with the sudo apt-get install -f install command jeggy@jeggy-XPS:~$ sudo apt-get -f ...
-1
votes
1answer
712 views

Cannot install VLC due to unmet dependencies

I am using a 32-bit version of Ubuntu, and I am trying to install VLC. But every time I do it, it shows unmet dependencies. I know this issue was addressed in VLC package dependencies cannot be ...
-1
votes
2answers
408 views

unmet dependencies 12.04 LTS [closed]

sudo apt-get install cinnamon Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have ...
-1
votes
3answers
107 views

The following packages have unmet dependencies!

I am writing this because I am very confused about installing postgresql 9.3 on mine Ubuntu 14.04. First I need it for mine Python/Django development, and I ran in to the problem, when i tried to ...
-1
votes
2answers
56 views

Unable to install acrobat reader in ubuntu 14.10

actually, I have tried doing it once. In the middle of installation, my desktop freezes and had to forcefully restart it soon. I am giving the error message , please help me ASAP. Reading package ...
-1
votes
1answer
121 views

How to remove dependency problem? [duplicate]

I'm trying to install offline g++ software on Ubuntu 14.04: $ sudo dpkg -i g++-4.4.4_4.4.3-4ubuntu5.1_i386.deb [sudo] password for ecil: dpkg: error processing archive ...