Questions concerning software and package dependencies.

learn more… | top users | synonyms (1)

1
vote
0answers
17 views

I cannot install openssh-server [duplicate]

When I go to install, I get this error: $ sudo apt-get install openssh-server The following packages have unmet dependencies: openssh-server : Recommends: ssh-import-id but it is not going to be ...
0
votes
1answer
875 views

QGIS on 14.04 packages have unmet dependencies

I have got a problem with my QGIS on a trusty 14.04.01. After upgrading my machine from precise 12.04 to trusty 14.04, QGIS was disappeared from the available software. I have autoremoved it and ...
2
votes
1answer
1k views

hplip 3.14.10, no python-devel

Tech specs: Intel® Xeon(R) CPU E5420 @ 2.50GHz × 8 , 32GB Memory, ubuntu 14.04 (64bit). HP 5660 envy aio richard@Doc:~$ cd Desktop richard@Doc:~/Desktop$ sh hplip-3.14.10.run Creating directory ...
0
votes
1answer
2k views

Error processing package fglrx. Package fglrx is not configured yet

I faced with this message after reinstalling fglrx package. The reason of reinstalling fglrx was solve the problem with nvidia drivers (I tried some answers to solve black screen on system boot or ...
2
votes
1answer
1k views

Ubuntu 14.04.1 and unmet dependencies for ubuntu sdk. Use Qt Creator instead [duplicate]

I'm trying to install Ubuntu SDK, but get the same problem like here (first, second). The promoted solution like this doesn't help me either ( The following packages have unmet dependencies: ...
1
vote
1answer
1k views

apt- Error installing Deepin Desktop Environment in Ubuntu 14.04

I have been trying to add the Deepin Desktop Environment to Ubuntu. I have followed several guides that consist of adding the sources etc and then trying sudo apt-get install dde-meta-core however ...
1
vote
1answer
567 views

How do I resolve unmet dependencies caused by a conflict between Open Office and LibreOffice? Software Update is broken and will not update [duplicate]

I recently uninstalled LibreOffice to install OpenOffice and experienced no problems in using Open Office. Later, I installed a file preview software known as Sushi. When trying to view .odp files, ...
2
votes
1answer
3k views

Not able to fix the error “Unable to correct problems, you have held broken packages.”

I am trying to install python-pip. But I am getting the following error: root@w.x.y.z:~# apt-get install python-pip Reading package lists... Done Building dependency tree Reading state ...
0
votes
1answer
124 views

Need to delete packages from '/boot' directory

I'm very new to Linux so please bear with me. I attempted to upgrade to 14.04 from 12.04.02 I received the error: "The following packages have unmet dependencies" I ran apt-get -f install and ...
0
votes
1answer
257 views

Packages Broken not able to Play Videos [duplicate]

Hi not able to play videos getting and unable to install video players too gstreamer1.0-libav : Depends: libavcodec54 (>= 6:9.1-1) but it is not going to be installed or ...
1
vote
2answers
652 views

Unity having “Damaged Packages” upon reinstall over Gnome 3

When I got Gnome installed over Unity, on login I couldn't chose to return to the standard Unity desktop. Every time I attempt the simple sudo apt-get install ubuntu-desktop I get the error Some ...
0
votes
1answer
259 views

Unable to install Any media Player [duplicate]

Getting Following error while trying to install media player This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a ...
0
votes
1answer
2k views

How to install packages in ubuntu without internet connection? [duplicate]

I am using Ubuntu since last 2 years but still I couldnt find better way to install Ubuntu packages offline. As each package needs multiple dependencies its harder to find & get all the required ...
0
votes
0answers
48 views

How do I resolve these unmet dependencies? [duplicate]

Opening the Ubuntu software center yields an error that says: Items cannot be installed or removed until the package catalog is repaired. Do you want to repair it now? After clicking repair, the ...
1
vote
1answer
1k views

ffmpeg installation, kubuntu utopic unicorn

I haven't found any utopic unicorn ffmeg repositories, so I am trying to install it from https://launchpad.net/~jon-severinsson/+archive/ffmpeg by changing version from utopic to trusty in ...
2
votes
0answers
2k views

fresh install, python-software-properties unmet dependencies

attention: This might be more a question for "gis.stackexchange" but it is Ubuntu-related Geonode 2.0 is available for Ubuntu 12.04 but not for Ubuntu 14.04. According to the docs it should be ...
0
votes
1answer
2k views

Install Virtualbox-4.3 in Ubuntu 12.04

Kindly someone help. I am quite new in Ubuntu. While installing the package, these error messages appear. dpkg: dependency problems prevent configuration of virtualbox-4.3:i386: ...
-1
votes
1answer
227 views

How to remove dependency problem? [duplicate]

I'm trying to install offline g++ software on Ubuntu 14.04: $ sudo dpkg -i g++-4.4.4_4.4.3-4ubuntu5.1_i386.deb [sudo] password for ecil: dpkg: error processing archive ...
0
votes
1answer
1k views

Trying to install cifs-utils - the attempt created dependency hell

Trying to mount a smb share in Linux (12-10, kernel 3.5.0-17-generic) - I tried to install mounting utils sudo apt-get install cifs-utils response / error: ... Preparing to unpack ...
0
votes
1answer
3k views

Dependency Problems after updating to 14.04?

I can't seem to install or uninstall anything after updating to 14.04 because emacs and LaTeX was broken. I think I removed all the corrupt LaTeX files, but the emacs ones won't go away. Anyone know ...
2
votes
3answers
12k views

How to install needed Qt packages to build kernel on 14.04?

I'm going to compile kernel on Ubuntu 14.04 64-bit, so I start with installing packages that I need: sudo apt-get install build-essential bin86 kernel-package libqt3-headers libqt3-mt-dev wget ...
0
votes
2answers
1k views

Unable to find phonon library

I am trying to build an application that requires the phonon library... I got an error because the lphonon was not found. so I tried to look for it... there is no "phonon" on my system. I tried ...
1
vote
0answers
932 views

Ubuntu 14.04, Rhythmbox, missing gstreamer1.0-libav (i386) plugin dependencies

I've recently updated Ubuntu 12.04 to 14.04 (64 bit version). The problem that I've noticed is that Rhythmbox cannot play ALAC (m4a) files. Also, when I run some radio stations, the systems complains ...
1
vote
5answers
5k views

Dependencies | not able to install from Ubuntu Software Center | Ubuntu 14.04

I am not able to download and install programs (including vlc and unity tweak tool) from the Ubuntu Software Center. Every time i try to get them, there is a dependency error and i am completely lost ...
2
votes
0answers
148 views

“Depends: ___ but ___-saucy is to be installed” type broken dependencies after Trusty upgrade

The installer threw an error near the end of the 14.04 Trusty upgrade. unity-control-center is not installed and upon trying to install it I now have a chain of broken dependencies which, after going ...
3
votes
1answer
341 views

Is there a way to check Ubuntu installation health?

I'm a person who wants to be sure before continue working on his system. Because of that, I would like to know if my Ubuntu installation is in a good condition or not. Some of the things I would like ...
0
votes
1answer
245 views

Error installing ubuntu-desktop on 14.04 [duplicate]

I am trying to install ubuntu-desktop on 14.04 but when I run apt-get install ubuntu-desktop it gives error: Some packages could not be installed. This may mean that you have requested an impossible ...
0
votes
1answer
106 views

Trying to install wine on 14.04, have tried removing all wine related but still no joy [duplicate]

After alot of dependency problems decided to remove all wine related packages from synaptic. Recently upgraded from 12.04 to 14.04. Do not understand what is happening. Get depends wine1.6-i386, ...
0
votes
1answer
80 views

Dist-Upgrade - LibreOffice dependencies later than required

When I try to update my Ubuntu box, I get this error : dpkg: dependency problems prevent configuration of libreoffice-base: libreoffice-base depends on libreoffice-base-core (= ...
0
votes
1answer
87 views

unresolvable broken packages [duplicate]

I have been desperate to resolve this problem as I am not being able to install certain programs. my computer says that I have broken packages: The following packages have unmet dependencies: ...
1
vote
0answers
10 views

Wine error, packages being held, help please :S [duplicate]

I am getting this error: The following packages have unmet dependencies: udev : Depends: libudev1 (= 204-5ubuntu20.2) but 204-5ubuntu20.4 is to be installed E: Error, pkgProblemResolver::Resolve ...
0
votes
0answers
97 views

Try 'apt-get -f install' with no packages [duplicate]

I am using Ubuntu 14.04 lts OS. So when I go to installed mysql server using below command sudo apt-get install mysql-server I have some error message. This is the error message: Reading package ...
2
votes
1answer
243 views

How to get out of dependency hell

I am doing this from memory from work. Basically, I have libjpeg-turbo8 installed. But I have libjpeg-turbo8:i386 installed at version xxx4.4 and libjpeg-turbo8:amd64 installed at version xxx4.3. I ...
1
vote
1answer
2k views

Unable to install Inkscape on ubuntu 14.04 [duplicate]

Hi I am new to Linux Ubuntu 14.04. I wanted to install Inkscape but it has shown following error(Dependencies as it says): inkscape: Depends: python:any (>= 2.7.1-0ubuntu2) but it is a virtual ...
0
votes
0answers
22 views

Spotify installed packages have unmet dependencies [duplicate]

I used wine to emulate the Windows version of Spotify and I recently just uninstalled it and ever since then, when I start up my Ubuntu, after a while I will get this restricted logo beside the wifi ...
0
votes
1answer
82 views

Packages go missing after bootup and certain indicators don't seem to install anymore

I'm running an up-to-date Ubuntu 14.04, which I frankenstein'd into Xubuntu and up to this point it's been working just fine. When I booted my computer up today, I noticed that a few icons on my dock ...
0
votes
1answer
530 views

Trying to install ncview on Ubuntu 12.04 [duplicate]

The package ncview requires X development headers and headers. On Ubuntu 12.04 I tried the following command sudo apt-get install xorg-dev and I got the below error message. This looks like a very ...
2
votes
1answer
41 views

How to diagnose package dependancies?

I want to install postfixadmin on trusty. I'm confused about dependencies. http://packages.ubuntu.com/trusty/postfixadmin shows (I think) that it needs apache2 OR lighttpd OR the httpd to be ...
0
votes
1answer
1k views

Unmet dependencies problem on 12.04 - libcurl4-openssl-dev depends librtmp-dev

I'm having troubles with unmet dependencies on Ubuntu 12.04: libcurl4-openssl-dev depends librtmp-dev Here is what I've got after running sudo apt-get -f install which suggested running apt-get ...
3
votes
1answer
824 views

libqt4-opengl:i386 has unmet dependencies

I am running Ubuntu 14.04 64-bit. I have an error in my system tray: sudo apt-get update runs normally. But sudo apt-get upgrade returns the following: Reading package lists... Done Reading ...
2
votes
2answers
298 views

Translating from Red-Hat to Ubuntu

I am starting in linux because I need it for my reseach. Since I have little time and no local expert support, this is a need based self-learning experience. I have to install a tool and I got this ...
0
votes
1answer
748 views

How to build dependency list for deb package

I want to pack my qt application to deb. During investigation dependencies with ldd i got ~50 libraries. Full list below: libgstreamer-plugins-base0.10-0, libgstreamer0.10-0, libglib2.0-0, ...
1
vote
1answer
4k views

Resolve Unmet dependencies

vikiboy@BatCave:~$ sudo apt-get install ros-indigo-openni-launch Reading package lists... Done Building dependency tree Reading state information... Done ros-indigo-openni-launch is already ...
9
votes
3answers
16k views

Ubuntu 14.04, problem when install gstreamer1.0-libav, unmet dependencies

Suddenly my Ubuntu stopped playing video. When I open a video, the player suggests that I install gstreamer1.0-libav. However, it fails to install. I tried installing it manually, here is the error ...
1
vote
1answer
880 views

Error on installing downloaded Chrome .deb [duplicate]

I have downloaded Chrome on 14.04 as .deb package. Whenever I try to install it, it gives error "Dependency is not satisfiable".
2
votes
1answer
638 views

Quick question about installing multiple versions of the same package

So two pieces of software that I need on my system have dependencies for libfltk1.1-dev and libfltk1.3-dev . I tried installing both, as when I installed one, it would remove the other. I put in this ...
1
vote
1answer
1k views

PlayOnLinux won't install? [duplicate]

I'm running 12.04 LTS, and whenever I try to install PlayOnLinux, I keep getting this error: The following packages have unmet dependencies: playonlinux : Depends: python-wxgtk2.8 but it is not ...
1
vote
2answers
997 views

Update broken on libdbus

On a recent update to my precise install the package manager seems to have got itself into a twist. cat /var/log/apt/history.log Start-Date: 2014-07-10 16:17:22 Upgrade: libdbus-1-3:amd64 ...
2
votes
6answers
14k views

Package dependencies cannot be resolved Ubuntu 14.04 vlc-audacius

vlc: Depends: vlc-nox (= 2.1.4-0ubuntu14.04.1) but 2.1.4-0ubuntu14.04.1 is to be installed Depends: libc6 (>= 2.15) but 2.19-0ubuntu6 is to be installed Depends: libfreetype6 (>= ...
0
votes
1answer
356 views

Can't upgrade ubuntu 12.04 to 14.04 (Package dependencies cannot be resolved) [duplicate]

This is what I get each time I try to upgrade: "The following packages have unmet dependencies: libgl1-mesa-glx-lts-trusty: Depends: libglapi-mesa-lts-trusty (= 10.1.3-0ubuntu0.1~precise1) but ...