Questions concerning software and package dependencies.

learn more… | top users | synonyms (1)

2
votes
1answer
282 views

How to update Twidge 1.0.8 form repositories to 1.1.0 from GitHub?

I would like to install Twidge 1.1.0, but only 1.0.8 is available in repositories and this version is not compatible with new Twitter API and it's not usable anymore. 1.1.0 is available in Debian sid, ...
0
votes
2answers
2k views

Is lib32gcc1 exists in my system?

I'm trying to istall AMD/Intel hybrid drivers using this guide and have problem with lib32gcc1 when I'm try to install fglrx*.deb's sudo dpkg -i fglrx*.deb. I get dependency problems with it: ...
14
votes
2answers
2k views

How to visually display dependencies of a package?

This is just for fun and curiosity: is there a tool using which I can visually see the dependencies of a package as a graph? That is, the packages that a given package depends on. This can be a ...
4
votes
1answer
816 views

Why does pretty much everything depend on gstreamer phonon backend?

I’ve just installed and configured a minimal KDE distro based on the Ubuntu 13.04 minimal CD. It’s working really well but I have 1 gripe with it. After installing kde-plasma-desktop gstreamer was ...
0
votes
2answers
2k views

Dependencies nightmare

I'm trying to install openbts but it requires a bunch of dependencies, some of which fail: The following packages have unmet dependencies: libboost-all-dev : Depends: libboost-python-dev but it is ...
0
votes
0answers
27 views

unmet dependencies samba [duplicate]

seems to be a pretty common problem, and I've followed the guides in order to at least do updates around the problem, but before I do any more blind guessing, I'm asking the community for reasons (if ...
0
votes
0answers
14 views

Unable to upgrade ubuntu due to unmet dependencies [duplicate]

I am trying to upgrade Ubuntu Server, but get the following error message: The following packages have unmet dependencies: linux-server : Depends: linux-headers-server (= 3.2.0.44.53) but 3.2.0.48.58 ...
0
votes
1answer
1k views

Skype installation dependencies issue

Cannot install skype.. lots of dependencies issues.. Please help.... :( Aptitude shows this solution only.. My OS is Ubuntu 12.04 LTS tau@UBUNTU:~$ sudo aptitude install skype --without-recommends ...
2
votes
1answer
633 views

Unmet Dependencies for handbrake-gtk

I have reviewed the suggestions at [How do I resolve unmet dependencies?]. As yet, my issue remains. Here's hoping the good folk here can help me. sudo apt-get install handbrake-gtk ...
0
votes
1answer
3k views

Can't install libssl-dev, dependency problem

I'm trying to install the package libssl-dev, but I get the following error: libssl-dev: Depends: libssl1.0.0 (= 1.0.1-4ubuntu3) but 1.0.1-4ubuntu5 is to be installed the package libssl1.0.0 is ...
2
votes
1answer
2k views

Getting dpkg-buildpackage depencency errors when using apt-get install source --compile [closed]

I was playing around with apt-get install source --compile And I used audacity: sudo apt-get install source --compile audacity However, I am getting a dependency error: ...
1
vote
1answer
46 views

how exactly package dependencies works?

How exactly package dependencies works when we are transferring packages from one PC to other? Is there anything else that influence on package dependencies? How exactly computer architecture matters ...
1
vote
2answers
1k views

Ubuntu SDK does not install on Ubuntu 12.04 64bit?

Trying to install the ubuntu-sdk on Ubuntu 12.04 64bit using instructions at http://developer.ubuntu.com/get-started/gomobile/ and I get the following errors: Some packages could not be installed. ...
4
votes
2answers
533 views

Why do I get unmet dependencies installing spotify on 12.10?

I followed the instructions to install spotify as on various forums & sites, pretty much the same steps everywhere. But when I get to the install spotify line, this is what happens: The following ...
0
votes
2answers
630 views

How To: Install Proteus from Humble Indie Bundle Depends: proteus (= 1.1-0ubuntu3)

After redeeming my software center key to download Proteus from the new Humble Indie Bundle #8, this error appears: proteus-meta: Depends: proteus (= 1.1-0ubuntu3) but 1.1-0ubuntu2 is to be installed ...
0
votes
1answer
232 views

Fix broken dependencies [duplicate]

I'm trying to install TortoiseHg but I get an error: $ sudo apt-get install tortoisehg Reading package lists... Done Building dependency tree Reading state information... Done Some packages ...
0
votes
1answer
568 views

Failed to fetch *.deb Size mismatch, then packages with unmet dependencies [closed]

I recently bought the wonderfully looking and reviewed Amnesia The Dark Descent and I'm trying to install it. The first time I tried to download it, I had to stop in the middle of the download (may ...
0
votes
1answer
511 views

packages have been unpacked but not yet configured

I am stuck with this weired issue. I am running Ubuntu 12.04 Sudo dpkg --audit Output is The following packages have been unpacked but not yet configured. They must be configured using dpkg ...
1
vote
0answers
148 views

Ubuntu dependency problems after `do-release-upgrade`

I recently performed do-release-upgrade, and it appears to have broken some of my packages. I can't properly apt-get autoremove or apt-get upgrade any more. $ sudo apt-get install -f ... Errors ...
0
votes
1answer
262 views

How to resolve dependency conflict (perl conflicts with libxml-sax-perl)?

I am trying to install a package called libxml-simple-perl, but it depends on libxml-sax-perl, I have installed other dependencies without issues, but this one below is giving me a lot of trouble, and ...
0
votes
1answer
457 views

aptitude dependency resolution issue when trying to install build-deps for openjdk-6

I am running into some kind of rather serious issue with resolving the dependencies if I try to install the build-deps for openjdk-6, as specified in the directions for compiling custom OpenJDK ...
1
vote
2answers
2k views

Valgrind - problem with held broken packages

When I try to install Valgrind with sudo apt-get install valgrind, I get error: valgrind : Depends: libc6-dbg but it is not going to be installed E: Unable to correct problems, you have held broken ...
0
votes
1answer
1k views

Ubuntu 12.4 Will Not update [Unmet Dependencies] [duplicate]

The following packages have unmet dependencies: libc6: Depends: libc-bin (= 2.15-0ubuntu10.3) but 2.15-0ubuntu10.4 is installed libc6-dev: Depends: libc6 (= 2.15-0ubuntu10.4) but 2.15-0ubuntu10.3 is ...
0
votes
1answer
160 views

Ubuntu Server Manager Installation Fails on 13.04 - Why

Installation of Server Manager Utility on 13.04 fails. Have tried many combination of loading packages to fix. Dependency Problems prevent configuration of ubuntu-server. Denpendency on on ...
2
votes
2answers
2k views

Cannot install Crossover

I can't install crossover from the package, ".deb". Here is a screenshoot of it : Here is what I got when I was trying to install with terminal: `young@jianyue:~$ cd /home/young/Desktop ...
3
votes
1answer
429 views

Issues opening everything

I recently installed Ubuntu 12.04. I had issues opening Skype. I looked at a few tutorials that I found from Google searches to no avail. I figured it may just be an issue and went to try and update ...
1
vote
0answers
11 views

E:Malformed Line 61 [duplicate]

Hello I am new to Linux (Only installed today). I have an issue though which is "This is a serious problem. Try again later. If this problem appears again, please report an error to the developers." ...
3
votes
1answer
2k views

How can I upgrade while having unmet dependencies?

I just install a package that has these unmet dependencies: Depends: sun-java5-jre but it is not installable or sun-java6-jre but it is not installable or openjdk-6-jre ...
3
votes
3answers
2k views

will apt-get autoremove break other dependencies?

I want to use apt-get autoremove to remove liba for instance, but I'm not sure whether it is smart enough to preserve other dependencies. For instance, if liba depends on libb, while libc also depends ...
1
vote
1answer
354 views

Role of dependencies while installing software??

What is the role of dependencies while installing any software?I was installing vlc player and it were closed by giving me error something like check dependency . What is to solution of this and how ...
3
votes
1answer
493 views

apt-get and dependencies

I thought apt-get was a package manager that installs all dependencies by default when it installs an application. But when I tried installing gcc-4.7, I get this: sudo apt-get install gcc-4.7 ...
1
vote
1answer
1k views

Problems installing Nitro Application?

I installed Nitro using apt-get. However, it is dependent of gir1.2-launchpad-integration-3.0 and is missing. How can I get the source code of gir1.2-launchpad-integration-3.0 somehow and install it ...
0
votes
2answers
2k views

Do I need linux-libc-dev and libc6-dev?

I removed the stock 3.8.0-19-generic kernel (and meta packages for the stock ubuntu kernel) and installed the 3.9 mainline kernel, do I need these 2 packages or can I remove them? ~$ apt-cache policy ...
0
votes
1answer
646 views

12.04 64-bit how to solve, pcscd : Depends: libccid (>= 1.4.1~) but it is not going to be installed or pcsc-ifd-handler?

I need to install a package but its failing in 12.04 64 -bit. root@sun-To-be-filled-by-O-E-M:/var/tmp# apt-get install pcscd Reading package lists... Done Building dependency tree Reading ...
1
vote
2answers
193 views

Install a Program from a Directory with All of Its Dependencies

Suppose I have a directory in which I have .deb packages for two programs with all there dependencies. I want to know if there is a apt or dpkg command, or another program to install one out of these ...
2
votes
0answers
17 views

Unmet dependencies (libgssapi-krb5-2: Depends: libkrb5-3 (= 1.10.1 + dfsg-4) but 1:10 + dfsg ~ beta1-2 is installed) [duplicate]

How do I solve this dependency? root @ server :/ # apt-get upgrade Reading package lists ... ready Building dependency tree Reading state information ... ready You might want to run `apt-get-f ...
0
votes
1answer
957 views

Cannot install GTK+3.6.4

When trying to run the ./configure for gtk+-3.6.4 I get the following: Requested 'glib-2.0 >= 2.35.3' but version of GLib is 2.34.0 Requested 'atk >= 2.7.5' but version of Atk is 2.4.0 ...
0
votes
2answers
3k views

How to solve unmet dependencies? [duplicate]

I'm trying to install Nitro with this : sudo apt-get install nitro And then I get this : Some packages could not be installed. This may mean that you have requested an impossible situation or if ...
1
vote
0answers
152 views

Trying to install cinnamon and getting a dependency error [duplicate]

Trying to install cinnamon 1.6.4 using apt-get install cinnamon and I'm getting this error. How can I resolve this error? cinnamon : Depends: gir1.2-muffin-3.0 but it is not going to be installed ...
1
vote
1answer
645 views

How do I install sasl2-bin dependencies?

I'm trying to install sasl2-bin on Natty. However, it depends on db4.8-util, which could not be installed because the default package on Natty is db4.7-util. If I try to install the 4.8 version either ...
0
votes
1answer
839 views

How do I get Glibc >= 2.16.0?

I know there are already built packages for Pidgin. I need to build Pidgin so I can build plug-ins. I need Glibc >= 2.16.0. Unfortunately, I get stuck in an endless dependency loop. I need ...
2
votes
0answers
614 views

Cannot install libglade2-ruby dependency for Grism

Hey Guys I'm trying to install Grism. I've followed installation steps from http://www.grism.org/install.html, which are fairly simple, just need to install dependencies and than install the deb ...
3
votes
1answer
1k views

Why am I getting the error E: Package php5-gd has no installation candidate when trying to install php5-gd?

I am trying to install php5-gd and receive this error Reading package lists... Done Building dependency tree Reading state information... Done Package php5-gd is not available, but is referred to by ...
1
vote
1answer
1k views

I get dependency issues with linux-image-pae while upgrading

justsmit1@moodle:~$ sudo aptitude safe-upgrade The following packages will be upgraded: linux-image-generic-pae 1 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded. Need to get 0 ...
4
votes
1answer
3k views

Gwoffice 0.97 has a dependency issue and won't install

When trying to install the latest version of gwoffice 0.97 I get: The following packages have unmet dependencies: gwoffice : Depends: libgranite1 but it is not installable E: Unable to correct ...
1
vote
1answer
1k views

Dependency error while installing cinnamon

I get following error while installing Cinnamon sudo apt-get install cinnamon Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be ...
2
votes
1answer
807 views

I cannot run DOSBox SVN-Daum on Ubuntu 12.04

I've got the DOSBox SVN-Duam from its homepage. Maybe I have solved the dependency problems, $ ldd ./dosbox linux-gate.so.1 => (0xb776d000) libSDL_sound-1.0.so.1 => ...
1
vote
1answer
354 views

“apt-get -f install” not working [duplicate]

Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following packages were automatically installed and are no longer ...
2
votes
3answers
10k views

How to deal with “not installable” dependencies?

I ran sudo apt-get install -y unity-dictionary-lens and received a warning of unmet dependencies: unity-dictionary-lens : Depends: unity-singlet (>= 0.2.0) but it is not installable I found the ...
1
vote
1answer
323 views

Installing Miramath in Ubuntu 12.10

I tried building this application via downloading from http://sourceforge.net/projects/miramath/?source=dlp & in the process have already downloaded +500mb data but at one point I am constantly ...