Questions concerning software and package dependencies.

learn more… | top users | synonyms (1)

0
votes
2answers
671 views

Unmet dependencies Pipelight

I am trying to install pipelight onto my notebook. Sadly I can't manage to get it installed. Every try to install it ends up with: Some packages could not be installed. This may mean that you have ...
2
votes
1answer
104 views

How can I repair broken softwares?

I want to install ffmpeg as Documented here . but some errors are accurates when I want install on terminal: The following packages have unmet dependencies: libfaac-dev : Depends: libfaac0 (= 1.28-6)...
1
vote
1answer
619 views

Mysql workbench installation failed?

I am unable to install mysql workbench community addition on ubuntu 14.04 I am installing latest version by debian file downloaded from server 1. sudo apt-get install gdebi-core 2. sudo gdebi mysql-...
0
votes
1answer
154 views

I have had this red circle with the white icon

I have had this red circle with the white icon in the top right corner for a while now, and the specific message is: An error occurred. Please run Application Manager from the Right Click Menu or ...
0
votes
1answer
259 views

Unable to install anything

I wonder if someone can help me , when I try install or remove a package , this is the error I get dpkg: error processing package libdrm-nouveau2:i386 (--configure): package is in a very bad ...
8
votes
2answers
4k views

Unable to install Springseed 2 on Ubuntu 15.04

I've downloaded Springseed 2 deb file and when I open it by Ubuntu Software Center, it shows this error: Dependency is not satisfiable: libgcrypt11 I've looked for this package in my Synaptic ...
0
votes
1answer
462 views

How to repair my apt-get

I am using Ubuntu 14.04 with HWE stack (kernel 3.16) on a Dell Inspiron 15-5547, AMD Radeon HD R7 M265. I've been trying to install the proprietary drivers fglrx drivers in order to be able to switch ...
1
vote
1answer
154 views

How to I install Bastion in Ubuntu 15.04?

I downloaded Bastion quite a while ago from the Humble Indie Bundle. I still have the .deb file and would like to install it in Ubuntu 15.04. Unfortunately, the installation fails: [me@ubuntu debs]$ ...
1
vote
2answers
320 views

fresh re installation of ckan, jetty, solr

I am trying to install ckan on my ubuntu 14.04, but i got into some errors that i cant fix, so i decided to do a fresh installation after i remove everything from my computer. I am getting some errors ...
0
votes
2answers
104 views

Dependency problem in Trusty [duplicate]

shakil@shakil-Aspire-5733Z:~$ sudo apt-get -f install [sudo] password for shakil: Reading package lists... Done Building dependency tree Reading state information... Done Correcting ...
1
vote
1answer
116 views

Dependency problems [duplicate]

I am not able to install anything because I get the follworing dependecy issues: dpkg: dependency problems prevent configuration of locales: libc6 (2.19-18) breaks locales (<< 2.19) and is ...
2
votes
1answer
209 views

How to get unity build dependencies after apply the LTS Enablement Stacks?

I have a Ubuntu 14.04.2 installation with the LTS Enablement Stacks (https://wiki.ubuntu.com/Kernel/LTSEnablementStack). I would like to build the Unity package from source to apply some custom ...
1
vote
2answers
69 views

Damaged and locked dependencies

First of all I point out I'm not expert so sorry if I don't understand something or I write some silly stuff. I downloaded the TLP for power saving while using my laptop with the battery, even though ...
5
votes
6answers
3k views

Unable to insall libgtk2.0-dev on ubuntu 12.04

I am using opencv 3 on ubunut 12.04 and while displaying an image the error message asks me to build the library with libgtk2.0-dev. I tried sudo apt-get install libgtk2.0-dev but I get the following ...
1
vote
3answers
2k views

Why am I getting an error related to linux-image-3.13.0-53-generic (3.13.0-53.88)?

Every time I install or remove existing software I get the following error. isuru@isuru-Inspiron-3420:~$ sudo apt-get autoremove Reading package lists... Done Building dependency tree Reading ...
1
vote
2answers
117 views

Debian's Depend: tag doesn't work with apt-get

Package A_0.0_all.deb's control file contains a dependency on Package B 0.0: Depends: B (= 0.0) Package B_0.0_all.deb's control file has the version 0.0: Version: 0.0 Sitting in the same Debian ...
0
votes
2answers
183 views

Installing Dependencies for Building Unity 8

If somebody could please tell what I can do to fix this that would be great, because I've tried clearing the build by deleting the cache file and many other desperate attempts. I've searched for every ...
0
votes
1answer
881 views

How to know from ldd command which library is missing?

When I run ldd -r binary_file I get something like this: libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf6d7a000) and this seems ok. However, I don't know what this line means, do I have the ...
2
votes
4answers
7k views

How can I install Wine in 15.04 when there are unmet dependencies?

When I try to install Wine in Ubuntu 15.04, I get the following message: >sudo apt-get install wine Reading package lists... Done Building dependency tree Reading state information... Done ...
2
votes
1answer
564 views

Downloading DeSmuME (Gtk) Error

I went to install DeSmuME (Gtk) (Nintendo Ds Emulator) and I encountered error message. $ sudo apt-get install desmume The following packages have unmet dependencies: desmume: Depends: libasound2 (&...
2
votes
0answers
81 views

Monodevelop installation issues [closed]

I am unable to install monodevelop on ubuntu 12.10. I am getting the following error. any help is appreciated. revathi@revathi-AcerLaptop:~$ sudo apt-get install monodevelop-current [sudo] password ...
0
votes
1answer
45 views

unmet dependecies problem

When I try to install libxinerama-dev, I get this error: The following packages have unmet dependencies: libxinerama-dev : Depends: libxinerama1 (= 2:1.1.3-1) but 2:1.1.3-1+b1 is to be installed E: ...
0
votes
1answer
484 views

Linux mint 17.1 libgtk [closed]

Hi i have problem while i want install gnome shell in linux mint ,iam using this command: sudo apt-get install gnome-shell gnome-shell-extensions gnome-tweak-tool and its display this: The ...
1
vote
0answers
24 views

package dependencies [duplicate]

While installing ubuntu from ubuntu software center, i got the following error: package dependencies could not be resolved After clicking detail button, shows the following error: The ...
0
votes
1answer
127 views

Ubuntu 12.04 LTS server in Virtualbox - problems with apt-get update and Prosody

Playing around with learning how to run an Ubuntu server (specifically, trying to set up Prosody as per a video on ArsTechnica, and a Linode guide), using Virtualbox. I've got it up and running, ...
6
votes
3answers
302 views

Uninstalling Dependencies. Is This a Good Practice?

As far as I know I can uninstall a program from Ubuntu using this command... $ sudo dpkg -r packagename But this does not remove the dependencies while the packagename installed. To remove all ...
0
votes
0answers
21 views

Having Trouble Installing DeSmuME from the Software center [duplicate]

I tried installing DeSmuME on 14.04.2 LTS. But I keep getting this error: "Package dependencies cannot be resolved..." How can I fix this and install DeSmuME?
1
vote
0answers
178 views

Unable to install Virtualmin

I am using Ubuntu 12.04.5 LTS Release: 12.04 Codename: precise I want to install Virtualmin on my VPS, but I am getting errors while installating. Check the below errors: INFO - ...
13
votes
2answers
8k views

“Unmet dependencies” When trying to install KDE Plasma 5.3 on Ubuntu 15.04

I'm trying to install the latest KDE Plasma here but I'm getting You might want to run 'apt-get -f install' to correct these. The following packages have unmet dependencies: kde-telepathy-minimal: ...
0
votes
0answers
30 views

How to install gcc? [duplicate]

I tried to install gcc, but couldn't install because of dependency on gcc-4.4, which in turn depends on list of so many packages. gcc-4.4 : Depends: cpp-4.4 (= 4.4.3-4ubuntu5.1) but it is not going ...
1
vote
1answer
756 views

Cant install libsdl2-dev or cmake glfw.. (libxinerama-dev problem)

So I was going to continue learning Opengl after switching to Ubuntu, I tried this explanation to compile glfw and use it, but I got this: -- Using X11 for window creation -- Using GLX for context ...
2
votes
1answer
481 views

Why doesn't “apt-get autoremove” remove all installed dependencies?

Installing libav-tools and ubuntu-restricted-extras also installs these new packages: cabextract chromium-codecs-ffmpeg-extra freepats gstreamer0.10-fluendo-mp3 gstreamer0.10-plugins-bad ...
0
votes
1answer
2k views

“gzip: stdout: No space left on device” error message when updating [duplicate]

My previous to last update was showing the following warning: Generating grub configuration file ... Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer ...
2
votes
3answers
2k views

Can't install anything from the terminal of software center in 15.04

A while back I installed some software (I think it was some SDK software) and it didn't work so I removed it. Ever since I have been having problems with Ubuntu. That was back in 14.10 and I was ...
1
vote
2answers
770 views

unmet dependencies when trying install wine1.7

I'm trying to install wine1.7 from official ppa,my OS is Ubuntu 14.04 64bit, however when I use the apt-getcommand to install wine, the output is: The following packages have unmet dependencies: ...
1
vote
2answers
382 views

VLC media player Installing error

I'm totally new to Ubuntu, I have version 14.04, and when I go to Software Centre to install VLC Media Player it gives an error: "Package dependencies cant be solved" The following packages have unmet ...
1
vote
2answers
359 views

`dpkg-query` and virtual packages: how to read or interpret `${Provides}`?

Background During my periodic auditing of installed packages, I encountered an error. For this auditing, an application generates a graph of installed packages, using dpkg-query. During this process, ...
2
votes
3answers
2k views

Unmet dependencies error

So some unmet dependencies are there and I cant install anything without getting rid of them. When i type in: sudo apt-get install -f I get this: patrick@patrick-Z97N-WIFI:~$ sudo apt-get ...
3
votes
2answers
143 views

reverse-depends: looking for reverse dependencies of source packages

My goal is finding ALL reverse-depends of a certain package and the belonging source package. For example, I want all packages that depend on libsslcommon2 and the source package that can be installed ...
2
votes
2answers
1k views

How can I fix this dependency issue that broke Makerware with my last update?

Today I updated Ubuntu 14.04 and Makerware was removed! I tried to install it and got his message: $ sudo apt-get install makerware Reading package lists... Done Building dependency tree ...
0
votes
2answers
231 views

Can't install Teamviewer due to libxtst6

I cant seem to install Teamviewer 10, at the Software Center it says: "Dependency is not satisfiable: lib32asound2" Not really sure what to do there, I tried: sudo apt-get install lib32asound2 ...
2
votes
1answer
847 views

I'm trying to install programs/apt upgrade and this group of libs aren't allowing me to do so

I can't apt-get upgrade, I also tried installing software with the software center but no luck since those libs need dependencies. I tried removing them but that didn't work and I also tried various ...
0
votes
1answer
222 views

Broken link for kernel (nonexistent future version)

My version (from lsb_release -a): No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 14.10 Release: 14.10 Codename: utopic I want to make some room ...
3
votes
1answer
333 views

What does “packages have unmet dependecies” mean and what can I do about it? [duplicate]

The following packages have unmet dependencies: account-plugin-facebook : Depends: libaccount-plugin-generic-oauth but it is not going to be installed or ubuntu-...
2
votes
1answer
540 views

Broken libgcrypt11 dependency

I've run a casual apt-get update && apt-get upgrade command. The process completed (with an error): You might want to run 'apt-get -f install' to correct these. The following packages have ...
4
votes
4answers
2k views

Unmet dependencies unable to fix

I'm running ubuntu 14.04. I cannot use software center to install anything, even a local deb package so I have to rely on Terminal. Recently I was trying to install mysql-server which generated error ...
0
votes
1answer
299 views

Is it possible to update npm version in Ubuntu 14.04?

I try to install yeoman and it require npm 1.4 I installed npm with apt-get but is has version 1.3.10 I try commands: sudo add-apt-repository ppa:chris-lea/node.js sudo apt-get update sudo apt-get ...
0
votes
1answer
336 views

broken dependencies are not solved

When i installed the sudo apt-get install dhcp3-server tftpd-hpa syslinux nfs-kernel-server initramfs-tools I got error. after that i wanted to fix the broken dependencies problem i tried ...
0
votes
1answer
572 views

packages have unmet dependencies: libegl1-mesa: Depends: libgl1-mesa-dri (= 10.4.0-0intel1) but 10.1.3-0ubuntu0.4 is to be installed

This error I get during the installation of "Intel Graphics Installer": The following packages have unmet dependencies: libegl1-mesa: Depends: libgl1-mesa-dri (= 10.4.0-0intel1) but 10.1.3-0ubuntu0.4 ...
1
vote
0answers
215 views

Fix unmet dependencies libc-bin

I am trying to install some programs, but I met with unmet dependencies. For example, sudo apt-get upgrade yields Reading package lists... Done Building dependency tree Reading state information... ...