Questions concerning software and package dependencies.

learn more… | top users | synonyms (1)

1
vote
0answers
30 views

Apt-get install -f and apt-get autoremove error

I've tried to install new software on Ubuntu and it told me to use that command apt-get install -f, but I get back an error message and I have no idea how to fix it. After that, I tried to use ...
0
votes
1answer
12 views

Cannot install 32bit libs, even if it has its dependency [ubuntu 16.04 LTS]

I am trying to install 32bit libs but it wont install saying it has unmet dependency. When I try to install its dependency it says I already have it installed: ozcan@ozcan-P55-UD3L:~$ sudo apt-get ...
1
vote
2answers
131 views

After Ubuntu 16.04 installation can't install almost anything

I fresh installed Ubuntu 16.04 to my laptop recently and since that I can't install lots of things. I know there is a bug in the Software Center but the problem is not limited to that. I can't install ...
0
votes
0answers
15 views

Unmet dependencies error

When I try to install gparted Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have ...
0
votes
1answer
30 views

Error Code E: Sub-process /usr/bin/dpkg returned an error code (1)

I've been using Ubuntu for a few years now, but I just installed Version 16.04, and I've been having a lot of issues. I'm not a command line programmer, but I tried to install some software last ...
0
votes
4answers
161 views

vidyo desktop on ubuntu 16

I recently moved to Ubuntu 16 and I noticed that VidyoDesktop was no more available on my system. I tried to install it from the deb package using dpkg but I received the following error: $ sudo dpkg ...
1
vote
2answers
93 views
0
votes
1answer
17 views

Unable to install npm on ubuntu 14.04 due to broken packages error

Tried installing npm on ubuntu 14.04 however the following error has occurred gwt@gwt-Aspire-E1-571:~$ sudo apt-get install npm Reading package lists... Done Building dependency tree Reading ...
1
vote
3answers
25 views

Azureus runs fine on latest java but its dependency check asks for dated version of JRE. How to tell Ubuntu to stop naggin me for “unmet dependency”?

So I force installed Vuze (and its dependency Azureus) via apt-get, and it is working fine on default-jre. Even though the default-jre works as a dependency for Azureus (at least for my use-case ...
0
votes
0answers
20 views

Dependency problem

I use Ubuntu on my offline laptop. Since I want to install python, I have to install a lot of dependencies as well, and to install those dependencies I need even more dependencies of the ...
0
votes
0answers
16 views

Cant install skype on ubuntu 14.04 LTS

I am getting the below error while trying to install skype. :~$ sudo apt-get install skype Reading package lists... Done Building dependency tree Reading state information... Done Some ...
1
vote
2answers
213 views

Problem installing Dolphin-emu, Unmet dependencies

When attempting to install Dolphin-Emu, I have come across a un-met dependences that are preventing the installation. I installed Dolphin-Emu as a PPA, so I could manually install the package. Every ...
0
votes
1answer
30 views

Gnome dependency problems with Nvidia drivers

I am running Ubuntu 14.04. I once installed the nvidia drivers (nvidia-355) and then after a few days I installed Gnome 3.10. It kept complaining about some dependency problem so I figured it'd be ...
1
vote
1answer
44 views

How do I reinstall shared dependencies after upgrade to 16.04?

I just upgraded to 16.04. When I tried to launch Emacs from the command line, I get the following error emacs/src/emacs: error while loading shared libraries: libgif.so.4: cannot open shared ...
0
votes
1answer
50 views

Launchpad Build Recipes: How do I correctly specify build dependencies for packages in the same PPA?

I am trying to build Code::Blocks IDE on Ubuntu 16.04 using this recipe: https://code.launchpad.net/~damien-moore/+recipe/codeblocks-16.01-release It needs libwxgtk2.8-dev, which isn't in the 16.04 ...
0
votes
0answers
116 views

Error while installing libqt4-core on Ubuntu 16.04

I'm trying to install libqt4-core, but it seems that for the dependencies, I have more recent versions than are compatible with this package. When I use sudo apt-get install libqt4-core my output is ...
-1
votes
0answers
23 views

Netscaler VPN Gateway Client not working in 16.04

the Netscaler Gateway VPN Client worked great for 12.04. Attempts to install on 16.04 doesn't work via Software Center or Command line dpkg method. From the Software Center Install will not complete ...
-1
votes
0answers
18 views

install gpg 2.1.7+ on *ubuntu 16.04 (support for ECC keys)

so I want to create ECSDA keys. so I tried to install gpgv2 2.1.7 http://www.gniibe.org/memo/software/gpg/keygen-25519.html but that failed with following The following packages have unmet ...
0
votes
0answers
16 views

“Error: Opening the cache …installed packages have unmet dependencies” [duplicate]

I recently started using Ubuntu, and today I got the following error and am unsure how to proceed. I would appreciate any input. An error occurred, please run Package Manager from the right-click ...
0
votes
1answer
23 views

How to get this game to run by fixing this list of issues it displayed?

Screenshot with errors on left monitor So I installed Witcher (game) from a .sh file, and when I try to run the game,it gives me that screen on the left in the image. I wanted to install the intel ...
1
vote
1answer
143 views

Can not install openssh-server on Ubuntu 16.04

As a fresh new install of Ubuntu 16.04 sudo apt-get install openssh-server outputs Also it is a fress install I could not understand why this happens. dpkg -l openssh\* Output is If ...
0
votes
0answers
16 views

Epson WF 36xx series shooting blanks driver not installing 16.04

As the title states, my printer isn't working right and things aren't installing easily. I have this networked on wireless. The test pages printed directly from the printer were fine. I am using the ...
2
votes
1answer
168 views

How to resolve a missing libproxy1 dependency on Wily

I'm installing the Citrix VPN client using the installer nsgclient.deb on Wily and I get the error Dependency is not satisfiable: libproxy1. I tried apt-get with this result: $ sudo apt-get install ...
0
votes
0answers
14 views

Dependency problem in install filezilla in ubuntu 14.04 from ubuntu software center

i use Ubuntu 14.04 when i try to install filezilla from ubuntu software center so it return dependency error like "The following packages have unmet dependencies: filezilla: Depends: libgcc1 (>= ...
0
votes
0answers
7 views

Getting Dependencies error anytime while trying to install any package

I am getting the following error while removing or adding any new software, rfc5766-turn-server:i386: Depends: libc6 (>= 2.7) but 2.19-0ubuntu6.7 is installed Depends: ...
0
votes
2answers
220 views

Cannot install build-essential on ubuntu 16.04 [closed]

I am trying to install build-essential package on Ubuntu 16.04 (Xenial Xerus) but there is a dependency issue. root@server:~# apt-get install build-essential Reading package lists... Done Building ...
0
votes
0answers
82 views

Upgrading to 16.04 failed due to unmet dependencies

Upgrading 15.10 -> 16.04 produced errors, but the upgrade went on. Now I can't install new packages, due to unmet dependencies. Libreoffice, PHP and probably other programs don't work now. Updating ...
0
votes
1answer
122 views

How to install ubuntu-device-flash in Ububtu 14.04?

I m trying to install ubuntu-device-flash on Ubuntu 14.04 (64 bits). I'm following the instructions here: Prepare your Ubuntu desktop I do: sudo add-apt-repository ppa:ubuntu-sdk-team/ppa sudo ...
1
vote
0answers
133 views

Webex on Ubuntu 16.04

I'm trying to get Webext to work. I read this http://www.linuxintro.org/wiki/Use_WebEx_with_Linux which tells me to check for missing dependencies via ldd *.so | grep "not found" It gives me this ...
0
votes
0answers
12 views

How to add two alternative dependencies in control file? [duplicate]

The software depends on any of python-wxgtk2.8 or python-wxgtk3.0. What should be in the dependency field in the control file so that any one (which is available) of them is installed? ...
0
votes
0answers
18 views

dpkg - how to install pre-dependency? [closed]

i need to install apt package on a machine where the only package system is dpkg. To do so, i have to install multiarch-support, it depends on libc6 which depends on libgcc1. But libgcc1 pre-depends ...
1
vote
1answer
562 views

Cant install libsdl2-dev or cmake glfw.. (libxinerama-dev problem)

So I was going to continue learning Opengl after switching to Ubuntu, I tried this explanation to compile glfw and use it, but I got this: -- Using X11 for window creation -- Using GLX for context ...
0
votes
1answer
205 views

Just installed Ubuntu 16.04 but no software center

Installed Ubuntu 16.04 here are my specs: OS: Ubuntu 16.04 LTS x86_64 Kernel: 4.4.0-21-generic Uptime: up 17 hours, 39 minutes Packages: 3268 Shell: /usr/bin/fish Resolution: 1366x768 Desktop ...
0
votes
0answers
16 views

following packages have unmet dependencies

I want to update codelite on my computer, but when I download the new version and uninstall my previous one. However, when I add the deb file, the terminal said: The following packages have unmet ...
0
votes
0answers
47 views

Installing KDE in Ubuntu GNOME 15.10

I'm trying to install KDE on Ubuntu GNOME 15.10, but I cannot get it to work. I'm trying to install it through the command line, using sudo apt-get install kubuntu-desktop but it doesn't work. It ...
0
votes
0answers
41 views

Multiple points of failure running World of Warcraft with Wine 1.8?

I am trying to get World of Warcraft 6.2.4 to run on Ubuntu 16.04. I've solved a couple of problems already by updating Wine to 1.8. I have tried using Wine in XP and Windows 7 "compatibility" mode. ...
0
votes
1answer
96 views

pkgProblemResolver::Resolve generated breaks Ubuntu 15.10

When I try to install something I received an error of dependencies and a incorrect gcc-5-base version installed. When I put sudo apt-get install anyprogram: Reading package lists... Building ...
0
votes
0answers
36 views

Package dependency is not going to be installed

I try to install ROS, but it does not work properly, so they write I should install libgl1-mesa-dev-lts-utopic first. This produces this error, for which I can't find the solution. Why doesn't apt-get ...
1
vote
1answer
121 views

How to install odbcinst and odbcinst1debian2 via dpkg -i, when they depend on each other?

Using Ubuntu 12.04 LTS 64bit. Host is offline, and of necessity must stay that way. I need to install odbc to talk with a remote database from a C++ application running on the system. I have ...
0
votes
1answer
17 views

cannot install qtbase5-dev due to unmet dependencies

I need to install qtbase5-dev but $> sudo apt-get install qtbase5-dev Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be ...
0
votes
0answers
135 views

Error unmet dependencies can't install or remove software

I can't use software center or terminal to install or remove software (always render unmet dependencies error). I fix follow guest in software center: It fails with: installArchives() failed: W: ...
0
votes
2answers
40 views

Can multiple versions of the same package co-exist on the same system?

In order to install tmux 2.1, I needed to install libtinfo5 version 6, I did this by downloading a .deb archive containing libtinfo5 and installing directly with command: sudo dpkg -i ...
0
votes
0answers
15 views

E: malformed line 56

I am new to Ubuntu{new OS for me} 14.04 and after last boot I am not being able to do many things like I am not able to open few programs like software updater,and Ubuntu software center, I have ...
0
votes
1answer
50 views

Ubuntu 14.04.4 LTS Enablement Stack has unmet mesa-dev dependencies

I have just updated to the latest LTS Enablement Stack for Ubuntu 14.04.4 using the wiki. I am trying to install some dependencies for building plexhometheater and getting an error. Any ideas what ...
0
votes
1answer
24 views

Broken packages Libreoffice - unmet dependencies

I have a red no entry icon on 15.04 showing following my attempt to uninstall OpenOffice and replace with LibreOffice. It states: The following packages have unmet dependencies: libreoffice-core: ...
0
votes
1answer
31 views

Can't install Upwork application on Ubuntu 15 with gksu

I am not able to install Upwork 64 bit application on Ubuntu, reason I am asking this again as I followed the answer posted in another similar question but I could not get it working. I am having ...
1
vote
1answer
132 views

Install readr in R and met dirty dependency tree

My Ubuntu and R versions: alvas@ubi:~$ lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 14.04.2 LTS Release: 14.04 Codename: trusty alvas@ubi:~$ R > ...
0
votes
0answers
29 views

Ubuntu 14.04.4 LTS update post-installation error exit status 2

I use the muon updater; it's worked fine until now on this 64-bit system. Today, it returned this: linux-image-3.16.0-70-generic subprocess installed post-installation script returned error exit ...
0
votes
2answers
65 views

Can't install Steam because of unmet dependencies

Today I tried to install Steam using sudo apt-get install steam. It didn't work and showed me this error: barend@barend-ubu:~$ sudo apt-get install steam Reading package lists... Done Building ...
0
votes
0answers
17 views

easy way to make a fake package depending on libfoo-dev's when compiling from source? [duplicate]

I often install various development libs required by some package I'm compiling from source and/or hacking on temporarily. I like keeping track of what I install in these situations so that I can ...