1
vote
0answers
17 views

“Depends: ___ but ___-saucy is to be installed” type broken dependencies after Trusty upgrade

The installer threw an error near the end of the 14.04 Trusty upgrade. unity-control-center is not installed and upon trying to install it I now have a chain of broken dependencies which, after going ...
0
votes
1answer
14 views

unresolvable broken packages

I have been desperate to resolve this problem as I am not being able to install certain programs. my computer says that I have broken packages: The following packages have unmet dependencies: ...
0
votes
0answers
34 views

Depending on postgresql-plpython for every installed version of postgresql

I'm working on a project which gets installed as an Ubuntu package. This is part of the code for generating the database (modified): CREATE EXTENSION plpythonu; CREATE FUNCTION foo (str text) ...
0
votes
1answer
305 views

Can't upgrade ubuntu 12.04 to 14.04 (Package dependencies cannot be resolved) [duplicate]

This is what I get each time I try to upgrade: "The following packages have unmet dependencies: libgl1-mesa-glx-lts-trusty: Depends: libglapi-mesa-lts-trusty (= 10.1.3-0ubuntu0.1~precise1) but ...
0
votes
0answers
56 views

Problems in downloading and installing packages

I am a newbie in Ubuntu. I have installed 12.04 LTS in my laptop and it was moreover all fine. I want to install packages like wine,VLC,Chromium Browser,etc I was getting various error messages. 1). ...
1
vote
0answers
29 views

Upgrade conflicts with some packages, in particular - Violetland

Ubuntu 12.04's last upgrade deleted game "Violetland". When I tried to (re)install it, it wants two older packages The following packages have unmet dependencies: violetland : Depends: ...
2
votes
0answers
141 views

After updating the system to 14.04, an application fails due to lack of libpng15. How do i obtain it?

After updating my Kubuntu to 14.04, one of applications (the "King Arthur's Gold" indie game) would fail due to lack of libpng15 in the system. The error message is: [13:47:13] PNG warning: ...
0
votes
1answer
70 views

Can't upgrade past 11.10 - libc6 dependency errors [closed]

Since upgrading to 11.10 I can't upgrade any further (trying to get my web server to latest version.) I'm aware of How do I resolve unmet dependencies? and have tried up to the point of running this: ...
0
votes
0answers
625 views

Dependency issues preventing update

I'm trying to do routine software upgrades but made the mistake a while back of installing acestream:i386, which broke a fair amount of stuff. When I run apt-get upgrade, I get the following: E: ...
1
vote
1answer
44 views

cannot upgrade Catfish file searching tool

I receive the following error messages attempting to upgrade the Catfish file searching tool: The following packages have been kept back: catfish The following packages have unmet dependencies: ...
0
votes
1answer
59 views

Problems when trying to upgrade from 10.04 to 12.04 [duplicate]

When I was trying to upgrade my server from ubuntu 10.04 to 12.04 I was facing problems with some packages. It was saying, sudo apt-get dist-upgrade Reading package lists... Done Building dependency ...
1
vote
1answer
386 views

upgrade from 13.04 to 13.10 failed and broken dependencies

I tried running the upgrade from my Ubuntu 13.04 to 13.10 but it failed to upgrade a latex package with the error from [here] (Upgrading from 13.04 to 13.10 stops) and calmed to try to roll back. ...
2
votes
2answers
266 views

Adding KDE Backports PPA has caused unmet dependencies. How to fix?

I added ppa:kubuntu-ppa/backports in the usual way, then performed a dist-upgrade. It needed to download over gigabyte of files, so I left if for the afternoon. Upon my return, I found that the system ...
1
vote
0answers
253 views

dpkg Unmet dependency linux-image-generic 13.10

I've upgraded a few of my boxes to 13.10 and have started to see the following error on them when running apt-get update and apt-get upgrade: Setting up linux-image-3.11.0-13-generic (3.11.0-13.20) ...
3
votes
2answers
4k views

Ubuntu 12.04 LTS initramfs-tools dependency issue

I know this has been asked several times, but each issue and resolution seems different. I've tried almost everything I could think of, but I can't fix this. I have a VM (VMware I think) running ...
0
votes
0answers
151 views

Unable to calculate upgrade from 13.04 to 13.10

I'm getting that error message when I try to upgrade. I've removed all ppa I do not need, next I've started looking into grep Broken /var/log/dist-upgrade/apt.log but the list is huge and I do ...
1
vote
1answer
922 views

dependency problem prevent upgrade

After falling into a root disk full issue due to the automatic updates installing new kernel with removing of old ones, I am now facing a dependency issue that prevent any upgrade of my system. the ...
3
votes
3answers
3k views

Dependency issues while trying to upgrade 12.04.2 to the 12.04.3 HWE stack

While trying to upgrade my system to the latest hardware enablement stack from Ubuntu 12.04.2/Linux 3.5 I get the following error: $ sudo apt-get install --install-recommends linux-generic-lts-raring ...
0
votes
0answers
14 views

Unable to upgrade ubuntu due to unmet dependencies [duplicate]

I am trying to upgrade Ubuntu Server, but get the following error message: The following packages have unmet dependencies: linux-server : Depends: linux-headers-server (= 3.2.0.44.53) but 3.2.0.48.58 ...
4
votes
3answers
8k views

dependency problems prevent configuration of linux-headers-virtual

I'm running Ubuntu 12.04.2 LTS on a virtual box and have run into a little problem. Whenever I try to do an upgrade, I get: apt-get upgrade Reading package lists... Done Building dependency tree ...
1
vote
0answers
128 views

Ubuntu dependency problems after `do-release-upgrade`

I recently performed do-release-upgrade, and it appears to have broken some of my packages. I can't properly apt-get autoremove or apt-get upgrade any more. $ sudo apt-get install -f ... Errors ...
3
votes
1answer
725 views

How can I upgrade while having unmet dependencies?

I just install a package that has these unmet dependencies: Depends: sun-java5-jre but it is not installable or sun-java6-jre but it is not installable or openjdk-6-jre ...
2
votes
2answers
886 views

interrupted upgrade

I was running ubuntu 11.10 without major flaws and somewhat adapted to my taste and decided to give upgrading another shot. Somehow I do so every couple of years and every time I face reinstall. This ...
3
votes
0answers
992 views

Ubuntu 12.10 stuck in incomplete upgrade state [closed]

I started upgrade from Ubuntu 12.04 to Ubuntu 12.10 x64. All of a sudden, the upgrade process stops due to extra.ubuntu.com being unreachable. Any attempts to resume the process didn't give any ...
2
votes
0answers
694 views

Ubuntu upgrade 12.04 the disk drive for / is not ready or not present

When upgrading Ubuntu to 12.04, I get the message the disk drive for / is not ready or not present. I tried mount -n -o remount,rw /` and `dpkg --configure -a which gives me this error: ...
2
votes
0answers
115 views

12.04 upgrade hosed my system

I wish I could be more specific. I installed the upgrade from the update manager and after the computer rebooted, I found I could not run a lot of programs. I tried running them from the command ...
0
votes
2answers
730 views

Failing to upgrade to linux-image-3.0.0-26-generic

When I try to upgrade linux-image-3.0.0-26-generic I get following problems: dpkg-deb (subprocess): data: internal bzip2 read error: 'DATA_ERROR' dpkg-deb: error: subprocess <decompress> ...
0
votes
1answer
280 views

How to upgrade nautilus to 3.4 on 11.04?

I'd like to upgrade Nautilus from 2.32.2.1 to 3.4 because I've encountered a problem which I cannot reproduce on Nautilus 3.4 (on Ubuntu 12.04). I guess there might be a bug in my current version. ...
0
votes
0answers
59 views

Quantal: Broken apt-index, cant fix dependencies [duplicate]

Possible Duplicate: There's an issue with an Alpha/Beta Release of Ubuntu, what should I do? I can't seem to add/remove/update packages Ubuntu software update has a notice about partial ...
3
votes
1answer
2k views

How to fix “apt-get upgrade” errors?

I get these errors when I try to upgrade the packages installed on my Ubuntu system: m@m-desktop ~ $ sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state ...
0
votes
2answers
566 views

Can't install FlightGear after upgrading to ubuntu 12

I upgrade ubuntu to v12 and flightgear quit working. So I uninstalled it and tried the reinstall it but it will not install. This is what happens when I try to install it. "Package dependencies cannot ...
0
votes
0answers
83 views

Totem was deleted in upgrade process and now it have unmet dependencies [duplicate]

Possible Duplicate: How do I resolve unmet dependencies? What can I do to solve this problem? Error: totem: Depends: libnautilus-extension1a (>= 1:2.91) but 1:3.4.1-0ubuntu1 must be ...
3
votes
3answers
546 views

Does dist-upgrade require PPA software to be uninstalled first?

I'm still running Ubuntu 10.04 with quite a few PPAs. Amongst the PPAs there is Guiodic (Guido Iodice) Lucid quasi-rolling :) PPA which brings most recent versions of many programs to my desktop. My ...
2
votes
2answers
525 views

Error while upgrading to 10.10

I tried to upgrade 10.04 to 10.10 and got an error: 'E:Couldn't configure pre-depend x11-common for x11-xkb-utils, probably a dependency cycle.'. Can I fix this and finalize the upgrade?