Questions concerning software and package dependencies.

learn more… | top users | synonyms (1)

0
votes
0answers
16 views

Dependency problems with bitcoinqp

I keep getting this message when trying to install bitcoin-qt on my VPS: dpkg: dependency problems prevent configuration of bitcoin-qt: bitcoin-qt depends on libboost-chrono1.54.0; however: ...
0
votes
0answers
12 views

libc-l10n package error [migrated]

I was attempting to install katoolin and ran into some errors. When I run sudo apt-get update My output: zayascom_m1@Zayascom-mobile-1:~$ sudo apt-get update [sudo] passwor: Hit http://download....
0
votes
0answers
18 views

Error in downloading mysql server

I am downloading mysql on ubauntu software center I am getting error as follows: The following packages have unmet dependencies: mysql-workbench: Depends: libgcc1 (>= 1:4.1.1) but 1:4.9.1-...
3
votes
1answer
39 views

Cannot install ownCloud on ubuntu 16.04

I get the following errors while trying to install ownCloud: The following information may help to resolve the situation: The following packages have unmet dependencies: owncloud : Depends: ...
0
votes
0answers
34 views

Can't Install Wine On Ubuntu 16.04 For Unkown Reason!

The problem: Every time I've tried to install Wine on Ubuntu 16.04, it doesn't work. When I attempt to install it, I receive the following message: E: Unmet dependencies. Try 'apt-get -f install' ...
1
vote
0answers
29 views

APT install package with dependency

I created own debian packages with dependencies. Package A: Version 1.0 depends on Package B = 1.2 Version 1.1 depends on Package B = 1.2 Package B: Version: 1.0, 1.1, 1.2, 1.3 If I'm trying to ...
0
votes
0answers
42 views

several paths deleted to break ordering cycle on booting

On booting my laptop, right after BIOS is loaded I get these lines: [10.368134] systemd[1]: paths.target: job paths.target/start deleted to break ordering cycle starting with basic.target/start [10....
3
votes
1answer
38 views

Unmet dependencies and possible conflicts? [duplicate]

It seems that I have messed up somewhere along the line and now I can no longer install anything without the following message showing up: The following packages have unmet dependencies: kde-...
6
votes
1answer
82 views

Do I have to create a new snap package everytime a dependency gets a security update?

If I create a snap package with lets say 5 dependencies. Do I have to create a new package version everytime a dependency gets a (security) update? I mean the advantage of .deb packages is that in ...
0
votes
0answers
18 views

QT unmet dependencies for smplayer

I was trying to upgrade smplayer, but aptitude tells that it's unable to solve the dependencies for libqt5script5 $>sudo aptitude dist-upgrade The following NEW packages will be installed: ...
1
vote
1answer
90 views

Large snap packages because of dependencies

Snap packages each have their own copy of dependencies, right? This means there are lots of packages in each snap, which would equate to large package sizes. Wouldn't this mean that snaps would be so ...
8
votes
2answers
199 views

How do snap packages handle shared dependencies?

The snap packaging format finally frees us from dependency hell by allowing each package to have its own copy of dependencies. I'm interested in the technical details in how it does this. How does it ...
1
vote
1answer
44 views

Service not avaliable Unity3d error in Kubuntu

I'm trying to use Unity3d in Kubuntu, but I'm getting this error: Service not avaliable, please try again later. I've found this post: Certain systems may experience "Service unavailable" errors ...
0
votes
1answer
44 views

I can't download anything on 16.04 LTS

When I try to download anything at all through the terminal on 16.04, it doesn't finish something as I do this command: sudo apt-get install kdenlive. It then tells me Unmet Dependencies. Try 'apt-get ...
0
votes
1answer
77 views

apt-get update not Working due to unmet dependencies

Whenever I try installing using apt-get install command I am getting errors like these Reading package lists... Done Building dependency tree Reading state information... Done You might want ...
0
votes
0answers
19 views

Package dependencies cannot be resolved. Trying to install Audacity

I'm very new to Linux and just installed Ubuntu on an iMac G5. I'm trying to install Audacity but everytime I do it through the Software Center I get the following. audacity: Depends: audacity-data (...
0
votes
0answers
22 views

How to fix the error about incompatible version of libc and libgcc when upgrading Ubuntu server 14.04 LTS?

I encountered the following error when trying to upgrade a server running Ubuntu 14.04.2 LTS. To summary, this error complains that there are incompatible versions (amd64 and i386) of two libraries ...
-1
votes
1answer
27 views

Can wine and play on linux be installed in Ubuntu 16.04? [closed]

I'm upgrading from 14.04 to 16.04 and having trouble installinging some items I used in the old OS.
0
votes
0answers
26 views

zeroc-ice dependencies has broken apt-get, help!

I've busted apt-get while I was trying to get a mumble server viewer running, and have since given up on doing that as I can't find/discover the resources/solutions to make that happen. but now I can'...
0
votes
2answers
66 views

Trelby not installing in 16.04

Trying to install trelby by using sudo dpkg -i trelby_2.2_all.deb produces this error: Selecting previously unselected package trelby. (Reading database ... 267174 files and directories currently ...
0
votes
2answers
64 views

Can't install or update any software

I'm new to Linux and I was trying a few new things. I was having problem install stuffs on software center at first because if this error Failed to fetch http://llvm.org/apt/precise/dists/llvm-...
0
votes
0answers
17 views

Dependencies issue while installing vlc

The following packages have unmet dependencies: vlc: Depends: vlc-nox (= 2.0.8-0ubuntu0.12.04.1) but 2.1.5-0ppa1~precise1 is to be installed Depends: libavcodec-extra-53 (>= 4:0.8-1~) but 4:0....
2
votes
1answer
136 views

How to install Arc Theme on Ubuntu GNOME 16.04

I tried installing the Arc Theme on Ubuntu GNOME 16.04 using the following commands: sudo sh -c "echo 'deb http://download.opensuse.org/repositories/home:/Horst3180/xUbuntu_16.04/ /' >> /etc/...
1
vote
0answers
28 views

Ubuntu 12.04 LTS - Upgrade to a specific version of previously available GCC version

I've added the ppa:ubuntu-toolchain-r/test repo for getting the latest GCC-5 version but I had the unfortunate surprise that the available version for 12.04 LTS changed a few days ago from 5.3 to 5.4. ...
0
votes
0answers
57 views

Can't install libgcrypt11 on ubuntu 16.04

I want to install an EasyCAP DC60+ capturer on my computer running Ubuntu 16.04. I followed the steps on this site: http://randomlinux.com/uncategorized/how-to-properly-install-usb-easycap-device-in-...
1
vote
0answers
36 views

Software updates failing with dependency issues 16.04 LTS

Recently a software update failed with dependency issues and now they're all failing. The same four modules appear to be the root cause: Errors were encountered while processing: udev apport ...
0
votes
0answers
35 views

distribution upgrade 14.04 to 15.04 halted due to multiple errors

During distribution upgrade 14.04 to 15.04, process halts due to many dpkg errors, here are a few of them. dpkg: too many errors, stopping Errors were encountered while processing: udev gnome-...
0
votes
1answer
45 views

How do i fix dependency issue with apport and apt-get (ubuntu 16.04 upgraded from 14.04)

I'm having trouble with dependencies and apt-get upgrade. I've looked around and tried a group of approches from this site and other stuff found on google. b@asus:~$ sudo apt-get upgrade Reading ...
0
votes
0answers
48 views

Can't install pgadmin3 on ubuntu 16.04

After I try sudo apt-get install pgadmin3 I get this message: Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable ...
0
votes
0answers
37 views

Error on Skype on Ubuntu 16.04 installation

I am trying to install Skype from the deb package (skype-ubuntu-precise_4.3.0.37-1_i386.deb) on my 16.04 Ubuntu. What is causing the error? How can I fix the problem / install it?
0
votes
0answers
29 views

'libpeas-1.0-0-python3loader' dependency issue after upgrade

I ran the command: sudo apt-get dist-upgrade Today and this was how it went: Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... ...
0
votes
1answer
22 views

installing ubuntu touch -unmet dependancies when installing ubuntu-flash-packagr using Precise or Trusty

in trying to install ubuntu-flash-package (tried on both Precise and Trusty) I get The following packages have unmet dependencies. ubuntu-device-flash : Depends: click-ubuntu-policy but ...
0
votes
1answer
33 views

Error in software installation

I have installed Ubuntu 16.04 LTS and when I want to install any software I encounter this error: sudo apt-get install openjdk-7-jre openjdk-6-jre [sudo] password for ali: Reading package lists... ...
1
vote
1answer
22 views

Failure while removing unwanted packages/configurations/dependencies

I have a minor problem which occurs everytime I'm installing a new application. Basically there must be some unused packages/configurations/dependencies which make some troubles. What happens is, that ...
0
votes
2answers
51 views

Package dependencies

I am installing vlc in ubuntu 14.04 then its showing some error.. This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be ...
1
vote
1answer
23 views

Query for dependencies [duplicate]

The following packages have unmet dependencies: gstreamer1.0-libav: Depends: libavcodec-extra-54 (>= 6:9.13) but 6:9.18-0ubuntu0.14.04.1 is to be installed Depends: ...
1
vote
1answer
65 views

I have a version dependency that I don't understand

Nautilus threw a SEGFAULT, the Ubuntu bug handler caught the crash and generated a crash report. So far, so good. In the bug report, it said that there some packages that were out of date. Okay, I'...
0
votes
0answers
48 views

E: Unable to locate package ubuntu-desktop

So I am making this post because I have a special case. There are like four questions like this and the right answer seems to be to just do apt-get update, but that does not work for me. So let's ...
0
votes
2answers
82 views

can't install ubuntu-software on 16.04

I did a clean install of 16.04. When I opened the software center, it showed the categories, but everything inside them was empty, no software was listed, any search turned 0 results. So I decided I'...
1
vote
0answers
31 views

Error on installation of apache2 and php5

This error occurs when I install the apache2 & php5 around the time that libapace2-mod-php5 is installed: root@ubuntuServerASC:/home/asc# apt-get install libapache2-mod-php5 Reading package lists....
0
votes
0answers
33 views

Newbie: problem with building dependencies

I am trying to read video file in Octave(previously in Windows I am running the same program in Matlab with some inbuilt functionalities and works fine),but in Octave it is not able to read the video ...
0
votes
0answers
24 views

Getting Error while installing epad

sudo dpkg -i epad_2.3-11907_i386.deb Selecting previously unselected package epad. (Reading database ... 211800 files and directories currently installed.) Preparing to unpack epad_2....
0
votes
0answers
28 views

gstreamer dependencies problem

When I try and install gstreamer I get dependency errors. I already followed this thread and it did not work. Here is the error output: The following packages have unmet dependencies: gstreamer1.0-...
1
vote
3answers
87 views

held broken packages after purging and trying to reinstall skype

I use 16.04 64 bit desktop and had skype installed from the partners repository. Because of issues with sending messages, I wanted to reinstall it. I ran: sudo apt purge skype sudo apt autoremove ...
0
votes
0answers
50 views

Dependency is not satisfiable: libwxgtk3.0-0 (>= 3.0.0) 16.04

I'm trying to install a .deb file that requires libwxgtk3, but it isn't anywhere in the repositories. I have libwxgtk3.0-0v5 installed, but I still get the error. Is there any way to install the ...
4
votes
2answers
542 views

14.04 --> 16.04 failed; apt (>= 1.0.1ubuntu2.13)' is not installed

(This question was not resolved. Due to time constraints Computer was restored to factory settings.) I was attempting to upgrade from 14.04 to 16.04, but apt threw this error: The required ...
0
votes
0answers
36 views

Cant install apps using terminal or appstore or anything on Ubuntu 16.04

I am trying to install gksu on my Ubuntu but am getting the following error $ sudo apt install gksu Reading package lists... Done Building dependency tree Reading state information... Done E: ...
0
votes
1answer
8 views

Purging libglew1.13 broke Ubuntu

I'm on the latest Ubuntu distro (Xenial?) and was installing libglew1.10. Before doing so I wanted to get rid of 1.13 so they didn't clash. However after running a apt-get purge libglew1.13, and ...
0
votes
0answers
29 views

Blocked upgrades after upgrade 15.10 to 16.04

So I upgraded my system from 15.10 to 16.04 and I've got several items that can't upgrade. The following packages have been kept back: findutils gcc-5-base initramfs-tools initramfs-tools-bin ...
0
votes
0answers
24 views

hplip missing dependencies after hp-doctor

I encountered problems with my printer HP Laserjet 6p. I run XUbuntu 16.04 So I downloaded the latest hplip, and I installed it. Unfortunatelly when I run hp-doctor and hp-check, I have 2 errors : ...