1
vote
0answers
30 views

How to find top-level dependencies in a list of deb packages?

Suppose I have a list of packages: foo libfoo bar baz quux And suppose foo requires libfoo and bar, and baz requires quux. I want a way to put in that list, and get out this list: foo baz I.e. ...
0
votes
0answers
344 views

How to make linux-{image,header}-3.11.x satisfy linux-generic dependencies?

What is the difference from apt's perspective between Ubuntu 12.04 LTS (Precise) kernel packages: linux-image-3.2.0-57-generic linux-image-3.11.0-14-generic Such that the former satisfies ...
0
votes
1answer
307 views

dpkg and missing dependency problem

I downloaded an open source software from the Internet to emulate white board on my computer. The link is here: http://open-sankore.org/ The download was as .zip file with .deb file inside (which I ...
2
votes
4answers
3k views

How do I create a .deb file?

Yes, I know that this question has been asked many times before, but none of the answers really helped. I'd like to package the Minecraft launcher (which has no proprietary code, AFAIK,) into a .deb ...
3
votes
2answers
356 views

DEB installer - Dependency Checks

Using a third-party install generation tool, I created a .deb package for my application. There are several dependencies that are required to be present on user’s Linux OS for my application to run ...
0
votes
1answer
104 views

Installing from Local Dependencies?

I have a folder with all dependencies needed for my program (gimp) in a folder. I don't have internet connection on that System. How can i install Gimp Dependencies from that Folder. Note: All ...
3
votes
1answer
595 views

How apt-get selects from a list of alternative dependencies?

I understand that in the Depends: section of the deb control files, a package may specify alternative dependencies separated by | symbol to satisfy a single dependency. My question is, how does ...
4
votes
2answers
3k views

Can't install package libglib2.0-dev because it depends on some unknown version

I have 10.04.2 LTS and I want to install libglib2.0-dev. So I do: $ sudo apt-get update && sudo apt-get upgrade $ sudo apt-get install libglib2.0-dev Reading package lists... Done Building ...
36
votes
5answers
45k views

How to automatically fetch missing dependencies when installing software from .deb?

I'm trying to install MySQL Workbench on my Ubuntu box (11.04). The website has a Ubuntu .deb available for download (for 10.10 and 10.04 so I chose 10.10). However, sudo dpkg -i ...
14
votes
5answers
13k views

How to remove a deb without removing its dependencies

I would like to install the most recent version of boto, which I do via python setup.py install Yet when I try to remove the old version the following packages also get removed: apt-get remove ...