cryptsetup - setup cryptographic volumes for dm-crypt (including LUKS extension). cryptsetup is used to conveniently setup dm-crypt managed device-mapper mappings.

learn more… | top users | synonyms

1
vote
0answers
25 views

update-grub fails on lvm cryptoroot

Disclaimer: I'm running this server now but I did NOT install it. I have two disks connected to an Intel Hardware Raid Controller running in RAID1. On top of it there is a fully encrypted 12.04 ...
2
votes
0answers
155 views

Encrypted disk kernel warning - initramfs image won't boot

After an upgrade to 14.10 on my netbook, I can only manage to boot with the old kernel remaining from the previous 14.04 installation. For the most recent kernels, I get this warning when they are ...
0
votes
0answers
76 views

Auto mount encrypted FS with grub2

I have been looking for a way to mount my encrypted partitions automatically during boot up, without asking for password. my setup for this process.. USB key: /boot partition /boot/efi partition ...
1
vote
1answer
44 views

Problem after using LuksRemovekey?

I have an encrypted partition on /dev/sda5, yesterday I use cryptsetup to remove the encryption using cryptsetup luksRemovekey /dev/sda5, but when I restart I have to provide a passphrase for ...
0
votes
0answers
47 views

Encrypted Lvm , passphrase nor working

I am using ubuntu server 14 on virtual box and i have used entire disk and set up encrypted lvm ,the system ran completely fine on first start , but once i rebooted it the same passphrase is not ...
0
votes
0answers
102 views

How do I fix the fstype boot issue?

I'm new to Ubuntu (running 14.04) and I need to get back to Windows 8 as soon as possible so I tried using testdisk to at least access my files but when I rebooted I couldn't get past the crypt page. ...
0
votes
1answer
316 views

Can I “cryptsetup … luksFormat” a partition formatted with Ext4, or must it be unformatted?

I would like to setup Full Disk Encryption (FDE) for an external harddrive. My question is about the sequence of formatting. Will the following sequence work fine or do I need to run luksFormat on an ...
0
votes
1answer
81 views

Cryptsetup with optimized AES version

I am trying to set up an encrypted partition with dm-crypt and LUKS. I want to use the version of the AES cipher optimized with assembly instructions. I recompiled my kernel and added the required ...
0
votes
0answers
383 views

cryptsetup failed - but manual cryptsetup luksOpen worked

I boot my ubuntu 14.04 and it doesnt accept my password. Some trys later, busybox start. The following command mount my root dir in /mnt echo -n "Passw0rd1" | cryptsetup luksOpen /dev/sda5 crypt1 ...
0
votes
1answer
126 views

Cannot mount partition with cryptsetup

I have a spare drive. I've attempted to format it and encrypt it. But even though the process appears to succeed and I can open the crypt, I cannot mount the newly mapped device. Here is the output of ...
0
votes
0answers
154 views

cryptsetup-encrypted disks failing after restart (mb solved?)

I am using cryptsetup/luks (ETA: On 12.04) to encrypt partitions on external hard drives. Several times now, I've had disks fail to mount after an apparently normal restart (often a kernel upgrade, ...
0
votes
0answers
147 views

cryptsetup passphrase prompt disappears too quickly (LUKS)

My problem is the passphrase prompt at boot (which is set up by cryptsetup) is disappearing too quickly. During boot the passphrase prompt is displayed for about 5 seconds and then the console ...
0
votes
0answers
60 views

Why won't my passphrase work

cryptsetup: evms_activate is not available I am new to ubuntu and after everything I am stuck here, I type in my password and press enter and nothing happens.
0
votes
1answer
197 views

How to enable crypttab to run at boot

The cryptdisks service is set to run levels 0 and 6. However, I don't know if this is a correct setting because perhaps crypttab is made to run in some other fashion. In either case, this is a ...
1
vote
0answers
515 views

LVM on encrypted partition drops me to initramfs root missing

I installed Ubuntu 13.10 64bit on my PC. I have single hard disk (/dev/sda) with LVM encrypted partition. So the problem is that after reboot I cannot start Ubuntu (it dropped me to initramfs prompt ...
1
vote
0answers
101 views

Problem with cryptdisks-udev service

I am getting an error when I run 'puppet resource services' that complains about the cryptdisks-udev service. The exact error message is as follows: status: Unknown parameter: DEVNAME The error ...
1
vote
0answers
126 views

12.04, Kernel 3.2.0-55 & cryptsetup

I am running into a problem regarding the following setup: Partitions: /dev/sde1 cryptswap /dev/sde2 cryptroot |_ /dev/vg_root/lv_root / |_ /dev/vg_root/lv_usr /usr/local |_ ...
1
vote
1answer
3k views

Full System encryption with LUKS on headless server - unlock with dropbear and busybox. How?

I encrypted a headless server with cryptsetup/LUKS. 2 HDDs with 512 MB /boot on /dev/md0 and 1,61 TB LUKS encrypted /dev/md1 with LVM containing /, swap, and others. I installed dropbear (and busybox ...
2
votes
0answers
348 views

Ubuntu 13.04 does not boot after update

as a complete newbie to Linux, I just installed a brand new Lenovo ThinkPad X230 with Ubuntu 13.04 from USB stick. Downloaded the installer from ubuntu.com and put it on a stick. No issues. Next day ...
2
votes
0answers
1k views

What is the correct way to use key file LUKS authorization?

Before filing new bug reports i decided to try to get support on my situation here. Sorry for my english (it may sound frustrating) in advance, feel free to ask about additional details and thanks!! ...
2
votes
1answer
275 views

Cryptsetup does not accept passphrase after installation

I used the xubuntu 13.04 installer and selected german keyboard layout. Afterwards i checked that I want to install with encryption via LUKS on a LVM. There I entered my passphrase and the setup ...
0
votes
1answer
258 views

How do I find the password to a hard drive partition?

I am running Lubuntu 13.04 and I have a problem with a partition on my external drive. Basically, I either do not remember the password or some sort of error is not allowing my access the partition. ...
0
votes
1answer
4k views

Problems with cryptsetup during update

I'm still new to all of this. I think I was installing a bunch of updates, and after what seemed like an hour or so, I finally got this message in the Terminal window: cryptsetup: WARNING: failed to ...