Questions about configure scripts

learn more… | top users | synonyms

0
votes
0answers
21 views

Error executing “./configure” command : bash: ./configure: No such file or directory

I have downloaded CiscoPacketTracer6.2.tar.gz file. Now I want to install it. The command I have use is tar xvfz CiscoPacketTracer62Student.tar.gz Then I navigate to that directory using cd ...
-1
votes
1answer
10 views

configure: error: --enable-application=APP is required [on hold]

I have downloaded source code of mozilla firefox. when i configure it, gives an error: configure: error: --enable-application=APP is required Please help me to remove this error. Thanks
0
votes
0answers
10 views

Problem configuring openvrml-0.18.9 [duplicate]

Downloaded latest version from http://openvrml.org/ Working with Ubuntu 14.04.2 LTS (x86_64) Tried to configure it without success: alex@pc:~/Downloads/openvrml-0.18.9$ ./configure ... checking for ...
0
votes
1answer
29 views

Error when using command 'make'

I get error whenever I'm trying to 'make' file, I did this before I typed 'make': tar xjf xarchiver-0.5.4.tar.bz2 cd ./xarchiver-0.5.4 ./configure Configure command: ...
0
votes
1answer
43 views

What is meant by “put the file in your path” [duplicate]

I am little confused about an instruction I came across. It stated "put the file in your path". I interpreted that as to add PATH=$PATH:'~/.conkystart' to my ~/.bashrc. The file is ~/.conkystart ...
0
votes
0answers
26 views

Not able to configure bluetooth wireless earphones w/3.11.0-12-generic kernel

Greeting Linux Debug Demigods, Just confiscated a really slick pair of Bluetooth wireless earplugs. I finally realized my machine does not include Bluetooth hardware, and so tracked down, and plugged ...
0
votes
1answer
80 views

tesseract-ocr `./configure` triggering Error “leptonica not found”

I was trying to install tesseract-ocr using these commands: auto-apt run ./configure make checkinstall Auto-apt and apt-file are installed on my Ubuntu 14.04 and up to date. However, during the ...
1
vote
0answers
51 views

wacom intuos disable cursor select when pen makes contact with tablet (CTH480)

So I have been messing around with xsetwacom with my wacom and I would like to touch the pen to the tablet without it thinking I want a "left mouse button" being held down. The reason for this is ...
1
vote
0answers
63 views

C Library requires -D_FILE_OFFSET_BITS=64

I've installed binutils 2.24 and gcc 4.8.3 on a 32-bit Ubuntu 14.04.1-desktop-i386.iso I'm trying to install a 32-bit MIPS machine simulator called SYS161. When I run the following: ./configure ...
-3
votes
1answer
231 views

“configure: error: invalid variable name: `–prefix'” while runing configure [closed]

I got the following error: jay@ubuntu:~/Downloads/systemc-2.3.1/objdir $ sudo ../configure –prefix=/usr/local/systemc-2.2 configure: error: invalid variable name: `–prefix'
0
votes
1answer
64 views

Wine 1.6 USB Mouse Detection

I have a Perixx MX3000 mouse with 5 fully customizable profiles with different speeds, colors, and button binding. The problem is, its software is not made for Linux based operating systems, so I ...
0
votes
0answers
248 views

How to install ATLAS

I'm trying to install sextractor on a dual-booted windows8.1/ubuntu14.04 machine with i5 processor. I'm following this guide on how to install ATLAS onto Ubuntu. I always encounter the error: ``` ...
2
votes
2answers
26 views

What to do with the config files in home partition?

If i have a separate home partition and reinstalled ubuntu will it be safe to delete all config files?
0
votes
0answers
89 views

problem in installing virtuoso (make)

I want install 'virtuoso'. there is instruction like this: # For Ubuntu, make sure these dependencies are installed sudo apt-get install -y automake gawk gperf libtool bison flex libssl-dev ...
2
votes
1answer
133 views

broken package install, purge, configure, reinstall, apt-get -f wont work

so i was installing some packages by the command: openstack@controller:~$ sudo apt-get install ceilometer-api ceilometer-collector ceilometer-agent-central ceilometer-agent-notification ...
0
votes
1answer
53 views

How to compile PythonMagick against custom lib path

I want to compile latest PythonMagick. I am able to compile older one compatible with Ubuntu 14.10 libs, but this version is not sufficient. First step was compile recent imagemagick packages itself ...
0
votes
1answer
126 views

Configure Wacom Intuos S Pen (CH480L)

Hello My problem is this: I can not configure the 4 physical buttons tablet. I searched a lot but can not find a post that speak clearly about it. I tried using "xsetwacom" but to enter "button Stylus ...
0
votes
1answer
30 views

Ubuntu configuration for dialup

I need to configure dialup on my computer because it is the only internet I have access to at school. I tried the code below but it doesn't seem to have done anything. pppconfig (pon/poff) bash: ...
0
votes
0answers
71 views

The `zlib.h` can not be found in `./configure`

I am trying to build gumstix-x11-image however i am stuck at following point NOTE: Running task 188 of 2139 (ID: 283, ...
0
votes
1answer
384 views

HDF5 and GSL library problem on Ubuntu 14.04.1 64-bit

I ran into errors in the installation of the FDTD software MEEP on Ubuntu.Although I have hdf5-tools and libhdf5 installed on my system(Ubuntu 14.04.1 64-bit), the make step of the installation of ...
0
votes
0answers
31 views

How to tell a configure script the location of a library?

In Ubuntu 14.04.1 LTS 64-bit I am installing MEEP. I already installed all the dependicies stated in the website; however although I set LDFLAGS and CPPFLAGS as indicated in the installation page the ...
0
votes
0answers
23 views

Configure server machine

I have a server machine. Number of networks and sub-networks are connected through it. I want to configure my server machine like, every client machine can install operating system through network ...
0
votes
1answer
78 views

how to fix error ./configure error configure: error

configure: error: Package requirements (libczmq > 2.0) were not met: No package 'libczmq' found Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a ...
0
votes
1answer
197 views

install conky, configure:error:required header(s) not found

I am trying to install:http://sourceforge.net/projects/conky/files/conky/ But when I do ./configure I get: configure:error:required header(s) not found. What to do?
0
votes
0answers
75 views

Where do the extensions of self compiled PHP on ubuntu 14.04 go?

I downloaded PHP 5.3.29 and configured it with the following options: ./configure' '--with-apxs2=/usr/bin/apxs2' '--enable-ftp' '--enable-mbstring' '--with-mcrypt' '--with-mysql' '--with-mysqli' ...
1
vote
1answer
67 views

How to do unattended installation for packages which ask the same question?

I need to automate apt-get installation of kde-plasma-desktop which winds up installing both kdm and lightdm Display Managers. I'm using debconf-set-selections prior to installation to set the ...
0
votes
1answer
349 views

How to install IRSTLM (automake warning during the build)?

I am trying to install MT. So this purpose, i am trying to install "irstlm-5.80.03" version on "Ubuntu 14.04," but, when I give the command ./regenerate-makefiles.sh then found following error: ...
0
votes
0answers
70 views

how change transparency amount of subtitle text in mplayer?

I want to change amount of transparency of subtitle in mplayer. Like -sub-bg-alpha option, but i want to change alpha of subtitle text. How i can do this?!
1
vote
1answer
35 views

Configuring arrow keys on media

I just installed Ubuntu and I'm extremely happy about it, I can see myself switching to Linux from Windows permanently. There's a slight problem however, when I'm watching a movie, arrow keys skip ...
0
votes
1answer
239 views

install issue opengl Mesa-10.2.6 cannot find llvm shared libraries

So I was working on this one most of yesterday. I am trying to install the mesa3d opengl libraries on ubuntu 14.04 x64. So I downloaded and installed the dependency for this install: llvm-3.4.2. So ...
0
votes
0answers
2k views

configure command not found

I was trying to compile some library. From inside the library source directory when I wrote sudo ./configure it says configure command not found but if I write sudo /bin/bash ./configure ...
0
votes
0answers
64 views

error in ./configure

I have a problem in ./configure, please help: checking for CAIRO... no configure: error: Package requirements ( cairo >= 1.2.0 librsvg-2.0 >= 2.14.0 ) were not met: No package 'cairo' found No ...
0
votes
1answer
108 views

No desktop only blank screen

I started my Laptop this morning and after login there is only a black screen. I tried to re-install the desktop, but it didn't work. When I rebooted the machine with Shift key pressed it displayed ...
3
votes
1answer
144 views

does “make” recompile all of the files or just changed ones

suppose that you have a program which you installed that from source by make command . That program include files a.cc, b.cc, c.cc, d.cc and ... . Now I changed a.cc a bit. In order to enable the ...
3
votes
2answers
1k views

What to do with “recompile with -fPIC” message

I'm trying to configure the ffmpeg source package to build .so files rather than .a files. I run make after doing ./configure --enable-shared This gives me the following message: /usr/bin/ld: ...
0
votes
1answer
35 views

Replace Black screen/kernel text compiling with image

Does anyone know of a method or program that allows you no display an image instead of the black screen/compiling text that is normally displayed while booting? Thanks
1
vote
1answer
608 views

C compiler cannot create executables

Everything was right. I have installed gdb from github and installed in /usr/local/bin. After that i removed default gdb(/usr/bin) using the following command sudo apt-get remove gdb Now, when try ...
1
vote
2answers
1k views

No speex packages for freeswitch building on Ubuntu

I am trying to build freeswitch on Ubuntu and getting numerous libraries absent. One of them is speex. configure says it is absent while dpkg says it is here: checking for speex >= 1.2rc1 speexdsp ...
2
votes
2answers
591 views

Ubuntu Juju local configure failed

When i run bootstrap in How do I configure juju for local usage? i got this error. I have done the same steps. So why that error is comming? Then i checked the permission for index.json file i changed ...
1
vote
1answer
37 views

How to understand configuration files syntax?

Now I know this is a little abstract but how does one know how do edit a config file for example /etc/systemd/logind.conf how do you know what syntax is allowed and what not?
0
votes
1answer
434 views

“pkg-config --modversion glib-2.0” reports older version

I have Ubuntu 14.04 32 bit. I am trying to compile an application from source code. It gives me an error message during linking in make process though ./autogen.sh and ./configure passed without ...
1
vote
0answers
95 views

Configure privacy settings via the command line

I am trying to compile a script to run upon booting a network attached computer (which has no hard drive and therefore is a new computer upon every reboot) to configure all settings. Because it will ...
1
vote
2answers
58 views

Howto specify library location when compiling

How do I specify the location of a library when running ./configure ? I have searched around and think the answer lies in setting LDFLAGS and CPPFLAGS, but I,m not sure how to do it. Specifically, I ...
0
votes
2answers
8k views

How to install aircrack on Ubuntu 12.04 [duplicate]

I have downloaded the tar.gz package from the site and then I have extracted using tar -zxvf command as mentioned over there. After that I used sudo apt-get install build-essential then I further ...
0
votes
2answers
748 views

Rufus compiling error

vivek@vivek-N61PB-M2S:/usr/local/src/rufus-1.4.7$ ./configure checking for a BSD-compatible install... /usr/bin/install -c checking whether build environment is sane... yes checking for a thread-safe ...
4
votes
2answers
3k views

Building ATLAS (and later Octave w/ ATLAS)

I'm trying to set up ATLAS (so I can later compile octave with ATLAS support). If I'm correct, I still need to build this manually due to the environment specific optimizations. I do see a package ...
3
votes
1answer
3k views

How to fix “PKG_PROG_PKG_CONFIG: command not found” error?

I have Ubuntu 13.10 32 bit system. Recently when I try to to compile by running ./autogen.sh and ./configure I get PKG_PROG_PKG_CONFIG: command not found error. I have libtool installed. I have ...
1
vote
2answers
545 views

Right package for JSON-GLib development headers

During configuration of one project, I got the error: checking for JSON... no no configure: error: You must have JSON-GLib >= 0.14.0 development headers installed to build. make: *** ...
2
votes
2answers
14k views

Configure Microsoft Exchange email on Ubuntu

I want to configure Microsoft Exchange emails on Ubuntu the way I use it in Outlook on Windows XP. Please help me to find a good step by step article.
2
votes
1answer
342 views

Error: “No package 'libgpod-1.0' found” when trying to install gtkpod2.1.4

I am very new to using Ubuntu but I know the basics. I've been having a series of errors while trying to compile gtkpod2.1.4. I've managed to fix most of them so far with a little googling, mostly ...