Questions related to compiling software, normally using the "make" command.

learn more… | top users | synonyms (2)

0
votes
0answers
6 views

How to compile source which needs -lopencv_contrib on Ubuntu?

I want to compile this code I installed glut via sudo apt-get install freeglut3 freeglut3-dev To install OpenCV, i run a script from this page, went to build subfolder of OpenCV and run make install ...
0
votes
4answers
6k views

Post installing comodo issues

I have installed comodo antivirus for my Ubuntu 12.04, even if I'm a newbie I managed to enter finalize the installation, you know when you have to type sudo /opt/COMODO/post_setup.sh, went through ...
2
votes
1answer
29 views

can't install swm on Ubuntu 15.04

I apologize if this has already been asked I couldn't find any solutions online, I am trying to install swm from here, but i keep getting this error when running make in terminal c99 swm.o -o swm ...
2
votes
1answer
157 views

gcc is gone probably after an update

gcc was installed in my system at the start, I still remember using it but after some time it was gone and replaced by some other versions of gcc. When I type in gcc from the terminal several ...
0
votes
0answers
28 views

vim binary with all libraries statically linked

I want to build vim with all libraries, which vim depends on, statically linked. Vim version is sufficient to run YouCompleteMe. I use the following flags with configure script: $./configure ...
0
votes
1answer
20 views

How do you install an application that doesnt have makefile in folder?

Sometimes I download applications and they don't include a makefile; just a bunch of source code and an executable application. For instance, I downloaded tor but it comes with the application and a ...
0
votes
1answer
23 views

Can't compile and install ardour and jack2

On the left is JACK and on the right is ARDOUR. To compile JACK,./configure --prefix=/usr/local/jack,but configure: error: *** a required header file is missing,I don't know what header file is ...
0
votes
0answers
130 views

Program exits when building in mingw studio in ubuntu

Is anyone here who uses mingw developer studio in ubuntu? I found this arhive: http://www.iit.upcomillas.es/libroc/mingw-devstudio_linux-2.06.tar.gz I launch the program and everything works well ...
0
votes
2answers
3k views

make command not working ERROR 2

I was trying to install Realtek_RTS5229_Linux_Driver_v1.07 which I downloaded from [here][1] When I run the make command I get the following error:- make[1]: Leaving directory ...
3
votes
2answers
6k views

How to build curl with the latest openssl?

So I build openssl ./config make sudo make install sudo ln -sf /usr/local/ssl/bin/openssl `which openssl` I build curl ./configure --with-ssl make make install OpenSSL looks installed ...
0
votes
1answer
20 views

Problems with compiling

I am pretty new to this here but i hope to learn quick. Anyways, i am trying to install a open source software but i get an error when trying to build it. it says :~$ ~/trunk/src/autogen.sh ...
0
votes
0answers
40 views

VMware workstation is not working with GCC 5.1.1

Ubuntu 15.04 GCC 5.1.1 after installing ubuntu 15.04 vmware is no longer working with gcc 5.1.1 while trying to launch vmware workstation ... pic : ...
1
vote
2answers
44 views

Compilation time slow on a single computer

We are experiencing some really slow compilation times on a single desktop computer that we use as the primary workstation for a research project. Compiling our codebase on this computer takes 42 ...
0
votes
0answers
22 views

PPA Failed Build

I am trying to upload a package to a PPA to be built. The package ucc in this repository won't build. It fails by saying: make: *** No rule to make target '../src/parser.y', needed by ...
0
votes
1answer
31 views

Can't install GNU GSL library from source

I'm trying to install the GNU GSL Scientific library 1.16 from source under Ubuntu Server 14. I've already done that several times under OS X with no problems, but I keep getting the same error on the ...
0
votes
0answers
9 views

iron-spring PL/I compiler (plic) not accepting absolute path

I am trying to run PL/I programs on ubuntu using PL/I compiler from iron-spring. I created a file a.pl1 in /tmp folder and set current folder to /tmp The command I use to compile is /usr/bin/plic ...
0
votes
0answers
17 views

error: expected unqualified-id before ‘;’ token when build c++ project?

I get an error when building a c++ project that works under Visual Studio but fails in Eclipse Some sample code to be able to simulate: #include <utility> #include ...
-2
votes
1answer
48 views

binary to install on ubuntu [closed]

would need to install this https://github.com/mdrasmus/argweaver on the system. Downloaded it - then compile with make - that works bu t then i type sudo make-nstall and that works as well. But then ...
0
votes
0answers
19 views

How do I compile and install a change made to a kernel source file?

I was to apply a patch to config.c file in the drivers/usb/core directory. Specifically, I'm trying to fix the issue detailed in this post. I'm running Ubuntu 15.04 with the 3.19 kernel, a stock ...
0
votes
0answers
12 views

Linking f95 to ifort instead of Gfortran

I have Ubuntu 14.04. I have installed intel fortran compiler. I am trying to compile a code through makefile that uses ifort. However, it points out to f95 from gfortran. lrwxrwxrwx 2 root root 17 ...
0
votes
0answers
31 views

Build unity 7 from source for ubuntu 15.04

I followed the instructions at build unity from source on Ubuntu desktop 15.04 but it didn't work when I do make install it exits with error cannot create /pam.d it requires a privileged user. If I ...
0
votes
0answers
35 views

vlc can't compile

OS: (Ubuntu 14.04 32bit) linux ubuntu 3.13.0-32 generic 2014 i686 NDK: android-ndk-r10e JDK: adt-bundle-linux-x86-20140702 32bit java-version : java version "1.7.0-79" OpenJDK runtime Environment ...
25
votes
4answers
12k views

What are the packages/libraries I should install before compiling Python from source?

Once in a while I need to install a new Ubuntu (I used it both for desktop and servers) and I always forget a couple of libraries I should have installed before compiling, meaning I have to recompile, ...
0
votes
0answers
15 views

Prefix and Path for Cross GCC in Eclipse

I'm pretty new in ubuntu and have a problem with it. I wanna to write a c++ program in eclipse and compile it with cross gcc. At the first i Added "CDT" from "help-->install new software" Now when ...
0
votes
1answer
60 views

Error running .exe compiled with i586-mingw32msvc-g++ and SFML

So well, I'm fighting with WINE and MinGW32 right now. So I have a file, sortem.cpp which is compiled with a Makefile and linked and all from that Makefile. sortem.cpp #include <windows.h> ...
2
votes
2answers
89 views

How I can create a 32-bit version of Atom?

The new Atom 1.0 text editor is now available. But only to 64-bit processors. How I can create a 32-bit version?
1
vote
1answer
20 views

Why is the python built from source is still showing the wrong version?

So I've downloaded the most recent tar from https://www.python.org/ftp/python/2.7.10/Python-2.7.10.tar.xz, untar'd, configured, built and installed to a user directory. I've also used those ...
1
vote
1answer
23 views

Installing latest FFmpeg with latest external libraries and keeping them up-to-date

I want to use latest version of ffmpeg with latest versions of external libraries. How do i do that? BTW, I just began using linux yesterday, so please be easy :) ...
1
vote
2answers
1k views

How to get .so file to show up in package?

As many of you know by now, I'm building a package :) I am so close to getting it finished so I can upload it to my PPA, but there is still one slight problem: the shared library (.so file) doesn't ...
1
vote
1answer
80 views

GNU Octave 4.0.0 - compiling from souce - error messages - your opinion?

I have been trying to install Octave 4.0.0 on Ubuntu 14.04. During the compiling there were some messages that something is missing on my computer in order to run Octave with all it's normal features. ...
1
vote
1answer
39 views

Execution of a file

How to execute a makefile? This file is contained in the sts-2.1.2 file downloadable from here: According to the NIST documentation (section 5.3), I need to edit the makefile. Modify the ...
0
votes
0answers
20 views

Compiling Avidemux not working

Im trying to install avidemux 2.6.10 following the wiki instruction from the oficial site but i dont know how to continue. For the installation i've downloaded this avidemux_2.6.10.tar.gz file ...
7
votes
4answers
6k views

How to solve dpkg-source source problem when building a package?

Has anyone here had some experience creating a Debian / Ubuntu package? I am trying to backport the lammps package (http://packages.ubuntu.com/quantal/lammps) from Ubuntu 12.10 (Quantal) to Ubuntu ...
0
votes
0answers
9 views

Double-compilation when building package with pbuilder

I am creating a package using cmake. Everything works fine, although somehow, with pbuilder (and only with pbuilder), by program gets re-configured during make install. This can happen if a file or ...
3
votes
2answers
45 views

Deleting duplicate files in installed from source?

I'm rather new to the Linux environment and have learned how to install software via using following commands $ mkdir build $ cd build $ cmake $ sudo make install. I noticed that there is a build ...
0
votes
1answer
14 views

Is it possible to configure compile option for libs installed from apt-get?

After installing wxwidgets by running sudo apt-get install libwxgtk3.0-* I wanted to compile opennx against it. However, I received a message Your wxWidgets does not provide the required ...
0
votes
2answers
299 views

Recipe for target 'vmlinux' failed?

I'm attempting to build a kernel for QEMU to emulate a raspberry pi: http://xecdesign.com/compiling-a-kernel/ https://www.raspberrypi.org/documentation/linux/kernel/building.md However, running the ...
1
vote
1answer
28 views

Use g++-4.8 with Qt

I am trying to compile a Qt project that uses the "override" keyword, and thus needs GCC 4.8. I have installed GCC 4.8 on my Ubuntu 12.04 machine already, and it lives in /usr/bin as gcc-4.8 and ...
0
votes
2answers
31 views

gcc fails to compile

I'm a newbee but adventuresome. I'm tri-booting Windows, Fedora, and Ubuntu 14.04 LTS (all 64). Learning but not using dpkg, apt, and apt-get. Starting to study C++ using Ubuntu (the only one with gcc ...
1
vote
1answer
58 views

Why am I getting this undefined reference error while trying to build a c++ project? [closed]

To fix another debug error, I added -std=c++11 to the build command. Now I'm getting a ton of "undefined reference errors like this one: In function encrypt(std::string&, int)': ...
1
vote
0answers
33 views

bug in ncurses.h? [closed]

I have been trying to compile a program I have written in C. I notice that there is an error in compiling saying: clock.c: In function ‘main’: clock.c:22:2: warning: passing argument 2 of ‘wgetnstr’ ...
1
vote
2answers
2k views

libusb program not compiling

I am trying to compile a program that uses libusb library in Ubuntu 12.04. I have installed the libusb-1.0-0-dev. However, when I try to compile a program as below: #include<usb.h> ...
0
votes
2answers
37 views

How do you “compile” something in Ubuntu?

I'm trying to use Gfx Tablet. However, I am struggling to interpret the installation instructions given by the developer. http://rfc2822.github.io/GfxTablet/#part-1-uinput-driver His instructions ...
2
votes
1answer
53 views

How to compile my first C++ program (geany)?

I'm an experienced Windows developer (Delphi, C/C++, C#, etc). I've just downloaded uBuntu 14.04 64-bit and then looked for some IDEs and saw geany got good reviews. After downloading it, I'm stumped ...
0
votes
1answer
28 views

Runing a program appears to not work [closed]

I do not know what the problem is or what happened but when I want to run a program compiled with g++ not working. I starts like this: gabi@gabi-work:~/Desktop/comp$ ./a.out and receive this: ...
0
votes
0answers
13 views

Ubuntu Scope with Framework 14.10 - Intltool

Recently, I want to create a scope project, but then I found the following error when running CMake: CMake Warning at CMakeLists.txt:26 (find_package): By not providing "FindIntltool.cmake" in ...
1
vote
1answer
177 views

The imported target “Qt5::Gui” references the file “/usr/lib/x86_64-linux-gnu/libEGL.so” but this file does not exist. [closed]

So, 15.04 x64, just installed. I installed the nvidia binary in the old way (console, switching off lightdm) because I got an error about DRI2 authentication. Then I wanted to build the nv opengl ...
0
votes
1answer
41 views

Compile error, g++ and c++11 [closed]

Im trying to compile this code via g++, #include <iostream> #include <set> using namespace std; std::set<int> s; int main(){ for(int i=0;i<10;i++) s.insert(i); for(auto ...
2
votes
1answer
740 views

how to install webp plugin for gimp?

how to install gimp webp plugin? I found out that we can do it using with gimp-plugin-registry, but donno how. I have install gimp-plugin-registry extension for gimp from ubuntu software center, now ...
7
votes
2answers
5k views

How do I set up ccache?

I want to use ccache to speed up compilation. I came across how do I enable ccache This is what I have done so far: $ sudo apt-get install -y ccache $ dpkg -l ccache ii ccache 3.1.6-1 Compiler ...