Questions related to compiling software, normally using the "make" command.

learn more… | top users | synonyms (2)

1
vote
1answer
1k views

How to install build-essential:i386 to compile a 32-bit executable on a 64-bit system?

apt-get install build-essential:i386 doesn't work at all: The following packages have unmet dependencies: build-essential:i386 : Depends: gcc:i386 (>= 4:4.4.3) but it is not going to be installed ...
0
votes
1answer
25 views

I need help compiling evince from source package on Ubuntu 14.10

After obtaining build-dependencies and source code for Evince document viewer through sudo apt-get build-dep evince apt-get source evince on ubuntu 14.10, I run configure script and got the ...
0
votes
3answers
6k views

Python: module not found after manual install

I've recently updated to the current version of Ubuntu, 13.04 and Python 2.7.4. Since then I have problems importing the gobject module and dunno what to do to fix it. I'd like to use dreampie which ...
0
votes
1answer
6 views

get objdump to display full hex of a 64 bit mov instruction

objdump won't show me the hex of a long 64 bit instruction. objdump -d myobj.o here is one of the lines: 3: 48 bb 2f 2f 62 69 6e movabs $0x68732f6e69622f2f,%rbx the instruction hex cuts off ...
0
votes
0answers
24 views

Compiler is not available to compile modules, aborting…ubuntu 14.10

First i tried intel-linux-graphic-installer., which gives me "Distribution not supported" then I downloaded a Tar file from Intel website and untar . when i run ./install.sh the following error occur ...
0
votes
1answer
13 views

error bcap library not found

During compiling of reaver-wps in Ubuntu 14.04 virtual machine on windows 7 32-bit host I received the error error : bcap library not found. I already installed sqlite3 , libsqlite3-dev , libcap-dev, ...
0
votes
3answers
2k views

Broken python (2.7) after manually building and installing python 2.6

running Ubuntu 12.04, I had the usual python 2.7 in place . I needed python 2.6 , so I downloaded the source and did ./configure make sudo make install A mistake, as I did not want to replace my ...
1
vote
0answers
23 views

sa-compile compilation error

I have a problem with the latest update for sa-compile (package 3.4.0-1ubuntu2 ) on ubuntu 14.04. When I install the package, I get the following error: .sa-compile (3.4.0-1ubuntu2) wird eingerichtet ...
0
votes
0answers
9 views

Cabal error:Cannot run c compiled programs [closed]

I have an old version of cabal-install so I downloaded cabal-install 1.20 and When installing it errors out. Additional note: ghc 7.8.3 OS: CentOs 6.6 Error: Building network-2.4.2.3... ....... ...
0
votes
1answer
17 views

Build Emacs: cannot find -lpng15

I'm trying to build Emacs 24.4 and this error occured: /usr/bin/ld: cannot find -lpng15 collect2: error: ld returned 1 exit status make[1]: *** [temacs] Error 1 make[1]: Leaving directory ...
0
votes
0answers
22 views

No Wireless drive detection in new built kernel for reverse bisecting

I need to do a reverse bisect for a bug and I narrowed the versions down to two. Now, I need to build a 8 new kernels. However, when I built them, the kernel cannot detect my wifi drive so that I can ...
1
vote
0answers
490 views

Compile or install Octave 3.6 in Ubuntu 12.04 with ATLAS

I want to install or compile from source octave 3.6.4 in Ubuntu 12.04 (64 bit) that uses the ATLAS library (to make it fast when executing vectorized code). Did anybody ever do that? Can somebody put ...
0
votes
0answers
44 views

Ubuntu 14.04 Error when compile PHP 5.6.3

I did everything right with the installation of all dependencies for Apache2 and PHP i think. First I installed a clean Ubuntu 14.04 with all actual updates. Then I installed with "apt-get build-dep ...
0
votes
1answer
42 views

Compiling error

Hi I need to run some tests with a CP ABE toolkit I've found, I'm a total newbie of Linux, I've started using for a few days, so please bear with me. I've found this video tutorial that was quite ...
1
vote
1answer
18 views

What is the best practice to manual build software on Ubuntu?

apt is great, this is also why many people choose Debian-based systems; however, there're some times that we need to build some software manually. (For example, for a newer version). I create a ...
2
votes
0answers
43 views

compile and install calligra-2.8.6 from source

How do I compile and install calligra-2.8.6 from source? I couldn't find any text file or readme in the source folder that would show how to install it. This is not a duplicate of How do I install ...
0
votes
1answer
34 views

How to overcome this error while compiling RT2870 driver?

I bought a rather cheap wifi antenna and now have to install RT2870 driver on Ubuntu 14.04 64 bit. I downloaded driver file 2010_0709_RT2870_Linux_STA_v2.4.0.1 from its official web page and tried ...
0
votes
0answers
28 views

Caffe: /usr/bin/ld: Syntax error: “(” unexpected collect2: error: ld returned 2 exit status

I downloaded Caffe Lib for Deep Learning. I followed the instruction mentioned in its website. I used GPU-ONLY := 1 flag to use GPU computing. I've installed the NVIDIA tool kit with required ...
0
votes
0answers
22 views

How to fix errors while installing gemrb?

I am just coming in Ubuntu and trying to use gemrb. However, something comes up to me as installing it. It looks like i didn't install SDL properly, but i don't know how to fix it. The below is the ...
1
vote
1answer
341 views

Building Awesome WM

I am following these steps in order to build Awesome window manager on 10.04 I am building 3.4 while the tutorial is for 3.1 I installed all of the specified dependencies including cairo. After ...
1
vote
1answer
50 views

Problem with installing and compiling PHP 5.4.0

I have a VPS server on OVH Cloud, Ubuntu 14.04.1 LTS with plesk 12 installed. The server has been set up with the newest version of PHP , but Plesk can manage two different version of PHP in the ...
1
vote
1answer
18 views

How to pause a process until memory requirements drop

I'm compiling source code in the terminal but 75% of the time the build will freeze my system and I have to hard reboot or wait for a LONG time until oom kills it. I'm positive it's a memory issue ...
50
votes
6answers
53k views

How do I install the latest version of node.js?

How do I install node.js in Ubuntu? I've been looking around, and I can't find anything. Is there a Ubuntu package for node.js, or do I have to compile it myself?
3
votes
1answer
6k views

“error adding symbols: DSO missing from command line” while compiling g13-driver

I'm trying to compile the download received here: https://code.google.com/p/linux-g13-driver/ by running make but I'm receiving errors that to me, after searching on the web, look like they're the ...
0
votes
0answers
8 views

DSO missing form command line [duplicate]

I'm trying to compile a file and I get this error /usr/local/lib/libgmp.so: error adding symbols: DSO missing from command line I have properly installed the libgmp, infact as I run the make ...
0
votes
1answer
18 views

compile workrave from source

How do I install workrave from source? I cloned the source from github: git clone https://github.com/rcaelers/workrave.git cd workrave there is an INSTALL file which sais, I should use ...
3
votes
2answers
1k views

Bochs Compiling Error AGAIN

I'm trying to compile bochs with this command: ./configure --with-x11 --with-wx --enable-ne2000 --enable-iodebug --enable-disasm --enable-debugger --enable-e1000 --enable-usb --enable-pci it works, ...
0
votes
2answers
69 views

How to resolve the “/lib/modules/3.13.0-27-generic/build: No such file or directory” error message?

I'm following the instructions on this page so I can submit enough information about my machine to this bug report module. I'm stuck in running some of the following commands git clone ...
0
votes
1answer
727 views

Vim cannot find syntax.vim

Recently, I needed to build Vim from source to use a plugin that required Lua interpreting. This worked fine on my laptop, but my tower computer is having some issues. Any time I run Vim, I recieve ...
0
votes
0answers
43 views

Can't compile C++ in Code::Blocks

I have some trouble with compiling c++ code from **Code::Blocks* IDE on Ubuntu. When I save the code as a .cpp data and click on Run under Build it says: "Target uses an invalid compiler; run ...
0
votes
3answers
10k views

Can't run make - gcc: command not found

I'm trying to follow a tutorial to get CudaMiner working on Linux. I have PAINSTAKINGLY installed NVidia drivers, Cuda 5.0 and incidentally I'm failing on the last step when I run make: make ...
0
votes
2answers
40 views

grep to get compile error

I have created a simple c program and have left off a ';' on purpose to get an error. I want using the grep command to know whether the compilation was successful or not. I use: gcc test.c | grep ...
-1
votes
0answers
24 views

Converting ifort maakefile to gfortran makefile

I am trying to compile a program which was written for the ifort compiler but i have a gfortran/gcc compiler. Part of the makefile reads FC = ifort FLAGS= -c -w -r8 -O3 On replacing ifort ...
0
votes
0answers
23 views

Building and hosting Ubuntu packages using C++11

The full question would be: Is Ubuntu ready to host C++ applications packages, compiled with C++11, and which use a large set of dependencies? Let's say that we have an official Ubuntu package (C++ ...
0
votes
0answers
29 views

Cannot compile MEEP 1.2.1 and libctl-3.2.2 from source on Ubuntu 14.04.1 Lts 64-bit

In order to install MEEP 1.2.1 I first installed Guile 2.0 packages via the command line with the following commands: sudo apt-get install guile-2.0 guile-2.0-dev guile-2.0-doc guile-2.0-libs Then ...
3
votes
2answers
164 views

How do I prevent apt-get from upgrading packages built from source with apt pinning? [duplicate]

I have a package installed (xcp-xapi) which is prone to a bug. The fix is very simple (only a couple of lines in the code) so what I do is the following: apt-get source xcp-xapi Then I find the ...
0
votes
2answers
801 views

How to build the Darling project on Ubuntu?

The Darling project is an open source Darwin/OS X emulation layer for Linux. I downloaded the source code with git and tried to build it with cmake but it failed. The document says I need these ...
1
vote
2answers
1k views

Cannot find -lgfortran

I'm trying to install a package in R (package "ks"). It fails with error message: /usr/bin/ld: cannot find -lgfortran I've already installed the Ubuntu package build-essential: sudo apt-get ...
4
votes
1answer
1k views

Maya Calendar from Elementary OS on Ubuntu

The Maya Calendar from Elementary OS seems really nice: Has anyone been able to run it on Ubuntu ? Is it available on some repository ? After installing the dependencies, I only get a ton of error ...
0
votes
0answers
11 views

Missing Shared Library - Common Problem

I am trying to execute an example Hello World program from http://www.vlfeat.org/gcc.html. I am able to successfully compile the program but when I am running the program I am getting the following ...
0
votes
2answers
4k views

Help locating linux/version.h

I'm trying to fix an old program, Previous issues I had could be found at Missing modversions.h When I make the program it gives me the following error, kaodv-mod.c:22:27: fatal error: ...
4
votes
3answers
1k views

Compiling midnight commander

I need help with compiling midnight commander so that I can make some changes (for educational purposes). Or even creating the make files. After downloading latest version from git. I try to perform ...
0
votes
1answer
65 views

“No such file or directory” when trying to build ecolab

Im trying to build ecolab.5.D19 but I get error message "No such file or directory" even if the directories and files exists, and im in the same folder as MAKEFILE. I use the following command, which ...
1
vote
0answers
71 views

Errors when trying to compile Android

Here's my error, any help would be greatly appreciated: libcore/luni/src/main/native/Register.cpp:36: error: undefined reference to 'register_android_system_OsConstants(_JNIEnv*)' clang: error: ...
-1
votes
1answer
85 views

Can't configure gr-ais

http://www.reddit.com/r/RTLSDR/comments/1mcikt/for_the_nautical_set_rtlsdr_with_grais_and_opencpn/ following the above, I get this error scott@scott-P5QC:~/gr-ais/build$ cmake ../ -- Build type not ...
0
votes
1answer
28 views

error when compiling lgogdownloader

My system is Ubuntu 12.04 ,I compiled and installed gcc 4.8.2 myself . The homepage of lgogdownloader is :https://sites.google.com/site/gogdownloader/ When I tried to follow the official instructions ...
0
votes
4answers
164 views

I cant install Sleepyhead under Ubuntu

I am trying to install Sleepyhead following the tutorial http://ubuntuforums.org/showthread.php?p=11756055#post11756055 but I cant compile the src code` horacio@horacio-ThinkPad-X201:~/sleepyhead$ ...
0
votes
3answers
3k views

Post installing comodo issues

I have installed comodo antivirus for my Ubuntu 12.04, even if I'm a newbie I managed to enter finalize the installation, you know when you have to type sudo /opt/COMODO/post_setup.sh, went through ...
1
vote
1answer
19 views

Custom compile sqlite as php so

In Compile sqlite with soundex feature I learned how to do a custom compile of sqlite. While this was a step towards my goal of using sqlite's soundex in a functional test, I find I'm not there yet. ...
4
votes
3answers
6k views

How to fix compilation errors that mention “stray ‘\342’” and “stray ‘\200’”?

I wrote this program: #include<stdio.h> int main() { printf(“Hello World\n”); return 0; } I saved it as first.c and tried to compile but receiving this problem I have installed even gcc ...