Questions related to compiling software, normally using the "make" command.

learn more… | top users | synonyms (2)

1
vote
0answers
141 views

use NUT 2.7.1 in Ubuntu server 12.04 [closed]

I have questions in regards to using a different version of NUT than what is available through apt-get for Ubuntu server 12.04. The version of NUT that is available in Ubuntu server 12.04 is 2.6.3. ...
0
votes
0answers
424 views

g++ 4.8.2 on ubuntu 14.04 fails to compile source files

I'm really frustrated at present in that g++ is throwing up so many errors even on a simple .cpp file. I'm typing: g++ test.cpp at the command line. Thanks in advance for any help. I downloaded g++ ...
1
vote
0answers
138 views

RTL8723AE PCIe driver problem

I have looked at this question but I get this error while compiling and am unable to load the module afterwards: make -C /lib/modules/3.13.0-24-generic/build ...
0
votes
1answer
150 views

Compiling the mysql_fdw for postgresql?

I'm attempting to compile the MySQL Foreign Data Wrapper for Postgresql 9.1+, on Ubuntu 12.04 LTS and having a fair bit of trouble getting it to work. So far I've managed to use git to download the ...
1
vote
1answer
159 views

Is it possible to produce an ISO image of my current installed Ubuntu OS?

I am running Ubuntu 12.04 TLS. Is there a way to produce an ISO installable image of my current system so as I could burn the image on a CD and be able to install it on an other laptop ? I tried ...
0
votes
1answer
398 views

Compile evolution development snapshot 3.13.1

I have downloaded evolution development snapshot from this link: https://wiki.gnome.org/Apps/Evolution and now I have trouble compiling the source code. I am using ubuntu 14.04 and this version of ...
0
votes
1answer
5k views

ubuntu /usr/bin/ld: cannot find -lgcc_s

I am compiling a fortran program by using g77 on Ubuntu 14.04, I got the following error: ubuntu /usr/bin/ld: cannot find -lgcc_s Didn't you ever have experience with such problem?
1
vote
1answer
601 views

How do I install a specific version of java on Ubuntu

I am trying to build Android from source and it require Java 1.6 to build. So, I installed OpenJDK version 6. However, when I try to build using the make command I get the following message: Your ...
0
votes
1answer
103 views

gem install eventmachine fails, using rvm

Ubuntu 13.10 64bit, ruby 2.1.1 rvm 1.25.24 gem 2.2.2 from log file: compiling pipe.cpp ...
2
votes
0answers
142 views

Compiling error checkinstall

Hi I wanna compile my first package (Wine) under Ubuntu (it's also my first day with this OS). I ran ./configure and make, no errors. But when I did checkinstall then I got this back: ...
0
votes
0answers
91 views

globus toolkit installation

I'm trying to install globus toolkit on Ubuntu 14.04. When I ran make command I got problem that I mentioned below: globus@JMD:~/gt5.0.2-all-source-installer$ sudo make | tee installer [sudo] ...
0
votes
1answer
144 views

Which is exact method to install from source?

I have run (gradually) following command to install gdebi from source: apt-get build-dep gdebi apt-get source gdebi cd gdebi-0.9.5.3 dpkg-buildpackage -uc -us -b Which gives me error (posted last ...
1
vote
0answers
23 views

How to point to Boost built from source

I like to keep my Boost installations full and up to date to the latest release. I just noticed that I sloppily approved libboost-dev-all, and some of my programs that I develop are not able to ...
0
votes
0answers
170 views

/usr/bin/ld: error: cannot find -lpython2.7

While installing pyscard.py I get this error, gcc -pthread -shared -Wl,-rpath,$ORIGIN/../lib -g -L/home/builder/jenkins/workspace/Python_Masters/ARCH/x86_64/label/Linux/core/lib ...
1
vote
1answer
486 views

Compiling Intel-phc says I don't have headers

Trying to follow an online tutorial "Intel-phc with latest kernel on Ubuntu". My ubuntu kernel version is 3.2.0-38-generic (Ubuntu 14.04). Following the instructions I downloaded kernel 3.14.2 from ...
0
votes
0answers
38 views

problem in compiling xv6 mit's project

Currently, I am working on XV6 but there is a problem when I build it withmake qemu then it gives me following error: i386-elf-gcc -fno-pic -static -fno-builtin -fno-strict-aliasing -Wall -MD -ggdb ...
1
vote
0answers
18 views

Could not find Urbi when compiling

I have installed urbi-suite-1.22.1-linux32 and to compile the system I try both of the following commands: ./build.sh and cd __build cmake -DCMAKE_INSTALL_PREFIX=$(pwd)/install But I get ...
0
votes
0answers
26 views

Workoflow for regularly updating custom compiled kernels

Suppose you want a kernel with additional features such as the grsecurity patches which are not included in the ubuntu standard kernel images. Doing this once is not a big deal but when you update it, ...
2
votes
0answers
234 views

bfd.h should include libiberty/ansidecl.h in Ubuntu 14.04?

binutils package seems to be changed, as include directory of libiberty.h has moved to /usr/include/libiberty, thus there is possible a wrong include in bfd.h regarding ansidecl.h. Getting those ...
1
vote
1answer
3k views

Error 255 when trying to install openssl-1.0.1g from source

installing man1/cms.1 cms.pod around line 457: Expected text after =item, not a number cms.pod around line 461: Expected text after =item, not a number cms.pod around line 465: Expected text after ...
2
votes
1answer
125 views

Compile error when trying to run make

I have the following error when trying to run make command, /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/4.7/../../../libcppunit.a when searching for -lcppunit /usr/bin/ld: ...
0
votes
1answer
79 views

Adding extract tool to nautilus (compiled from source code)

How can add and Extract Zip File tool to nautilus? I installed nautilus from the standard source code in repository. Now: ? I remember there was a extract here selection in this menu before ...
0
votes
1answer
83 views

./configure error xft.pc is missing

i try to install something and did as asked in the readme ./configure but it gives me the following error: checking for xft... Package xft was not found in the pkg-config search path. Perhaps you ...
0
votes
1answer
33 views

`build-dep` download location?

I downloaded build dependency of nautilus with sudo apt-get build-dep nautilus now; where can I find its .h and .cpp files?
2
votes
2answers
161 views

ffmpeg: installing from repository or compiling from source?

When googling for "install ffmpeg ubuntu" the first link I've got was https://trac.ffmpeg.org/wiki/UbuntuCompilationGuide, so I followed it, and unfortunutely got some errors during ffmpeg ...
0
votes
0answers
72 views

Using .apk files on ubuntu

I wanted to know if .apk files xan be reverse compiled to get source code and then be recompiled for x86 platform to make it work on an ubuntu or windows system? Related Question: Can I run Android ...
1
vote
1answer
87 views

Error in connecting CMake to FreeBASIC compiler. CMake Error: The source directory does not appear to contain CMakeLists.txt

I was in the middle of installing Allegro to help me compile C++ games and animations. I needed to install a Make program to get the ball rolling. I installed CMake and tried to connect it to my ...
1
vote
1answer
40 views

Missing libriaries for a GUI .bas test and how does one get them? ld: cannot find -lX11, -lXext, -lXpm, -lXrandr, -lXrender

I was testing out FreeBASIC compilier for its ability to make interactive software (in this case, a simple game called Asteroids.) The .bas code for it is right below: ' ÜÛÛÛÛÜ ...
1
vote
1answer
92 views

Error when compiling a .bas file using FreeBASIC: Expected End-of-Line, found '['

I tried making a simple code to get into .bas based coding. I was using FreeBASIC code compiler to create my codes. I tried making a simple code that will bring out any text into the terminal. ...
0
votes
0answers
291 views

I already have the newest version of g++ but I still get a 127 error what do I do?

I have done the following. I just don't know what to try next. I supposedly have the newest version of gcc by following these directions sudo add-apt-repository ppa:ubuntu-toolchain-r/test sudo ...
0
votes
2answers
802 views

How do you fix a gcc compile 127 error? sudo apt-get install g++ doesn't work

*emphasized text*when I try to run a program I get the following error. ubuntu@ubuntu-VirtualBox:~/Desktop$ make g++ -Wall -Wno-switch -I. -g -c -o pass.o pass.cpp make: g++: Command not found ...
0
votes
0answers
19 views

Recompiling the kernel after modifying the “irq.c” Module

I modified the irq.c file in the kernel by including several printk() statements to trace some values that I wanted to recovered. Logically, after modifying the irq.c file I attempted to recompile the ...
0
votes
0answers
46 views

Trying to compile 'mips64' program with gcc 3.3 but it has an error when building binutils and gcc

I tried building binutils and gcc3.3 for mips64 and everything goes well until: make CC=$GCC make install [For make an error saying, that: gmp.h and confdefs.h are not found] [For make install: ...
3
votes
2answers
74 views

Is there a plugin for the terminal which allow to detect and open files?

I'm looking for a terminal plugin/extension that would allow me to detect files path in terminal output and open them in a text editor by clicking on them. The perfect solution would open the file at ...
0
votes
1answer
27 views

Can i recompile kernel in dualboot environment?

I need to fix a value hid-ids.h and compile kernel so that my device will work. But i'm on dualboot with windows 8. If this goes wrong can it damage grub or will this just affect my ubuntu ...
0
votes
0answers
215 views

Buliding and running NS-3 based program and doing all that trough Geany

everyone! Now, I wanted to set up my Geany so I can build, compile and execute any NS-3 based program instead of always using console way and compiling there the program and executing again in the ...
-3
votes
1answer
104 views

Trying to Compile Latest OpenSSL from Source Fails With Errors [closed]

I'm running Ubuntu x86_64, and want to upgrade to OpenSSL 1.0.1.f. wget <openssl latest> tar -xzvf openssl.tar.gz cd <openssl dir> ./configure --prefix=/usr make In the console output, ...
0
votes
1answer
93 views

collect2 error while compiling fortran code

I have installed necdf-4 successfully. I am getting collect2: error: ld returned 1 exit status error when I compile a fortran code that writes netcdf files. I use gfortran compiler. I am sure the ...
0
votes
1answer
607 views

Vim cannot find syntax.vim

Recently, I needed to build Vim from source to use a plugin that required Lua interpreting. This worked fine on my laptop, but my tower computer is having some issues. Any time I run Vim, I recieve ...
1
vote
0answers
44 views

Wubi-installed ubuntu won't allow me to execute executable files

I'm trying to run executable files on Ubuntu, but it's not working, although the exact same executable file works fine on others' machines, which are also running Ubuntu 12.04 like me. Based on this, ...
1
vote
0answers
573 views

How to install Enlightenment 19 on Lubuntu 14.04 [closed]

all guides are for old version of ubuntu and enlightenment. Im compiling from source but the EFL package says configure: error: Software Xlib dependencies not found Ive been able to install many ...
0
votes
1answer
216 views

Realtek RTL8188CUs

I am trying to use an airlink wifi dongle with RTL8188CUs chip. It has not been going very well. I found a link to a driver installer Download rtl8192cu-tjp-dkms_1.6_all.deb 1.0 MB When I run ...
0
votes
1answer
44 views

Why isn't launchpad building my package?

I attempted to upload files to launchpad for building, using dput ppa:sparhawkthesecond/ahm xserver-xorg-input-evdev_2.8.2-1ubuntu2ahm0ly1_source.changes It completed fine, and I was told that it ...
2
votes
1answer
914 views

Problem loading LaTeX KOMA-script and fontspec after freshly installing vanilla texlive

I have just installed vanilla TeXlive according to the TUG instructions on my Ubuntu 13.10. A standard minimal example properly compiles the way it is supposed to do: ...
0
votes
0answers
102 views

Use gcc-4.6-arm-linux-gnueabihf to compile .c file, What is the command?

I am doing cross compiling. I install the gcc-4.6-arm-linux-gnueabihf and want to use it to compile the .c file(example of hello world) and then run it on ARM. I don't know what is the exact command. ...
1
vote
1answer
37 views

I want to change some of the linux files, how to recompile the linux and reinstall it [duplicate]

I want to make changes to the kernel files /linux/net/ipv4/ip_output.c in my case. I want to add a script to be run that changes the payload of the data whenever a packet passes through the ...
0
votes
1answer
571 views

Upgrade vim/gvim on Ubuntu 12.04

Ubuntu 12.04 has vim 7.3.429, which has an issue with match() function, because of it I need to upgrade vim and gvim. I need for vim >= 7.3.829 && <= 7.3.1268, or >= 7.4.018 (because of ...
0
votes
0answers
9 views

KCModuleInfo and KCMultiDialog undefined references

I'm trying to finish an abandoned KDE3-to-KDE4 port of a program and I'm running into these errors: undefined reference to `KCModuleInfo::KCModuleInfo(QString const&)' undefined reference to ...
2
votes
1answer
792 views

“No executable specified.” Ubuntu SDK Unity8

Was working last night, but today when I started up again, I could not run unity8 out of QtCreator/UbuntuSDK. After building and running, it just states: "No executable specified." FYI; This is a ...
0
votes
1answer
330 views

'make' compiling error in ubuntu

I installed ubuntu 14.04 by debootstrap with those packages required for configuring or building a specific package. Everything went well but one thing, it could not build or compile (or configure) ...