Questions related to compiling software, normally using the "make" command.

learn more… | top users | synonyms (2)

1
vote
1answer
8k views

Terminal commands for installing g++ 4.8?

Could somebody please advise how I could install g++ 4.8 ? I understand its not an official release yet (and that I would need to manually download a file) but I get internal compiler bug issues with ...
1
vote
1answer
7k views

cannot install lxml in virtualenv (python)

I cannot install lxml. In system i have python-lxml package, but i need other... Please help, if you can - my task is install lxml for development in virtual enviroment using virtualenv. I found this ...
1
vote
0answers
1k views

How to build a newer version of a package than is available for my stable release?

I want to use a newer package version with my stable Ubuntu release. Asking for backport takes too long without visible result, so I thought that maybe I can build newer version myself. Can anybody ...
1
vote
1answer
272 views

Compile Linux Source in /home

I went through many Linux kernel compilation tutorials ... All of them suggest to put the kernel code in /usr/src . Is it for any special reason ? What happen if i compile code in /home ? Because my /...
1
vote
1answer
3k views

How do I install Rigs of Rods?

How do I install Rigs of Rods (open source vehicle simulator based on soft-body physics)? I have compiled applications before like Gedit, Handbrake, XBMC but I can't seem to install/compile Rigs of ...
0
votes
1answer
2k views

getting build dependencies and source by default

Is there an application by which the build dependency as well as the source code of the software gets downloaded automatically as soon as we install the software from a .deb package or the software ...
0
votes
1answer
83 views

determining what files a package updates / copying software between machines

How do I determine which files comprise an application (built from source, not from a repo), so I can copy it? I built an application from source, but because the libraries it needed to build were ...
5
votes
3answers
3k views

Building Awesome WM, missing dependencies

Trying to compile Awesome Window Manager on 11.04, I've done apt-get build-dep awesome but still get errors about missing dependencies: $ make Running cmake… -- cat -> /bin/cat -- ln -> /bin/ln -- ...
5
votes
2answers
4k views

How I can create a 32-bit version of Atom?

The new Atom 1.0 text editor is now available. But only to 64-bit processors. How I can create a 32-bit version?
5
votes
1answer
360 views

PPA hosting packages not built on launchpad build farm

Is it possible to build the deb packages in house and then upload the binaries to launchpad PPA, instead of uploading the source package and let it build by the build farm ?
4
votes
1answer
285 views

How to build a 32-bit deb file on a 64-bit machine?

I have followed this answer to get the build dependencies for what I am building, and then actually compile the source and build it into a deb file, however I am needing to create a deb file for 32-...
4
votes
0answers
217 views

Rebuild davfs2 with libneon27 instead of libneon27-gnutls [closed]

I can't connect to my office's sharepoint webdav with davfs2. According to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=668968, it's a bug with the libneon27-gnutls instead of libneon27. How can ...
4
votes
1answer
27k views

Missing linux/autoconf.h [closed]

I 'm trying to compile a package in Ubuntu but getting error "linux/autoconf.h: No such file or directory" Now I see that the missing file is under /usr/src/linux-headers-2.6.38-11-generic/include/...
4
votes
4answers
835 views

How to compile bcmwl-ubuntu?

Running on kernel < 4.0 I used the precompiled bcmwl-kernel-source from the repository without any problems. Now I updated my Ubuntu 14.04.2 LTS to kernel 4.0.0-040000-generic where the package isn'...
4
votes
1answer
7k views

Why can't I use conio.h or ncurses.h?

I am new user to Ubuntu. I wrote a simple program in C. When I try to compile it to use conio.h, the compiler gives me fatal error. So I tried by ncurses.h, but still I am getting same error.
3
votes
1answer
433 views

How to build ubuntuone-client so that it doesn't depend on nautilus and gnome

Basically I want to build ubuntuone-client so that it doesn't have nautilus and gnome related dependencies. Can this be done? if so how?
3
votes
1answer
12k views

Error : Cannot run C compiled programs. if you meant to cross compile use --host' Ubuntu

I'm completely new to Ubuntu I downloaded and unpacked a tar.gz package, after extraction, it is said in its documentation : "type ./configure --disable-gts" But when I run this command alone it ...
2
votes
1answer
283 views

How to compile a program from launchpad

I tried looking through the documentation but I couldn't figure it out. make and ./configure don't work so I thought I would ask here. I'm trying to install this ( https://launchpad.net/...
2
votes
1answer
9k views

/bin/bash: g++: command not found error 127

I was trying to install a software quicknet from a tar.gz file. After using ./configure when i tried using make it showed the following erroe g++ -I. -I. -c QN_args.cc /bin/bash: g++: command not ...
2
votes
2answers
3k views

I think “/lib/modules/$(uname -r)/build” points to incorrect folder

I compile/create my own deb packages of kernel with: make-kpkg --rootcmd fakeroot --initrd --append-to-version=$version --revision=1 kernel_image kernel_headers But when I install both packages, in ...
2
votes
3answers
12k views

How to install needed Qt packages to build kernel on 14.04?

I'm going to compile kernel on Ubuntu 14.04 64-bit, so I start with installing packages that I need: sudo apt-get install build-essential bin86 kernel-package libqt3-headers libqt3-mt-dev wget ...
2
votes
1answer
1k views

How can I compile Shotwell to be able to use the faces feature?

It seems shotwell has the capability, you just have to compile it. I tried to configure with --define=ENABLE_FACES but the feature isn't showing up. I used playya git which included a recent fix for a ...
2
votes
1answer
184 views

OEM Install of Ubuntu Server [14.04.3]

I am trying to do an OEM install of Ubuntu Server (14.04.3) but cannot seem to get it working. I have managed to do a Ubuntu Desktop (14.04.3) easily. Why? I am trying to this to: Install all ...
2
votes
2answers
3k views

Linking error when trying to compile on a shared drive

I am trying to compile OpenCV library on a shared drive on my system. I was able to configure and generate makefiles successfully by using these settings, but when i try to compile I get the following ...
2
votes
1answer
535 views

Building Awesome WM

I am following these steps in order to build Awesome window manager on 10.04 I am building 3.4 while the tutorial is for 3.1 I installed all of the specified dependencies including cairo. After ...
2
votes
1answer
4k views

How do I compile a kernel module?

A good man on NetworkManager mailinglist provided a patch that hopefully would solve an issue I'm experiencing related to slow mobile broadband detection on Ubuntu 11.04 64-bit. I'd really like to ...
2
votes
2answers
6k views

Compile 32 bit on 64 bitsystem

I'm trying to compile a 32 bit version of python on a 64 bit ubuntu system with the following configure command: CC="gcc -m32" LDFLAGS="-L/lib32 -L/usr/lib32 \ -Lpwd/lib32 -Wl,-rpath,/lib32 \ -Wl,...
1
vote
1answer
219 views

How to compile and install this? [duplicate]

https://github.com/thestinger/vte-ng I see a CONFIGURE, autogen.sh and a makefile but I can't seem to figure out how to install this. Can someone help explain what I need to do to install this?
1
vote
1answer
734 views

Package was not found in the pkg-config search path

I am trying to install WaoN. When I run sudo make -f Makefile.waon it gives me the following errors: gcc -Wall -march=pentium -O3 -ffast-math `pkg-config --cflags fftw3` `pkg-config --cflags sndfile` ...
1
vote
0answers
177 views

Build ubuntu-kernel-test mainline-crack v4.4 kernel fails to clean

fakeroot debian/rules clean step fails due to a missing ubuntu/ directory when building the Ubuntu kernel team's upstream branch of Linus' v4.4-rc8 . Is there another patch besides the three at http:...
1
vote
2answers
3k views

Recipe for target 'vmlinux' failed?

I'm attempting to build a kernel for QEMU to emulate a raspberry pi: http://xecdesign.com/compiling-a-kernel/ https://www.raspberrypi.org/documentation/linux/kernel/building.md However, running the ...
1
vote
1answer
752 views

Replace prebuilt package with self-compiled version

I need to update my Point Cloud Library (PCL) that I installed via official instructions with my own version that I just compiled according to this manual. The reason is I need to fix a bug in PCL ...
1
vote
1answer
49 views

Mounting Flash Drive to Compile C++ Programs

I am very new to Linux, and thus have very noob questions. I currently have Ubuntu 14.04 LTS installed on my hard disk. However, my biggest issue is with flash drives. I have all of my .cpp files on ...
1
vote
1answer
242 views

How to install build dependencies for source not available in Ubuntu repositories?

I keep myself busy compiling (makeing) several packages and some of them are not in the repositories (so apt-get build-dep doesn't help), the complete documentation about build dependencies is missing ...
1
vote
1answer
3k views

/usr/bin/ld: cannot find -lpulse

Can you help me to fix this issue. I try to compile Qt application but I always get this error: /usr/bin/ld: cannot find -lpulse I know I have to install some libs I just don't know which one.
1
vote
1answer
486 views

When will the sdl 1.3 libraries be available (implementing force feedback), or how do I compile them?

I want to use sdl force feedback for my joystick and use it on dolphin-emu. I need the 1.3 sdl libraries and only 1.2 are available. I tried to build them, but with no luck. Can anyone help?
1
vote
1answer
687 views

What is changelog.Debian.gz file during packaging?

while packaging I encountered following error dh_builddeb dpkg-deb: building package `remotedevicecontroller' in `../remotedevicecontroller_1.0-1_i386.deb'. dpkg-source -b remotedevicecontroller-1.0 ...
1
vote
1answer
4k views

Makefile:448: *** missing separator. Stop. error

The tutorial I am following is the automake hello world. I am compiling a code using GTK+2 and C language hp@ubuntu:~/amhello$ autoreconf --install configure.ac:2: installing `./install-sh' configure....
1
vote
1answer
1k views

Compilation of Realtek RTS5229 driver fails

I'm currently trying to compile the driver for the SD card reader, a Realtek RTS5229, of my new laptop computer. However, when running make, I'm presented with the following errors: $ make # ...
1
vote
1answer
4k views

How to compile and install ia32-libs in Ubuntu 14.04? [duplicate]

How can I compile and install the package ia32-libs in Ubuntu 14.04?
1
vote
1answer
620 views

Driver installation: compiling source code for newer kernel

I am trying to install a driver for this DAQ card, but when I execute (as in given documentation): insmod /usr/.../advdrv_core.ko i get this error: invalid module format As I found out, this is ...
0
votes
1answer
2k views

How to add a custom driver to my kernel?

I want to add a custom driver to my kernel source. But I have no idea how to do this. Any help will be appreciated. Thanks.
0
votes
2answers
55 views

Command on ubuntu

I'm using gnuradio , i'd tried to build a new block with c++ , after i finished my cpp file i wrote commands to build and install this block to work properly, mkdir build cd build cmake .. till ...
0
votes
1answer
1k views

Upgrade vim/gvim on Ubuntu 12.04

Ubuntu 12.04 has vim 7.3.429, which has an issue with match() function, because of it I need to upgrade vim and gvim. I need for vim >= 7.3.829 && <= 7.3.1268, or >= 7.4.018 (because of ...
0
votes
1answer
1k views

msp430/bin/ld: cannot find -lc

I installed successfully msp430-gcc 4.7.0 compiler. The compiler at the final stage of the linking process it shows me the following error for Ubuntu 12.04. msp430-gcc -mmcu=msp430f1611 -Wl,-Map=...
0
votes
1answer
299 views

version `GLIBCXX_3.4.20' not found

When I am trying to execute my hdl file with iverilog, I am getting the following error : "/usr/local/lib/ivl/ivl: /opt/Xilinx/Vivado/2015.3/lib/lnx64.o/libstdc++.so.6: version `GLIBCXX_3.4.20' not ...
0
votes
0answers
315 views

Error compiling kernel in iw_ndis.c [duplicate]

Possible Duplicate: Kernel compile error with iw_ndis.c I just wanted to compile a kernel (as described here), but I got this error: ubuntu/ndiswrapper/iw_ndis.c:1966: error: unknown field ‘...
0
votes
1answer
1k views

Header files missing

I'm trying to compile a source code and I'm getting many errors indicating that header files are missing from my system checking sys/ioccom.h usability... no checking sys/ioccom.h presence... no ...
0
votes
3answers
7k views

How to compile Asus-syntec-webcam-driver stk11xx

i have asus v1s and some time ago i was able to easily compile and install it. but now compiling fails... i hope u guys know what i can do, if there is anything that can be done... after svn ...
0
votes
1answer
5k views

Trying to compile from source newest apache with newest openssl

I need to install apache 2.4.10 using openssl 1.0.1i. I compiled openssl from source with: $ ./config \ --prefix=/opt/openssl-1.0.1i \ --openssldir=/opt/openssl-1.0.1i $ make $ sudo make ...