Questions related to compiling software, normally using the "make" command.

learn more… | top users | synonyms (2)

2
votes
2answers
47k views

Help do I install the Ralink RT3070 wireless driver?

I bought an AZTECH WL562USB wireless adapter and am stuck trying to install the driver. The driver file I downloaded is a BZ2, called ...
4
votes
1answer
496 views

Recompile all packages and trigger on updates

I am using Ubuntu on a bespoke router and after seeing the latency drops capable with custom compiling on Gentoo, I would like to recompile all packages with CFLAGS="-march=atom". The guide for this ...
3
votes
2answers
1k views

How to use -exec option in find command

I wanna solve some problems in compiz with my brain and hands. By the way I entered following command to build compiz from source in Ubuntu 12.04 find /opt/compiz-built/share/gconf/schemas -exec ...
3
votes
2answers
9k views

Error when I try to compile the kernel 2.6.37

I have downloaded the kernel 2.6.37 from kernel.org. I have tried to compile it but I get an error: $ make menuconfig scripts/kconfig/conf --silentoldconfig Kconfig *** *** Configuration file ...
2
votes
2answers
4k views

Installing Python 3.4 from source

I am running Xubuntu 13.10 i386 with the python (2.7) and python3 (3.3) packages installed. I have downloaded and compiled the source code for Python 3.4 but the binary file is named python. How can I ...
1
vote
0answers
2k views

How to configure debian/rules file for packaging with CDBS and Cmake, Qt5 on Ubuntu 12.04

this is the first time I ask here. Recently I played packaging --a new thing for me-- in Launchpad. I tried compiling Sigil 0.7.4 for Ubuntu Precise. The source code had to be compiled with Qt5, while ...
7
votes
2answers
6k views

Compiling error while installing Realtek RTL8111E in 64 bit 13.10. “CONFIG_X86_X32 enabled but no binutils support”

I downloaded the Linux drivers for my onboard RTL8111E (Mobo MSI B75 Pro3-M) from the Realtek site. The Realtek driver has been updated 23/09/2013, so I assume it can handle 64 bit Ubuntu (13.10 in my ...
3
votes
1answer
12k views

“ERROR: zlib check failed” while compiling Qemu

I recently formatted my PC and reinstalled Ubuntu 13.04 via Wubi in Windows. And after updates I'm getting this error: basel@ubuntu:~/Desktop/qemu-1.6-test$ ./configure ...
3
votes
1answer
2k views

How do I install a driver provided as source code?

I have a USB-to-LAN converter, and downloaded the its drivers. The driver folder consists of a Makefile file, a .c file and a .h file. How do I install such a driver?
3
votes
2answers
1k views

What is the minimum requirement to compile Kernel modules

I want to compile a Kernel module. What is the minimal set of packages that I need to download to succeed? Cheers, Stefan
2
votes
1answer
8k views

How to get 32 bit version of libraries on Ubuntu 64 bit?

I'm trying to compile a program which uses Google's V8 library (which is 32 bit). Therefore any library I use within my program also has to be 32 bit. Where can I download the 32 bit version of ...
1
vote
2answers
3k views

Installing rtl8812AU_linux_v4.2.0_6952.20130315.tar.gz

Hi while trying to get the drivers for my "EDIMAX AC600 Dual-Band High Gain Wi-Fi USB Adapter" I run into the following problem: After sudo apt-get install build-essential and cd /home/"USERNAME" I ...
1
vote
3answers
603 views

How to install RevKit

I’m trying to install a software called RevKit on Ubuntu 12.10 and the following instructions1 need to be followed: RevKit can be downloaded from the www.revkit.org website. Opening a Bash ...
1
vote
1answer
4k views

Missing modversions.h

I`m trying to compile a program, which was actually designed for Linux OS based on kernel 2.4. When I run the make command, I get the following error ...
1
vote
1answer
360 views

Cannot compile Glasgow Haskell Compiler

./configure checking for gfind... no checking for find... /usr/bin/find checking for sort... /usr/bin/sort checking for ghc... no configure: error: GHC is required unless bootstrapping from .hc files. ...
1
vote
2answers
4k views

Madwifi Driver Installation Error : “Cannot detect kernel version”

I cannot get past this error when trying to run "make" on the driver source. Makefile.inc:81: *** Cannot detect kernel version - please check compiler and KERNELPATH. Stop. Does anyone know the ...
1
vote
2answers
1k views

Kernel compile error with iw_ndis.c

I have a hp pavilion dm3t with intel HD graphics running ubuntu 10.10 64 bit. I'm trying to compile and install a patched kernel according to this, ...
0
votes
1answer
98 views

How to compile and install this?

https://github.com/thestinger/vte-ng I see a CONFIGURE, autogen.sh and a makefile but I can't seem to figure out how to install this. Can someone help explain what I need to do to install this?
0
votes
1answer
179 views

Trouble installing VMware workstation 11.1 on ubuntu 14.04

Trouble installing VMware workstation 11.1 on ubuntu 14.04 Kernel Module Updater prompts Compiling Error : Virtual Network Device Unable to start services See log file .... I have gone through several ...
0
votes
1answer
1k views

Compiling rtl8188ee driver fails

I am trying to compile and install the proprietary driver for my RTL8188ee Wireless card. Using make in the download directory ...
12
votes
3answers
10k views

vmhgfs module not compilable for VMware Tools 9.9.0 (Fusion7.1) after Ubuntu Linux kernel update to 3.13.0-46-generic?

vmhgfs module not compilable for VMware Tools 9.9.0 (Fusion7.1) and VMware Tools 9.9.2 (Fusion7.1.1 Build 2496486) after Ubuntu Linux kernel update to 3.13.0-46-generic (Febr. 2015) (Shared Folder ...
20
votes
2answers
16k views

Where can I find the configure options used to build a package?

I need to install asterisk 1.6.2.18 on Ubuntu 10.10 I would like to know what the configure options were that were used to generate the ubuntu package of asterisk 1.6.2.7. My favorite server distro ...
20
votes
3answers
80k views

How do I install glib?

I want to build the Empathy in Ubuntu 11.04. When I follow the build process, ./autogen.sh The shell said to me that libtoolize: copying file `m4/lt~obsolete.m4' checking for autoconf >= ...
5
votes
3answers
4k views

How to build application without sudo privileges?

What do I need to setup on a Ubuntu 9.10 server so that a user can build applications of there choice (i.e. ./configure , make && make install) with out the need for sudo/admin privileges. I ...
12
votes
5answers
20k views

Where does Ubuntu store its library files?

I want to add my own library to use in c compiling, but don't really know where ubuntu stores it.
11
votes
1answer
5k views

How to speed up compilation of Ubuntu apps (make, cmake, gcc)

I am compiling some programs here and I have 4 cores. Is there a way to tell make, cmake or gcc to compile using all cores or something to that affect.
10
votes
3answers
739 views

Is there any open-source way to make a static from a dynamic executable with no source code availability?

Let me explain the problem with an example. I use some old program in my day to day work, like for example xfig and pdfedit. Now, these programs are quite old and not updated too often; my fear is ...
8
votes
3answers
14k views

How to install ktechlab?

How to install ktechlab in Ubuntu 11.10?
5
votes
4answers
6k views

Can't build gcc anymore since upgrade to 11.10

On Monday I've upgraded to from Ubuntu 11.04 (my initial installation) to 11.10 and now I can't build gcc from source anymore. Since I forgot to uninstall the gcc package before the upgrade, Ubuntu ...
20
votes
1answer
26k views

What is “openssl binaries” and “openssl development package”?

Build it using general C development environment with bash, gcc (3 or 4 series), make, etc on a linux machine. Building pre-requirements are: ** 1. openssl binaries; 2. openssl ...
11
votes
2answers
12k views

How do I set up ccache?

I want to use ccache to speed up compilation. I came across how do I enable ccache This is what I have done so far: $ sudo apt-get install -y ccache $ dpkg -l ccache ii ccache 3.1.6-1 Compiler ...
7
votes
1answer
2k views

How to build Compiz from source?

Similarly to this question made for Unity, I would like to know what is the correct procedure to build the latest development release of Compiz from source. In particular, it would be useful to know ...
6
votes
2answers
19k views

“make” and “make install” never work

I have been trying it from a long time now and this time it got my nerves. The commands make and make install used to install a program from an extracted tar ball never work for some reason. The ...
5
votes
3answers
9k views

Initialising the Build Environment for Android on 64-bit 12.04

I am looking to initialise the build environment for the AOSP codebase (or for that matter, any Android source), and one of the first steps in the process is to; $ sudo apt-get install git gnupg flex ...
4
votes
1answer
4k views

How to build and install latest SimpleScreenRecorder from git?

I want to install SimpleScreenRecorder (SSR) from git as recommended by the developer. The binary version crashes and it is possible that the git version already has the fixes for my crash problem. ...
4
votes
2answers
5k views

Building a static version of Python?

I tried asking this question at StackOverflow, but the dead silence that followed made me wonder if some more Ubuntu-specific expertise might be required. I am trying to build a static version of ...
3
votes
2answers
133 views

Is there a plugin for the terminal which allow to detect and open files?

I'm looking for a terminal plugin/extension that would allow me to detect files path in terminal output and open them in a text editor by clicking on them. The perfect solution would open the file at ...
3
votes
1answer
4k views

Why does gsl-library not compile/link in 11.10, despite that it did under 11.04 with the same makefile and program?

I have a problem with the gsl library in Oneiric - after upgrade from Natty to Oneiric I cannot build a program anymore with my own makefile, despite the fact that in QT Creator everything works fine ...
3
votes
3answers
4k views

The best way to compile a kernel for an i7 processor?

I have compiled my own kernels for a while now. I started when I got my i7 processor and wanted its turbo boost to work properly. I've since bought an SSD so continue to benefit from a more recent ...
2
votes
1answer
259 views

I have installed QT4.8.7 but CMAKE codul not match the path

I got the error message CMake Error at /usr/local/share/cmake-3.4/Modules/FindPackageHandleStandardArgs.cmake:148 (message): Could NOT find Qt4 (missing: QT_QTOPENGL_INCLUDE_DIR ...
11
votes
5answers
8k views

How to solve dpkg-source source problem when building a package?

Has anyone here had some experience creating a Debian / Ubuntu package? I am trying to backport the lammps package (http://packages.ubuntu.com/quantal/lammps) from Ubuntu 12.10 (Quantal) to Ubuntu ...
9
votes
2answers
1k views

Can't compile with GCC on Ubuntu 12.04

I'm trying to compile and run the below C program on my Ubuntu & Windows machines with both GCC & VC9. However, I'm facing below issues: On Ubuntu machine: GCC compiles fine, but when run, ...
8
votes
2answers
684 views

How to cross-compile an existing deb package from 64bit to 32bit architecture

I have rebuilt a deb package with a custom patch for my computer which is a 64bit machine. I did it using: sudo apt-get -b source [package name] Now my question is, how to do that in a similar ...
7
votes
2answers
5k views

Maya Calendar from Elementary OS on Ubuntu

The Maya Calendar from Elementary OS seems really nice: Has anyone been able to run it on Ubuntu ? Is it available on some repository ? After installing the dependencies, I only get a ton of error ...
7
votes
1answer
11k views

Does a file reported as “not a dynamic executable” by 'ldd' depend on other libraries?

Just making sure I got this right - I call ldd /path/to/executable and it returns "not a dynamic executable". This means that it doesn't depend on other libraries, correct? If so, does it mean that ...
6
votes
3answers
5k views

Unable to compile RealTek RTL8188CE driver on Ubuntu 13.10

I am trying to compile the Realtek drivers on my machine and I am getting the following errors: make -C /lib/modules/3.11.0-12-generic/build M=/home/david/Downloads/rtl8188ce-linux-driver modules ...
6
votes
4answers
3k views

Installing CoverGloobus

Is there any easier way to install Covergloobus 1.6 in Ubuntu 10.10 ? PPA doesnt work , tried to compile it but failed , are there any other ways??
5
votes
2answers
42k views

Getting an error when using 'make' command (installing aircrack-ng on Ubuntu 12.04)

I followed these instructions. I edited the common.mak file successfully and when I ran make I get this error: mohd-arafat-hossain@TUD:~/aircrack-ng-1.1$ make make -C src all make[1]: Entering ...
4
votes
3answers
9k views

Error 255 when trying to install openssl-1.0.1g from source

installing man1/cms.1 cms.pod around line 457: Expected text after =item, not a number cms.pod around line 461: Expected text after =item, not a number cms.pod around line 465: Expected text after ...
4
votes
1answer
3k views

How to compile wine

I am a Wine PPA user for Scott Ritchie for several years and have loved that PPA but I want to start compiling Wine for testing purposes in another PC with Ubuntu. So I have a couple of questions ...