Tagged Questions

Questions related to compiling software, normally using the "make" command.

learn more… | top users | synonyms (2)

3
votes
1answer
2k views

How do I compile ALSA 1.0.24?

I'm using Ubuntu Maverick on my main PC, and I got the system configured just the way I like it (yay!) a long time ago. Everything was well until the recent Wine releases which are apparently made to ...
5
votes
2answers
375 views

How to install Media Explorer?

Media Explorer is a Media Center much like XBMC, it is part of Meego. The latest version, 0.3, is only available as source, which one has to build. A PPA exists, providing version 0.2, yet I don't ...
10
votes
7answers
984 views

How do I port software that I have written for Windows to Ubuntu?

I have written software packages for the Windows platform. I want to change to Ubuntu. At the moment I use Visual Basic and Access Databases. Can anyone suggest What I should use to rewrite my ...
0
votes
1answer
3k views

Problem with compiling GTK3 program

I recently decided to learn gtk+, so I installed the gtk3 developement package which contains all the necessary libraries, then I just wrote a simple program test which is supposed to display a gtk ...
3
votes
1answer
609 views

How to install ffmpeg without root?

I want to install ffmpeg, however it seems that its impossible without root. there are sources, but I have to compile it somehow. how to compile it? I just need ffmpeg "exec".
0
votes
1answer
91 views

Kernel compiling help

I was compiling the kernel 3.2 when it was taken more time than the walkthrough indicated. So I cancelled it, realizing that it took 5 gb of hard drive space. I deleted all the kernel folders ...
0
votes
1answer
656 views

Error in node_crypto.cc when building node.js with nvm

The error message is the following (tried with multiple versions of node v0.4.1, v0.4.7, etc): ../src/node_crypto.cc:101:29: error: ‘SSLv2_method’ was not declared in this scope ...
2
votes
1answer
837 views

How can I compile Shotwell to be able to use the faces feature?

It seems shotwell has the capability, you just have to compile it. I tried to configure with --define=ENABLE_FACES but the feature isn't showing up. I used playya git which included a recent fix for a ...
10
votes
1answer
24k views

How to solve configure: error: readline library not found?

I have an Ubuntu 10.04 LTS server with a minimal install that I want to compile postgres on. With the minimal install the server did not have gcc so I had to do an apt-get install gcc but now I keep ...
10
votes
3answers
380 views

How to find out how many people have downloaded from PPAs

How do I find out how many people use a particular PPA. I see on a particular PPA ; Package build summary A total of 108 builds have been dispatched for this PPA. Completed builds 108 successful 0 ...
4
votes
1answer
2k views

How do I install Clang Version 3 in 10.10?

How would I go about installing version 3 of Clang/LLVM in Ubuntu 10.10? Ubuntu 10.10 installs version 2.8 by default. Version 3 has more extensive/up to date support for C++ and possibly C (I am not ...
0
votes
1answer
70 views

Specifying variables in checkinstall

The compile command that I should use is: make KLIB=/lib/modules/$(uname -r) But as make utility is not good at uninstalling packages I want to use checkinstall like so: checkinstall install=no ...
46
votes
4answers
26k views

If I build a package from source how can I uninstall or remove completely?

I used source code to build one package such as below: ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib --with-package-name="Myplugin" ...
0
votes
1answer
483 views

Configuration and compilation settings used for Ubuntu packages

I want to be able to recreate specific packages by compiling the source code of the package. To compile the source code one has to run the configuration process, followed by the compilation process. I ...
5
votes
1answer
295 views

How to install software from source and tell the apt-get that I have installed the version?

For installing software from source: ./configure make sudo make install How to tell the apt-get that the software has been installed, so that sudo apt-get install someSoftware Will show that the ...
1
vote
1answer
847 views

PCRE compilation errors on 11.10 (but not on 10.10 and 11.04) [closed]

I compile a project in C + +. The project uses a library PCRE. The project is not written by me. I run the SH-file. On Ubuntu 10.10 and 11.04 is compiled. At 11.10 - no. This error occurs when: g + ...
14
votes
1answer
7k views

How to download, modify, build and install a Debian source package?

If I want to make minor changes to the source code of a Debian package, how do I go about downloading, incrementing the package version, building the (modified) source, and installing it on my ...
2
votes
1answer
577 views

How to escape spaces in pwd path when creating a Boost build script?

I want to compile Boost with some specific options (eg: using zlib from its latest source) So I try next bash code like: WD=`pwd` #//... cd $BOOST_ROOT_DIR echo_run ./bootstrap.sh #// problem with ...
1
vote
1answer
216 views

Best practices for maintaining Ubuntu packages across versions?

I have a bunch of packages in my PPA and a reasonable knowledge on how to build Debian/Ubuntu packages, so far so good. My issue is that I don't really have an idea how to properly maintain them for ...
0
votes
1answer
1k views

Has anyone gotten Edimax 7811 to work under 11.10?

I recently upgraded to Ubuntu 11.10. Afterwards I needed to have wireless capability on the same machine. The Edimax 7811 is listed as Linux compatible, but it did not work with Ubuntu 11.10. It uses ...
1
vote
2answers
675 views

Build Avahi without GUI

I'm running Ubuntu Jaunty on a plug computer which I only ever access via SSH. I want to update Avahi on the device (without GUI) and the only way (that I know of) to get the very latest version is ...
1
vote
2answers
398 views

How do I install the penmountlpc kernel module?

I would like to install the penmountlpc touchscreen driver in Ubuntu 11.10 on a Dialogue Flybook A33i. When I try installing it using module-assistant from the source packed in ...
1
vote
1answer
487 views

Cant install/compile utorrent from tar.gz source

I tried to install/compile utorrent like that: sudo ./configure make make install and like that: sudo ./configure --prefix=/path make make install and like that: sudo ./configure ...
1
vote
1answer
282 views

Auto compile service on for Ubuntu packages? [duplicate]

Possible Duplicate: What are PPAs and how do I use them? create a .deb Package from scripts or binaries Is there any service provided by Ubuntu , to automatically compile source to binary ...
1
vote
2answers
95 views

Cannot run compiled files on file exchange partition on a MBP 3,1

Since I dual boot on my Macbook Pro I created a partition to exchange files between Ubuntu and Mac OS X easily. I can copy and delete files easily on the exchange partition from both OS. I can also ...
0
votes
1answer
1k views

Kernel xconfig for cross-compilation fails with “no package 'qt-mt' found error”

I am cross-compiling a Kernel.org Linux kernel (linux-3.0.4) for an embedded ARM system. A few days ago, I was able to successfully build the kernel xconfig on an Ubuntu 11.04 Natty (64-bit) host ...
1
vote
0answers
116 views

How can I build GNOME Shell from jhbuild? [duplicate]

Possible Duplicate: How do I install and use the latest version of GNOME Shell? I'm running Ubuntu 11.10, and wanted to build gnome with jhbuild to get the latest and greatest. ...
21
votes
4answers
36k views

How can I install a realtime kernel?

I have read a lot of threads with similar questions, but after reading the answers, I am very confused. I have found in them lots of url's with repositories but people discusses about which ...
1
vote
1answer
967 views

Can't install inkscape

I tried to install several packages older ones too.Tried to upgrade it from terminal,to compile it.Once I did it and wait it for long time,but at the end of instalation it showed me 2 errors.When I'm ...
3
votes
1answer
3k views

Why does gsl-library not compile/link in 11.10, despite that it did under 11.04 with the same makefile and program?

I have a problem with the gsl library in Oneiric - after upgrade from Natty to Oneiric I cannot build a program anymore with my own makefile, despite the fact that in QT Creator everything works fine ...
11
votes
2answers
3k views

How to compile gedit LaTeX plugin?

Because I'd like to use the Gedit LaTeX plugin that is unfortunately not available for Gedit 3.2 in the repositories, I want to compile it myself. The most recent version you can get on ...
1
vote
1answer
1k views

How to install pymedia without compiling prereq's from source?

I'm trying to install pymedia: http://pymedia.org/ on ubuntu. I'm fine with building pymedia itself from source, as that seems my only option, but I'd rather not have source built versions of its ...
5
votes
4answers
6k views

Can't build gcc anymore since upgrade to 11.10

On Monday I've upgraded to from Ubuntu 11.04 (my initial installation) to 11.10 and now I can't build gcc from source anymore. Since I forgot to uninstall the gcc package before the upgrade, Ubuntu ...
1
vote
2answers
4k views

Madwifi Driver Installation Error : “Cannot detect kernel version”

I cannot get past this error when trying to run "make" on the driver source. Makefile.inc:81: *** Cannot detect kernel version - please check compiler and KERNELPATH. Stop. Does anyone know the ...
2
votes
1answer
564 views

LaTeX build server with git

I have a LaTeX project in git, there is a makefile. So basically a server would have to do this: git checkout master make > logfile 2>&1 Given that I push into a repo on the server. I ...
4
votes
1answer
20k views

Missing linux/autoconf.h [closed]

I 'm trying to compile a package in Ubuntu but getting error "linux/autoconf.h: No such file or directory" Now I see that the missing file is under ...
5
votes
4answers
11k views

Writing a “Hello World” Device Driver for kernel 2.6 using Eclipse

Goal I am trying to write a simple device driver on Ubuntu. I want to do this using Eclipse (or a better IDE that is suitable for driver programming). Here is the code: #include ...
0
votes
1answer
201 views

Easy Native Package Rebuild [duplicate]

Possible Duplicate: Recompile all packages and trigger on updates What's easiest way of to rebuild a package in Debian/Ubuntu using a specific set of CFLAGS/CXXFLAGS. In all the tutorials I ...
2
votes
2answers
3k views

Building a static version of Python?

I tried asking this question at StackOverflow, but the dead silence that followed made me wonder if some more Ubuntu-specific expertise might be required. I am trying to build a static version of ...
-1
votes
1answer
106 views

Where should I put newly build software? [closed]

I have been curious for a long time about software installation in Linux (Ubuntu). Because I am so used to Windows OS, every software is installed by some sort of 'wizard', usually I don't need to ...
1
vote
1answer
988 views

Add new files into .deb package you're building

How do you add new files, eg custom init script into .deb package that you're building?
2
votes
2answers
528 views

Compiling vim-gnome with ruby support

I followed this blog post to compile gvim with ruby support. However, when I make, I get this error: /usr/bin/ld: cannot find -lruby-static collect2: ld returned 1 exit status link.sh: Linking failed ...
1
vote
0answers
288 views

need help compiling SDL as a windows executable on ubuntu [closed]

I'm trying to compile JumpnBump to run on Windows, from Ubuntu and it's giving me a very hard time. Somebody made a port, that I have to compile myself because I needed to change the controls. There ...
2
votes
0answers
608 views

How to cross-compile open-zwave library for asus rt-n16? [closed]

Open-zwave lib link: http://code.google.com/p/open-zwave/source/browse/ Toolchain used: http://code.google.com/p/wl500g/downloads/list?can=3&q=hndtools-mipsel-uclibc-4.4.6-K26 Asus RT-N16 ...
1
vote
2answers
4k views

Compile 32 bit on 64 bitsystem

I'm trying to compile a 32 bit version of python on a 64 bit ubuntu system with the following configure command: CC="gcc -m32" LDFLAGS="-L/lib32 -L/usr/lib32 \ -Lpwd/lib32 -Wl,-rpath,/lib32 \ ...
0
votes
1answer
891 views

How to compile openzwave-control-panel?

Trying to compile openzwave-control-panel. But getting the following error: user@ubuntu1004desktop:~/openzwave-control-panel$ make g++ -o ozwcp -g ozwcp.o webserver.o zwavelib.o ...
3
votes
1answer
754 views

Recommendation for a Colecovision emulator?

I'm searching an emulator for colecovision - a home games console from the early '80s. I've found two: ColEM, which starts but doesn't seems to load the cartidges AdamEM, compiled but not working ...
11
votes
3answers
45k views

How do I install glib?

I want to build the Empathy in Ubuntu 11.04. When I follow the build process, ./autogen.sh The shell said to me that libtoolize: copying file `m4/lt~obsolete.m4' checking for autoconf >= ...
1
vote
1answer
1k views

Help with compiling error

I already compiled I already compiled libfreenect for natty and now I am trying to install kinect mouse: https://github.com/Ooblik/Kinect-Mouse/ But when I type make I receive an error... This is ...
4
votes
2answers
2k views

Building Awesome WM, missing dependencies

Trying to compile Awesome Window Manager on 11.04, I've done apt-get build-dep awesome but still get errors about missing dependencies: $ make Running cmake… -- cat -> /bin/cat -- ln -> /bin/ln -- ...