Questions related to compiling software, normally using the "make" command.

learn more… | top users | synonyms (2)

1
vote
3answers
14k views

“fatal error: gtk/gtk.h: No such file or directory” using make

I am trying to use make command to build. I am following this. I am compiling a code using GTK+2 and C language hp@ubuntu:~/amhello$ make make all-recursive make[1]: Entering directory ...
1
vote
1answer
3k views

Makefile:448: *** missing separator. Stop. error

The tutorial I am following is the automake hello world. I am compiling a code using GTK+2 and C language hp@ubuntu:~/amhello$ autoreconf --install configure.ac:2: installing `./install-sh' ...
1
vote
1answer
360 views

cross compiling error for helloworld program

I have already created the amhello-1.0.tar.gz using this tutorial click to open now am trying to make cross compiling but error occurs. i am following this tutorial click to open after entering ...
0
votes
1answer
1k views

“undefined reference to `std::ios_base::Init::Init()” while compiling a hello world in netbeans

I am new to ubuntu and I want to code in C++. I intalled g++ through software manager and after I installed netbeans to have a nice IDE to code in C++. Then I write this simple code: #include ...
0
votes
1answer
1k views

How to backport a patch to my current kernel?

I used to download compat-wireless-3.6.8-1 on Ubuntu 12.04 And successfully compile it into target files for compat.ko, cfg80211.ko, mac80211.ko, ath.ko, ath9k_hw.ko, ath9k_common.ko ath9k.ko . Now I ...
1
vote
0answers
832 views

How to build a newer version of a package than is available for my stable release?

I want to use a newer package version with my stable Ubuntu release. Asking for backport takes too long without visible result, so I thought that maybe I can build newer version myself. Can anybody ...
0
votes
1answer
720 views

GitLab dpkg-buildpackage error

This is a question related to my other question I am following these instructions to build a Debian package out of gitlab management software. I got the following error dpkg-buildpackage ...
0
votes
1answer
7k views

g++ (4.6.1) does not recognize -std=c++11 [closed]

I'm trying to compiling a program (via Make) using g++ 4.6.1 with flag -std=c++11. It's giving me: cc1plus: error: unrecognized command line option ‘-std=c++11’ This is running on Ubuntu 11.04 ...
0
votes
1answer
622 views

Building nginx on Ubuntu with cache_purge module - help?

I have been trying to rebuild nginx with cache_purge module from http://labs.frickle.com/. I did the following and somehow the new build doesn't seem to include the module. Here is what I did: ...
1
vote
1answer
268 views

Connect K8055n Experiment Board to Ubuntu

I purchased a K8055n Velleman Experimental Board and for some reason every program I run or if I try to access the board I get the following error: Could not open the k8055 (port:0) Please ensure ...
0
votes
1answer
949 views

IOError: [Errno 13] Permission denied. FEniCS JIT compiler

I keep getting the permission denial error: IOError: [Errno 13] Permission denied, when I try running making a function space. I think it it something to do with the JIT compiler. Somehow, all the ...
0
votes
1answer
5k views

dogecoin wallet client dependencies (boost)

I seem to be missing something boost related. Dogecoin gives the requirements as: qt4-qmake libqt4-dev build-essential libboost-dev libboost-system-dev libboost-filesystem-dev ...
0
votes
2answers
5k views

how to build dogecoin CLI wallet

I'm trying to install dogecoin wallet, which depends on: Library Purpose Description ------- ------- ----------- libssl SSL Support Secure communications libdb4.8 Berkeley DB Blockchain & ...
1
vote
2answers
2k views

“/usr/bin/ld: cannot find -lX11” building Firefox OS?

Tried to Build Firefox OS with Ubuntu 13.10 and got this error: host SharedLib: libOpenglRender (out/host/linux-x86/obj/lib/libOpenglRender.so) /usr/bin/ld: cannot find -lX11 /usr/bin/ld: cannot find ...
3
votes
1answer
6k views

Aircrack-ng SVN error 1 [closed]

i've already downloaded aircrack-ng from the SVN repo and i'm trying to build it from source and this is what i get: make -C src all make[1]: Entering directory `/home/chris/aircrack-ng/src' gcc -g ...
1
vote
2answers
8k views

Help locating linux/version.h

I'm trying to fix an old program, Previous issues I had could be found at Missing modversions.h When I make the program it gives me the following error, kaodv-mod.c:22:27: fatal error: ...
0
votes
4answers
272 views

I cant install Sleepyhead under Ubuntu

I am trying to install Sleepyhead following the tutorial http://ubuntuforums.org/showthread.php?p=11756055#post11756055 but I cant compile the src code` horacio@horacio-ThinkPad-X201:~/sleepyhead$ ...
-1
votes
1answer
124 views

if i manually compile php, should i uninstall it in dpkg first?

Around 2 years ago I attempted my first PHP compile and succedded. I occasionaly upgrade my compile script as I add modules and new versions come out. However, I'm finding that apt-get unattended ...
1
vote
0answers
329 views

How to build and run Concorde and Traveling Salesman Problem? [closed]

I need to use a library that is called Concorde to solve a well known problem called Traveling Salesman Problem. This library is available here I've downloaded and compiled it resulting in two main ...
0
votes
1answer
64 views

leJOS build help!

I'm currently trying to install leJOS in my Ubuntu laptop (12.04) and I've followed the instructions from here but I'm unable to build it. ...
0
votes
1answer
3k views

Missing modversions.h

I`m trying to compile a program, which was actually designed for Linux OS based on kernel 2.4. When I run the make command, I get the following error ...
7
votes
1answer
9k views

How to add libraries path to the ./configure command?

I would like ./configure to link to a library and some include files. My library is stored in /home/foo/sw/lib/ and my files are stored in /home/foo/sw/include. ./configure --help throws out the ...
0
votes
1answer
2k views

Error compiling a package: “configure: error: no gstreamer-1.0 >= 1.0.0”

I am trying to compile a package, which requires gstreamer-1.0 >= 1.0.3. I think I have an older vesion installed on my system. So I downloaded and compiled gstreamer-1.0.4 and it got installed in ...
2
votes
0answers
355 views

After compiling QT 5 how do I to update my system? With update-alternatives?

I'm on Ubuntu 12.04. I followed the instructions in this guide in order to compile QT5. Everything compiled fine. My problem now is that my QT related programs are still pointing to an older ...
0
votes
1answer
956 views

undefined reference to 'dlopen' 'dlclose' 'dlerror' 'dlsym

I'm installing a program on Ubuntu 12.04 LTS. I've run ./configure and I get no error messages, when I then run make I get errors. Please see below for the errors: make all-recursive make[1]: ...
0
votes
2answers
1k views

Cross compiling, library gmp not found

I'm trying to cross compile StrongSwan package on Ubuntu for Synology NAS using official Synology toolchain. Host: hostname = ubuntu uname -m = i686 uname -r = 3.8.0-32-generic uname -s = Linux ...
1
vote
1answer
1k views

compile and run Android apps from the console

I installed eclipse and all the sdk/jre etc... I can make Android Apps now and it's working, but often my eclipse crash. I would like to know if it's possible to: compile build run from the ...
1
vote
3answers
810 views

“make” command is not doing any thing

I am new to Ubuntu and I am trying to compile a small program. I have a Makefile and raw1394.c file in a folder raw1394. when I run a make command it should produce raw1394.ko file but I am getting ...
0
votes
1answer
358 views

Difference between make-kpkg and make deb-pkg

I have build the kernel image by make-kpkg and make deb-pkg in 13.04 ubuntu and noticed that image size is very big in case of deb-pkg build. deb-pkg build size is 13 times bigger than make-kpkg . ...
-1
votes
2answers
1k views

Unable to update to Evolution version 3.10.1?

I'm unable to update to the lastest stable version of evolution. I got the .tar.xz file but I cannot install it. Appreciate your assistance
0
votes
2answers
2k views

Can Synaptic install application from a .tar.gz file downloaded from outside the repositories?

I would like to know if Synaptic package manager can install an application from a .tar.gz file downloaded from a different source than is in the repositories in /etc/apt/sources.list. I mean those ...
1
vote
1answer
195 views

How to install build dependencies for source not available in Ubuntu repositories?

I keep myself busy compiling (makeing) several packages and some of them are not in the repositories (so apt-get build-dep doesn't help), the complete documentation about build dependencies is missing ...
3
votes
2answers
2k views

Bochs Compiling Error AGAIN

I'm trying to compile bochs with this command: ./configure --with-x11 --with-wx --enable-ne2000 --enable-iodebug --enable-disasm --enable-debugger --enable-e1000 --enable-usb --enable-pci it works, ...
0
votes
1answer
2k views

gui/libgui.a(x.o): undefined reference to symbol 'XSetForeground' when compiling Bosh

I need to compile bochs from source, I've already run this command: ./configure --with-x11 --with-wx --enable-ne2000 --enable-gdb-stub --enable-disasm --enable-e1000 --enable-usb --enable-pci now ...
2
votes
0answers
867 views

Undefined reference to `memcpy@GLIBC_2.14' : Building Android SDK with SmartCard API support:

I am trying to build Android emulator with SmartCard API support. I was following this manuals: one two All steps passed ok, but when I run: PCSC_INCPATH=<path_to_pcsc-lite_32bit>/src/PCSC/ ...
2
votes
0answers
121 views

Building lirc package from source with patches

I'd like to build latest lirc package for 12.04 with two patches from here to make USB Infrared toy v2 work: Running sudo apt-build source lirc gave me ➜ build ll total 960 drwxr-xr-x 10 root root ...
0
votes
1answer
7k views

Terminal commands for installing g++ 4.8?

Could somebody please advise how I could install g++ 4.8 ? I understand its not an official release yet (and that I would need to manually download a file) but I get internal compiler bug issues with ...
1
vote
0answers
2k views

gcc problem -> stdio.h not found

I have to compile one programme. theoretically i need just to change the two path... can you help me? Makefile # Original #CC=arm-1136jf_s_r1_vfp_hard_float-linux-gnueabi-gcc #CFLAGS= -O3 ...
3
votes
2answers
10k views

'Make' command compiling errors

Im trying to locally install a program which is written in C++. I have downloaded the program and am attempting to use the "make" command to compile the program as the programs instructions dictate. ...
6
votes
2answers
4k views

Compiling error while installing Realtek RTL8111E in 64 bit 13.10. “CONFIG_X86_X32 enabled but no binutils support”

I downloaded the Linux drivers for my onboard RTL8111E (Mobo MSI B75 Pro3-M) from the Realtek site. The Realtek driver has been updated 23/09/2013, so I assume it can handle 64 bit Ubuntu (13.10 in my ...
1
vote
1answer
1k views

CPUMiner won't compile

I am trying to compile a CPUMiner program, but get errors which I don't know what to do about. I am compiling as said here: http://www.return1.at/bitcoin-miner-ubuntu/ The error is: checking build ...
6
votes
3answers
5k views

Unable to compile RealTek RTL8188CE driver on Ubuntu 13.10

I am trying to compile the Realtek drivers on my machine and I am getting the following errors: make -C /lib/modules/3.11.0-12-generic/build M=/home/david/Downloads/rtl8188ce-linux-driver modules ...
0
votes
1answer
832 views

configure: error: You need 32-bits luac when using using lua from contrib

I installed ubuntu 13.10 64 bits on virtualbox. I am trying to compile vlc using these steps: https://wiki.videolan.org/Win32Compile/ When I reached this step: ../extras/package/win32/configure.sh ...
1
vote
0answers
277 views

how to install package requirements gtk+-3.0 >= 3.9.10, glib-2.0 >= 2.37.5 and gio-2.0 >= 2.30.0

I am trying to compile Disk Usage Analyzer. In preparing to compile, I am informed of certain requirements that are not present: configure: error: Package requirements ( gtk+-3.0 >= 3.9.10 ...
0
votes
1answer
321 views

Is is possible to use two kernels at the same time?

After upgrading from Ubuntu 13.04 to Ubuntu 13.10 Intel VTune Amplifier stopped working. As recommeded by developer I tried to reinstall the program and manually compile the needed drivers. However I ...
0
votes
1answer
296 views

Problem with function fpos_t and fgetpos [closed]

when I try to use those functions it sends this error: main.cpp: In function ‘int main()’: main.cpp:11:17: error: conversion from ‘int’ to non-scalar type ‘fpos_t {aka _G_fpos_t}’ requested ...
1
vote
1answer
506 views

arm-none-ebai-gcc does not work from mounted directory

I want to build project for ARM micro controller. For this purpose in folder with project was placed script, which download toolchain and build him. After run this script toolchain was placed in ...
5
votes
2answers
3k views

Building TrueCrypt on Ubuntu 14.04

With the whole NSA thing people tried to re-build identically looking binaries to the ones which truecrypt.org provides, but didn't succeed. So some think they might be compiled with back-doors which ...
0
votes
2answers
1k views

How to build the Darling project on Ubuntu?

The Darling project is an open source Darwin/OS X emulation layer for Linux. I downloaded the source code with git and tried to build it with cmake but it failed. The document says I need these ...
0
votes
1answer
1k views

Compiling rtl8188ee driver fails

I am trying to compile and install the proprietary driver for my RTL8188ee Wireless card. Using make in the download directory ...