0
votes
0answers
18 views

Compile error when trying to run make

I have de following error when trying to run make command, /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/4.7/../../../libcppunit.a when searching for -lcppunit /usr/bin/ld: ...
0
votes
0answers
26 views

I already have the newest version of g++ but I still get a 127 error what do I do?

I have done the following. I just don't know what to try next. I supposedly have the newest version of gcc by following these directions sudo add-apt-repository ppa:ubuntu-toolchain-r/test sudo ...
0
votes
2answers
44 views

How do you fix a gcc compile 127 error? sudo apt-get install g++ doesn't work

*emphasized text*when I try to run a program I get the following error. ubuntu@ubuntu-VirtualBox:~/Desktop$ make g++ -Wall -Wno-switch -I. -g -c -o pass.o pass.cpp make: g++: Command not found ...
0
votes
0answers
17 views

I need some help with ld not found library lgcc

I need some help with language C. Well I am trying to compile from my iPad, with the mobile terminal. So I have installed gcc , the headers and the ldid writing apt-get install ldid. It looks like it ...
0
votes
0answers
13 views

Trying to compile 'mips64' program with gcc 3.3 but it has an error when building binutils and gcc

I tried building binutils and gcc3.3 for mips64 and everything goes well until: make CC=$GCC make install [For make an error saying, that: gmp.h and confdefs.h are not found] [For make install: ...
0
votes
0answers
38 views

Use gcc-4.6-arm-linux-gnueabihf to compile .c file, What is the command?

I am doing cross compiling. I install the gcc-4.6-arm-linux-gnueabihf and want to use it to compile the .c file(example of hello world) and then run it on ARM. I don't know what is the exact command. ...
0
votes
1answer
90 views

Header files missing

I'm trying to compile a source code and I'm getting many errors indicating that header files are missing from my system checking sys/ioccom.h usability... no checking sys/ioccom.h presence... no ...
3
votes
0answers
670 views

collect2: error: ld returned 1 exit status

I want to install nexalign (can be downloaded from here) on ubuntu 13.10. I previously installed it on ubuntu 10 without any problem. The error I got is: gcc -O9 -Wall -Dthread -lpthread main.o ...
1
vote
1answer
68 views

-lm option doesn't work in GCC 4.8.1

I know I'm not supposed to be posting problems related to programming here. But I couldn't think of any better place and it's quite relevant too. The problem is exactly what the title indicates: when ...
0
votes
0answers
146 views

Compiled packages and apt-get mess

Due to my work I have to use the last version of gdb (7.7) which is not provide in the ubuntu repositories. For that purpose I download the source code, compiled it and installed it successfully. My ...
0
votes
1answer
46 views

Problem installing SCTK 2.4.0 on Ubuntu 13.10

I'm trying to install SCTK 2.4.0 on Ubuntu 13.10 with gcc 4.8.1 installed on my system but I get this error after I run "make all" command: In file included from main.cpp:20:0: recording.h:122:29: ...
0
votes
0answers
32 views

Why does Ubuntu make larger compiled kernel file (.deb) than Debian does?

When I compile a kernel in Ubuntu, it is 40% bigger than in Debian (with the same .config). Why? Is it because of little different versions? 40% seems too much to me. Both are up to date, Ubuntu 13.10 ...
-2
votes
2answers
55 views

compiling a c++ program

I tried to compile a cpp program through the terminal on 13.04 but got this message: npg@NPG-ideaPad-S210:~$ gcc -o comp-LCG.cpp The program 'gcc' can be found in the following packages: * gcc * ...
0
votes
1answer
185 views

C compiler cannot create excecutables

When I am trying to install a openvpn from a tarball , following error occurs checking whether the C compiler works... no configure: error: in `/home/shubhamd/Downloads/openvpn-2.3.2': ...
1
vote
1answer
79 views

cross compiling error for helloworld program

I have already created the amhello-1.0.tar.gz using this tutorial click to open now am trying to make cross compiling but error occurs. i am following this tutorial click to open after entering ...
0
votes
1answer
1k views

g++ (4.6.1) does not recognize -std=c++11 [closed]

I'm trying to compiling a program (via Make) using g++ 4.6.1 with flag -std=c++11. It's giving me: cc1plus: error: unrecognized command line option ‘-std=c++11’ This is running on Ubuntu 11.04 ...
0
votes
1answer
228 views

Building nginx on Ubuntu with cache_purge module - help?

I have been trying to rebuild nginx with cache_purge module from http://labs.frickle.com/. I did the following and somehow the new build doesn't seem to include the module. Here is what I did: ...
0
votes
0answers
258 views

How to verify a manual build of gcc-4.8.2 on Ubuntu 12.04?

After getting the latest gcc-4.8.2 from one of the gcc mirrors, I issued the following commands as a mere mortal: ./gcc-4.8.2/configure --enable-languages=ada,c,c++,fortran make ulimit -s 32768 make ...
0
votes
2answers
298 views

Cross compiling, library gmp not found

I'm trying to cross compile StrongSwan package on Ubuntu for Synology NAS using official Synology toolchain. Host: hostname = ubuntu uname -m = i686 uname -r = 3.8.0-32-generic uname -s = Linux ...
0
votes
1answer
419 views

Bochs Compiling Error AGAIN

I'm trying to compile bochs with this command: ./configure --with-x11 --with-wx --enable-ne2000 --enable-iodebug --enable-disasm --enable-debugger --enable-e1000 --enable-usb --enable-pci it works, ...
0
votes
1answer
1k views

Terminal commands for installing g++ 4.8?

Could somebody please advise how I could install g++ 4.8 ? I understand its not an official release yet (and that I would need to manually download a file) but I get internal compiler bug issues with ...
1
vote
0answers
726 views

gcc problem -> stdio.h not found

I have to compile one programme. theoretically i need just to change the two path... can you help me? Makefile # Original #CC=arm-1136jf_s_r1_vfp_hard_float-linux-gnueabi-gcc #CFLAGS= -O3 ...
1
vote
1answer
959 views

CPUMiner won't compile

I am trying to compile a CPUMiner program, but get errors which I don't know what to do about. I am compiling as said here: http://www.return1.at/bitcoin-miner-ubuntu/ The error is: checking build ...
1
vote
1answer
174 views

arm-none-ebai-gcc does not work from mounted directory

I want to build project for ARM micro controller. For this purpose in folder with project was placed script, which download toolchain and build him. After run this script toolchain was placed in ...
1
vote
1answer
3k views

Error : Cannot run C compiled programs. if you meant to cross compile use --host' Ubuntu

I'm completely new to Ubuntu I downloaded and unpacked a tar.gz package, after extraction, it is said in its documentation : "type ./configure --disable-gts" But when I run this command alone it ...
1
vote
1answer
73 views

Different versions of libstdc++6 on 12.04

After upgrading Server 10.04 to 12.04, I was receiving errors related to lgcc_s while trying to compile with g++ and gcc. There are several versions of libgcc_s installed in ...
0
votes
1answer
245 views

Help on installing a tar.gz on Ubuntu

Okay, I am trying to install, Icecast http://www.icecast.org/ guggy@guggy-pc:~/Downloads/icecast$ ./configure checking for a BSD-compatible install... /usr/bin/install -c checking whether build ...
2
votes
0answers
112 views

Problem when compiling GCC in Ubuntu

I have run into the well known problem when installing GCC: configure:3605: error: in /usr/local/gcc-4.8.1/i686-pc-linux-gnu/libgcc': configure:3608: error: cannot compute suffix of object files: ...
1
vote
1answer
229 views

wsnet simulator: Segmentation fault (core dumped) during installation

I installed wsnet simulator about one month ago and everything was OK (I had any problem). Now I uninstalled wsnet ( sudo rm –r /usr/local/wsnet.2) I want to install it again and I follow install ...
0
votes
0answers
165 views

why do I get undefined reference to zheev when linking against lapack

Using gcc version 4.6.3 I try to compile C code that invokes the LAPACK routine zheev, but I get the following error message: In function 'HermiteEigValVec': HermiteEigValVec.c (text+0x192): ...
-1
votes
1answer
5k views

How to compile a C program that uses math.h?

I am having problems in math.h header file and when I use square root function as in sqrt(d). But my compiler is not supporting this. Please advise me about this problem. My Ubuntu version is 2012.
0
votes
1answer
206 views

cooja compiling error: msp430/bin/ld: cannot find -lc

I updated msp430-gcc to 4.7.0 version in InstantContiki2.6. When I simulate the hello-world example, it shows the following error: > make hello-world.sky TARGET=sky msp430-gcc -DCONTIKI=1 ...
-3
votes
3answers
401 views

How to install gcc and g++ compilers

I have tried these commands in terminal , sudu apt-get upgrade sudu apt-get update sudu apt-get install build essential but failed. Please help me, I am getting the following error. No command ...
2
votes
1answer
2k views

gcc segmentation fault on Ubuntu 12.04

I am trying to compile a C program on Ubuntu precise 12.04. Here's the program: #include <stdio.h> int main(int argc, char** argv) { printf("Hello World!"); return 0; } My gcc version is ...
1
vote
1answer
4k views

Compiling apib undefined reference to symbol 'pthread_create@@GLIBC_2.2.5'

I want to compile apib on my ubuntu 13.04 box but I am having issues with pthread lib. This is the error that I get : $ colormake -j 5 cd src && make all make[1]: Entering directory ...
0
votes
1answer
529 views

msp430/bin/ld: cannot find -lc

I installed successfully msp430-gcc 4.7.0 compiler. The compiler at the final stage of the linking process it shows me the following error for Ubuntu 12.04. msp430-gcc -mmcu=msp430f1611 ...
0
votes
1answer
2k views

diff between x86_64-linux-gnu-gcc and plain old gcc?

I'm trying to compile something called a "Voice Cloning Toolkit" for Festival and HTS. (see: http://homepages.inf.ed.ac.uk/jyamagis/software/page37/page37.html) I've found that lots of things break ...
0
votes
1answer
134 views

compiled executable cannot run

cpp program. But now I cannot run it. It show that command not found. I compile it by; gcc `pkg-config --cflags opencv` OpenCV_ViolaJones.cpp -o OpenCV_ViolaJones `pkg-config --libs opencv` It's ...
1
vote
0answers
49 views

Problem with compiling fft using gcc

I have downloaded the source codes of Splash2 from here and i tried to compile fft.c using gcc command on my own machine but i got this error : fft.c:62:28: fatal error: parmacs_config.h: No such ...
0
votes
0answers
65 views

Multiple undefined references using FFMPEG libs

I installed FFMPEG libraries and headers as it is described here . In my C++ application when I compile (gcc) I am getting this : /usr/local/lib/libavcodec.a(libfaac.o): In function ...
1
vote
1answer
1k views

Problem with /usr/bin/ld: main.o: undefined reference to symbol 'exp@@GLIBC_2.2.5'

During installation Emerald in ubuntu 13.04 when I write "sudo make" I have problem: libtool: link: gcc -g -O2 -pthread -I/usr/include/libwnck-1.0 -I/usr/include/compiz -I/usr/include/gtk-2.0 ...
3
votes
1answer
4k views

How to compile & install Emerald window manager in Ubuntu 13.04 64bit?

Please give me directions to compile & install Emerald specifically in Raring Ringtail 64bit edition. I've tried to compile it from the source many times, but had no luck.(Compile log : ...
0
votes
1answer
2k views

Installing proxychains. HELP NEEDED! [duplicate]

OK so i am new to linux. I am trying to install proxychains but im sure it has dependencies that i do not have on my system can somebody look at the following script and tell me the list of packages i ...
2
votes
1answer
132 views

How to repair a broken compiler?

Few months ago I was using gcc 4.6. In order to get C++11 functionality I upgraded to gcc 4.7 using a PPA. Today gcc 4.7 was recommended to me through the update manager. I just mindlessly clicked ...
1
vote
2answers
2k views

Building GCC 4.8 on Ubuntu 12.04

I am trying to install GCC 4.8 on Ubuntu 12.04, but during make I get the error shown below where compilation aborts. (To the best of my knowledge I have all prerequisites satisfied as I have already ...
1
vote
1answer
819 views

Cannot find -lgfortran

I'm trying to install a package in R (package "ks"). It fails with error message: /usr/bin/ld: cannot find -lgfortran I've already installed the Ubuntu package build-essential: sudo apt-get ...
4
votes
1answer
532 views

warning messages while compiling c program using gcc [closed]

I am new to linux. I use gcc (Ubuntu/Linaro 4.6.3-1ubuntu5) 4.6.3 on Ubuntu 12.04 LTS. When I compiled the c program using pointer, I got the -Wformat warning as shown below. But if I execute a.out ...
8
votes
2answers
563 views

Can't compile with GCC on Ubuntu 12.04

I'm trying to compile and run the below C program on my Ubuntu & Windows machines with both GCC & VC9. However, I'm facing below issues: On Ubuntu machine: GCC compiles fine, but when run, ...
3
votes
2answers
2k views

How to fix compilation errors that mention “stray ‘\342’” and “stray ‘\200’”?

I wrote this program: #include<stdio.h> int main() { printf(“Hello World\n”); return 0; } I saved it as first.c and tried to compile but receiving this problem I have installed even gcc ...
0
votes
3answers
933 views

Error while installing tiff-4.0.3

I get the following errors while installing tiff-4.0.3: pranav@pranav-Inspiron-1545:~$ cd dependency/ pranav@pranav-Inspiron-1545:~/dependency$ tar -xvf libtiff4-3.6.0-5.tar.bz2 usr/bin/cygtiff4.dll ...