1
vote
2answers
63 views

How to install needed Qt packages to build kernel on 14.04?

I'm going to compile kernel on Ubuntu 14.04 64-bit, so I start with installing packages that I need: sudo apt-get install build-essential bin86 kernel-package libqt3-headers libqt3-mt-dev wget ...
0
votes
1answer
41 views

How to get appropriate lib package name for a specific header file [duplicate]

It's common problem that we get some error like "abc.h no such file" when compile source. Only way to find the solution(as i know) is search in internet. What i need to do, compile the source, it will ...
0
votes
1answer
262 views

Compile evolution development snapshot 3.13.1

I have downloaded evolution development snapshot from this link: https://wiki.gnome.org/Apps/Evolution and now I have trouble compiling the source code. I am using ubuntu 14.04 and this version of ...
3
votes
2answers
75 views

If I'm building from source, why does it require more space than installing via apt-get?

I was trying to install the program by compiling and then installing it. I choose PINTA. It requires these dependencies: mono mono-xbuild automake autoconf libmono-cairo2.0-cil gtk-sharp2 and it ...
0
votes
1answer
792 views

How do I find missing dependencies for cinepaint 1.0-4 Ubuntu 13.04

I am a photojournalist/digital photo artist and I am getting into video editing projects I have used GIMP for my photo editing for years... I've been doing some research on other alternatives which ...
0
votes
1answer
333 views

aptitude dependency resolution issue when trying to install build-deps for openjdk-6

I am running into some kind of rather serious issue with resolving the dependencies if I try to install the build-deps for openjdk-6, as specified in the directions for compiling custom OpenJDK ...
0
votes
1answer
48 views

Source package: precise build dependencies policy for Software Centre

I was seeking for a detailed specification of what's allowed as build dependencies for sources packages to be published in the Software Centre. I found Ubuntu Policy Manual — Chapter 4 - Source ...
4
votes
3answers
7k views

Initialising the Build Environment for Android on 64-bit 12.04

I am looking to initialise the build environment for the AOSP codebase (or for that matter, any Android source), and one of the first steps in the process is to; $ sudo apt-get install git gnupg flex ...
0
votes
1answer
526 views

getting build dependencies and source by default

Is there an application by which the build dependency as well as the source code of the software gets downloaded automatically as soon as we install the software from a .deb package or the software ...
2
votes
0answers
52 views

All special dependencies are lost when I do “quickly share” or “quickly package” [duplicate]

Possible Duplicate: Why does 'quickly package' fail with “An error has occurred when creating debian packaging”? I am developing an app using Quickly and it has a few ...
1
vote
1answer
280 views

How can we install all the necessary dependencies for a package so that we can build it?

well, after i installed freecad on my ubuntu 12.04 with the help of this blog i started asking about compiling and building from source. So, when we are trying to install a package some times the ...
4
votes
2answers
2k views

Building Awesome WM, missing dependencies

Trying to compile Awesome Window Manager on 11.04, I've done apt-get build-dep awesome but still get errors about missing dependencies: $ make Running cmake… -- cat -> /bin/cat -- ln -> /bin/ln -- ...
0
votes
1answer
88 views

vtg-plugin dependencies not met

I am trying to compile the vtg-plugin from source however I am getting the error "vtg-dependencies not met" which complains about libpeas and gedit. The version of gedit it is asking for is 2.91.0, ...
2
votes
1answer
653 views

Adding apt-get packages to a usb boot drive (and storing them on the drive)?

I want to compile some 3rd party software and install it on a bootable usb drive...there are several packages that I need to install with apt-get before I compile it. How could I store the apt-get ...
2
votes
1answer
324 views

Missing Build Dependencies when upload to Launchpad

bit of a different question. I'm trying to upload a package to a repository that I just started on Launchpad. Launchpad accepts the upload happily, and everything seems good up until the build. It ...
3
votes
2answers
355 views

PPA build failed because of unmet dependencies of another package in the same PPA

I have 2 packages swami-2.0.0 and libinstpatch-1.0.0 in my PPA where the first one depends on the latter. The swami-2.0.0 control file contains libinstpatch-dev (>= 1.0.0) but it seems this is not ...
10
votes
1answer
845 views

How to upload package with dependencies to my PPA?

I made a package for my PPA and uploaded it. It built without any problems. Then I made another package that depended on the first and uploaded it. It failed because it couldn't find the files in the ...