C++ is a general-purpose programming language.

learn more… | top users | synonyms

5
votes
1answer
44 views

How to install new versions of G++ that use the corresponding C++ standard library?

I am trying to install multiple versions of the g++ compiler for testing purposes. I would like to be able to install g++ 4.9.3,5.1.0, 5.2.0, and 6.1.0. I know that I can do sudo add-apt-...
4
votes
1answer
69 views

How to install jsconcpp in ubuntu 14.04 for C++ development?

As the question tells how should I install jsonccpp in ubuntu 14.04. I have downloaded the jsoncpp-src-0.5.0.tar.gz form sourceforge. Then I opened nautilus using sudo and copied,pasted and extracted ...
0
votes
0answers
22 views

Codeblocks error undefined reference to curl_global_ in C++

I new to the web application of c++ and trying to learn about fetching websites and its contents using curl in c++ . My aim is to create a c++ programe which can parse json data from a website. I am ...
0
votes
1answer
15 views

X11/extensions/Xcomposite.h: No such file or directory

I've tried to compile http://unix.stackexchange.com/a/228674 under Ubuntu. Unfortunately ending up with following error: /tmp/find-cursor$ make cc find-cursor.c -o find-cursor -lX11 find-cursor.c:...
1
vote
2answers
48 views

Undefined References eclipse using libav

I am trying to install the newest version of libav from the libav website. Currently being version 11.7. I have unziped, configured, make, and make install. For ./configure I had tried using various ...
30
votes
5answers
276k views

What is a command to compile and run C++ programs?

I am new to Linux. I am using Ubuntu 11.04 and do not know how to compile and execute C++ program in it. I need to know the commands to Compile and Execute a C++ program in Linux.
0
votes
0answers
36 views

collect2: fatal error: cannot find 'ld' compilation terminated

When I try to run c and C++program I am getting collect2: fatal error: cannot find 'ld' compilation terminated. I have already install GCC and G++ latest version. Any buddy please help.
0
votes
1answer
68 views

Create Ogre3D 2.1 project

I have downloaded the Ogre3D 2.1 source, compiled and installed it without any issues. To my knowledge I have a working installation. The problem now is that none of the official project templates ...
0
votes
0answers
19 views

Can't find installed app

I downloaded CLion IDE for C and C++ the other day, and I am trying to remove it. But when I go to the software store under the "installed" section, CLion isn't there. But I am able to load up the app ...
0
votes
0answers
18 views

Caffe installation

CXX src/caffe/util/math_functions.cpp In file included, from /usr/include/boost/optional.hpp:15:0, from /usr/include/boost/format/internals.hpp:20, from /usr/...
0
votes
0answers
30 views

Installing and using universal-ctags instead of exuberant-ctags

How could I switch from exuberant-ctags to universal-ctags. I am using Ubuntu 16.04 LTS and ctags --version reports Exuberant Ctags 5.9~svn20110310, Copyright (C) 1996-2009 Darren Hiebert
1
vote
3answers
2k views

Error while installing tiff-4.0.3

I get the following errors while installing tiff-4.0.3: pranav@pranav-Inspiron-1545:~$ cd dependency/ pranav@pranav-Inspiron-1545:~/dependency$ tar -xvf libtiff4-3.6.0-5.tar.bz2 usr/bin/cygtiff4.dll ...
0
votes
1answer
79 views

qtserialport in c++ app ubuntu

Can someone please tell me how to install the qtserialport to use in a c++ project in ubuntu? Thanks.
0
votes
2answers
433 views

Error while compiling c program using gcc <filename.c> thru the CLI

Whenever I try to compile a c program thru CLI using gcc <filename.c>, I get the error: gcc: error trying to exec 'cc1plus': execvp: No such file or directory I'm using Ubuntu 12.04. Also,...
3
votes
2answers
11k views

How to install gtkmm?

Is the gtkmm package already installed by default? If not how do I install it on Ubuntu with all the prerequisites? Would a command line install be better? Do I need to add a repository?
1
vote
1answer
4k views

How to compile a c++11 program using future in Ubuntu 12.04?

I'm trying to compile a c++ program in Ubuntu 12.04. I'm using g++ 4.7 (installed from a ppa). I'm using std::future, but I have an error. The code: $ cat main.cpp #include <iostream> #...
3
votes
1answer
7k views

CXXABI_1.3.8 not found

So, I'm trying to run heroes of newerth and get the error ./hon-x86_64: /home/c0ding/HoN/libs-x86_64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /usr/lib/x86_64-linux-gnu/libicuuc....
-1
votes
0answers
12 views

Link cups correctly in boost bjam to find 'cupsGetDests'

Desperately trying to build a c++ printing application with boost on Ubuntu 14.04.2 LTS. Installed cups and libcups, the application recognizes cups/cups.h correctly. But while building I get the ...
0
votes
0answers
46 views

Can not compile due to curl

I use Ubuntu 14.04 (trusty) under user to compile a project which linked to libcurl.so symbol, but it complains: ~/local/lib/libcurl.so.4: no version information available (required by cmake) /bin/...
0
votes
0answers
34 views

How to work with QVariant(QJsonDocument) in javascript

I try to write a ubuntu app. My problem is, that i want to fill the ListModel in my qml. ListModel { id: model } i do that by using javascript: fill(database.get()) The database is defined ...
0
votes
2answers
564 views

How to compile a c++ program from notepad++? [closed]

I am running notepad++ through wine. But I am not able to compile a program(specially c++). Is there any compiler that I could use? What should I do?
0
votes
0answers
42 views

Ubuntu Touch Development - first steps in cross-compiling and installing?

I have a bit of home-built C++ code using Qt that I run on my Ubuntu Desktop, and I've been fooling around with the Aquaris M10 tablet running Ubuntu Touch for a while... I got to thinking, I'd really ...
1
vote
0answers
23 views

How to compile code written in Solaris using g++?

I am trying to compile code written by a researcher, the code seems to have been written for solaris machine and compiler, with header files like sunmath.h etc. How do I compile and run this code on ...
8
votes
5answers
57k views

Can't execute .out files, getting permission denied

I have written a C++ program and complied it to produce a.out file. However, whenever I try to run it, I get Permission Denied. I read that we can use sudo, but I can't quite get it to work. I use ...
1
vote
1answer
37 views

How to add binary third party libraries in qt creator (Ubuntu-sdk verison of QT-Creator)

I try to write an app for ubuntu unity8 and i use a third party library in that app. My problem is that i would like to use the binary version of that library in my app and not the source files of ...
3
votes
1answer
56 views

Compiling a 32 application on 64 bit, without getting rid of GNU EABI for ARM

I want to build a C++ program for 32 bit on my 64 bit 16.04. /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/5/libstdc++.so when searching for -lstdc++ /usr/bin/ld: skipping ...
7
votes
2answers
1k views

How to install CLang using precompiled binaries?

How do I install CLang on Ubuntu, using precompiled binaries of CLang that I downloaded? Here's how I downloaded CLang: "LLVM Download Page" -> "Download LLVM 3.2" -> "Clang Binaries for Ubuntu-12.04/...
2
votes
5answers
454 views

how to code in ubuntu? [closed]

I used turbo c++ in windows to write c/c++ codes. Recently I started using Ubuntu, now where should i write c/c++ code in Ubuntu like we used to do in windows? Which software should I download from ...
12
votes
4answers
65k views

How to install latest cmake version in Linux/Ubuntu from command line?

I am trying to install latest cmake in my linux box and I am always getting the below exception - userName@phx5qa01c-4e23:~/build$ wget http://www.cmake.org/files/v2.8/cmake-2.8.11.tar.gz --2013-10-...
0
votes
1answer
38 views

how to download turbo c++ in DOSBOX?

I'm not be able to download TURBO C++. It says it is already extracted.
2
votes
2answers
523 views

Bad symbols on my eclipse C++ installation

http://stackoverflow.com/questions/9131763/eclipse-cdt-c11-c0x-support I come from that website. I have a C++ project that compiles with g++-4.8 without problems. I just wanted to use std::int8_t ...
2
votes
0answers
624 views

GLIBCXX_3.4.21 not defined in file libstdc++.so.6 with link time reference

When trying to execute any c++ programs, I get this error. The full error message is: ./main: relocation error: ./main: symbol _ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEC1Ev, version ...
3
votes
1answer
1k views

How do I install gcc 6 (latest 6.1?) on Ubuntu 14.04 LTS, make c++14 the default and will my libraries work? [duplicate]

How do I install gcc 6 (latest 6.1?) on Ubuntu 14.04 LTS, make c++14 the default and will my libraries work? Also, what problems can I expect if any? Lastly, please walk me through this because i am ...
0
votes
0answers
12 views

Running AES in HElib

I am using Ubuntu 14.04. I am trying to run AES in HElib but I have a Segmentation fault (core dumped) I tried to find the error by strace command and I received the error: write(1, "computing key-...
0
votes
1answer
181 views

Installing boost into /usr/include

I am trying to install boost into the folder /usr/include. I tried sudo apt-get install libboost-dev, but the highest version apt-get provides is 1.58 instead of the newest 1.61. Then I downloaded ...
0
votes
1answer
52 views

Does Cppcheck has a gui for ubuntu 14.04?

I want to use Cppcheck for my C++ based program. If yes, how do I install it? I can't seem to find any instruction for that anywhere. Thanks
1
vote
1answer
33 views

thrift-0.9.3 package C++ build issues. Which boost packages to use?

I am seeing compilation issues in thrift-0.9.3 package( I did downloaded from https://thrift.apache.org/download). Some linking errors are observed in lib/cpp/test. Can any one suggest me what version ...
0
votes
1answer
55 views

system(“pause”) for Linux g++ C++ [closed]

In windows when compiling, system("pause") works, what is the equivalent in linux?
1
vote
0answers
23 views

error: SCmathlib: No such file or directory

I have written code for conjugate gradient in PuTTy C++. When I try to compile it, it throws the error below. error: SCmathlib.h: No such file or directory cg13.cc:11: error: '::main' must return '...
2
votes
1answer
130 views

How can I write a dynamically updated panel app / indicator?

I am trying to write some panel apps for ubuntu Mate. I know C/C++, and SDL reasonably well. I have seen the Mate-University panel apps github page, but i cannot get it to work properly / Im having ...
0
votes
1answer
293 views

Clion “Bundled Cmake does not work in this enviroment” ubuntu 14.04

I used Eclipse CDT for college lectures, but today I found the solution for C/C++ by JetBrains. But I can't compile because I don't know how to set the compiler.
0
votes
1answer
1k views

Dell Inspiron 15 5559 hangs at shutdown, wierd start ups

I just bought a new Dell machine. It's awesome! It has a 6th Gen Intel i5, Radeon M335 (4gb ddr3), 8gb of ram< win 10. Nothing special, but still quite good. Anyways I wanted to install Ubuntu on ...
0
votes
1answer
44 views

How to run multiple or single C++ .cpp files on terminal? [closed]

Everything is running on codeblocks and I don't know how to do it on terminal.
0
votes
0answers
18 views

Ubuntu: Cannot open shared object while executing c++ program

I've tried to install library from sources. After calling "sudo make install" I've got following information: If you ever happen to want to link against installed libraries in a given directory, ...
0
votes
0answers
14 views

which include needed in Octave

I've started working with the octave library in C++. I need to uses the functions: polyfit and csaps. Which in includes do I need to run these functions? Koby
0
votes
0answers
22 views

Setting up a window manager development environment and a basic guide

I am using Ubuntu and I am not able to understand from where can I get the Xcb libraries. While I was checking some guide (whose name I forgot) I got the command : cc file_name.c -lxcb It was written ...
1
vote
1answer
110 views

Where are the headers of libavcodec and libavformat located?

I executed the following commands in the terminal: sudo apt-get install libavcodev-dev sudo apt-get install libavformat-dev I tried to find the headers (various #include<libavcodec/*.h>) in ...
3
votes
0answers
101 views

How can I run an c/c++ program that use GNU Scientific Library (GSL)?

I'm trying to run 2 simple examples in c/c++ using the GNU Scientific Library. That are the codes: 1st: An Example Program #include <stdio.h> #include <gsl/gsl_sf_bessel.h> int main (...
0
votes
1answer
256 views

How to link, and compile, a C++ code using GNU Octave functions?

I am new to C++, and I have troubles to get going. I want to re-implement a code, written in GNU Octave, using C++. I would, however, still want to use some GNU Octave functionality in that C++ code. ...
1
vote
0answers
119 views

'__FDELT' and '__FDMASK' not declared in this scope (posix_types.h not included)

I'm running Ubuntu 12.04 LTS, 64bit version. I'm getting the following error when compiling a C++ program: ../elements/userlevel/socket.cc:477: error: '__FDELT' was not declared in this scope ../...