The GNU build system, also known as the Autotools

learn more… | top users | synonyms

3
votes
1answer
44 views

Compiling Cheese from source, fails to compile

I am trying to install cheese from source, and Im not interested in finding a package, because I have source code changes I should like to apply, if I can get it to compile. I have libtool automake, ...
0
votes
0answers
61 views

Compiling PHP 5.3 on Ubuntu 14.04 - libtool: Version mismatch error

I have a php property which we are trying to migrate from CentOS 6 to Ubuntu 14.04. This property currently runs on php 5.3 and cannot be updated to a later version in the time allowed due to package ...
1
vote
1answer
501 views

Trying to Build and Install apinger

I am running 14.04 server (minimal install) and I am trying to build apinger (https://github.com/Jajcus/apinger). Here is a log of what I get when I run ./autogen.sh: The first couple of lines point ...
6
votes
2answers
25k views

How do I get the latest automake?

This is very similar to http://askubuntu.com/questions/453660/warning-automake-1-11-is-probably-too-old On Ubuntu 12.04 LTS, I'm getting the following error message: WARNING: 'automake-1.14' is ...
0
votes
0answers
63 views

How do I build Bitcoin from source on Ubuntu 14.04 [duplicate]

(Using Autotools) I have downloaded the Bitcoin source from "Bitcoin Core Version 0.9.1" When I input the following command ./autogen.sh it produces the following warning: includes' is the old name ...
9
votes
3answers
17k views

installing autotools, autoconf

I am a new Ubuntu user, I need to install autotools, when I search on the Internet various ways are given that do ./configure and stuff. Please guide me on how to install autoconf, autotools etc on ...
4
votes
1answer
634 views

checkinstall asking for version

I have a autoconf/automake/autoeverything project that I'm installing with checkinstall. When I go to install it, I'm shown this This package will be built according to these values: 0 - ...
16
votes
2answers
56k views

Installing aclocal on Ubuntu 11.04?

How can I install aclocal from the autotools bundle in Ubuntu 11.04? I tried to find it to no avail: sudo apt-get install aclocal sudo apt-get install autotools-dev apt-cache search aclocal ...
3
votes
2answers
2k views

How make a configure/makefiles from an C file?

Hope this is not a stupid question. But here it goes... Over the last month I have learned Programming in C and Gtk to a point where I have written a small program in C. I would like to make a ...