Aptitude is a quite powerful package manager leveraging CLI and an ncurses-style interface.

learn more… | top users | synonyms

1
vote
0answers
54 views

Replace '0ubuntu1~12.04' packages with '16ubuntu6'

I recently upgraded my server from Ubuntu 12.04 to 14.10. I had installed GCC 4.9 (4.9.2 apparently) before the upgrade and today I wanted to install gcc-4.9-multilib, but apt-get gave me: ...
9
votes
2answers
11k views

I can't add PPA repository behind the proxy

I'm trying to add the ppa repository (as a root) with the following command: export HTTP_PROXY="http://firstname.surname@xxx.com:my_pass@165.x.x.232:8080" add-apt-repository ppa:nilarimogard/webupd8 ...
3
votes
1answer
971 views

How do I install python-virtualenv on Ubuntu server 12.04?

When ever I try to sudo apt-get install python-virtualenv, I'm told that Ubuntu is unable to locate the package. I'm running the server in a VirtualBox. It has networking and can access the web via ...
22
votes
8answers
10k views

How to see packages installed on a given date using aptitude

Does anyone know if there's an easy way to find a list of packages installed, sorted by date, when using aptitude (or apt-get)? I was installing a bunch of packages to try something new, and it ...
1
vote
1answer
62 views

I am unable to install skype on ubuntu 14.04

When trying to install skype using aptitude I get the following error : The following NEW packages will be installed: libaudio2:i386{a} libavahi-client3:i386{a} libavahi-common-data:i386{a} ...
0
votes
1answer
260 views

Apt-get holds back kernel images (generic, server and extra)

Today, apt-get told me several packages have been held back. Typing apt-get dist-upgrade -su gave me this: apt-get dist-upgrade -su Reading package lists... Done Building dependency tree ...
0
votes
0answers
13 views

How to download all packages in ubuntu [duplicate]

I'd like to download all the packages in Ubuntu repository This command apt-get download XYZcan be used to download XYZ package Is there a modifier that would select all the packages by replacing ...
1
vote
0answers
10 views

Boot-repair issue with Ubuntu 14.04

My VPS works absolutely fine but has had a few issues with booting since I upgraded it to Ubuntu 14.04 from 12.04. It will not boot after being switched off. So I Googled the problem and it looked ...
2
votes
0answers
21 views

Aptitude is unmarking packages as “Auto”, is this a bug or feature?

I have a brand new Ubuntu server installation and go in to aptitude. Whenever I set a package to remove, the default action is the equivalent of apt-get autoremove. However, it seems that when you go ...
3
votes
2answers
302 views

Installing Wine with aptitude

I'm trying to install Wine on Ubuntu Precise. I'm used to using aptitude for package management, so I tried to use that to install Wine. When I do that, I'm told I have to resolve dependencies that ...
0
votes
0answers
13 views

How to batch remove software using aptitude's regular expressions? [duplicate]

For example, when I removed kubuntu, I did this: sudo apt-get remove kubuntu* How to do this in aptitude? Is there any documentation on aptitude regex?
1
vote
1answer
119 views

Chrubuntu 14.04 WINE install unmet dependencies

Okay, I understand that there have been quite a few solutions to this problem. None of them have worked for me. To explain my conundrum I shall post the output of "sudo aptitude install wine1.7". ...
0
votes
2answers
345 views

unity-control-center uninstalled itself

I don't know how it got uninstalled since I had it before, but when I try to install it again I get the following error: oierlauzi@akerbeltz:~$ sudo apt-get install unity-control-center Reading ...
0
votes
1answer
20 views

foxpro on ubuntu trusty

How can I (or is even possible to) run Visual FoxPro 6 on Ubuntu 14.04? Please provide detailed installation instructions as I'm new to Ubuntu.
0
votes
0answers
45 views

dpkg configure -a fails after trying to install gnome-desktop

After trying to run aptitude install gnome-desktop im getting this failures in dpkg ubuntu:~⟫ sudo dpkg --configure -a dpkg: dependency problems prevent configuration of tk8.6: tk8.6 depends on ...
0
votes
1answer
17 views

How to remove some packages which contain a certain keyword?

For example, when I want to remove Xfce, I did this: aptitude search xfce | grep ^i id gtk2-engines-xfce - GTK+-2.0 theme engine for Xfce id libxfce4ui-common ...
0
votes
1answer
42 views

Smallest Ubuntu server self-contained installable .iso for development

I'm looking for a development server to run in VirtualBox that can do run apt-get. That's it. I don't need anything else really. I've started with the Minimal CD which is nice at 37Mb, but to ...
2
votes
0answers
47 views

xfonts installation failed and apt compromised

I started the installation of all the xfonts packages on my Ubuntu 14.04.1 system with sudo apt-get install xfonts-* While extracting a package (one of the hundreds of the list), the system got ...
1
vote
0answers
34 views

New Apt tool vs. Aptitude

Ubuntu Utopic has recently introduced a new package management frontend named apt (manpage) which provides a sort of high-level interface to tools apt-get, apt-cache and some other tools in the apt-* ...
46
votes
2answers
15k views

What is the difference between dpkg and aptitude/apt-get?

When installing a software via dpkg -i packageA.deb, will the dependencies required by packageA be downloaded and installed automatically? How is this different from using apt-get or aptitude?
12
votes
3answers
10k views

Why does “tasksel” give an “aptitude failed” error?

The problem started in the following way. I was using tasksel from the terminal menu that it shows when I simply do sudo tasksel. I select Lamp Server from the list and started to install all packages ...
6
votes
2answers
13k views

What's difference of apt-get and aptitude? [duplicate]

What is difference of apt-get and aptitude? Does both of them use same repositories? Which one is better?
1
vote
3answers
5k views

how do I downgrade google chrome?

Presumably after an update, google chrome has very serious problems with page rendering. I want to downgrade it. (Switching to vmlinuz.old and initrd.img.old did not help). $ apt-cache policy ...
0
votes
0answers
10 views

Where can I find the softwares/programs that I installed from USC and can I change where apt installs programs? [duplicate]

I just recently Installed Ubuntu, and as you can guess, I'm not good at it. Questions: 1.) I just want to know where to locate the programs/softwares I installed from the Ubuntu Software Center. ...
0
votes
0answers
311 views

dpkg: error processing package libapache2-mod-php5

I have a problem at moment of use my apt-get/aptitude package manager When I want install some packages I get the following output: sudo aptitude install libxslt1.1 libxml2 The following partially ...
34
votes
8answers
14k views

Generating list of manually installed packages and querying individual packages

I'd like to get a list of packages installed manually by apt or aptitude and be able to find out whether a foobar package was installed manually or automatically. Is there any neat way of doing that ...
0
votes
1answer
34 views

how do I install Aptitude on Ubuntu

I was trying to install MemCached using this command: sudo aptitude install memcached, but I got the following error: sudo: aptitude: command not found. After researching, I found out that Aptitude ...
12
votes
5answers
31k views

Cannot get mcrypt for PHP5

I've done this many times: sudo aptitude install php5-mcrypt sudo apache2ctl restart aptitude says mcrypt is installed. I've reinstalled it 3 times already. I've restarted apache about 20 times ...
10
votes
2answers
16k views

How to remove warnings like `Unknown media type …`

Each time apt-get tries to process triggers for shared-mime-info, it reports warnings like: ... Processing triggers for shared-mime-info... Unknown media type in type 'all/all' Unknown media type in ...
1
vote
0answers
40 views

Aptitude conflicts with apt-get

I am using both apt-get and aptitude and it seems that they do not have the same policy for the old kernels management. apt-get automatically installed two kernels: 3.13.0-36 (after a dist-upgrade) ...
0
votes
2answers
121 views

apt-get remove <package> installs alternative package [closed]

Amusingly, whenever I try to remove a package using apt-get on Ubuntu 11.04, apt-get attempts to install an alternative package in addition to removing the requested package(s). Here are a couple ...
0
votes
1answer
514 views

Error encountered when using dpkg to install packages (--configured)

I used sudo aptitude update and sudo aptitude upgrade to update the packages, and encountered an error when processing the package man-db (with --configure). A few days later, same error occured with ...
2
votes
1answer
105 views

apt-get install automatically cancelled

When I'm doing an update or installation on Ubuntu 13.10, the task is automatically cancelled in the terminal. I got this error since that the \boot partition was missing some space. I fixed this ...
0
votes
1answer
283 views

How to get gfortran to work with i386? I have “undefined reference” errors. How to get a compatible libf2c?

I have Ubuntu 14.04 on a 64-bit machine. I would like to run gfortran -m32 for my f77 fortran code that also uses i386 CERN libraries. I downloaded Ubuntu packages cernlib, lib32gfortran-4.8-dev, and ...
0
votes
1answer
203 views

How do I install qps from repositories on ubuntu 13?

I'm trying to install qps on ubuntu with aptitude install qps Where I get Couldn't find package "qps". ... I probably could download the sources and recompile, but I think I might be missing ...
0
votes
1answer
48 views

Stuck in a mess

I'm stuck in mess. I recently blanked my administrative password. When I try to do anything that requires a password, I don't have one. Also installing software from the networking bash console(to ...
2
votes
1answer
102 views

apt-get and aptitude seem to disagree — do I really have broken packages?

If I do aptitude search ~b I get a list of 78 broken packages. But 76 of them aren't even installed (they have a status of pB). How can an installed package be considered broken?? But if I do ...
110
votes
6answers
40k views

Is aptitude still considered superior to apt-get?

When I first started with Ubuntu using aptitude was the 'in-thing', with some stated improvements over apt-get. Am I correct in saying that apt-get has now 'caught up' with aptitude, and it makes ...
1
vote
0answers
28 views

Complete Deletion/Reinstallation of Downloaded Package

I want to know how to delete every file installed by a package using either aptitude or apt-get and then re-download and re-install that package completely again. I've tried doing aptitude reinstall ...
0
votes
1answer
414 views

How to install python3-dateutil in Ubuntu 12.04 (Precise)?

I am trying to install the package python3-dateutil in a Ubuntu 12.04.4 LTS (Precise) with aptitude, but I cannot find it anywhere. How can I install it?
0
votes
0answers
31 views

Locked apt-get directory

I downloaded Pipelight using the following commands: sudo apt-add-repository ppa:pipelight/stable sudo apt-get update sudo apt-get install --install-recommends pipelight-multi sudo pipelight-plugin ...
0
votes
0answers
22 views

Package not present in ubuntu package list. Different approach (ubuntu precise 12.04)

I currently have an application that I am doing packaging now. I require ruby2.0 and the package is for Ubuntu precise. (12.04LTS) but the issue is that, ubuntu precise package list does not have ...
0
votes
0answers
13 views

Can aptitude add user tags in interactive mode?

aptitude has a feature to mark packages with arbitrary "user tags". From the command line, one can do this with aptitude add-user-tag. Can one access this feature from aptitude's interactive mode? ...
1
vote
0answers
331 views

Can't exec “locale”: No such file or directory

I am new to linux. I tried today to install steam on my Ubuntu 14.04 64-bit through the .deb from the steam website. On launch, steam gave me the following error: "You are missing the following 32-bit ...
4
votes
2answers
699 views

Why does apt-get install Skype easily while aptitude complains about MAJOR dependency errors?

I was trying to install Skype on Ubuntu 13.04, from the Canonical repositories. With apt-get it worked easily, while aptitude had a huge problem with dependencies and proposed a complicated solution. ...
20
votes
6answers
6k views

How do I figure out what package something is in without resorting to Google?

I often find myself wanting to install something, but I'm unsure of what package it's in. This is a very common occurrence for me: $ make html sphinx-build -b djangohtml -d _build/doctrees . ...
0
votes
1answer
35 views

Aptitude Installing a lot of Packages?

I recently launched aptitude only to notice that it wanted to install 2GB of packages "to satisfy dependencies". Is is normal for aptitude to want to install this many packages all at the same time?
9
votes
1answer
3k views

Why does aptitude give me the “Does not have Super Cow Powers” error?

When I try to update 11.10 with current updates, I receive this error message stating Does Not Have Super Cow Powers. Why is it not updating with the current security packages?
7
votes
1answer
450 views

Why does aptitude insist on installing packages?

Why does aptitude want to install so many packages when I simply run the following? sudo aptitude install I'd rather not provide specific packages it wants to install because this has happened ...
6
votes
5answers
20k views

Errors running apt-get update and apt-get install mysql-server

Since yesterday I've been trying to run apt-get update unsuccessfully in Ubuntu instances I am creating on the EC2. In specific I've been getting these errors: Ign http://security.ubuntu.com ...