Aptitude is a quite powerful package manager leveraging CLI and an ncurses-style interface.

learn more… | top users | synonyms

1
vote
1answer
1k views

How to get gfortran to work with i386? I have “undefined reference” errors. How to get a compatible libf2c?

I have Ubuntu 14.04 on a 64-bit machine. I would like to run gfortran -m32 for my f77 fortran code that also uses i386 CERN libraries. I downloaded Ubuntu packages cernlib, lib32gfortran-4.8-dev, and ...
1
vote
2answers
5k views

unity-control-center uninstalled itself [duplicate]

I don't know how it got uninstalled since I had it before, but when I try to install it again I get the following error: oierlauzi@akerbeltz:~$ sudo apt-get install unity-control-center Reading ...
1
vote
2answers
62 views

Does apt 1.0 supports search patterns like aptitude?

aptitude search ~ipackage will search for installed package only. Can apt 1.0 (i.e. standalone apt, not apt-cache, dpkg or any else) do that?
1
vote
1answer
36 views

How to find packages that are not listed in aptitude

Often there are some packages that I was required to install as prerequisites of some tools, but are not listed in the aptitude package list (or with a slightly different name). For example, I once ...
1
vote
1answer
3k views

Ignoring specific unmet dependencies with aptitude?

This is my situation: I've installed a program called ipe "forcably" through a deb package; the reason for this is that ipe depends on texlive-latex-base, however, I already maintain a separate ...
1
vote
1answer
1k views

Ubuntu 12.04 apt-get update failing

I have a brand new, fresh install of 12.04 LTS. When I attempt to run a simple apt-get update this is what I get: Ign http:/us.archive.ubuntu.com precise InRelease Ign http:/security.ubuntu.com ...
1
vote
1answer
1k views

Cannot add or remove packages; Errors were encountered while processing: libbz2-1.0 libbz2-1.0:i386

I noticed Ubuntu had not asked me to update in a while, which is strange. So, I opened the update manager and received the message, Software index is broken It is impossible to install or remove any ...
1
vote
1answer
150 views

How to search for APT packages with a specific substring in their names only?

In the past I used to search for a package specifying a part of its name in Synaptic, as far as I can remember. Now it searches in package descriptions too and this is very inconvenient as it gives a ...
1
vote
1answer
102 views

Install a package manager without package manager

I'm doing some work on a really, really minimalistic Debian dist and noticed that there is no package manager on it. Can anyone tell me how I can fix this? There is no GUI but I have a Internet ...
1
vote
1answer
135 views

How do I find which packages could be set as automatically installed?

I am having a hard time understand who depends on who using apt-cache depends and apt-cache rdepends. I am keeping a long list of packages that I installed to solve a number of dependency problems. I ...
1
vote
1answer
252 views

Compiled package and dependency management

I have a package that depends on squid 3.2. I want to replace squid 3.2 with source compiled version of squid 3.3 beta (which is not available in repository). When I remove squid 3.2, the depending ...
1
vote
1answer
448 views

I Can't Install or Remove Any Application

when i try to install or remove an application via either software center or apt-get install they both fail and give some debconf errors below is the log please help.Sorry some of the text is not ...
1
vote
3answers
1k views

apt-get update really slow when i'm at the university

When i'm using my university connection I can't run apt-get update normally as I do at home or any other place. Everything else (that use connection) works properly. I've already tried to change the ...
1
vote
1answer
105 views

How to upgrade MySQL to >=5.1.51 on Lucid via aptitude

The mysql-server package in Lucid is listed as 5.1.41-3ubuntu12.7. Is there a safe way to upgrade to the latest 5.1 release via aptitude?
1
vote
1answer
295 views

Is it normal for aptitude to automatically remove packages during an installation?

Usually I install via apt-get or Software Center. For secure delete tools, I installed using aptitude. sudo aptitude install secure-delete aptitude however, removed a whole bunch of packages. ...
1
vote
1answer
1k views

How do I remove a package with “rU” status?

I was trying to install some 32bit libraries with dpkg -i --force-architecture command. But it failed due to dependency problem. Now if I try to install 64 bit version of the same library, it says it ...
1
vote
0answers
15 views

What's the difference between 'suggest' and 'recommends' package in apt terminology? [duplicate]

root@xxx:~# aptitude show gcc Package: gcc New: yes State: installed Automatically installed: no Version: 4:5.2.1-3ubuntu1 Priority: optional Section: devel Maintainer: Ubuntu Developers ...
1
vote
0answers
13 views

Aptitude Install Always Calling Mongodb and failing

I tried to install mongodb last week for an unrelated project and now whenever I try to sudo apt-get install a package I get an error that says * Starting database mongodb [fail] How ...
1
vote
0answers
120 views

Error opening the cache: could not open file /var/lib/dpkg/status - open (13: permission denied)

I got the following error: Error opening the cache: could not open file /var/lib/dpkg/status - open (13: permission denied) I cannot update my system at all. When I hit update I get that all the ...
1
vote
0answers
13 views

Commands to search by project homepage tag

Some packages list a homepage, such as the one for Texmaker. $ apt-cache show texmaker | grep http Homepage: http://www.xm1math.net/texmaker/ However, I can't find a way to search for the URL of a ...
1
vote
1answer
275 views

Install haproxy 1.5 without telling apt specific version

In Ubuntu 14.04 installing haproxy through apt-get install haproxy installs haproxy 1.4, while 1.5 is in the repository. How can I install haproxy 1.5 (or the newest) without resorting to specific ...
1
vote
0answers
40 views

Aptitude install wants to remove many libs

After execution command aptitude install udisks I got following message: ggg@gmLatitude:~$ aptitude install udisks E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied) E: ...
1
vote
0answers
206 views

Update PHP without removing every dependency

I'm having an issue where I just need to do something as simple as upgrade my PHP version from 5.3 to 5.6. The only issue is that Plesk is installed and I don't know how to upgrade it without Plesk ...
1
vote
1answer
495 views

Replace '0ubuntu1~12.04' packages with '16ubuntu6'

I recently upgraded my server from Ubuntu 12.04 to 14.10. I had installed GCC 4.9 (4.9.2 apparently) before the upgrade and today I wanted to install gcc-4.9-multilib, but apt-get gave me: ...
1
vote
0answers
64 views

Boot-repair issue with Ubuntu 14.04

My VPS works absolutely fine but has had a few issues with booting since I upgraded it to Ubuntu 14.04 from 12.04. It will not boot after being switched off. So I Googled the problem and it looked ...
1
vote
1answer
262 views

Chrubuntu 14.04 WINE install unmet dependencies

Okay, I understand that there have been quite a few solutions to this problem. None of them have worked for me. To explain my conundrum I shall post the output of "sudo aptitude install wine1.7". ...
1
vote
0answers
92 views

New Apt tool vs. Aptitude

Ubuntu Utopic has recently introduced a new package management frontend named apt (manpage) which provides a sort of high-level interface to tools apt-get, apt-cache and some other tools in the apt-* ...
1
vote
0answers
62 views

Aptitude conflicts with apt-get

I am using both apt-get and aptitude and it seems that they do not have the same policy for the old kernels management. apt-get automatically installed two kernels: 3.13.0-36 (after a dist-upgrade) ...
1
vote
1answer
1k views

Error encountered when using dpkg to install packages (--configured)

I used sudo aptitude update and sudo aptitude upgrade to update the packages, and encountered an error when processing the package man-db (with --configure). A few days later, same error occured with ...
1
vote
0answers
36 views

Complete Deletion/Reinstallation of Downloaded Package

I want to know how to delete every file installed by a package using either aptitude or apt-get and then re-download and re-install that package completely again. I've tried doing aptitude reinstall ...
1
vote
1answer
865 views

Can't exec “locale”: No such file or directory

I am new to linux. I tried today to install steam on my Ubuntu 14.04 64-bit through the .deb from the steam website. On launch, steam gave me the following error: "You are missing the following 32-bit ...
1
vote
1answer
51 views

Apptitude - Have I removed my entire system?

I was trying to remove an unused package via Aptitude interface but I seem to have removed my entire system? Luckily my personal data is backed up. Aptitude ran for about 10 minutes or so listing ...
1
vote
0answers
63 views

libnm-glib4:386 with amd64

I have ubuntu 13.10 amd64 and I use libnm-glib4 but I also need i386 version of this lib. But amd64 version conflicts with i386 so I can't install it: sudo aptitude install libnm-glib4:i386 The ...
1
vote
1answer
359 views

How to get older version of opencv

This fails: sudo apt-get -t=2.3.1 install libopencv Is there a way to figure put which command I have to type to get 2.3.1 running? The default on Ubuntu 13.04 is 2.4 Thanks
1
vote
2answers
113 views

Aptitude or something else?

I'm pretty new to Ubuntu and Linux in general. I've also already managed to bork a few installs. Anyways, my question is whether I should stick with a package manager like Aptitude or is there ...
1
vote
0answers
581 views

How to install xnviewmp using package management aptitude `apt-get` on Ubuntu 12.10?

How to install xnviewmp using package management aptitude apt-get on Ubuntu 12.10? Visiting https://apps.ubuntu.com/cat/applications/xnviewmp/ and clicking through to software center ends results in ...
1
vote
0answers
34 views

Aptitude depends [duplicate]

How do i fix this? I also did sudo apt-get -f install but same error The following packages have unmet dependencies: aptitude: Depends: libapt-pkg4.12 (>= 0.8.16~exp12ubuntu6) but it is not ...
1
vote
1answer
218 views

Aptitude installs automatically certain packages

I removed Nagios with sudo apt-get remove --purge nagios3-core nagios3-common and sudo apt-get autoremove but when I use Aptitude to install something else, It automatically installs Nagios again. ...
1
vote
0answers
41 views

How would I see a list of current packages and compare them to the ones being upgraded?

I'm running 12.10 on a server and I have a list of packages that need to be upgraded. However I can run the command sudo aptitude to see what they are and what their about which is fine. My question ...
1
vote
0answers
21 views

Upgrading only several packages, ou packages from one source [duplicate]

Possible Duplicate: Is there a command to upgrade a package and all its dependencies without upgrading all packages? we use Deb/apt system to deploy PHP softwares (around 200 + libraries ...
1
vote
2answers
491 views

How can I upgrade a package without removing its dependencies?

For some reason (having used xorg-edgers in the past might be part of that), I still have a very old X server installed: xorg 7.6+7ubuntu7.1 xserver-xorg-core 1.10.4-1ubuntu4.2 ...
1
vote
0answers
3k views

Update manager generates 404 error while attempting update. Will not update [duplicate]

Possible Duplicate: How can I fix a 404 Error using a PPA? While running update manager in Ubuntu 11.10 Oneric Ocelot I receive this list of errors. > W:Failed to fetch > ...
1
vote
0answers
1k views

GPG error from apt-get [duplicate]

Possible Duplicate: What is the easiest way to resolve apt-get BADSIG GPG errors? Whenever I run apt-get update or apt-get install I get an error akin to the following: W: GPG error: ...
1
vote
2answers
76 views

Segmentation fault in aptitude

On our 64 bit Lubuntu 14.04 system, aptitude has started crashing with a bunch of scrolling errors, ending up with a seg fault. *** Error in `aptitude': free(): invalid next size (fast): ...
0
votes
2answers
933 views

Aptitude offers to remove some packages but apt-get doesn't?

I'm trying to install mint-meta-mate which is Gnome 2 fork on 11.10 - 32bit with aptitude i get this: The following NEW packages will be installed: caja{a} cowsay{a} fortune-mod{a} ...
0
votes
1answer
1k views

Aptitude in ubuntu 10.10 [duplicate]

Possible Duplicate: Tab completion for commands Aptitude command is missing from Ubuntu 10.10. I just installed it using apt-get install aptitude but it doesn't support autocompletion as it ...
0
votes
1answer
58 views

/usr/local/lib contains libraries which Aptitude reports aren't installed

I am trying to build a project that uses a specific library (SDL) on Ubuntu. The project uses old version of the library (libSDL-1.2). I've made mistake of installing the newest library but have since ...
0
votes
3answers
3k views

I can't install Skype on Ubuntu 14.04 64-bit

I've tried lots of tutorials I found online, but I can't install Skype. apt-get gives me this error: (but Synaptic doesn't report any broken packages) Some packages could not be installed. This may ...
0
votes
1answer
624 views

Cannot purge roundup

I was trying to purge roundup, and aptitude has output the following error lines: update-rc.d: /etc/init.d/roundup exists during rc.d purge (use -f to force) dpkg: error processing roundup (--purge): ...
0
votes
1answer
348 views

How do I install qps from repositories on ubuntu 13?

I'm trying to install qps on ubuntu with aptitude install qps Where I get Couldn't find package "qps". ... I probably could download the sources and recompile, but I think I might be missing ...