Aptitude is a quite powerful package manager leveraging CLI and an ncurses-style interface.

learn more… | top users | synonyms

0
votes
1answer
1k views

aptitude unable to find dependencies, broken packages

I installed an ubuntu on a virtual machine 6 months ago. I never needed a ssh connection until now. But when I try to install sshd, I get this error: root@onur-vmdesktop:/home/onur# apt-get install ...
0
votes
3answers
538 views

Removing packages through a list [closed]

I'm running Peppermint OS Two and it uses natty packages. I want to introduce some oneiric packages. As I go along I backup my list of packages and /var/cache/apt/archives. The plan is if I install ...
3
votes
2answers
643 views

Partially Dist-upgrade from CLI?

Sometimes a sudo aptitude upgrade fails and sudo aptitude upgrade --full-resolver then wants to remove about 100 Packages, because of "dependecy conflicts". Often I can then start update-manager and ...
0
votes
1answer
173 views

“aptitude update” as cronjob, customize the cron-mail-output

I have set up aptitude update as cronjob for root and sending the mail to my normal user account. What I want to have now, is that all the output of aptitude is ommited and instead only a ...
1
vote
0answers
3k views

Update manager generates 404 error while attempting update. Will not update [duplicate]

Possible Duplicate: How can I fix a 404 Error using a PPA? While running update manager in Ubuntu 11.10 Oneric Ocelot I receive this list of errors. > W:Failed to fetch > ...
1
vote
2answers
2k views

Installing php5 gives an error for some unment dependencies!

When I try yo install php5 using sudo aptitude install php5 I get the following error. The following packages have unmet dependencies: apache2-mpm-worker: Conflicts: apache2-mpm which is a ...
8
votes
2answers
1k views

Will aptitude be added back in 12.04 or future versions?

Since there is more space in the ISO (750MB for now) for the 12.04 version and the limit of 700MB is removed, has there been any thoughts about adding aptitude to the command line tools. I ask this ...
1
vote
1answer
264 views

Is it normal for aptitude to automatically remove packages during an installation?

Usually I install via apt-get or Software Center. For secure delete tools, I installed using aptitude. sudo aptitude install secure-delete aptitude however, removed a whole bunch of packages. ...
2
votes
1answer
213 views

Why do dpkg and aptitude want to remove MOST of my system?

I was installing and uninstalling some packages on my home 11.10 system, when I suddenly noticed that dpkg and aptitude want to remove almost everything. Synaptic seems fine. At work, where I have an ...
0
votes
2answers
794 views

Aptitude offers to remove some packages but apt-get doesn't?

I'm trying to install mint-meta-mate which is Gnome 2 fork on 11.10 - 32bit with aptitude i get this: The following NEW packages will be installed: caja{a} cowsay{a} fortune-mod{a} ...
1
vote
0answers
1k views

GPG error from apt-get [duplicate]

Possible Duplicate: What is the easiest way to resolve apt-get BADSIG GPG errors? Whenever I run apt-get update or apt-get install I get an error akin to the following: W: GPG error: ...
1
vote
1answer
390 views

How can I use aptitude to install Nagios?

I've seen several guides online which describe downloading and building Nagios on Ubuntu servers. Is there also an aptitude package I could use to install Nagios 3?
7
votes
2answers
2k views

How to prevent apt-get/aptitude keeping a cache

I have installed Apt-Cacher NG to provide a cache of packages for several machines. I therefore see no point in having aptitude/apt-get keeping their own (second) cache in /var/cache/apt/archives. I ...
4
votes
1answer
198 views

How to force aptitude to display each search result in multiple lines?

When I am using "aptitude search", usually some results will be too long to be held in the console window. So are there any ways to display each result in multiple lines, so that I can see the full ...
0
votes
2answers
1k views

Can't install libglib2.0-dev

Since Handbrake can't be installed in Oneiric, I decided to try and build it from source instead. The build is interrupted because it complains glib is not installed, so I thought I better install the ...
4
votes
1answer
1k views

Why does aptitude want to remove a bunch of files?

Recently I encountered dependencies resolve issues when using APTITUDE (it is my favorite). Nevertheless, I started to feel that APTITUDE does not behave as it is supposed to be in 64 bits systems ...
2
votes
1answer
1k views

aptitude state is corrupt - how do I fix it?

It appears that the aptitude state is corrupt - note that apt-get and the other dpkg tools still work fine. Is there some way to reset the state of aptitude? Signs of corruption: aptitude search ...
1
vote
1answer
225 views

install package with apt-get and remove with aptitude?

Anything wrong with this practice? would it work? If I install package with apt-get and remove with aptitude? In addition, I recently removed webmin. Does apt-get --purge remove - delete also ...
2
votes
1answer
4k views

Which INPUT rules do I need to add to iptables so apt (apt-get, aptitude) can work (update, upgrade, search, install)?

I need to use aptitude to update and install software but it fails. It says... 0% [Connecting to archive.ubuntu.com] ...and halts. I need to type CTRL-C to move out. I'm using Ubuntu Server 10.04 ...
4
votes
1answer
144 views

Remove aptitude's “Press Enter To Continue” after installations

Whenever I install/update with the curses interface of aptitude, it keeps the log window open and asks you to press enter. Can I just let aptitude skip this and return to the main screen if nothing ...
10
votes
3answers
7k views

How to use wildcards with aptitude?

Is there a way to use wildcards with aptitude such as in the following: sudo apt-get remove openoffice*.*
2
votes
2answers
2k views

How to install aptitude without an internet connection?

I've just installed Ubuntu 11.04 and there no internet connection. Firstly I've tried sudo apt-get install aptitude, but it says that there's no installation for this. Then I downloaded on USB ...
1
vote
1answer
1k views

How do I remove a package with “rU” status?

I was trying to install some 32bit libraries with dpkg -i --force-architecture command. But it failed due to dependency problem. Now if I try to install 64 bit version of the same library, it says it ...
8
votes
1answer
223 views

Annotating packages at installation to ease maintenance with apt / aptitude

I manage my packages with aptitude. I occasionally go through my list of packages, removing obsolete applications (in the sense that I do not want to use them any more). For example, while I have a ...
7
votes
2answers
3k views

Is there a safe way to reinstall via the package manager?

Assume, I have a system with all the packages installed, which I want, and all configuration files set up as desired. However, the files on the file system could have become corrupted or missing due ...
1
vote
1answer
5k views

How do I install missing dependencies on my system?

I was fooling around trying to fix this problem, and I removed some important packages. When I realized that it was cleaning out more things that I had intended, I just rebooted, rather than try to ...
2
votes
2answers
742 views

How to install a package from a PPA and ignore the official one?

How do I tell aptitude to grab a package specifically from a PPA and ignore the one from official repository?
3
votes
1answer
109 views

How can I prevent a package from being automatically removed in order to install another one?

This is the example: I want to install elementary-desktop (from PPA), but it requires to remove esound in order to install pulseaudio (which I removed because it was causing problems with many apps). ...
0
votes
4answers
1k views

How to do critical system updates through the Command Line under Kubuntu 10.10

I really need to do some system updates because sometimes my S.O Kubuntu 10.10 fails to start, crash down or keeps freezing after I log in. The problem is, I cannot use KPackageKit because it ...
10
votes
2answers
13k views

How to remove warnings like `Unknown media type …`

Each time apt-get tries to process triggers for shared-mime-info, it reports warnings like: ... Processing triggers for shared-mime-info... Unknown media type in type 'all/all' Unknown media type in ...
4
votes
1answer
2k views

Crash during installation of flashplugin-installer after upgrade

I can't install flashplugin-installer after having upgraded from Maverick to Natty. Something crashes during the installation: $ sudo aptitude install flashplugin-installer The following NEW packages ...
10
votes
7answers
6k views

Ubuntu tells me I have packages to upgrade when I don't

I have a server machine that I never log into the X display on, only via ssh. Recently I logged in and it told me I had 12 packages can be updated. 6 updates are security updates. I actually ...
0
votes
2answers
176 views

Ubuntu Netbook update interrupted

I was updating my netbook latest version after 1st installation so a lot of updates where there. The updates were downloaded and it was being installed. The computer got switched off in between. Now ...
20
votes
6answers
6k views

How do I figure out what package something is in without resorting to Google?

I often find myself wanting to install something, but I'm unsure of what package it's in. This is a very common occurrence for me: $ make html sphinx-build -b djangohtml -d _build/doctrees . ...
3
votes
1answer
1k views

apt-get : unmet dependencies

I wish to compile vim7.3 with python-interp enabled, which requires python-dev package. The problem is I have python-2.6.6-2ubuntu2 while python-dev requires python-2.6.6-2ubuntu1. (I don't how i got ...
25
votes
3answers
1k views

Why was aptitude removed in favor of apt-get?

Why was aptitude removed in favor of apt-get by default? I read it somewhere, but forgot - anyone bother to clear it up? And doesn't Debian prefer aptitude and Canonical apt-get? Update From the ...
6
votes
1answer
12k views

Where can I install termcap from?

From apt-get or aptitude there's just termcap-compact, but I still see "no termcap library found" when trying to install my software (a development kit from another enterprise). This happens just on ...
22
votes
3answers
5k views

apt-get vs. aptitude .vs synaptic compatibility

I had been a Debian user for almost 3 years... but memories have gone really fuzzy... I "kind of" remember that I should only use one of the package managers... Either apt-get, aptitude, or synaptic, ...
8
votes
4answers
9k views

Why does apt-get fail when automated with cron?

I'm trying to use cron to automate my system updates. You can see my crontab, commands, and resulting errors below. When I run upgrades.sh as root, the script runs fine. When cron runs it, apt-get -y ...
3
votes
2answers
4k views

How do I pin a particular MySQL version to avoid unnecessary upgrades?

I'm running a MySQL server, and want to keep it up to date with regular apt-upgrades. I don't want this to cause MySQL to upgrade unless I'm doing it during scheduled downtime! How do I alter my ...
2
votes
2answers
621 views

What's wrong with tasksel ubuntustudio- packages?

Trying to install any of ubuntustudio- (ubuntustudio-audio, ubuntustudio-font-meta, etc.) "tasks" with tasksel always fails, saying "tasksel: aptitude failed (100)" (while other options, like ...
4
votes
1answer
3k views

aptitude update gives 404's for intrepid

I'm having issues trying to update my packages. I haven't used this server since last September and now I'm getting 404 errors on all the intrepid repos. How do I fix this? Thanks aptitude update ...
8
votes
3answers
792 views

Is there a way to check if a program is available in the repository by commandline?

When i find a interesting program i want to test and install in ubuntu i first check if it's available in the repository. For that i use the software center. But does a possibility exist to check it ...
11
votes
3answers
5k views

Why does update-mime-database complain about uri/rtspt and other unusual types?

When running update-mime-database - usually automatically launched by apt-get - why do I reliably get complaints like: Unknown media type in type 'all/all' Unknown media type in type 'all/allfiles' ...
3
votes
2answers
2k views

Can I use apt-get or aptitude to install software to non standard location?

When I install a software using apt-get it installs to default locations i.e to /usr/bin, /usr/lib, /usr/share and etc. For example when I install "Meld Diff Viewer" using sudo apt-get install meld ...
4
votes
2answers
154 views

What will be the default set of package management tools in future versions of Ubuntu?

With the introduction of Ubuntu Software Centre, I remember reading, though I can't find any reliable source right now, that the various package managers were going to eventually be deprecated. ...
2
votes
2answers
200 views

determining the source for a package upgrade

Running aptitude dist-upgrade on my system currently results in an attempt to upgrade a few packages. All of these packages are being flagged as "untrusted packages" which "could compromise your ...
4
votes
2answers
2k views

How to clean up aptitude output?

Every time I use the CLI to install something with aptitude I get this output: warning, in file '/var/lib/dpkg/status' near line 60509 package 'virtualbox-3.0': error in Version string ...
7
votes
7answers
9k views

Saving deb files from repositories to a custom location for installing offline [duplicate]

Possible Duplicate: How can I install software offline? I want to download and save some deb files, and preferably their dependencies, of certain apps, from the repositories (apt-get, ...
3
votes
3answers
2k views

apt-get upgrade segfault!

I installed ubuntu server 10.04 and booted as normal. Some time later, I booted the server and tried to install a new package/upgrade the existing packages using: sudo apt-get upgrade sudo aptitude ...