Aptitude is a quite powerful package manager leveraging CLI and an ncurses-style interface.

learn more… | top users | synonyms

4
votes
1answer
6k views

Why is apt no longer updating the kernel?

Somehow I got a 12.04 server to stop updating the kernel. It's stuck at 3.2.0-24-generic and doesn't want to fetch any new updates. The new kernel at the moment is 3.2.0-29 apt-get clean && ...
3
votes
1answer
450 views

Show available/installed version in the output of aptitude search

Is it possible to make aptitude show the available/installed version of a package in an output of aptitude search mypackage? I know that I can show the version via aptitude show mypackage, but I want ...
6
votes
2answers
340 views

What is apt and aptitude in Ubuntu?

I've been blindly copy pasting code that contains these keywords to install programs and having migrated from Windows, I don't quite understand what they mean. Can anyone explain them and their ...
6
votes
1answer
11k views

What is “Manual Package Selection” in Ubuntu Server?

What does choosing "Manual Package Selection" allow me to do, versus choosing one of the other options?
5
votes
3answers
2k views

how to uninstall all packages installed by “aptitude build-dep”

Is it possible to undo all changes made by "aptitude build-dep xxxxxx" i.e to un-install all dependencies installed by this command?
3
votes
2answers
466 views

How can I set up aptitude-curses so that it doesn't automatically select *recommended* packages?

When I select a package for installation using aptitude-curses, sometimes a huge list of extra packages appear selected under "Packages being automatically installed to satisfy dependencies". When I ...
3
votes
1answer
4k views

Using sudo aptitude/apt-get update does not work

Trying to update via terminal via aptitude or apt-get is not working. There is no other package management program running in the background or any other user. I tried both, sudo aptitude update ...
17
votes
1answer
10k views

Assign highest priority to my local repository

Summary How can I make apt-get prefer local repository packages instead of downloading again the same package version from official repositories? The local repository is signed and trusted. We've ...
2
votes
1answer
917 views

What's the meaning of “action flag” of a package?

Suppose the flag of a package is "pi". I learnt that the "i" stands for "i - the package will be installed." What's the meaning of "will be installed", please?
1
vote
2answers
2k views

ubuntu-restricted-extras wants to remove over 200 packages. Could this harm the system?

Has anybody installed ubuntu-restricted-extras yet? (You need this for example to encode mp3). When I try to install that, it wants to remove the following packages: # aptitude install ...
1
vote
2answers
480 views

How can I upgrade a package without removing its dependencies?

For some reason (having used xorg-edgers in the past might be part of that), I still have a very old X server installed: xorg 7.6+7ubuntu7.1 xserver-xorg-core 1.10.4-1ubuntu4.2 ...
1
vote
3answers
1k views

apt-get update really slow when i'm at the university

When i'm using my university connection I can't run apt-get update normally as I do at home or any other place. Everything else (that use connection) works properly. I've already tried to change the ...
0
votes
2answers
402 views

Unable to install applications (Oneiric)

When I use the software center to install something, I get the error: An unhandlable error occured There seems to be a programming error in aptdaemon, the software that allows you to ...
2
votes
1answer
1k views

Cannot install packages. “Warning: untrusted versions…” plus “method driver /usr/lib/apt/methods/http could not be found”

Judging from Internet forums, these errors appear to be popular when attempting to install packages: steve:~$ sudo aptitude install examplepackage The following NEW packages will be installed: ...
4
votes
1answer
2k views

Could not open lock file /var/lock/aptitude No such file or directory

For all those who installed aptitude to easily search through apt on ubuntu 11+, upon upgrading to 11.10 I am now receiving this error. [ ERR] Reading state information E: Could not open lock file ...
2
votes
1answer
516 views

Why does aptitude list a package as not installed while dpkg says it is installed?

When I stat on my 11.10 machine aptitude search lightdm I get this: p gir1.2-lightdm-1 - Typelib file for liblightdm-1 p liblightdm-gobject-1-0 - LightDM ...
15
votes
2answers
16k views

aptitude safe-upgrade equivalence with apt-get

Is there an equivalent to doing aptitude safe-upgrade using apt-get?
1
vote
0answers
57 views

How to undo forgetting new packages in aptitude [closed]

Can't remember how many new packages there were before I've choosen that menu item. Does aptitude remember forgotten packages after rerun?
0
votes
3answers
713 views

Get list of recommended packages (suggestions) for touch screen support after apt-get install lxde

I was manually installing X server and lxde on my cellphone's chrooted ubuntu. There were a couple of packages suggested after install related to touchscreen support. I can't remember the name of ...
10
votes
1answer
3k views

Why does aptitude give me the “Does not have Super Cow Powers” error?

When I try to update 11.10 with current updates, I receive this error message stating Does Not Have Super Cow Powers. Why is it not updating with the current security packages?
2
votes
1answer
223 views

Can't remove libreoffice3.5-dict-de package

I just installed the wrong version of LibreOffice (x86 instead of 64bit). So I tried to remove it but I get this error: > aptitude remove libreoffice3.5-dict-de Couldn't find package ...
2
votes
1answer
247 views

Byobu available updates broken on Ubuntu 10.04 LTS? [closed]

I noticed that since release of byobu 5.10 the available updates in the lower bar behaves funny: you issue for example an apt-get update available updates pop out with the #! in the lower bar ...
0
votes
1answer
117 views

aptitude package install error

apt-get install -f gives following Errors were encountered while processing: flashplugin-downloader:i386 flashplugin-installer E: Sub-process /usr/bin/dpkg returned an error code (1) I am unable ...
2
votes
2answers
665 views

How do I find a list of packages with Priority: Required?

I want to find a list of all packages with the Priority: field set to Required. These are packages that are normally installed on every system, however I've recently discovered that they aren't ...
2
votes
2answers
386 views

Uninstalling package unrecognized by aptitude

Some times ago I installed qtikz on my system, but I don't remember if I did it via dpkg -i --force-architecture or directly from source (perhaps via checkinstall). In short, it is not working and I ...
1
vote
1answer
458 views

How do I show the paths of a package in aptitude?

I know how to show the paths where I installed a package with dpkg: $ dpkg -L gnome How can I do that with aptitude?
12
votes
3answers
4k views

Why do some packages conflict with themselves?

After an upgrade to Oneiric I have had some troubles with the package manager (it wanted to remove half of my system, including libc6, zlib1g packages etc). During the fight with aptitude I've noticed ...
24
votes
1answer
19k views

Make apt-get (or aptitude) run with -y but not prompt for replacement of configuration files?

When running apt-get -y install <packages ...> on Ubuntu 10.04 I would like apt-get (or aptitude if that makes it easier) to not prompt me when installing additional dependencies (behavior of -y ...
27
votes
1answer
16k views

Restoring all data and dependencies from dpkg --set-selections '*'

So I can run on one machine: dpkg --get-selections '*' > selection.txt On another machine: dpkg --set-selections < selection.txt ... followed by either of the following: aptitude install ...
1
vote
1answer
105 views

How to upgrade MySQL to >=5.1.51 on Lucid via aptitude

The mysql-server package in Lucid is listed as 5.1.41-3ubuntu12.7. Is there a safe way to upgrade to the latest 5.1 release via aptitude?
0
votes
2answers
176 views

Install as user (not root) with aptitude to bin and lib in $HOME

I need to install some programs on a server where I cannot get super user privileges. Is there a flag or some way to get aptitude to install in my bin and lib folders in my home directory instead of ...
2
votes
2answers
2k views

Equivalent of yum distro-sync?

In redhat-based distros, the yum tool has a distro-sync command which will synchronize packages to the current repositories. This command is useful for returning to a base state if base packages have ...
0
votes
1answer
1k views

aptitude unable to find dependencies, broken packages

I installed an ubuntu on a virtual machine 6 months ago. I never needed a ssh connection until now. But when I try to install sshd, I get this error: root@onur-vmdesktop:/home/onur# apt-get install ...
0
votes
3answers
662 views

Removing packages through a list [closed]

I'm running Peppermint OS Two and it uses natty packages. I want to introduce some oneiric packages. As I go along I backup my list of packages and /var/cache/apt/archives. The plan is if I install ...
3
votes
2answers
726 views

Partially Dist-upgrade from CLI?

Sometimes a sudo aptitude upgrade fails and sudo aptitude upgrade --full-resolver then wants to remove about 100 Packages, because of "dependecy conflicts". Often I can then start update-manager and ...
0
votes
1answer
185 views

“aptitude update” as cronjob, customize the cron-mail-output

I have set up aptitude update as cronjob for root and sending the mail to my normal user account. What I want to have now, is that all the output of aptitude is ommited and instead only a ...
1
vote
0answers
3k views

Update manager generates 404 error while attempting update. Will not update [duplicate]

Possible Duplicate: How can I fix a 404 Error using a PPA? While running update manager in Ubuntu 11.10 Oneric Ocelot I receive this list of errors. > W:Failed to fetch > ...
1
vote
2answers
2k views

Installing php5 gives an error for some unment dependencies!

When I try yo install php5 using sudo aptitude install php5 I get the following error. The following packages have unmet dependencies: apache2-mpm-worker: Conflicts: apache2-mpm which is a ...
8
votes
2answers
1k views

Will aptitude be added back in 12.04 or future versions?

Since there is more space in the ISO (750MB for now) for the 12.04 version and the limit of 700MB is removed, has there been any thoughts about adding aptitude to the command line tools. I ask this ...
1
vote
1answer
283 views

Is it normal for aptitude to automatically remove packages during an installation?

Usually I install via apt-get or Software Center. For secure delete tools, I installed using aptitude. sudo aptitude install secure-delete aptitude however, removed a whole bunch of packages. ...
2
votes
1answer
220 views

Why do dpkg and aptitude want to remove MOST of my system?

I was installing and uninstalling some packages on my home 11.10 system, when I suddenly noticed that dpkg and aptitude want to remove almost everything. Synaptic seems fine. At work, where I have an ...
0
votes
2answers
888 views

Aptitude offers to remove some packages but apt-get doesn't?

I'm trying to install mint-meta-mate which is Gnome 2 fork on 11.10 - 32bit with aptitude i get this: The following NEW packages will be installed: caja{a} cowsay{a} fortune-mod{a} ...
1
vote
0answers
1k views

GPG error from apt-get [duplicate]

Possible Duplicate: What is the easiest way to resolve apt-get BADSIG GPG errors? Whenever I run apt-get update or apt-get install I get an error akin to the following: W: GPG error: ...
1
vote
1answer
480 views

How can I use aptitude to install Nagios?

I've seen several guides online which describe downloading and building Nagios on Ubuntu servers. Is there also an aptitude package I could use to install Nagios 3?
8
votes
2answers
3k views

How to prevent apt-get/aptitude keeping a cache

I have installed Apt-Cacher NG to provide a cache of packages for several machines. I therefore see no point in having aptitude/apt-get keeping their own (second) cache in /var/cache/apt/archives. I ...
5
votes
1answer
246 views

How to force aptitude to display each search result in multiple lines?

When I am using "aptitude search", usually some results will be too long to be held in the console window. So are there any ways to display each result in multiple lines, so that I can see the full ...
0
votes
2answers
2k views

Can't install libglib2.0-dev

Since Handbrake can't be installed in Oneiric, I decided to try and build it from source instead. The build is interrupted because it complains glib is not installed, so I thought I better install the ...
4
votes
1answer
1k views

Why does aptitude want to remove a bunch of files?

Recently I encountered dependencies resolve issues when using APTITUDE (it is my favorite). Nevertheless, I started to feel that APTITUDE does not behave as it is supposed to be in 64 bits systems ...
2
votes
1answer
1k views

aptitude state is corrupt - how do I fix it?

It appears that the aptitude state is corrupt - note that apt-get and the other dpkg tools still work fine. Is there some way to reset the state of aptitude? Signs of corruption: aptitude search ...
1
vote
1answer
243 views

install package with apt-get and remove with aptitude?

Anything wrong with this practice? would it work? If I install package with apt-get and remove with aptitude? In addition, I recently removed webmin. Does apt-get --purge remove - delete also ...