Aptitude is a quite powerful package manager leveraging CLI and an ncurses-style interface.

learn more… | top users | synonyms

3
votes
0answers
808 views

How to list installed packages in apt that are not backed by a repository? [duplicate]

I suppose you could build a list of all packages that would be installed if you started with an empty apt database and installed everything that deborphan -a currently tells you. Then compare that ...
3
votes
2answers
481 views

Installing Wine with aptitude

I'm trying to install Wine on Ubuntu Precise. I'm used to using aptitude for package management, so I tried to use that to install Wine. When I do that, I'm told I have to resolve dependencies that ...
3
votes
1answer
4k views

Using sudo aptitude/apt-get update does not work

Trying to update via terminal via aptitude or apt-get is not working. There is no other package management program running in the background or any other user. I tried both, sudo aptitude update and ...
3
votes
2answers
1k views

Aptitude install error

I'm running apt-get install aptitude but it gives me this error:‌ Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. ...
2
votes
3answers
2k views

Ubuntu repository change

After I have performed one of sudo apt-get install eclipse eclipse-cdt g++ procedure I found that Ubuntu is planning to download more than 400Mb and it will take more than 2 hours. It is too long. I ...
2
votes
2answers
2k views

How to install aptitude without an internet connection?

I've just installed Ubuntu 11.04 and there no internet connection. Firstly I've tried sudo apt-get install aptitude, but it says that there's no installation for this. Then I downloaded on USB ...
2
votes
1answer
5k views

how do I install Aptitude on Ubuntu

I was trying to install MemCached using this command: sudo aptitude install memcached, but I got the following error: sudo: aptitude: command not found. After researching, I found out that Aptitude ...
2
votes
1answer
302 views

Is it possible to do only the download part of apt-get/aptitude full-upgrade?

When I go to internet cafe, I'd like to take that opportunity to upgrade the system. Sometimes though there is not electrical sockets in the cafe. To conserve batteries I'd like to be able to only do ...
2
votes
1answer
954 views

What is aptitude's extended state information

I have both apt-get and aptitude installed on my system. When I am performing any operation using aptitude, I see Reading extended state information and Writing extended state information. These ...
2
votes
2answers
1k views

How do I find a list of packages with Priority: Required?

I want to find a list of all packages with the Priority: field set to Required. These are packages that are normally installed on every system, however I've recently discovered that they aren't ...
2
votes
1answer
999 views

list of apt-get packages for upgrade

I have a 9.10 machine used for development by one of my colleagues. A new team member has joined us, and he wants to have the same development environment on his 10.04 machine as the one used on the 9....
2
votes
1answer
179 views

Aptitude trying to remove a lot of packages

I'm trying to install libmysqlclient-dev with aptitude and it keeps saying it will remove these packages: The following packages will be REMOVED: esound-common gstreamer1.0-pulseaudio gyp ...
2
votes
1answer
552 views

What happens when we cancel apt-get install manually or due to network failure

hi today I was installing mongodb using apt-get its 114 mb download , when apt-get was running I lost network connection so downloading stopped so cancelled it using Ctrl + c . Later when my ...
2
votes
1answer
2k views

“E: The method driver /usr/lib/apt/methods/htp could not be found.” after removing the LAMP task

So, I tried uninstalling the LAMP stack I had following the Ubuntu documentation for it. I also manually removed dbconfig-common. Now, I'm unable to run apt-get update. When I do, I get the error ...
2
votes
1answer
1k views

Cannot install packages. “Warning: untrusted versions…” plus “method driver /usr/lib/apt/methods/http could not be found”

Judging from Internet forums, these errors appear to be popular when attempting to install packages: steve:~$ sudo aptitude install examplepackage The following NEW packages will be installed: ...
2
votes
2answers
393 views

Uninstalling package unrecognized by aptitude

Some times ago I installed qtikz on my system, but I don't remember if I did it via dpkg -i --force-architecture or directly from source (perhaps via checkinstall). In short, it is not working and I ...
2
votes
1answer
2k views

aptitude state is corrupt - how do I fix it?

It appears that the aptitude state is corrupt - note that apt-get and the other dpkg tools still work fine. Is there some way to reset the state of aptitude? Signs of corruption: aptitude search ...
2
votes
1answer
1k views

What's the meaning of “action flag” of a package?

Suppose the flag of a package is "pi". I learnt that the "i" stands for "i - the package will be installed." What's the meaning of "will be installed", please?
2
votes
1answer
560 views

Why does aptitude list a package as not installed while dpkg says it is installed?

When I stat on my 11.10 machine aptitude search lightdm I get this: p gir1.2-lightdm-1 - Typelib file for liblightdm-1 p liblightdm-gobject-1-0 - LightDM ...
2
votes
1answer
284 views

Byobu available updates broken on Ubuntu 10.04 LTS? [closed]

I noticed that since release of byobu 5.10 the available updates in the lower bar behaves funny: you issue for example an apt-get update available updates pop out with the #! in the lower bar apt-...
2
votes
2answers
2k views

Equivalent of yum distro-sync?

In redhat-based distros, the yum tool has a distro-sync command which will synchronize packages to the current repositories. This command is useful for returning to a base state if base packages have ...
2
votes
1answer
232 views

Why do dpkg and aptitude want to remove MOST of my system?

I was installing and uninstalling some packages on my home 11.10 system, when I suddenly noticed that dpkg and aptitude want to remove almost everything. Synaptic seems fine. At work, where I have an ...
2
votes
2answers
2k views

How to install a package from a PPA and ignore the official one?

How do I tell aptitude to grab a package specifically from a PPA and ignore the one from official repository?
2
votes
2answers
212 views

determining the source for a package upgrade

Running aptitude dist-upgrade on my system currently results in an attempt to upgrade a few packages. All of these packages are being flagged as "untrusted packages" which "could compromise your ...
2
votes
2answers
119 views

How do I block a specific VERSION of a package to be installed by aptitude (or apt-get)?

I have a problem with a program crashing, and I suspect that only the latest version of the package has this problem, so I wish to block this particular version from ever being installed – but I still ...
2
votes
1answer
3k views

How to find packages when updating Ubuntu and creating standard source.list file

I just upgrade to Ubuntu 14.04 LTS, amd64. I'm trying to install some software and it says for Ubuntu 13.10 and above, the following libraries need to be installed for 32-bit compatibility components:...
2
votes
1answer
154 views

apt-get install automatically cancelled

When I'm doing an update or installation on Ubuntu 13.10, the task is automatically cancelled in the terminal. I got this error since that the \boot partition was missing some space. I fixed this ...
2
votes
1answer
779 views

Downgrading a package with older version “physically” in the repository

I want to downgrade from OpenJDK Update 25 to OpenJDK Update 21. If I look, for example, at security.ubuntu.com or at mirror.pnl.gov, I can see that .deb files for Update 21 are still there, however, ...
2
votes
1answer
225 views

Can't remove libreoffice3.5-dict-de package

I just installed the wrong version of LibreOffice (x86 instead of 64bit). So I tried to remove it but I get this error: > aptitude remove libreoffice3.5-dict-de Couldn't find package "libreoffice3....
2
votes
2answers
644 views

What's wrong with tasksel ubuntustudio- packages?

Trying to install any of ubuntustudio- (ubuntustudio-audio, ubuntustudio-font-meta, etc.) "tasks" with tasksel always fails, saying "tasksel: aptitude failed (100)" (while other options, like lamp-...
2
votes
0answers
55 views

Aptitude is unmarking packages as “Auto”, is this a bug or feature?

I have a brand new Ubuntu server installation and go in to aptitude. Whenever I set a package to remove, the default action is the equivalent of apt-get autoremove. However, it seems that when you go ...
2
votes
0answers
349 views

xfonts installation failed and apt compromised

I started the installation of all the xfonts packages on my Ubuntu 14.04.1 system with sudo apt-get install xfonts-* While extracting a package (one of the hundreds of the list), the system got ...
2
votes
0answers
139 views

New apt tool vs. aptitude

Ubuntu Utopic has recently introduced a new package management frontend named apt (manpage) which provides a sort of high-level interface to tools apt-get, apt-cache and some other tools in the apt-* ...
2
votes
1answer
2k views

Error encountered when using dpkg to install packages (--configured)

I used sudo aptitude update and sudo aptitude upgrade to update the packages, and encountered an error when processing the package man-db (with --configure). A few days later, same error occured with ...
2
votes
0answers
128 views

Aptitude - Both 64 & 32-bit packages being selected

In aptitude, I selected the xubuntu-desktop task and was presented with a large number of package conflicts, per this example: It seems that both the 32- and 64-bit versions of packages are being ...
2
votes
2answers
470 views

kolab 3.0 sources

I'm attempting to install Kolab 3.0 following these steps on 12.04 Server, yet showpkg still shows 2.2.4 :~$ cat /etc/apt/sources.list.d/kolab.list deb http://mirror.kolabsys.com/pub/ubuntu/kolab-3....
2
votes
0answers
369 views

configure says I don't have lib, but aptitude says I do

I've just run a configure script which alerts me: checking for gcry_control in -lgcrypt... no configure: error: libgcrypt not found. Install libgcrypt or use --disable-libgcrypt. Have a nice day. ...
2
votes
0answers
166 views

Rollback instead of completing dpkg-configure -a? [duplicate]

On a new VPS, aptitude dist-upgrade hangs during /usr/sbin/grub. Now, aptitude is in a bad state: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. I ...
1
vote
3answers
1k views

Why would the aptitude binary be missing if its package is installed?

Yesterday I upgraded a laptop from Kubuntu 9.04 (Lucid) to 9.10 (Karmic). Then afterwards I tried to install some software $ sudo aptitude install dont-remember-what-it-was and I get sudo: ...
1
vote
5answers
12k views

How to completly remove php libraries?

I use zsh. when I try to upgrade the system, some packages related to php pop up, I want to remove them sudo apt-get upgrade Reading package lists... Done Building dependency tree ...
1
vote
2answers
963 views

Aptitude offers to remove some packages but apt-get doesn't?

I'm trying to install mint-meta-mate which is Gnome 2 fork on 11.10 - 32bit with aptitude i get this: The following NEW packages will be installed: caja{a} cowsay{a} fortune-mod{a} ...
1
vote
3answers
1k views

16.04 : “aptitude” at the command line

After upgrading to 16.04 I tried to use "sudo aptitude update" at the command line and got the error that the command was not found. What do I need to do to be able to use it again?
1
vote
2answers
208 views

Find and download a package without sudo using aptitude [duplicate]

I would like to install a bunch of packages (glogg, libprotobuf7, libleveldb1, libsnappy1, libhdf5-7) on an Ubuntu system on which I do not have root privileges. (I understand that this can be ...
1
vote
2answers
59 views

aptitude - Package removal on jdk installation

I tried the following command aptitude install sun-java6-jdk It prompts me that the following packages will be removed. ant{u} ant-gcj{u} ant-optional{u} ant-optional-gcj{u} ca-certificates-...
1
vote
2answers
2k views

Installing php5 gives an error for some unment dependencies!

When I try yo install php5 using sudo aptitude install php5 I get the following error. The following packages have unmet dependencies: apache2-mpm-worker: Conflicts: apache2-mpm which is a ...
1
vote
1answer
547 views

How can I use aptitude to install Nagios?

I've seen several guides online which describe downloading and building Nagios on Ubuntu servers. Is there also an aptitude package I could use to install Nagios 3?
1
vote
1answer
20 views

Why so many “removed but not purged” packages?

Running aptitude search '~c' prints a whole bunch of removed but not purged packages, including, e.g., all kernels I have ever had installed (starting with linux-image-3.19.0-30-generic). Why haven'...
1
vote
1answer
1k views

500 Internal Server Error whenever I use apt-get

I'm running ubuntu 12.04 I'm getting a huge number of "500 Internal Server Error" errors whenever I try to apt-get install/upgrade. aptitude yields exactly the same errors. I know there are ...
1
vote
1answer
231 views

Wrong autocompletion with sudo apt-get

Does anybody know why if I type: apt-get upg<TAB> I get: apt-get upgrade but if I type: sudo apt-get upg<TAB> I get: sudo apt-get upgrade-from-grub-legacy
1
vote
2answers
2k views

ubuntu-restricted-extras wants to remove over 200 packages. Could this harm the system?

Has anybody installed ubuntu-restricted-extras yet? (You need this for example to encode mp3). When I try to install that, it wants to remove the following packages: # aptitude install ubuntu-...