Aptitude is a quite powerful package manager leveraging CLI and an ncurses-style interface.

learn more… | top users | synonyms

1
vote
0answers
14 views

trying to upgrade from 15.10 to 16.04 but I got error

I tried to do it but I got these massages which are and also
1
vote
0answers
37 views

What is a correct way to remove old boost version and install new one?

I want to delete libboost1.54-dev(which I think was installed via sudo apt-get install --no-install-recommends libboost-all-dev) and install libboost1.56-devon Ubuntu 14.04. Seems command sudo apt-...
0
votes
1answer
49 views

Warnings and errors when updating Aptitude with multiple architectures enabled

I have an Odroid XU3 with Ubuntu installed on it. I recently installed qemu-user-static for the purpose of running i386 binaries. Part of this process was adding the URLs of a repository I can ...
0
votes
0answers
10 views

Aptitude group by automatic/manual

My current aptitude grouping setting is: --\ The default grouping method for package views task,status Is it possible to also group by whether the package is marked Auto or Manual?
0
votes
1answer
29 views

Make “aptitude” automatically choose solution “Install” instead of “Keep”

I'm trying to automatically install packages without asking user any questions. For the below situation, aptitude chooses "Keep" as the first solution, and doesn't install pkg_b. And I want to force ...
1
vote
0answers
31 views

What does the aptitude `why` and `why-not` mean?

From the manuals: The command why finds a dependency chain that installs the package named on the command line, as above. Note that the dependency that aptitude produced in this case is only a ...
0
votes
0answers
47 views

How to remove all garbage packages with aptitude

I am getting a big garbage package list obtained with the command: aptitude search ~g or aptitude search ?garbage (These commands Select packages that are not required by any manually ...
4
votes
3answers
121 views

Synaptic & aptitude broken after upgrade from 15.10 to 16.04

after I upgraded Ubuntu Gnome 15.10 (Wily Werewolf) to 16.04 (Xenial Xerus), I cannot start synaptic or aptitude for installing new software, and 'apt-get install whatever' does not work either. Here ...
0
votes
1answer
27 views

How to make Apt/Aptitude prefer a more recent virtual package over a real one

I've recently built a package which provides multiple virtual ones, more specifically snmp which provides libsnmp-base, libsnmp30 and so on: Version: 5.8~git20160427.8d07349f-14 Depends: ... ...
1
vote
3answers
640 views

16.04 : “aptitude” at the command line

After upgrading to 16.04 I tried to use "sudo aptitude update" at the command line and got the error that the command was not found. What do I need to do to be able to use it again?
18
votes
5answers
50k views

How to remove/install a package that is not fully installed?

I went to install bsnes the other day and for whatever reason the installation failed. Now, I cannot update, install new packages, or do basically any apt-get commands as they all try to process this ...
0
votes
1answer
213 views

KVM + Xenial Server. libvirt-bin won't configure

I just (foolishly) completed the upgrade from 14.04.4 to 16.04. Apparently there's a bug due to the introduction of systemd that breaks libvirt... or I've broken aptitude. Is there a workaround or fix ...
1
vote
1answer
19 views

Why so many “removed but not purged” packages?

Running aptitude search '~c' prints a whole bunch of removed but not purged packages, including, e.g., all kernels I have ever had installed (starting with linux-image-3.19.0-30-generic). Why haven'...
14
votes
3answers
7k views

apt-get or aptitude equivalent to yum whatprovides

Is there an equivalent to the yum "whatprovides" option in apt-get? For example on CentOS yum whatprovides /usr/share/gdm/themes/TreeFlower/background.png Tells me redhat-logos-4.9.99-11.el5....
2
votes
0answers
131 views

New apt tool vs. aptitude

Ubuntu Utopic has recently introduced a new package management frontend named apt (manpage) which provides a sort of high-level interface to tools apt-get, apt-cache and some other tools in the apt-* ...
1
vote
1answer
65 views

aptitude: symbol lookup error: aptitude: undefined symbol

When I run the following in my terminal: aptitude search linux-headers | grep ^i I get the following error: aptitude: symbol lookup error: aptitude: undefined symbol: ...
14
votes
3answers
5k views

Why do some packages conflict with themselves?

After an upgrade to Oneiric I have had some troubles with the package manager (it wanted to remove half of my system, including libc6, zlib1g packages etc). During the fight with aptitude I've noticed ...
3
votes
1answer
2k views

Installing clang 3.8 on Ubuntu 14.04.3

I've tried the following obvious commands: sudo apt-get update sudo apt-get install clang-3.8 but I get the message: Reading package lists... Done Building dependency tree Reading state ...
0
votes
0answers
37 views

On Ubuntu 14.04.3, ansible won't install python-keyczar on selected hosts - manual apt-get install python-keyczar -y works

I get this series of errors when trying to do a service install using the apt module with Ansible on an Ubuntu 14.x box. On most of the other Ubuntu 14.x boxes it works fine. There's a handful that ...
0
votes
0answers
41 views

Cannot Upgrade Ubuntu 15.10 - insserv and dpkg errors

I am currently unable to upgrade my Ubuntu 15.10 system using the apt-get dist-upgrade or aptitude dist-upgrade commands. If I recall correctly, the last change made was the installation of vncserver....
1
vote
0answers
225 views

Error opening the cache: could not open file /var/lib/dpkg/status - open (13: permission denied)

I got the following error: Error opening the cache: could not open file /var/lib/dpkg/status - open (13: permission denied) I cannot update my system at all. When I hit update I get that all the ...
146
votes
6answers
70k views

Is aptitude still considered superior to apt-get?

When I first started with Ubuntu using aptitude was the 'in-thing', with some stated improvements over apt-get. Am I correct in saying that apt-get has now 'caught up' with aptitude, and it makes ...
4
votes
3answers
19k views

how do I downgrade google chrome?

Presumably after an update, google chrome has very serious problems with page rendering. I want to downgrade it. (Switching to vmlinuz.old and initrd.img.old did not help). $ apt-cache policy google-...
0
votes
0answers
212 views

Aptitude upgrade does not work with dangling link

I am trying to do a full upgrade but getting this scary looking dangling link error, I also don't understand how the system got into an inconsistent state. sudo aptitude upgrade The following ...
15
votes
4answers
19k views

Why does “tasksel” give an “aptitude failed” error?

The problem started in the following way. I was using tasksel from the terminal menu that it shows when I simply do sudo tasksel. I select Lamp Server from the list and started to install all packages ...
9
votes
6answers
28k views

Errors running apt-get update and apt-get install mysql-server

Since yesterday I've been trying to run apt-get update unsuccessfully in Ubuntu instances I am creating on the EC2. In specific I've been getting these errors: Ign http://security.ubuntu.com ...
0
votes
0answers
29 views

why is 'aptitude upgrade' not seeing same packages as 'apt-get upgrade'?

I've always used aptitude to perform system updates. Today I noticed there were some updates waiting which aptitude search "~U" showed. When I tried to apply them, they were not there. I ran aptitude ...
5
votes
1answer
2k views

Force update from unsigned repository Ubuntu 16.04

I using an unsigned repo in Ubuntu 16.04 from Debian multimedia deb http://www.deb-multimedia.org jessie main To install deb-multimedia-keyring I'm running apt-get update && apt-get install ...
35
votes
1answer
27k views

Make apt-get (or aptitude) run with -y but not prompt for replacement of configuration files?

When running apt-get -y install <packages ...> on Ubuntu 10.04 I would like apt-get (or aptitude if that makes it easier) to not prompt me when installing additional dependencies (behavior of -y ...
3
votes
2answers
892 views

Aptitude install error

I'm running apt-get install aptitude but it gives me this error:‌ Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. ...
0
votes
0answers
15 views

Install older GNU toolchain

I need to compile my project using older version of GLIBC (GLIBC 2.15). For this reason I decided to install separate machine with older toolkit. Usually I do sudo apt-get -y install g++ But how I ...
0
votes
0answers
111 views

Broken packages error apt-get

I am trying to install ia32-libs. Following:http://stackoverflow.com/a/23307732/3646408 root@abhishek-sve15118en:/etc/apt/sources.list.d# apt-get install ia32-libs Reading package lists... Done ...
0
votes
1answer
62 views

Broken packages and how to deal with them

After installing Xmind software I got recommendation with removing packages. What kind of problem is it and what is general way of solving it and how to deal in current situation? aptitude output: ...
0
votes
1answer
28 views

Create new admin account with other account's software already installed

I have an admin account(say X) where I have installed some 50 software packages. Now I want to create another admin account(say Y) who can use all 50 software packages. Is this possible? How do I ...
1
vote
0answers
16 views

What's the difference between 'suggest' and 'recommends' package in apt terminology? [duplicate]

root@xxx:~# aptitude show gcc Package: gcc New: yes State: installed Automatically installed: no Version: 4:5.2.1-3ubuntu1 Priority: optional Section: devel Maintainer: Ubuntu Developers <ubuntu-...
0
votes
1answer
35 views

Log of all dependencies installed with a package

I installed xinit and ubuntu-desktop on my web server as an experiment. I want to remove them, so I ran apt-get autoremove for each of them. Much less space was freed than was used in installation. I ...
5
votes
2answers
700 views

Trying to remove Ubuntu-desktop with tasksel returns “aptitude failed”

I am following this guide trying to turn my Ubuntu-desktop-installation into Ubuntu-server. However, I am having problems already in step 2. Using tasksel to remove/install anything returns with: ...
1
vote
1answer
146 views

Hadoop & Spark - why no Ubuntu packages?

I want to install Hadoop & Spark using aptitude, not the lengthy and complicated process described in How to install Hadoop?. hadoop-ubuntu appears to have been dead for almost 2 years. I wonder ...
1
vote
2answers
116 views

Segmentation fault in aptitude

On our 64 bit Lubuntu 14.04 system, aptitude has started crashing with a bunch of scrolling errors, ending up with a seg fault. *** Error in `aptitude': free(): invalid next size (fast): ...
4
votes
1answer
90 views

Aptitude showing only links instead of full package descriptions

I recently installed Ubuntu 15.10, and now Aptitude is showing only a link to the package's homepage instead of a full description that it used to show in my previous installation of 14.04. What can I ...
1
vote
1answer
26 views

Aptitude - disable saving selections

If I mark packages to install in aptitude but I exits from aptitude without installing this packages aptitude remember this selections. How to prevent aptitude to remember this selections? I want to ...
35
votes
8answers
16k views

How to see packages installed on a given date using aptitude

Does anyone know if there's an easy way to find a list of packages installed, sorted by date, when using aptitude (or apt-get)? I was installing a bunch of packages to try something new, and it didn'...
0
votes
0answers
43 views

apt-get uses vivid sources after failed trusty distro-upgrade attempt

I tried updating from Trusty to Vivid. I ran the update-manager and it failed after 2 minutes because appearantly it was confused with some third party packages and untrusted sources. I decided to fix ...
1
vote
1answer
407 views

libdevmapper unmet dependencies

I am trying to install libvirt 1.2.7 from sources on Ubuntu 12.04 (64bit) LTS. In order to compile libvirt, libdevmapper-dev is required. I a getting following error while installing libdevmapper-dev ...
1
vote
1answer
30 views

Does “aptitude search '~U'” require “aptitude update” to display correct information?

As the title says: If I run aptitude search '~U’ do I need to run aptitude update before in order to get the correct results? The aptitude documentation says: ?upgradable | ~U | Select packages ...
27
votes
3answers
7k views

apt-get vs. aptitude .vs synaptic compatibility

As a former Debian user, I "kind of" remember that I should only use one of the package managers... Either apt-get, aptitude, or synaptic, but not the three in combination 'cause there may be ...
0
votes
1answer
410 views

Why don't these packages download?

I was following this guide: http://developer.ubuntu.com/en/start/ubuntu-for-devices/porting-new-device/ and when I got to the step: Then, install all the other packages you will need for the ...
3
votes
1answer
335 views

How do you fix unmet dependency when installing Cinnamon on Ubuntu 14.04?

How do you fix unmet dependency when installing Cinnamon on Ubuntu 14.04? I attached a bunch of info on what I've tried so far. Attempt 1: So I found this question on how-to install cinnamon on ...
10
votes
2answers
29k views

What's difference of apt-get and aptitude? [duplicate]

What is difference of apt-get and aptitude? Does both of them use same repositories? Which one is better?
0
votes
0answers
121 views

Having trouble installing i-nex

This is what happens when i try install it. fraser@fraser-All-Series:~$ sudo apt-get install i-nex [sudo] password for fraser: Reading package lists... Done Building dependency tree Reading ...