Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

learn more… | top users | synonyms (1)

369
votes
15answers
508k views

How do I resolve unmet dependencies after adding a PPA?

Occasionally, when I'm installing stuff, I get an error like the following: Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the ...
154
votes
5answers
245k views

How can I fix a 404 Error when using a PPA or updating my package lists?

PPA seems to be constantly offline. Whenever I use sudo apt-get update, this error is shown: W: Failed to fetch http://ppa.launchpad.net/ 404 Not Found How do I fix these errors?
267
votes
8answers
226k views

How do I fix a “Problem with MergeList” or “status file could not be parsed” error when trying to do an update?

The computer gave me this output in a window: E: Encountered a section with no Package: header E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_natty_main_binary-...
317
votes
15answers
889k views

Unable to lock the administration directory (/var/lib/dpkg/) is another process using it?

I get this error when trying to use apt-get: E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable) E: Unable to lock the administration directory (/var/lib/dpkg/) is ...
39
votes
8answers
74k views

How do I remove a malformed line from my sources.list?

I have unistalled and reinstalled the Ubuntu Software Center as per info I found in a similar thread and I got the same response about line 91 or something like that. I just tried to upload a screen ...
157
votes
10answers
203k views

How do I fix the GPG error “NO_PUBKEY”?

I added some extra repositories with the Software Sources program. But when I reload the package database, I get an error like the following: W: GPG error: http://ppa.launchpad.net trusty ...
227
votes
13answers
162k views

Trouble downloading packages list due to a “Hash sum mismatch” error

When I check for updates, I get a "Failed To Download Repository Information" error. This is what comes up under details: W: Failed to fetch gzip:/var/lib/apt/lists/partial/us.archive.ubuntu....
645
votes
23answers
597k views

How can PPAs be removed?

I've added many PPAs using the add-apt-repository command. Is there a simple way to remove these PPAs? I've checked in /etc/apt/sources.list for the appropriate deb lines but they aren't there. This ...
153
votes
7answers
180k views

How can I get apt to use a mirror close to me, or choose a faster mirror?

Downloading from the main Ubuntu archive is slow even when it's not release day, how can I get apt-get to automatically use a mirror that is close to me?
112
votes
6answers
76k views

What is the easiest way to resolve apt-get BADSIG GPG errors?

I frequently cross this issue, and always have to google for an answer. Does anyone have a permanent fix for BADSIG errors from apt-get? W: GPG error: http://download.virtualbox.org lucid ...
146
votes
25answers
239k views

How to fix Duplicate sources.list entry?

I keep getting this warning whenever I try to run sudo apt-get update. W: Duplicate sources.list entry http://archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages (/var/lib/apt/lists/archive....
14
votes
8answers
17k views

Failed to download repository information due to missing CDROM

When updating I got this error message: W:Failed to fetch cdrom://Ubuntu 11.10 _Oneiric Ocelot_ - Release amd64 (20111012)/dists/oneiric/main/binary-i386/Packages Please use apt-cdrom to make this ...
22
votes
3answers
26k views

How do I fix this “E:Type '*' is not known on line * in source list …” update error?

Every once in a while I see users having issues to update due to errors like this: E:Type 'ain' is not known on line 1 in source list /etc/apt/sources.list.d/some-ppa.list' with varying types/line ...
17
votes
6answers
99k views

Permission denied, are you root?

I get this error whenever I try to install programs using the terminal: home@ubuntu:~$ apt-get install myunity E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied) E: Unable ...
854
votes
18answers
1.3m views

How to list all installed packages

I'd like to output a list of all installed packages into a text file so that I can review it and bulk-install on another system. How would I do this?
189
votes
5answers
167k views

How can I accept the Microsoft EULA agreement for ttf-mscorefonts-installer?

After a recent update, ttf-mscorefonts-installer prompted me to accept its license agreement. For some reason my terminal will not allow me to accept, or for some reason I am pressing the wrong ...
85
votes
7answers
34k views

No more updates for Google Chrome | apt-get update error

I am using Google Chrome 48.0 32-bit. Today when I launched Google Chrome, I got this message: This computer will soon stop receiving Google Chrome updates because this Linux system will no longer ...
103
votes
5answers
255k views

Unable to correct problems, you have held broken packages

After upgrading from 10.04 to 12.04 I am trying to install different packages. For instance ia32-libs and skype (4.0). When trying to install these, I am getting the 'Unable to correct problems, you ...
40
votes
5answers
319k views

“Unable to locate package” while trying to install packages by apt

When I try to install any package through the command line, I get an error. Can anyone help me on this? $ sudo apt-get install <package> Reading package lists... Done Building dependency tree ...
80
votes
7answers
87k views

My /boot partition hit 100% and now I can't upgrade. Can't remove old kernels to make room

My first issue was when i tried to apt-get update/upgrade. On upgrade I get the following error: You might want to run 'apt-get -f install' to correct these. The following packages have unmet ...
201
votes
4answers
201k views

What is “dist-upgrade” and why does it upgrade more than “upgrade”?

I was wondering why upgrade sometimes doesn't want to upgrade certain parts of the system, while dist-upgrade does. Here's an example after running update: apt-get upgrade: rimmer@rimmer-Lenovo-...
286
votes
9answers
655k views

What does “sudo apt-get update” do?

I am wondering what sudo apt-get update does? What does it update?
36
votes
9answers
128k views

'apt-get' does not work with Proxy

For the command sudo apt-get update I get following error: W: Failed to fetch http://ch.archive.ubuntu.com/ubuntu/dists/maverick-updates/multiverse/binary-i386/Packages.gz 407 Proxy ...
41
votes
2answers
135k views

What does Package <package> has no installation candidate mean?

What does the above Error mean? What is an installation candidate? I was trying to do sudo apt-get install munin-memcached and I get this message: Reading package lists... Done Building ...
64
votes
10answers
103k views

How to create a local APT repository?

I would like to build my own local repository on my LAN, so that machines on the LAN can update and upgrade from it. I want to download the packages and store them on my local server so that I can ...
3
votes
0answers
2k views

How do I fix “malformed line” errors in sources.list? [duplicate]

Possible Duplicate: How do I remove a malformed line from my sources.list? I had problems with my movie player. The sound was fine but the picture seemed to hesitate or stick or pause every ...
33
votes
10answers
57k views

Unable to install Skype on 64bit Ubuntu

I am receiving the following message while I am trying to install Skype: nidhin@ubuntu:~$ sudo apt-get update nidhin@ubuntu:~$ sudo apt-get install skype Reading package lists... Done Building ...
392
votes
12answers
314k views

“The following packages have been kept back:” Why and how do I solve it?

I just added a PPA repository for the development version of the GIMP, but I get this error The following packages have been kept back: gimp gimp-data libgegl-0.0-0 libgimp2.0 Why and how can I ...
54
votes
1answer
24k views

create a .deb Package from scripts or binaries

I searched for a simple way to create .deb Packages for things which have no source code to compile (configs, shellscripts, proprietary software). This was quite a problem because most of the package ...
102
votes
7answers
100k views

Not enough free disk space when upgrading

I'm getting an error in software updater when I try and do my daily updates. it says: The upgrade needs a total of 25.3 M free space on disk `/boot`. Please free at least an additional 25.3 M of disk ...
8
votes
8answers
38k views

Got NODATA issue: 'NODATA' (does the network require authentication?)

I can use my mobile broadband to access Internet with Firefox but when I want to install any package from terminal or make 'apt-get update' command I got the following error: got 'NODATA' (does the ...
92
votes
9answers
133k views

How do you select the fastest mirror from the command line?

I want to update my sources.list file with the fastest server from the command line in a fresh Ubuntu Server install. I know this is trivially easy with the GUI, but there doesn't seem to be a simple ...
31
votes
9answers
179k views

apt-get update fails to fetch files, “Temporary failure resolving …” error

Err http://archive.canonical.com natty InRelease Err http://security.ubuntu.com oneiric-security InRelease Err http://extras.ubuntu.com natty InRelease ...
98
votes
5answers
87k views

How do I get and modify the source code of packages installed through apt-get?

I am assuming that all application installed through apt-get are open source; but for those that are available in that manner, where can I get the source code for these applications as well as update ...
-3
votes
0answers
393 views

Unable to locate package [duplicate]

There are many questions about Unable to locate package. For example : if user try to install package by using apt-get then the following error shown. (Here package is used only as example for ...
12
votes
4answers
17k views

Can't install libglew-dev because libcheese and libclutter don't have the required versions

I'm getting the following error message when attempting to install libglew-dev, Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not ...
24
votes
3answers
147k views

how to install packages with apt-get on a system connected via proxy?

I've got an Ubuntu 11.10 system connected via a proxy to the internet, and I would like to install packages via apt-get. When I try to do that I get this error message: sudo apt-get install libboost-...
18
votes
5answers
64k views

How to remove desktop environments?

I installed few environments that I wanted to try out on Ubuntu 12.04, but none of them worked at all. It could be that I installed them all at the same time, meaning the OS didn't get a chance to ...
176
votes
1answer
311k views

Installed Teamviewer using a 64-bits system, but I get a dependency error

I was trying to install Teamviewer, but I was getting a dependency error. I tried to install them, but with no luck. I'm getting this error: Unpacking teamviewer (from teamviewer_linux_x64.deb) ... ...
27
votes
5answers
7k views

the size of apt-get update lists is too big

This question contains circumventions for an bug in Ubuntu: Bug #1001780 “apt-get update size is too big” : Bugs : Launchpad itself, as well as some general advice on saving bandwidth when doing ...
10
votes
4answers
4k views

Update Manager Error - Authentication Error

When I run Update Manager I get this error: This is what the error box says: W: A error occurred during the signature verification. The repository is not updated and the previous index files ...
23
votes
3answers
34k views

“The package lists or status file could not be parsed or opened”

Everytime I sudo apt-get update it always not complete and will say in the end E: Read error - read (5: Input/output error) E: The package lists or status file could not be parsed or opened. Same ...
7
votes
1answer
9k views

GPG Error while downloading software: “Clearsigned file isn't valid, got 'NODATA'”

After installing Ubuntu 13.10 I try to install ubuntu-restricted-extras or any software, it shows me: E: GPG error: http://archive.canonical.com saucy InRelease: Clearsigned file isn't valid, got '...
39
votes
5answers
36k views

How to set up an APT repository?

I would like to set up an APT repository on a server that will provide a couple of packages. Is there a way to set one up without installing any software on the server? How do the files have to be ...
113
votes
6answers
82k views

Why am I getting authentication errors for packages from an Ubuntu repository?

I'm experimenting with VPNs, so I wanted to install pptpd. john@desktop:~$ sudo apt-get install pptpd [sudo] password for john: <snip> The following extra packages will be installed: bcrelay ...
156
votes
5answers
193k views

How to Downgrade a Package via apt-get?

How to downgrade a package to an older version via apt-get?! Another tools are also accepted but apt-get is preferred.
84
votes
5answers
55k views

How do I show apt-get package management history via command line?

Is there a way to show the history of packages that were changed by apt-get via command line?
23
votes
6answers
73k views

Package system is broken. How to fix it?

I just recently bought an arduino and requires gcc-avr/avrdude to compile the software. I installed avr for another microprocessor component a while ago but is obviously an outdated version (gcc ...
14
votes
4answers
49k views

Can't find boot-repair package for the newest version of Ubuntu

After upgrading Ubuntu 13.10 to 14.04, grub failed to load Ubuntu and threw the error symbol 'grub_term_highlight_color' not found. I followed the solution offered in the Bug Report but this failed ...
76
votes
4answers
21k views

apt-get update only for a specific repository

When I add a PPA and I want to install some of its content, it is quite annoying to re-update all my apt list using apt-get update. Is it instead possible to only sync the content of a given ...