Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

learn more… | top users | synonyms (1)

1
vote
1answer
254 views

E: Malformed entry 54 in list file /etc/apt/sources.list (Component)

I'm relatively new to Ubuntu 16.04, and everything has been going fine until my OS threw this error today. Below is the source code from /etc/apt/sources.list for line 54: deb ...
1
vote
1answer
20 views

apt-get upgrade gives GPG Error [duplicate]

How would I go about fixing this error? I have pycharm installed through a ppa that I have been using for years in various computers. W: GPG error: ...
1
vote
1answer
12 views

How to convert a deb package to udeb

Following up on How to install squid-deb-proxy-client via preseed/early_command, I want to have a udeb of the squid-deb-proxy-client package. From reading the Debian wiki it seems it should be easy ...
1
vote
1answer
17 views

how to install a specific package version

I'm building my first debian package (django), which needs some dependencies, so I was wondering if it's possible to install a specific package version with apt-get. For example instead of pip ...
0
votes
0answers
6 views

I can't share ethernet over the hotspot created in ubuntu 14.04

Earlier I could share the ethernet over Wifi Hotspot. But now I cant do it. I can create the hotspot and connect to it via my iphone but cant use the internet. I've tried everything. I even have the ...
1
vote
1answer
20 views

Redirecting apt-get output

So there's some output from apt-get that I can't seem to redirect anywhere else. Here's a sample of what I see: sudo apt-get -qq -y --force-yes install cowsay 2>&1 > /tmp/tmp.txt This is ...
1
vote
1answer
122 views

Unable to install libpcre3-dev in ubuntu 14.10

I am trying to install libpcre3-dev in ubuntu 14.10 and sudo apt-get install libpcre3-dev gives me the following error : The following packages have unmet dependencies: libpcre3-dev : Depends: ...
2
votes
2answers
4k views

How to resolve that error when I try to install build-essential?

I can't install build-essential on my laptop : It shows error: The following packages have unmet dependencies: build-essential : Depends: g++ (>= 4:4.4.3) but it is not going to be installed ...
0
votes
0answers
8 views

Installing Teamspeak via PPA

I want to install teamspeak client on Kubuntu 16.04. Of course I could download the .deb file from teamspeak.com, but I want to update it via apt-get. According to this article ...
0
votes
0answers
14 views

Error installing Samba4

I'm using Ubuntu Server 15.10 Wily. When I run: apt-get install samba In the end it generates a error, can someone help? Note: There was a samba compilation before and I have performed one # make ...
1
vote
1answer
15 views

Install Landscape dedicated server

I am having an issue to install landscape on prem. I receive the following message: sudo apt-get install landscape-server Reading package lists... Done Building dependency tree Reading ...
0
votes
0answers
16 views

Error do-release-upgrade

The following error when trying to update the version 15:10 to 16:04 version. # do-relase-upgrade Traceback (most recent call last): File "/tmp/ubuntu-release-upgrader-r8fv67ku/xenial", line 8, in ...
-1
votes
4answers
19k views

How to install Canon LBP2900 printer in ubuntu 12.10

Sir.. I have recently upgraded to ubuntu 12.10. I recently bought Canon LBP2900 printer. Unfortunately I tried to install it ..there is no use. Please tell me how to install it and work with it.
1
vote
1answer
190 views

Holding packages in Ubuntu 15.10, Unexpected un-hold. does APT knows when particular HW modules are updated?

I held the Kernel so while updating, the newer kernel version weren't marked for installation until yesterday. It is a security update so I know is recommended to do this update but the question is ...
0
votes
1answer
20 views

Unable to install package linux-image-3.13.0-83-generic

I get this message and I do not know what to do: $ sudo apt-get install git Reading package lists... Done Building dependency tree Reading state information... Done >E: The package ...
0
votes
1answer
17 views

apt-get wants to auto delete important packages

when i'm using apt-get upgrade, it shows me this, but I need those packages, how can I require those packages? root@K411:~# apt-get upgrade Reading package lists... Done Building dependency tree ...
9
votes
5answers
21k views

node: command not found

I don't understand why the node command will not work, whereas nodejs works: $ node --version zsh: command not found: node $ nodejs --version v0.10.15 I tried apt-get install nodejs, but the latest ...
0
votes
0answers
7 views

E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages in ubuntu 14.04

I am using ubuntu 14.04 and after updating smtube and youtube-dl I got this message on top bar of ubuntu desktop with a red circle containing a minus sign. I tried all that is available on posts. Help ...
0
votes
0answers
14 views

Disabling proxy problem

I've tried disabling the proxy using various command lines, it worked until I tried Maven clean install. Here's what is happening, $ mvn clean install[INFO] Scanning for projects... [INFO] ...
-1
votes
0answers
12 views

Installation DRAFTSIGHT [on hold]

Bonjour, je viens de télécharger Draftsight mais je n'ai pas réussi à l'installer ni via Qapt ni via Gdebi. Maintenant lorsque j'essaie de faire mes mises à jour, j'obtiens ce message d'erreur sudo ...
0
votes
0answers
24 views

sagemath-upstream-binary 7.2: install on Trusty fails because of size mismatch after download

The command, issued after sudo apt-get update, and the subsequent events are copied below. It seems to me that a 629 MB download is expected, whereas an actual 216 MB takes place, is this the cause of ...
0
votes
1answer
31 views

installing pip3 (for python3) on ubuntu 16.04 LTS using a proxy

I have tried entering: sudo apt install python3-pip The error I get is: $ sudo apt install python3-pip Reading package lists... Done Building dependency tree Reading state ...
0
votes
1answer
47 views

Why does Ubuntu Software Center not show every package available?

The Software Center in Ubuntu 16.04 (Gnome Software) shows only part of the packages available. While e.g. apt list qtcreator correctly lists the corresponding package a search in Software Center ...
0
votes
0answers
20 views

apt-get upgrade issue : Sub-process /usr/bin/dpkg returned an error code (1) [on hold]

I have had this problem for a while and would like to fix it. I am a newbie at the terminal. Any help would be appreciated. After running sudo apt-get upgrade in the terminal: Reading package ...
2
votes
3answers
662 views

List all versions of a package

Is there a equivalent of this command; yum list kernel-headers --showduplicates on Ubuntu with apt-get, apt-cache etc. The above command lists various versions of the kernel-headers rpm available on ...
1
vote
2answers
41 views

held broken packages after purging and trying to reinstall skype

I use 16.04 64 bit desktop and had skype installed from the partners repository. Because of issues with sending messages, I wanted to reinstall it. I ran: sudo apt purge skype sudo apt autoremove ...
2
votes
1answer
25 views

apt: relocation error: version GLIBCXX_3.4.21 not defined in file libstdc++.so.6 with link time reference

Since trying to upgrade to 16.04 xenial, I'm getting $ apt apt: relocation error: /usr/lib/x86_64-linux-gnu/libapt-pkg.so.5.0: symbol ...
0
votes
0answers
25 views

Install python3-setuptools

After this sudo apt-get install python3-setuptools: icedtea-7-jre-jamvm : depends: openjdk-7-jre-headless (= 7u101-2.6.6-0ubuntu0.14.04.1) but 7u95-2.6.4-0ubuntu0.14.04.2 will be installed. ...
-3
votes
0answers
20 views

How do I blacklist apache2?

I have done just about everything I can find on Google to blacklist apache2 on my machine (I run a custom version of nginx instead) and apache2 keeps coming back on its own. I have gone through these ...
12
votes
4answers
13k views

Find (and reinstall) packages with corrupted files (without breaking anything)

I usually prefer to fix a Linux system than to reinstall from scratch. My computers have seen many distribution upgrades and a list of PPAs or third-party repositories. APT usually makes sure that ...
0
votes
1answer
28 views

How to remove the MySQL Server 5.5 from Ubuntu 14.04?

I wanted to upgrade my MySQL server and client from v5.5.49 to the latest v5.6.*. To do this I firstly tried to uninstall the old version: $ apt-get remove mysql-server-5.5 mysql-server-core-5.5 ...
-1
votes
2answers
2k views

“The following packages were automatically installed and are no longer required:” what to do?

After trying to open and install google earth through the terminal it keeps bringing up this message. The following packages were automatically installed and are no longer required: ...
0
votes
0answers
19 views

How do I show all packages linked to a certain library?

I am looking for a way to show all packets linked to a certain library. ldd /path/to/file shows me all libraries linked to a certain file. What I want to know is: which packages available on my ...
2
votes
1answer
707 views

Apt wants to remove ubuntu-mate-desktop

To preface my question, I already know about this question, but it doesn't have any answers (plus it's for an older version), so I'm opening this one, because this is becoming a pretty big issue for ...
0
votes
0answers
23 views

Ubuntu 14.04 update wants to remove ubuntu-mate-desktop?

I've seen Apt wants to remove ubuntu-mate-desktop, but this is different. I use MATE desktop, and my Ubuntu is: $ uname -a Linux MYPC 4.2.0-36-generic #42~14.04.1-Ubuntu SMP Fri May 13 17:27:22 UTC ...
0
votes
0answers
20 views

howto show all packets with a certain dependency [duplicate]

i want to find out which packets link to openssl on my system. what would be the bash command to get that information. i know that using ldd /path/to/file i can see what links to a certain binary or ...
3
votes
3answers
48k views

How to install VLC in ubuntu 12.04 64-bit?

Can anybody help me to install VLC media player in Ubuntu 12.04 64-bit?
2
votes
3answers
991 views

Errors when installing wine in ubuntu 14.04 LTS

I have followed the below procedures to install wine in Ubuntu 14.04 LTS: add-apt-repository ppa:ubuntu-wine/ppa apt-get update apt-get install -y wine However, I see the below error messages: ...
0
votes
0answers
18 views

Error while using the Software Updater [duplicate]

I upgraded to 16.04 the day it was released; the process went smoothly. Last couple of days though I've been receiving the error message below when doing a software update, whether via the update ...
2
votes
0answers
18 views

How to add personal apt sources?

I have a decent number of debian packages I've compiled myself, that I keep on a personal build server. I want to be able to use apt-get install to install these but am unsure how to point to all the ...
171
votes
1answer
297k views

Installed Teamviewer using a 64-bits system, but I get a dependency error

I was trying to install Teamviewer, but I was getting a dependency error. I tried to install them, but with no luck. I'm getting this error: Unpacking teamviewer (from teamviewer_linux_x64.deb) ... ...
0
votes
0answers
15 views

Terminal fails to connect to a proxy server

I am trying to connect to the proxy server of my university. I have successfully logged in to proxy via firefox but when trying to use ftp or wget I get the following error: Resolving ...
2
votes
1answer
49 views

Unable to update with 'apt-get': errors

Can't run sudo apt-get update , I get errors like: E: Type '--2016-05-25' is not known on line 1 in source list /etc/apt/sources.list.d/playonlinux.list E: The list of sources could not be read.
0
votes
1answer
4k views

Fix “Package system is broken” error without synaptic

The package system is broken If you are using third party repositories then disable them, since they are a common source of problems. Now run the following command in a terminal: apt-get install -f ...
1
vote
0answers
37 views

Unable to locate package libqt4-core and libqt4-gui on Ubuntu 16

I am not an experienced user and I am having trouble installing Torch on my Ubuntu server. Apt is unable to find libqt4-core and -gui. I've read another thread saying to use dpkg but I cannot find the ...
0
votes
1answer
20 views

How to install the “Links 2” browser in Lubuntu?

I went to the official website but they had this complicated list of steps where I had to manually check a bunch of dependencies and then download a tarball, only to have to follow a further list of ...
0
votes
1answer
38 views

Unable to Install package from Ubuntu Xenial local repo

I created a local repo for Xenial using apt-mirror. When I tried sudo apt-get update in another machine (of course, I configured the webserver), I am getting the following errors and I am not able to ...
0
votes
2answers
36 views

“E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages” after long time without using ubuntu

After months of not using ubuntu, I turned on my PC and when I typed the usual apt-get update then upgrade, a red icon showed on my panel and when I clicked to upgrade packages, the Software Updater ...
0
votes
1answer
20 views

ignore-depends options passed from apt-get not behaving as expected

A package being installed with apt-get has a dependency on java that I want to ignore. $ apt-cache depends some-package some-package PreDepends: <java7-runtime-headless> ...
1
vote
1answer
2k views

Use apt-get in chroot directory

I am currently in need of using apt-get on a chroot directory. The setup is the following. I have a chroot setup with schroot. This chroot environment needs to be stripped down as much as possible. ...