Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

learn more… | top users | synonyms (1)

0
votes
0answers
14 views

Problem in invoke sudo make install in python script

I have written the following code to configure yara package in my script, but when it call sudo make install, python give me error. How can I fix it? def yara_installation(self): os.chdir("...
0
votes
2answers
36 views

Installing ubuntu packages within python script

I want to install following packages within my python script : python-pip python-sqlalchemy mongodb python-bson python-dpkt python-jinja2 python-magic python-gridfs python-libvirt python-bottle ...
0
votes
0answers
9 views

Cannot connect to internet or sudo apt-get in Ubuntu Server

I installed Ubuntu Server on an old windows laptop. I have my computer connected through an ethernet and I absolutely cannot get anything to work through sudo apt-get. Im very new to Linux, but I ...
2
votes
1answer
43 views

Can't install Programs Through APT

Since I last reinstalled ubuntu 16.04 I am having issues using apt. When I try (ubuntu-desktop (fixing another error), unity-tweak-tool etc) I get the error saying that there's unmet dependencies ...
1
vote
2answers
69 views

apt-get install not working [E: Read error - read (5: Input/output error)]

I have an old problem (since a week) with apt-get which prevents me from installing and upgrading packages. I have Ubuntu 16.04. I am receiving this message on the top bar: Error: opening the cache (...
0
votes
2answers
15 views

Package [zfsnap] installed incorrectly - what's what?

On Ubuntu Xenial server, installing zfsnap exists with error status 0. However, the package isn't properly installed: $ zfsnap zfsnap: command not found $ $ sudo dpkg -p zfsnap dpkg-query: package '...
5
votes
1answer
41 views

How to install new versions of G++ that use the corresponding C++ standard library?

I am trying to install multiple versions of the g++ compiler for testing purposes. I would like to be able to install g++ 4.9.3,5.1.0, 5.2.0, and 6.1.0. I know that I can do sudo add-apt-...
2
votes
1answer
1k views

Unable to use apt-get or cpan

I am using Ubuntu 12.10. A few days back I needed to change my proxy for connecting to the internet at my institute. After that I can't access the internet through terminal like can't install CPAN lib ...
1
vote
1answer
33 views

How to install Python 3.4.5 from apt?

I have Python 3.5 installed.I previously installed Python 3.4 from source and managed to uninstall it somehow. Now if I try to install Python 3.4 through apt-get install python3.4 , it returns ...
22
votes
13answers
121k views

apt-get update cannot find ubuntu servers

Running sudo apt-get update fails on my server (that has a 'net connection). Are the servers temporarily broken, or is my apt misconfigured and using old servers? In short, how do I fix this? Here's ...
0
votes
0answers
24 views

Unable to install any package with apt-get

When I am trying to install git using apt-get. I am using a Pre-Configured VM machine in my laptop which is configured for hadoop (CDH) environment. I got it from my coaching institute. It is Ubuntu ...
4
votes
2answers
395 views

ubuntu resolve unmet dependencies

I have tried to upgrade from ubuntu 14.10 to 15.04, it stopped upgrading and offered a partial upgrade which I didn't do. Right now I'm having an issue with deja-dup-monitor which is consuming about ...
0
votes
0answers
13 views

Python problem with Let's Encrypt

When trying to use the following command to setup my certs: ./letsencrypt-auto --apache -d example.com I get this error from Python: dpkg: dependency problems prevent configuration of python-...
0
votes
0answers
12 views

Can't access sudo apt update and sudo apt upgrade [duplicate]

After I Update and Install Ubuntu Software Like this enter image description here I can't process apt update, and get this error E: Could not get lock /var/lib/apt/lists/lock - open (11: Resource ...
1
vote
1answer
66 views

Fix Package Dependencies?

I'm trying to install build-essential using sudo apt-get install build-essential like I'm supposed to. It returns with the error The following packages have unmet dependencies: build ...
0
votes
0answers
7 views

Having issues with mime-support and apt

This error is being reported with any instance of apt or apt-get that I run: package mime-support 3.59ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error ...
7
votes
4answers
291 views

“apt-get update” always failed to fetch

I don't understand why this issue could be survive. It display this error message all the time Fetched 32.8 MB in 1min 16s (430 kB/s) W: Failed to fetch http:/...
848
votes
18answers
1.3m views

How to list all installed packages

I'd like to output a list of all installed packages into a text file so that I can review it and bulk-install on another system. How would I do this?
0
votes
1answer
60 views

Ubuntu 16.04 : can t apt due to mysql-server-5.7 issue

I m trying to install / update packages and everytime the process failed because of a mysql-server error : sudo apt install graylog-server Lecture des listes de paquets... Fait ...
-1
votes
0answers
14 views

How to trick apt-get into believing a package version is different?

The package I want to upgrade "is already the newest version". But I am using a previous version of it and what to see what happens if I upgrade it now. This package comes preinstalled on Linux ...
36
votes
3answers
120k views

E: Unable to correct problems, you have held broken packages

I am using Ubuntu 13.04 which I installed few days back. I am trying to install nodejs and npm. I tried to install from command line first and then uninstalled it. Then something broke. sudo apt-get ...
0
votes
1answer
11 views

Unable to update any software packages in VMWare Ubuntu

I want to understand why I am unable to install any packages. I am trying to install hadoop, but for that Ubuntu 14.04 & Java 7 or above are prerequisite and I cannot install them: sudo apt-get ...
0
votes
0answers
37 views

No GUI after upgrade in Kali linux [on hold]

I have upgraded my system yesterday using synaptic. I have continued installing even though some files were missing after download. Then after restarting, there is no GUI. The screen stops at Kali ...
0
votes
1answer
455 views

14.04 Cleanly upgrade to ppa:ondrej/php from ppa:ondrej/php5-5.6

I went through my usual server package upgrades today and discovered that ppa:ondrej/php5-5.6 has been depreciated and we must now upgrade to ppa:ondrej/php. The basic provided instructions are to ...
1
vote
2answers
554 views

dpkg broken by oracle-java8-installer

I want to remove the oracle-java8-installer but it gives the below errors. Perhaps good to mention that I messed a bit with apt, e.g. at some point I manually removed the apt cache (but the java ...
1
vote
1answer
27 views

Webupd8 Oracle Java8 on rpi missing javaws.policy

I'm trying to install Oracle java8 on my raspberry pi 3. My script follows the instructions at http://www.webupd8.org/2012/09/install-oracle-java-8-in-ubuntu-via-ppa.html. I tried both the option of ...
2
votes
2answers
66 views
+50

FileZilla: The following packages have unmet dependencies

I am trying to install FileZilla 3.19 but I get this error when running apt-get install filezilla: Reading package lists... Done Building dependency tree Reading state information... Done Some ...
0
votes
0answers
22 views

Can not update Restricted extras

The message that I receive when trying to play any audio file: Required plugin could not be found Videos requires to install plugins to play media files of the following type: MPEG-1 Layer ...
0
votes
0answers
12 views

Software center error, tried recommended commands, no dice [duplicate]

Software center just closes, error message sent. Here is what I am left with. Thanks in advance. rustybucket@rustybucket:~$ sudo apt-get autoclean [sudo] password for rustybucket: Reading package ...
0
votes
0answers
8 views

failed to remove dnscrypt-proxy

I am trying to remove dnscrypt-proxy from my system I tried to run sudo apt-get remove dnscrypt-proxy and then i get this error Removing dnscrypt-proxy (1.6.1-1pmo3~xenial) ... Failed to stop ...
2
votes
2answers
122 views

Can't purge old kernels (dependency problems), but /boot is out of space

I'm running Ubuntu 14.04.4 LTS, and I'm trying to install a new package using apt-get. Unfortunately, whenever I try I get messages like: The following packages have unmet dependencies: linux-image-...
0
votes
0answers
27 views

Avoid updating system while installing Ubuntu 14.04

I'd like to install Ubuntu 14.04 with Preseed out of a local archive. While installing, the routine wants to enter directory "trusty-updates" and can't find it just because it is not in the archive. ...
1
vote
1answer
135 views

Symantec Class 3 G4 intermediate certificate missing from ca-certificates/ca-certificates-java

I hope that you can help. I did a search and didn't find this exact issue. A vendor of ours recently updated their SSL certificate using a Symantec intermediate certificate. Our java process was no ...
312
votes
14answers
884k views

Unable to lock the administration directory (/var/lib/dpkg/) is another process using it?

I get this error when trying to use apt-get: E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable) E: Unable to lock the administration directory (/var/lib/dpkg/) is ...
0
votes
0answers
33 views

Ubuntu 16.04 Error Processing archive mysql-common

I've a problem when I'm tried to run apt-get update, error appears as follows: Reading package lists... Done Building dependency tree Reading state information... Done You might want to run '...
4
votes
3answers
14k views

nginx dependency problem trying to upgrade

Trying to upgrade my Ubuntu 12.04 vps I get the following error: henrik@neung:~$ sudo apt-get upgrade [sudo] password for henrik: Reading package lists... Done Building dependency tree ...
1
vote
1answer
21 views

How can I install php5-mcrypt

When I try to use sudo apt-get install php5-mcrypt to install php5-mcrypt, I receive the following error. I used sudo apt-get install lamp-server^ to install the php5 ahmad@ubuntu:/var/www/html$ sudo ...
0
votes
0answers
21 views

Unable to downgrade GNOME from 3.20 to 3.18

I'd like to downgrade GNOME because 3.20 on my Ubuntu 16.04 is a mess. There are countless sources on the Internet (including askubuntu) saying how to do this, and it's always: sudo ppa-purge ppa:...
34
votes
2answers
42k views

Installing PHP 5.6 on Xenial (16.04)

I need to use php5 (5.6) because I'm working on a Drupal 7 project which doesn't support php7. The problem is I recently updated to ubuntu 16.04 Xenial which seems to no longer support php5. I tried ...
0
votes
0answers
21 views

sudo apt-get install virtualbox downloading the android studio [duplicate]

I am using kubuntu and I used this command yesterday to download android studio sudo apt-get install android-studio and then I saw it installing the same file android-studio zip file that I have ...
1
vote
0answers
25 views

How do I install an older version of Google Chrome?

I'm not to familiar with Ubuntu, but I need to install the previous version because the current one has some bugs. I went to here and found the version that I wanted: http://www.ubuntuupdates.org/...
0
votes
1answer
65 views

I can't install softwares after failed removal of Python 3 (python3-pkg-resources)

I have two python in my computer 2.7 and 3.4. I stupidly assumed that 2.7 is the default python in ubuntu and tried to uninstall python3 using this command sudo apt-get remove python3 While in the ...
0
votes
0answers
16 views

At Login says security update and package upgrade available but unable to install [duplicate]

When i login i see 8 packages can be updated. 7 updates are security updates. When i try apt-get update Hit:1 http://us.archive.ubuntu.com/ubuntu xenial InRelease Hit:2 http://us.archive....
0
votes
0answers
14 views

Error:Unable to correct problems, you have held broken packages

Yesterday,I ran the command sudo apt-get autoremove pythonby mistake,and Toady something bad happened when I startup my machine.My desktop missed.Therefore,I run sudo apt-get install ubuntu-desktop,...
0
votes
1answer
14 views

How to get a list of all packages installed from PPAs even for PPA repositories that may have been removed

I've already seen this question: How to list all the packages which are installed from PPAs? It only works for packages installed from PPAs where the PPA repository is still added to the system. Is ...
0
votes
2answers
28 views

Verifying installation: 'apt-cache policy' vs 'which'

I have searched for every variation of this question for days and I have not been able to find a clear explanation therefore I come to the collective knowledge here in the hopes of resolving my ...
0
votes
0answers
20 views

Upgrade to 15.04 didn't finish correctly: how to resolve failed issues? [on hold]

I upgraded Ubuntu from 12.04 to 15.04, and during the upgrade - I noticed that the setting of changing keyboard's language direction (from L2R to R2L) failed, along with the upgrades/installation of ...
2
votes
1answer
249 views

“sudo apt-get upgrade” not working

I am using Ubuntu 12.04 installed on a Dell Vostro 15 3000 series laptop. when I hit sudo apt-get update it works fine and then I hit sudo apt-get upgrade it shows me: and then when i press Y ...
1
vote
2answers
31 views

Accidentally deleted current kernel [duplicate]

I've been very stupid and while trying to free space on /boot, I think I've accidentally deleted my current kernel. How it happened: >>uname -i linux-image-extra-4.4.0-24-generic now uname ...
4
votes
1answer
6k views

apt-get not working behind socks proxy

I am trying to connect a Ubuntu 12.04 machine to a socks proxy server. I have my 192.168.30.0/24 LAN, and dante socks proxy server is running on 192.168.30.134:1018. I have also a pfsense router on ...