Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

learn more… | top users | synonyms (1)

0
votes
3answers
2k views

apt-get update fails to find some mirrors

I've configured my sources to use the mirrors:// "protocol" to find servers close to me, mainly since I move around a lot. However, for some reason it doesn't work for all the repos - when I run sudo ...
0
votes
1answer
122 views

Ubuntu 12.04.2 upgrade issue

Before the upgrade (Ubuntu web server) was run, I had run apt-get auto-remove. Upgrade went forward and failed. Currently not able to connect to it. sudo networkmanager says: command not found ...
0
votes
1answer
732 views

12.04 64-bit how to solve, pcscd : Depends: libccid (>= 1.4.1~) but it is not going to be installed or pcsc-ifd-handler?

I need to install a package but its failing in 12.04 64 -bit. root@sun-To-be-filled-by-O-E-M:/var/tmp# apt-get install pcscd Reading package lists... Done Building dependency tree Reading ...
0
votes
1answer
102 views

Update from 12.10 to 13.04 does not work?

When trying to update through sudo apt-get update I am getting these errors: I am kinda new to Ubuntu so any help would be appreciated :) W: Failed to fetch ...
2
votes
0answers
19 views

Unmet dependencies (libgssapi-krb5-2: Depends: libkrb5-3 (= 1.10.1 + dfsg-4) but 1:10 + dfsg ~ beta1-2 is installed) [duplicate]

How do I solve this dependency? root @ server :/ # apt-get upgrade Reading package lists ... ready Building dependency tree Reading state information ... ready You might want to run `apt-get-f ...
1
vote
2answers
210 views

Install a Program from a Directory with All of Its Dependencies

Suppose I have a directory in which I have .deb packages for two programs with all there dependencies. I want to know if there is a apt or dpkg command, or another program to install one out of these ...
0
votes
1answer
81 views

Any way to tabulate the package name and license avail on Ubuntu repo? [duplicate]

I need to create a table with all installable packages on first column and its license in the second. e.g.: Gedit | GPL
0
votes
1answer
524 views

Ubuntu update problem [duplicate]

I`m trying to update & upgrade my current version of Ubuntu but I have some problems : When I run apt-get update i get the following errors : W: Failed to fetch ...
2
votes
0answers
44 views

Why does `apt-get install python-` remove everything? [duplicate]

Have a look at the output of this simulated apt-get: $ apt-get -s install python- NOTE: This is only a simulation! apt-get needs root privileges for real execution. Keep also in mind that ...
0
votes
1answer
848 views

Updating problems Ubuntu 12.10

Whenever I try to update my computer by opening the Update Manager I get this problem and it just closes. Can someone help me? W:GPG error: http:/packages.medibuntu.org quantal InRelease: The ...
2
votes
2answers
304 views

How can I install Vagrant on 12.04 if ruby-json is already installed?

I tried to install the software , which are in software center and new software like virtual box, but it is showing the error: Items cannot be installed or removed until the package catalog is ...
2
votes
1answer
529 views

Apt-get retries download endlessly

May be I am putting this wrong. I have this problem: for some packages apt-get retries download endlessly (but does not get stuck), like this: Need to get 19.3 MB/20.0 MB of archives. After this ...
3
votes
1answer
163 views

Does installed from source software get overwritten by automatic updates?

As an example I've installed libcurl v7.30 from source, using their tutorial: ./configure --disable-ipv6 --enable-ares make make install I've had libcurl installed from the official repository ...
0
votes
1answer
354 views

Ubuntu menu and applications bar gone, and some programs too

I was following this guide (https://help.ubuntu.com/community/OpenCV) in order to install openCV. sudo su sudo apt-get install build-essential sudo apt-get install libavformat-dev sudo apt-get ...
2
votes
0answers
3k views

How do I setup a fine grained preseed with tasksel set to manual?

I am trying to preseed a netboot install of Ubuntu 13.04 (Raring Ringtail) x64. Work Setup My preseed configuration works fine as long as tasksel is not set to manual. For example: [...] d-i ...
1
vote
1answer
4k views

“cannot determine current directory” while building Haskell in 13.04

I'm trying to install the Haskell Platform on Raring. Since there's no apt package, I've downloaded the GHC 7.4.2 binary x86_64 distribution (which is a prerequisite), and I am trying to run ...
1
vote
1answer
236 views

Upgrade from 12.10 to 13.04 failed, now neither Software Center nor Software Updater will open

The update to 13.04 was offered, I accepted but it failed. Now neither Software Centre nor Updater will open. SC opens for a second then closes; Updater tells me: Failed to load the package list This ...
3
votes
2answers
1k views

How can I install git-annex assistant

I install recently git annex in ubuntu 12.10 using APT. However, the package seems to be built without the assistant support. Is there a PPA or another way of installing it ? I'd rather avoid ...
3
votes
1answer
191 views

Release upgrade notification after upgrade completed

I've upgraded my ubuntu server to the 13.04 release. Unfortunately during the upgrade process I lost the connection to the server and the server hasn't completed correctly the upgrade to this release. ...
0
votes
1answer
392 views

Unable to update by sudo apt-get update in the terminal [duplicate]

john:~$ sudo apt-get update E: Type 'ain' is not known on line 3 in source list /etc/apt/sources.list.d/ferramroberto-filezilla-oneiric.list E: The list of sources could not be read. when I run ...
1
vote
1answer
491 views

Lost/Deleted dpkg (package manager for Debian). How do I get it back?

OS: Ubuntu 12.04 Accidentally deleted dpkg. Now, packages can't be installed. So, needs an dpkg installer which installs packages.
0
votes
3answers
53 views

asking on using apt to install packages

i'm new to using ubuntu or any linux distro. On reading and watching tutorials on the internet, I've seen others just use sudo apt-get install package-name while others do these commands before ...
1
vote
1answer
99 views

I just lost /var/lib/dpkg

I have an empty /var/lib/dpkg and as consequence both apt and dpkg are starting to complain about everything and with every simple task I would like to do with them: there is a way to rebuild that ...
0
votes
1answer
513 views

software “qucs” could not be installed on 13.04; but could be installed on 12.04 by apt-get

Unfortunately the package "qucs" which could be installed on Ubuntu 12.04, got the following error and could not be installed on Ubuntu 13.04. Package qucs is not available, but is referred to by ...
7
votes
1answer
8k views

Obsolete packages vs. orphaned packages

What is the difference between obsolete and orphaned packages? More specifically, why does deborphan produce this: dave@ubuntu:~$ deborphan libbind9-80 libllvm3.1 libgrail5 libpython3.2 libsvga1 ...
-2
votes
1answer
1k views

Ubuntu 13.04 installation problem

I have tried the install numerous times but it always has a apt error when it finishes checking the CD-ROM. Sorry, I forgot what the full name is.
3
votes
1answer
243 views

Upgrade release - with fallback options, or do it virtually

So then the 13.04 release came along. Unfortunately I have only had trouble with earlier upgrades and always ended up in a FUBAR and consequently reinstalling entire system. Would like to avoid that ...
0
votes
2answers
361 views

Authentication required for every 1 hour for Internet but NO proxy. How do I get out from this problem?

OS: Ubuntu 12.04 and/or above My system connected to University campus Internet which has no proxy. But needs authentication (username and password) for every 1 hour. If the web-browser is running ...
0
votes
2answers
31k views

Unable to locate package when running apt-get

I installed rvm and it tells me I'm missing some packages: viggy@viggy:~$ rvm requirements Installing requirements for ubuntu, might require sudo password. Skipping `apt-get update` make sure your ...
2
votes
1answer
2k views

v12.10 can't apt-get update

I know there are lots of questions posed about this, but after troubleshooting for several hours, I'm not sure what to do anymore... I first installed Ubuntu 12.10 and had no internet access at all. ...
1
vote
1answer
11k views

Command “apt-get-repository” doesn't work on Ubuntu 12.04 [closed]

I'm trying to install Libreoffice 4.0 on Ubuntu 12.04. I try to begin with add the repository. sudo add-apt-repository ppa:libreoffice/libreoffice-4-0 I get this output: sudo: apt-get-repository: ...
0
votes
1answer
690 views

Upgrading to Ringtail 13.04 broke some APT repositories?

When I run sudo apt-get update on Ringtail, I get this: Err http://overviewer.org debian/./ amd64 Packages 404 NOT FOUND [IP: 208.69.124.224 80] and Err http://overviewer.org debian/./ i386 ...
4
votes
2answers
426 views

How to reduce the size of apt-get update list on a Development Release once it has been released as Stable?

I have been using the development version of 13.04 since early March. In development release, the general behavior of running the sudo apt-get update command is to download the list files completely ...
0
votes
2answers
153 views

avoid reinstall virtualbox and update to the latest release

Installing virtualbox-extension-pack-4.2.12 to enable USB2.0 controller prompted only to work with the latest release. But my current version is 4.0.18 on debian wheezy. The latest release of ...
5
votes
4answers
31k views

Uninstall an specific version of PostgreSQL

I have Postgresql 9.1.1 in my Ubuntu 12.04 which got installed due to automatic upgrades and whenever I uninstall it using the command: sudo apt-get --purge remove postgresql-9.1.1 I get an error ...
0
votes
1answer
1k views

How do I get Glibc >= 2.16.0?

I know there are already built packages for Pidgin. I need to build Pidgin so I can build plug-ins. I need Glibc >= 2.16.0. Unfortunately, I get stuck in an endless dependency loop. I need ...
3
votes
2answers
707 views

How to instruct apt-get and/or synaptic to install from source code? [duplicate]

As I asked in the title, I would like to know how to setup Synaptic or how to instruct apt-get to install/upgrade software exclusively from source. I mean, apt-get/synaptic install only pre-compiled ...
1
vote
2answers
948 views

apt authentication failure on self-signed package

I did create a gpg key using "gpg --gen-key", here is the listing: > gpg --list-keys /home/<user>/.gnupg/pubring.gpg -------------------------------- pub 2048R/99EDE0B7 2013-02-05 uid ...
0
votes
0answers
31 views

Problem installing i-mscp [duplicate]

I have a problem on my Ubuntu...When I try to install i-mscp I get this error: Reading package lists... Done W: Duplicate sources.list entry ro.archive.ubuntu.com/ubuntu/ precise/multiverse i386 ...
0
votes
2answers
3k views

Unable to locate any package error

Just a second before closing my question as duplicated, I want to say I have already looked at the other similar questions and didnt find any appropriate answer :(. I have a clean set up of Ubuntu ...
1
vote
0answers
3k views

Using 13.04 I get “Duplicate sources.list entry” warnings from i386 and AMD64 packages [duplicate]

I understand this was a bug in Oneric, but was fixed, so why is Raring trying to fetch both achetypes when I use APT in the terminal, and how do I fix it? I tried running YPPA and it says I have no ...
1
vote
1answer
6k views

Couldn't find any package by regex - ruby

I need to install ruby1.9.3-dev sudo apt-get install ruby1.9.3-dev Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package ...
3
votes
1answer
2k views

Why am I getting the error E: Package php5-gd has no installation candidate when trying to install php5-gd?

I am trying to install php5-gd and receive this error Reading package lists... Done Building dependency tree Reading state information... Done Package php5-gd is not available, but is referred to by ...
-1
votes
1answer
46 views

Why does Ubuntu GNOME recommend make?

Running apt-cache depends ubuntu-gnome-desktop lists, among other things, GNU Make as a recommend. apt-cache depends gnome doesn't list Make. Why? It doesn't seem like Make and GNOME would be in any ...
1
vote
1answer
103 views

Install a package manager without package manager

I'm doing some work on a really, really minimalistic Debian dist and noticed that there is no package manager on it. Can anyone tell me how I can fix this? There is no GUI but I have a Internet ...
0
votes
1answer
956 views

Unable to install qt-sdk unmet dependencies

I tried to install qt-sdk under ubuntu 12.10 how can I fix this issue? install log: apt-get install qt-sdk Reading package lists... Done Building dependency tree Reading state information... ...
0
votes
2answers
2k views

Ubuntu 12.04 I can't download anything… at all

I recently upgraded from Maveric(10.10) to 12.04 (by wiping out Maveric from my system completely) I was using a pen drive, so it messed up my grub. I finally managed to reinstall the grub on the ...
1
vote
1answer
1k views

Dependency error while installing cinnamon

I get following error while installing Cinnamon sudo apt-get install cinnamon Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be ...
-1
votes
1answer
349 views

Unable to install Netflix

I have tried to install Netflix but I get stuck sudo apt-add-repository ppa:ehoover/compholio sudo apt-get update sudo apt-get install netflix-desktop after the 3rd command I get a disclaimer but ...
1
vote
1answer
4k views

apt-get upgrade failing due to dependency issue [duplicate]

I am running 12.04 LTS on a ASUS custom build server. I apologize in advance as my skills are a bit rusty in linux as I spend more time working with networking gear these days. I am running sudo ...